automatic version update by autodist [release 40.0.2214.111-1mamba;Mon Feb 09 2015]
This commit is contained in:
parent
92559c4c7f
commit
871909fb45
@ -1,10 +0,0 @@
|
||||
--- a/build/common.gypi 2013-01-09 07:02:00.000000000 -0700
|
||||
+++ b/build/common.gypi 2013-01-11 20:09:13.380197474 -0700
|
||||
@@ -594,7 +594,7 @@
|
||||
'linux_use_gold_flags%': 0,
|
||||
# sysroot needs to be an absolute path otherwise it generates
|
||||
# incorrect results when passed to pkg-config
|
||||
- 'sysroot%': '<!(cd <(DEPTH) && pwd -P)/arm-sysroot',
|
||||
+ #'sysroot%': '<!(cd <(DEPTH) && pwd -P)/arm-sysroot',
|
||||
}], # OS=="linux" and target_arch=="arm" and chromeos==0
|
||||
],
|
14
chromium-37.0.2062.120-chrome-wrapper-pepper-flash.patch
Normal file
14
chromium-37.0.2062.120-chrome-wrapper-pepper-flash.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- chromium-37.0.2062.120/chrome/tools/build/linux/chrome-wrapper.orig 2014-09-10 01:29:21.000000000 +0200
|
||||
+++ chromium-37.0.2062.120/chrome/tools/build/linux/chrome-wrapper 2014-09-19 21:35:12.045745151 +0200
|
||||
@@ -160,4 +160,10 @@
|
||||
done
|
||||
set -- "${ARGS[@]}" "$@"
|
||||
|
||||
-exec $CMD_PREFIX "$HERE/chrome" "$@"
|
||||
+if [ -r /opt/chromium/PepperFlash/manifest.json ]; then
|
||||
+ PEPPER_FLASH_VERSION="$(grep '"version":' /opt/chromium/PepperFlash/manifest.json | grep -Po '(?<=version": ")(?:\d|\.)*')"
|
||||
+ exec $CMD_PREFIX "$HERE/chrome" \
|
||||
+ --ppapi-flash-path=/opt/chromium/PepperFlash/libpepflashplayer.so --ppapi-flash-version=${PEPPER_FLASH_VERSION} "$@"
|
||||
+else
|
||||
+ exec $CMD_PREFIX "$HERE/chrome" "$@"
|
||||
+fi
|
11
chromium-40.0.2214.91-arm-sysroot.patch
Normal file
11
chromium-40.0.2214.91-arm-sysroot.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- chromium-40.0.2214.91/build/common.gypi.orig 2015-01-26 16:15:18.310585287 +0100
|
||||
+++ chromium-40.0.2214.91/build/common.gypi 2015-01-26 20:06:06.769806985 +0100
|
||||
@@ -926,7 +926,7 @@
|
||||
'use_allocator%': 'none',
|
||||
# sysroot needs to be an absolute path otherwise it generates
|
||||
# incorrect results when passed to pkg-config
|
||||
- 'sysroot%': '<!(cd <(DEPTH) && pwd -P)/chrome/installer/linux/debian_wheezy_arm-sysroot',
|
||||
+ #'sysroot%': '<!(cd <(DEPTH) && pwd -P)/chrome/installer/linux/debian_wheezy_arm-sysroot',
|
||||
}], # OS=="linux" and target_arch=="arm" and chromeos==0
|
||||
|
||||
['OS=="linux" and branding=="Chrome" and buildtype=="Official" and chromeos==0', {
|
111
chromium.spec
111
chromium.spec
@ -1,7 +1,7 @@
|
||||
Name: chromium
|
||||
Epoch: 3
|
||||
Version: 34.0.1847.137
|
||||
Release: 3mamba
|
||||
Version: 40.0.2214.111
|
||||
Release: 1mamba
|
||||
Summary: An open-source browser project that aims to build a safer, faster, and more stable way to experience the web
|
||||
Group: Graphical Desktop/Applications/Internet
|
||||
Vendor: openmamba
|
||||
@ -28,11 +28,12 @@ Patch10: chromium-21.0.1168.0-gcc-4.7.patch
|
||||
Patch11: chromium-24.0.1285.1-glibc-2.16.patch
|
||||
Patch12: chromium-24.0.1312.70-arm-gcc-4.5.3.patch
|
||||
Patch13: chromium-26.0.1410.49-speech_dispatcher.patch
|
||||
Patch14: chromium-26.0.1410.63-arm-sysroot.patch
|
||||
Patch14: chromium-40.0.2214.91-arm-sysroot.patch
|
||||
Patch15: chromium-34.0.1847.116-gn-r0.patch
|
||||
Patch16: chromium-34.0.1847.118-disable_depot_tools.patch
|
||||
Patch17: chromium-34.0.1847.137-glib-2.40.patch
|
||||
Patch18: chromium-34.0.1847.137-gnome-keyring-3.12.patch
|
||||
Patch18: chromium-34.0.1847.137-gnome-keyring-3.12.patch
|
||||
Patch19: chromium-37.0.2062.120-chrome-wrapper-pepper-flash.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libGConf-devel
|
||||
@ -133,6 +134,7 @@ BuildRequires: libgnutls-devel.i586
|
||||
BuildRequires: libgpg-error-devel.i586
|
||||
BuildRequires: libcap-devel.i586
|
||||
%endif
|
||||
BuildRequires: libsnappy-devel
|
||||
BuildRequires: ninja
|
||||
Requires(post): %{__install_info}
|
||||
Requires: xdg-utils
|
||||
@ -160,7 +162,7 @@ Chromium is an open-source browser project that aims to build a safer, faster, a
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
#%patch3 -p1
|
||||
%patch4 -p1
|
||||
#%patch4 -p1
|
||||
#%patch5 -p1
|
||||
#%patch6 -p3
|
||||
#%patch7 -p2
|
||||
@ -177,20 +179,20 @@ Chromium is an open-source browser project that aims to build a safer, faster, a
|
||||
%endif
|
||||
#%patch13 -p1
|
||||
%patch14 -p1
|
||||
%patch15 -p1
|
||||
%patch16 -p2
|
||||
#%patch15 -p1
|
||||
#%patch16 -p2
|
||||
%patch17 -p1
|
||||
%patch18 -p2
|
||||
#%patch18 -p2
|
||||
%patch19 -p1
|
||||
|
||||
# Download NaCL toolchains
|
||||
python build/download_nacl_toolchains.py -k
|
||||
#\
|
||||
# --packages nacl_x86_newlib,pnacl_newlib,pnacl_translator
|
||||
python build/download_nacl_toolchains.py \
|
||||
--packages nacl_x86_newlib,pnacl_newlib,pnacl_translator
|
||||
|
||||
%build
|
||||
#:<< ___EOF
|
||||
ln -sf %{_bindir}/ld.gold third_party/gold/ld.gold
|
||||
ln -sf %{_bindir}/ld.bfd third_party/gold/ld.bfd
|
||||
#ln -sf %{_bindir}/ld.gold third_party/gold/ld.gold
|
||||
#ln -sf %{_bindir}/ld.bfd third_party/gold/ld.bfd
|
||||
# Build with clang as a temporary solution to startup crash with GCC 4.9
|
||||
mkdir -p third_party/llvm-build/Release+Asserts/bin
|
||||
ln -sf %{_bindir}/clang third_party/llvm-build/Release+Asserts/bin/
|
||||
@ -201,12 +203,12 @@ sed -i '/-Wno-absolute-value/d' \
|
||||
build/common.gypi \
|
||||
third_party/ffmpeg/ffmpeg.gyp
|
||||
|
||||
%ifarch x86_64
|
||||
ln -sf %{_bindir}/ld.gold third_party/gold/gold64
|
||||
%else
|
||||
ln -sf %{_bindir}/ld.gold third_party/gold/gold64
|
||||
ln -sf %{_bindir}/ld.gold third_party/gold/gold32
|
||||
%endif
|
||||
#%ifarch x86_64
|
||||
#ln -sf %{_bindir}/ld.gold third_party/gold/gold64
|
||||
#%else
|
||||
#ln -sf %{_bindir}/ld.gold third_party/gold/gold64
|
||||
#ln -sf %{_bindir}/ld.gold third_party/gold/gold32
|
||||
#%endif
|
||||
%ifarch arm
|
||||
#export GYP_DEFINES="$GYP_DEFINES target_arch=arm disable_nacl=1 linux_use_tcmalloc=0 armv7=1 arm_neon=0 arm_thumb=1 arm_fpu=vfpv3-d16"
|
||||
export GYP_DEFINES="$GYP_DEFINES target_arch=arm linux_use_tcmalloc=0 armv7=1 arm_neon=0 arm_thumb=1 arm_fpu=vfp"
|
||||
@ -254,23 +256,27 @@ chromium_conf=(
|
||||
-Duse_system_libjpeg=1
|
||||
-Duse_system_libxml=1
|
||||
-Duse_system_libxslt=1
|
||||
-Duse_system_harfbuzz=1
|
||||
-Duse_system_libevent=1
|
||||
-Duse_system_yasm=1
|
||||
-Duse_system_flac=1
|
||||
-Duse_system_speex=1
|
||||
-Duse_system_snappy=1
|
||||
-Duse_system_ssl=0
|
||||
-Duse_system_vpx=1
|
||||
-Dffmpeg_branding=Chrome
|
||||
-Duse_system_ffmpeg=0
|
||||
-Dffmpeg_branding=Chrome
|
||||
-Dremove_webcore_debug_symbols=1
|
||||
-Dusb_ids_path=/usr/share/hwdata/usb.ids
|
||||
-Dlinux_fpic=1
|
||||
-Ddisable_sse2=1
|
||||
-Dlibspeechd_h_prefix=speech-dispatcher/
|
||||
-Dno_strict_aliasing=1
|
||||
%ifarch %{ix86}
|
||||
-Drelease_extra_cflags="-fPIC -m32"
|
||||
%else
|
||||
-Drelease_extra_cflags="-fPIC"
|
||||
%endif
|
||||
-Dlibspeechd_h_prefix=speech-dispatcher/
|
||||
-Dno_strict_aliasing=1
|
||||
%ifarch arm
|
||||
-Denable_webrtc=0
|
||||
%endif
|
||||
@ -279,16 +285,6 @@ chromium_conf=(
|
||||
%endif
|
||||
)
|
||||
|
||||
# -Duse_system_zlib=0: see http://code.google.com/p/chromium/issues/detail?id=143623
|
||||
|
||||
# -Duse_system_ffmpeg=1 \
|
||||
# -Duse_system_libjpeg=1 currently requires libjpeg-turbo >= 1.1.90
|
||||
# -Duse_system_ssl=1 \
|
||||
# -Duse_system_sqlite=1
|
||||
# -Duse_system_icu=1 \
|
||||
|
||||
#___ EOF
|
||||
|
||||
build/linux/unbundle/replace_gyp_files.py "${chromium_conf[@]}"
|
||||
build/gyp_chromium --depth=. "${chromium_conf[@]}"
|
||||
|
||||
@ -305,7 +301,7 @@ install -d -m0755 %{buildroot}/opt/chromium/ %{buildroot}%{_bindir}
|
||||
install -m0755 out/Release/chrome %{buildroot}/opt/chromium/
|
||||
install -m0755 out/Release/chrome_sandbox %{buildroot}/opt/chromium/chrome-sandbox
|
||||
install -m0755 out/Release/chromedriver %{buildroot}/opt/chromium/chromedriver
|
||||
cp out/Release/{*.pak,libffmpegsumo.so} \
|
||||
cp out/Release/{*.pak,libffmpegsumo.so,libpdf.so} \
|
||||
%{buildroot}/opt/chromium/
|
||||
|
||||
install -m0755 chrome/tools/build/linux/chrome-wrapper %{buildroot}/opt/chromium/
|
||||
@ -404,7 +400,7 @@ fi
|
||||
#/opt/chromium/ffmpegsumo_nolink
|
||||
/opt/chromium/icudtl.dat
|
||||
/opt/chromium/libffmpegsumo.so
|
||||
#/opt/chromium/libpdf.so
|
||||
/opt/chromium/libpdf.so
|
||||
#/opt/chromium/nacl_helper
|
||||
#/opt/chromium/nacl_helper-bootstrap
|
||||
#/opt/chromium/libppGoogleNaClPluginChrome.so
|
||||
@ -427,11 +423,54 @@ fi
|
||||
%{_mandir}/man1/chrome.1*
|
||||
|
||||
%changelog
|
||||
* Thu Dec 04 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 34.0.1847.137-3mamba
|
||||
* Mon Feb 09 2015 Automatic Build System <autodist@mambasoft.it> 40.0.2214.111-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jan 31 2015 Automatic Build System <autodist@mambasoft.it> 40.0.2214.94-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jan 28 2015 Automatic Build System <autodist@mambasoft.it> 40.0.2214.93-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jan 26 2015 Automatic Build System <autodist@mambasoft.it> 40.0.2214.91-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jan 14 2015 Automatic Build System <autodist@mambasoft.it> 39.0.2171.99-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Dec 10 2014 Automatic Build System <autodist@mambasoft.it> 39.0.2171.95-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Dec 04 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 39.0.2171.71-2mamba
|
||||
- install libpdf.so
|
||||
- set -Dffmpeg_branding=Chrome instead of Chromium and -Duse_system_ffmpeg=0
|
||||
- set -Dffmpeg_branding=Chrome instead of Chromium
|
||||
- require libvdpau-Mesa
|
||||
|
||||
* Wed Nov 26 2014 Automatic Build System <autodist@mambasoft.it> 39.0.2171.71-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Nov 24 2014 Automatic Build System <autodist@mambasoft.it> 39.0.2171.65-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Nov 14 2014 Automatic Build System <autodist@mambasoft.it> 38.0.2125.122-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Oct 28 2014 Automatic Build System <autodist@mambasoft.it> 38.0.2125.111-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Oct 16 2014 Automatic Build System <autodist@mambasoft.it> 38.0.2125.104-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Oct 09 2014 Automatic Build System <autodist@mambasoft.it> 38.0.2125.101-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Sep 19 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 37.0.2062.120-2mamba
|
||||
- chrome-wrapper: patch for automatic pepper-flash plugin support
|
||||
- build with internal ffmpeg to maybe fix html5 video support
|
||||
|
||||
* Thu Sep 18 2014 Automatic Build System <autodist@mambasoft.it> 37.0.2062.120-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Sep 09 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 34.0.1847.137-2mamba
|
||||
- build with clang because of startup crash with gcc 4.9
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user