choqok/choqok.spec

162 lines
5.3 KiB
RPMSpec

%define majver %(echo %version | cut -d. -f1-2)
Name: choqok
Version: 1.7.0
Release: 1mamba
Summary: A Free/Open Source micro-blogging client for KDE
Group: Graphical Desktop/Applications/Networking
Vendor: openmamba
Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
URL: http://choqok.gnufolks.org
#Source: http://downloads.sourceforge.net/project/choqok/Choqok/choqok-%{version}.tar.xz
Source: http://download.kde.org/stable/choqok/%{majver}/src/choqok-%{version}.tar.xz
Patch0: choqok-1.1-dbus_servicesdir.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: kdelibs-devel
BuildRequires: libattica-devel
BuildRequires: libgcc
BuildRequires: libindicate-qt-devel
BuildRequires: libphonon-devel
BuildRequires: libqjson-devel
BuildRequires: libqoauth-devel
BuildRequires: libqt4-devel
BuildRequires: libsoprano-devel
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
BuildRequires: chrpath
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Choqok is a KDE micro-blogging client.
Currently supports Twitter.com and Identi.ca services.
A quick and efficient client for KDE 4 Desktops.
It has a System tray Icon, and use notifications to notify user about updates, and fair configurable.
%package -n lib%{name}
Group: System/Libraries
Summary: Library for using Choqok
%description -n lib%{name}
Choqok is a KDE micro-blogging client.
Currently supports Twitter.com and Identi.ca services.
A quick and efficient client for KDE 4 Desktops.
It has a System tray Icon, and use notifications to notify user about updates, and fair configurable.
This package contains shared libraries needed for Choqok.
%package -n lib%{name}-devel
Group: Development/Libraries
Summary: Static libraries and headers for Choqok
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n lib%{name}-devel
Choqok is a KDE micro-blogging client.
Currently supports Twitter.com and Identi.ca services.
A quick and efficient client for KDE 4 Desktops.
It has a System tray Icon, and use notifications to notify user about updates, and fair configurable.
This package contains static libraries and header files need for development.
%debug_package
%prep
%setup -q
%patch0 -p0
%build
%cmake_kde5 -d build
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
%find_lang %{name}
#for file in %{buildroot}{%{_kde4_libdir}/{kde4/*.so,*.so.*},%{_kde4_bindir}/choqok}
#do
# chrpath --list $file && chrpath --delete $file || :
#done
%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.lang
%defattr(-,root,root)
%{_kde5_bindir}/choqok
%{_kde5_servicetypesdir}/choqokplugin.desktop
%{_kde5_servicetypesdir}/choqokshortenerplugin.desktop
%{_kde5_servicetypesdir}/choqokuploaderplugin.desktop
%{_datadir}/knotifications5/choqok.notifyrc
%{_datadir}/kservices5/ServiceMenus/choqok_share.desktop
%{_datadir}/kservices5/konqchoqok.desktop
%{_datadir}/kxmlgui5/konqchoqokplugin/konqchoqok.rc
%{_datadir}/kxmlgui5/choqok/choqokui.rc
%{_datadir}/kxmlgui5/choqok_filter/filterui.rc
%{_datadir}/kxmlgui5/choqok_nowlistening/nowlisteningui.rc
%{_datadir}/kxmlgui5/choqok_quickfilter/quickfilterui.rc
%{_datadir}/kxmlgui5/choqok_searchaction/searchactionui.rc
%{_datadir}/metainfo/org.kde.choqok.appdata.xml
%{_datadir}/applications/org.kde.choqok.desktop
%{_datadir}/choqok/images/splash_screen.png
%{_datadir}/cmake/modules/FindChoqok.cmake
%{_datadir}/icons/hicolor/scalable/apps/choqok*.svgz
%{_datadir}/kservices5/choqok_*.desktop
%{_kde5_sharedir}/config.kcfg/*.kcfg
%{_kde5_icondir}/hicolor/*/apps/*.png
%{_kde5_icondir}/hicolor/*/actions/*.png
%{_kde5_dbusservicesdir}/org.kde.choqok.service
%{_kde5_htmldir}/*/choqok
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/libchoqok.so.*
%{_libdir}/libgnusocialapihelper.so.*
%{_libdir}/libtwitterapihelper.so.*
%{_libdir}/qt5/plugins/*.so
%{_libdir}/qt5/plugins/kf5/parts/konqchoqokplugin.so
%{_libdir}/qt5/plugins/kf5/purpose/purposeplugin.so
%doc AUTHORS COPYING
%files -n lib%{name}-devel
%defattr(-,root,root)
%dir %{_includedir}/choqok
%{_includedir}/choqok/*
%{_libdir}/libchoqok.so
%{_libdir}/libgnusocialapihelper.so
%{_libdir}/libtwitterapihelper.so
#%{_kde5_datadir}/cmake/modules/*.cmake
#%doc changelog README TODO
%changelog
* Sat Mar 14 2020 Automatic Build System <autodist@mambasoft.it> 1.7.0-1mamba
- automatic version update by autodist
* Thu Dec 08 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-1mamba
- update to 1.6.0
* Mon Jan 26 2015 Automatic Build System <autodist@mambasoft.it> 1.5-1mamba
- automatic version update by autodist
* Fri Sep 06 2013 Automatic Build System <autodist@mambasoft.it> 1.4-1mamba
- update to 1.4
* Wed Aug 22 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3-2mamba
- rebuilt with libattica 0.4
* Wed Mar 28 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3-1mamba
- update to 1.3
* Mon Apr 04 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.1-1mamba
- update to 1.1
* Thu Mar 25 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.9.55-1mamba
- package created by autospec