140 lines
5.4 KiB
RPMSpec
140 lines
5.4 KiB
RPMSpec
%define plugins_ver 0.90
|
|
%define asound_ver 0.9.1
|
|
|
|
Name: childsplay
|
|
Version: 3.4
|
|
Release: 1mamba
|
|
Summary: A 'suite' of educational games for young children
|
|
Group: Applications/Educational
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://childsplay.sourceforge.net/
|
|
Source0: https://sourceforge.net/projects/schoolsplay/files/childsplay-%{version}.tgz
|
|
Source2: %{name}.desktop
|
|
Source3: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_ca-%{asound_ver}.tgz
|
|
Source4: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_de-%{asound_ver}.tgz
|
|
Source5: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_es-%{asound_ver}.tgz
|
|
Source6: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_fr-%{asound_ver}.tgz
|
|
Source7: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_it-%{asound_ver}.tgz
|
|
Source8: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_nl-%{asound_ver}.tgz
|
|
Source9: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_ru-%{asound_ver}.tgz
|
|
Source10: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_sv-0.9.2.tgz
|
|
Source11: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_pt-%{asound_ver}.tgz
|
|
#Source13: http://downloads.sourceforge.net/sourceforge/%{name}/childsplay_plugins_lfc-%{plugins_ver}.tgz
|
|
Source14: %{name}-icon.png
|
|
Patch0: childsplay-0.80.3.1-install.patch
|
|
Patch1: childsplay-0.90.2-locale_it.patch
|
|
Patch2: childsplay-0.90.2-install_plugins_lfc.patch
|
|
Patch3: childsplay-0.90.2-install_plugins.patch
|
|
Patch4: childsplay-0.90.2-install_score.patch
|
|
Patch5: childsplay-0.80.3.1-childsplay_sh.patch
|
|
Patch6: childsplay-0.90.2-it_lang_plugins_lfc.patch
|
|
Patch7: childsplay-0.90.2-locale_it_font.patch
|
|
Patch8: childsplay-1.6-python-SQLAlchemy-0.7.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: python2dist(sqlalchemy)
|
|
## AUTOBUILDREQ-END
|
|
Requires: python27
|
|
Requires: python2dist(sqlalchemy)
|
|
|
|
%description
|
|
Childsplay is a 'suite' of educational games for young children, like gcompris, but without the overkill of c/c++ and the gnome environ.
|
|
Also the use of the SDL libraries makes smooth animation and the playing of sound very easy.
|
|
|
|
#% debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
# due unknown Mail module
|
|
rm -fv SPDebugDialog.py
|
|
rm -fv SPWidgets/test.py
|
|
sed -i "s|import SpDebugDialog||" SPMainCore.py
|
|
|
|
# set pathes
|
|
cat <<EOF >SPBasePaths.py
|
|
# This module holds all paths needed for %name.
|
|
DOCDIR = '%{_datadir}/doc/%{name}-%{version}'
|
|
#PYTHONCPDIR = '%python_sitelibdir/%realname'
|
|
BASEDIR = '%{_datadir}/%{name}'
|
|
SHARELIBDATADIR = '%{_datadir}/%{name}/lib'
|
|
ALPHABETDIR = '%{_datadir}/%{name}/alphabet-sounds'
|
|
LOCALEDIR = '%{_datadir}/locale'
|
|
WWWDIR = 'www/backend'
|
|
EOF
|
|
|
|
%build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
|
|
install -d -m0755 %{buildroot}%{_bindir}
|
|
|
|
cat <<EOF >%{buildroot}%{_bindir}/%{name}
|
|
#!/bin/sh
|
|
cd %{_datadir}/%{name}/
|
|
python2 childsplay.py
|
|
EOF
|
|
chmod a+x %{buildroot}%{_bindir}/%{name}
|
|
|
|
install -d -m0755 %{buildroot}%{_datadir}/locale/
|
|
install -d -m0755 %{buildroot}%{_datadir}/%{name}/
|
|
|
|
cp -a *.py lib SPWidgets %{buildroot}%{_datadir}/%{name}/
|
|
cp sp_content.db %{buildroot}%{_datadir}/%{name}/lib/
|
|
cp -a alphabet-sounds %{buildroot}%{_datadir}/%{name}/
|
|
cp -a locale/* %{buildroot}%{_datadir}/locale/
|
|
|
|
install -D -m644 %{SOURCE2} %{buildroot}%{_datadir}/applications/%{name}.desktop
|
|
install -D -m644 lib/SPData/themes/childsplay/logo_cp_64x64.png %{buildroot}%{_datadir}/pixmaps/childsplay.png
|
|
|
|
%{find_lang} %{name} --all-name
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
|
|
%files -f %{name}.lang
|
|
%defattr(-,root,root)
|
|
%{_bindir}/childsplay
|
|
%dir %{_datadir}/childsplay
|
|
%{_datadir}/childsplay/*
|
|
%{_datadir}/pixmaps/childsplay.png
|
|
%{_datadir}/applications/childsplay.desktop
|
|
#%dir %{_docdir}/childsplay
|
|
#%{_docdir}/childsplay/*
|
|
%doc COPYING
|
|
|
|
%changelog
|
|
* Sun May 23 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4-1mamba
|
|
- update to 3.4
|
|
|
|
* Thu Sep 13 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3-1mamba
|
|
- update to 3.3
|
|
|
|
* Wed Apr 09 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5-1mamba
|
|
- update to 2.5
|
|
|
|
* Sun Jun 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6-3mamba
|
|
- python 2.7 mass rebuild
|
|
|
|
* Tue Dec 04 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6-2mamba
|
|
- added requirement and patch for python-SQLAlchemy 0.7
|
|
|
|
* Sat Jul 21 2012 Automatic Build System <autodist@mambasoft.it> 1.6-1mamba
|
|
- update to 1.6
|
|
|
|
* Wed Aug 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.90.2-2mamba
|
|
- fixed a syntax error in locale_it_font.patch preventing program to start
|
|
- fixed desktop menu icon
|
|
|
|
* Tue Sep 30 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.90.2-1mamba
|
|
- update to version 0.90.2
|
|
|
|
* Fri Nov 11 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.80.3.1-1qilnx
|
|
- update to version 0.80.3.1 by autospec
|
|
|
|
* Wed Jan 19 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.80.1-1qilnx
|
|
- package created by autospec
|
|
- added italian localisation
|