python 2.7 mass rebuild [release 1.6-3mamba;Sun Jun 02 2013]
This commit is contained in:
parent
1dec32d18e
commit
e10805e112
@ -1,2 +1,5 @@
|
||||
# childsplay
|
||||
|
||||
Childsplay is a 'suite' of educational games for young children, like gcompris, but without the overkill of c/c++ and the gnome environ.
|
||||
Also the use of the SDL libraries makes smooth animation and the playing of sound very easy.
|
||||
|
||||
|
6
childsplay-0.80.3.1-childsplay_sh.patch
Normal file
6
childsplay-0.80.3.1-childsplay_sh.patch
Normal file
@ -0,0 +1,6 @@
|
||||
--- childsplay-0.80.3.1/childsplay.sh.orig 2005-12-02 23:14:03.000000000 +0100
|
||||
+++ childsplay-0.80.3.1/childsplay.sh 2005-12-02 23:15:01.000000000 +0100
|
||||
@@ -1,2 +1,2 @@
|
||||
#!/bin/sh
|
||||
-/usr/local/lib/games/childsplay/childsplay.py $* &
|
||||
+/usr/lib/childsplay/childsplay.py $* &
|
129
childsplay-0.80.3.1-install.patch
Normal file
129
childsplay-0.80.3.1-install.patch
Normal file
@ -0,0 +1,129 @@
|
||||
diff -ru childsplay-0.80.3.1/INSTALL.sh childsplay-0.80.3.1-qi/INSTALL.sh
|
||||
--- childsplay-0.80.3.1/INSTALL.sh 2005-08-29 10:06:25.000000000 +0200
|
||||
+++ childsplay-0.80.3.1-qi/INSTALL.sh 2005-11-25 22:45:54.000000000 +0100
|
||||
@@ -8,30 +8,32 @@
|
||||
# However, you can change the "prefix" to "/usr" and childsplay will still
|
||||
# work. Set it to anything else and your on your own.
|
||||
|
||||
-PREFIX=/usr/local
|
||||
+PREFIX=/usr
|
||||
|
||||
#################################################################
|
||||
# DON'T EDIT BEHIND THIS POINT
|
||||
#################################################################
|
||||
-if [ $* ]
|
||||
-then PREFIX=$*
|
||||
-fi
|
||||
-echo "PREFIX=$PREFIX"
|
||||
+
|
||||
+DESTDIR=
|
||||
+
|
||||
+[ "$1" ] && DESTDIR="$1"
|
||||
+
|
||||
+echo "PREFIX=$DESTDIR$PREFIX"
|
||||
|
||||
PYTHON=`which python`
|
||||
|
||||
-EXECDIR=$PREFIX/bin
|
||||
-LOCALEDIR=$PREFIX/share/locale
|
||||
-ASSETMLDIR=/usr/share/assetml
|
||||
-SCOREDIR=/var/games
|
||||
+EXECDIR=$DESTDIR$PREFIX/bin
|
||||
+LOCALEDIR=$DESTDIR$PREFIX/share/locale
|
||||
+ASSETMLDIR=$DESTDIR$PREFIX/share/assetml
|
||||
+SCOREDIR=$DESTDIR/var/games
|
||||
SCOREFILE=$SCOREDIR/childsplay.score
|
||||
-DOCDIR=$PREFIX/share/doc/childsplay
|
||||
-MANDIR=$PREFIX/man/man6
|
||||
-CPDIR=$PREFIX/lib/games/childsplay
|
||||
-SHAREDIR=$PREFIX/share/childsplay
|
||||
-BINDIR=$PREFIX/games
|
||||
-LIBDIR=$CPDIR/lib
|
||||
-MODULESDIR=$LIBDIR
|
||||
+DOCDIR=$DESTDIR$PREFIX/share/doc/childsplay
|
||||
+MANDIR=$DESTDIR$PREFIX/share/man/man6
|
||||
+CPDIR=$DESTDIR$PREFIX/lib/childsplay
|
||||
+SHAREDIR=$DESTDIR$PREFIX/share/childsplay
|
||||
+BINDIR=$DESTDIR$PREFIX/bin
|
||||
+LIBDIR=$CPDIR/lib
|
||||
+MODULESDIR=$LIBDIR
|
||||
SHARELIBDATADIR=$SHAREDIR/lib
|
||||
SHAREDATADIR=$SHAREDIR/Data
|
||||
RCDIR=$SHARELIBDATADIR/ConfigData
|
||||
@@ -39,11 +41,11 @@
|
||||
HOME_DIR_NAME=.childsplay
|
||||
CHILDSPLAYRC=childsplayrc
|
||||
|
||||
-OLDCPDIR=$PREFIX/games/childsplay
|
||||
+OLDCPDIR=$DESTDIR$PREFIX/bin/childsplay
|
||||
|
||||
echo "Making directorys"
|
||||
mkdir -vp $CPDIR
|
||||
-mkdir -vp $CPDIR/lib
|
||||
+mkdir -vp $LIBDIR
|
||||
mkdir -vp $DOCDIR
|
||||
mkdir -vp $LOCALEDIR
|
||||
mkdir -vp $ASSETMLDIR
|
||||
@@ -58,17 +60,6 @@
|
||||
set -e
|
||||
|
||||
CWD=`pwd`
|
||||
-USERID=`id | sed -e 's/).*//; s/^.*(//;'`
|
||||
-if [ "$USERID" != "root" ]; then
|
||||
- echo " You must be root to install the plugins"
|
||||
- echo " exit"
|
||||
- exit 1
|
||||
-fi
|
||||
-echo " Looking for obsolete childsplay files in $OLDCPDIR"
|
||||
-if [ -e $OLDCPDIR ] && [ -d $OLDCPDIR ]
|
||||
-then rm -fr $OLDCPDIR
|
||||
- echo " Old files removed"
|
||||
-fi
|
||||
|
||||
echo -e "\n>>>>>>>>>>> Install childsplay >>>>>>>>>>>>>>>>>>>>"
|
||||
echo " Installing in $PREFIX"
|
||||
@@ -122,12 +113,6 @@
|
||||
chmod +x $CPDIR/childsplay.py
|
||||
chmod +x $CPDIR/letters-trans.py
|
||||
|
||||
-#echo " Looking for the old executable, if any"
|
||||
-#if [ -e /usr/local/bin/childsplay ]
|
||||
-#then rm -f /usr/local/bin/childsplay
|
||||
-# echo "found and removed"
|
||||
-#fi
|
||||
-
|
||||
echo " Setting the base path in childsplay to $PREFIX"
|
||||
echo "## Automated file please do not edit" > $CPDIR/BASEPATH.py
|
||||
echo "BASEPATH=\"$PREFIX\"" >> $CPDIR/BASEPATH.py
|
||||
@@ -152,7 +137,7 @@
|
||||
|
||||
echo ">>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>"
|
||||
echo ""
|
||||
-echo " Instalation of childsplay complete"
|
||||
+echo " Installation of childsplay complete"
|
||||
echo " The childsplay executable is $BINDIR/childsplay"
|
||||
echo ""
|
||||
echo ">>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>"
|
||||
diff -ru childsplay-0.80.3.1/letters-trans.py childsplay-0.80.3.1-qi/letters-trans.py
|
||||
--- childsplay-0.80.3.1/letters-trans.py 2005-08-29 10:06:24.000000000 +0200
|
||||
+++ childsplay-0.80.3.1-qi/letters-trans.py 2005-11-25 22:47:37.000000000 +0100
|
||||
@@ -36,10 +36,6 @@
|
||||
import os,fnmatch,operator,sys,locale
|
||||
from CPConstants import ASSETMLROOT
|
||||
|
||||
-if os.environ['USER'] != 'root':
|
||||
- print "\nOnly root can use this script, sorry.\n"
|
||||
- sys.exit(1)
|
||||
-
|
||||
try:
|
||||
import pyassetml,pyassetmlcreator
|
||||
except ImportError,info:
|
||||
@@ -66,7 +62,7 @@
|
||||
sys.exit(0)
|
||||
|
||||
# get description names from memory assetml, these are the words used by letters.py
|
||||
-parser = pyassetml.AssetmlParser('childsplay/memory-136x136/memory-136x136.assetml')
|
||||
+parser = pyassetml.AssetmlParser('assetml/childsplay/memory-136x136/memory-136x136.assetml')
|
||||
loc = parser.get_locale()# get current locale setting, only the first two chars !!
|
||||
wlist_org = parser.find_names((('file','.'),('description',"en")))
|
||||
wlist = parser.find_names((('file','.'),('description',loc)))
|
103
childsplay-0.90.2-install_plugins.patch
Normal file
103
childsplay-0.90.2-install_plugins.patch
Normal file
@ -0,0 +1,103 @@
|
||||
--- childsplay-0.90.2/childsplay_plugins-0.90/install.sh 2008-09-27 04:03:14.000000000 +0200
|
||||
+++ childsplay-0.90.2/childsplay_plugins-0.90/install.sh-gil 2008-09-27 04:12:53.000000000 +0200
|
||||
@@ -8,33 +8,33 @@
|
||||
# However, you can change the "prefix" to "/usr" and childsplay will still
|
||||
# work. Set it to anything else and your on your own.
|
||||
|
||||
-PREFIX=/usr/local
|
||||
+PREFIX=/usr
|
||||
|
||||
#################################################################
|
||||
# DON'T EDIT BEHIND THIS POINT
|
||||
#################################################################
|
||||
|
||||
-if [ $1 ] && [ -e $1 ]
|
||||
-then PREFIX=$1
|
||||
-fi
|
||||
+DESTDIR=
|
||||
+
|
||||
+[ "$1" ] && DESTDIR="$1"
|
||||
|
||||
-LOCALEDIR=$PREFIX/share/locale
|
||||
-MTDIR=$PREFIX/bin
|
||||
-ASSETMLDIR=/usr/share/assetml
|
||||
+LOCALEDIR=$DESTDIR$PREFIX/share/locale
|
||||
+MTDIR=$DESTDIR$PREFIX/bin
|
||||
+ASSETMLDIR=$DESTDIR$PREFIX/share/assetml
|
||||
PYTHON=`which python`
|
||||
-SCOREDIR=/var/games
|
||||
-DOCDIR=$PREFIX/share/doc/childsplay
|
||||
-MANDIR=$PREFIX/man/man6
|
||||
-CPDIR=$PREFIX/lib/games/childsplay
|
||||
-SHAREDIR=$PREFIX/share/childsplay
|
||||
-BINDIR=$PREFIX/games
|
||||
+SCOREDIR=$DESTDIR/var/games
|
||||
+DOCDIR=$DESTDIR$PREFIX/share/doc/childsplay
|
||||
+MANDIR=$DESTDIR$PREFIX/man/man6
|
||||
+CPDIR=$DESTDIR$PREFIX/lib/childsplay
|
||||
+SHAREDIR=$DESTDIR$PREFIX/share/childsplay
|
||||
+BINDIR=$DESTDIR$PREFIX/bin
|
||||
SHARELIBDATADIR=$SHAREDIR/lib
|
||||
SHAREDATADIR=$SHAREDIR/Data
|
||||
|
||||
##################################################
|
||||
# Package text to be displayed as last step
|
||||
# 0 = no readmes to display, 1 = there are readmes
|
||||
-README=1
|
||||
+README=0
|
||||
# if README=1 then READMES=names of readmes in CWD
|
||||
# like this READMES="README README2 README3"
|
||||
READMES="README README-PACKID README.MT_users2csv"
|
||||
@@ -45,52 +45,11 @@
|
||||
# the names of which plugins are to be added to the score file
|
||||
SCORE="Packid,Numbers,Soundmemory,Fallingletters,Findsound,Findsound2,Billiard,Puzzle"
|
||||
|
||||
-USERID=`id | sed -e 's/).*//; s/^.*(//;'`
|
||||
-if [ "$USERID" != "root" ]; then
|
||||
- echo " You must be root to install the plugins"
|
||||
- echo " exit"
|
||||
- exit 1
|
||||
-fi
|
||||
-
|
||||
echo -e "\n>>>>>>>>>>> Install childsplay plugins >>>>>>>>>>>>>>>>>>>>"
|
||||
echo -e "\n This release depends on childsplay version >= $DEPEN"
|
||||
-echo -n " Checking, version = "
|
||||
-#CP=`which childsplay`
|
||||
-CP=$BINDIR/childsplay
|
||||
-VERSION=$($CP --version)
|
||||
-echo $VERSION
|
||||
-
|
||||
-if [ `expr $VERSION \< $DEPEN` -eq 1 ]
|
||||
-then
|
||||
- echo " Childsplay version incorrect, please upgrade to at least";
|
||||
- echo " version $DEPEN";
|
||||
- echo "exit";
|
||||
- exit 1
|
||||
-fi
|
||||
-
|
||||
-if [ ! -f $CP ]
|
||||
-then echo "############# Can\`t find childsplay ###########" && \
|
||||
- echo "Be sure to install childsplay first" && \
|
||||
- exit 1
|
||||
-fi
|
||||
|
||||
set -e
|
||||
|
||||
-echo -e "\n The path to install the plugins in is $CPDIR."
|
||||
-echo " If you have installed childsplay in a other place, you can"
|
||||
-echo " give the full path to childsplay, otherwise just hit enter"
|
||||
-echo " Hit enter to install in $CPDIR, or give the full path"
|
||||
-read path
|
||||
-if [ $path ];then
|
||||
- if [ -e $path/install.py ];then
|
||||
- CPDIR=path
|
||||
- else
|
||||
- echo "*********** WARNING *************"
|
||||
- echo " $path does not exists or is not the childsplay directory"
|
||||
- echo " exit"
|
||||
- exit 1
|
||||
- fi
|
||||
-fi
|
||||
echo " Installing in $CPDIR"
|
||||
|
||||
echo "Compiling modules to bytecode..."
|
110
childsplay-0.90.2-install_plugins_lfc.patch
Normal file
110
childsplay-0.90.2-install_plugins_lfc.patch
Normal file
@ -0,0 +1,110 @@
|
||||
--- childsplay-0.90.2/childsplay_plugins_lfc-0.90/install.sh 2007-08-25 09:53:57.000000000 +0200
|
||||
+++ childsplay-0.90.2/childsplay_plugins_lfc-0.90/install.sh-gil 2008-09-27 05:36:28.000000000 +0200
|
||||
@@ -8,32 +8,33 @@
|
||||
# However, you can change the "prefix" to "/usr" and childsplay will still
|
||||
# work. Set it to anything else and your on your own.
|
||||
|
||||
-PREFIX=/usr/local
|
||||
+PREFIX=/usr
|
||||
|
||||
#################################################################
|
||||
# DON'T EDIT BEHIND THIS POINT
|
||||
#################################################################
|
||||
|
||||
-if [ $1 ] && [ -e $1 ]
|
||||
-then PREFIX=$1
|
||||
-fi
|
||||
+DESTDIR=
|
||||
+
|
||||
+[ "$1" ] && DESTDIR="$1"
|
||||
|
||||
-LOCALEDIR=$PREFIX/share/locale
|
||||
-ASSETMLDIR=/usr/share/assetml
|
||||
+LOCALEDIR=$DESTDIR$PREFIX/share/locale
|
||||
+MTDIR=$DESTDIR$PREFIX/bin
|
||||
+ASSETMLDIR=$DESTDIR$PREFIX/share/assetml
|
||||
PYTHON=`which python`
|
||||
-SCOREDIR=/var/games
|
||||
-DOCDIR=$PREFIX/share/doc/childsplay
|
||||
-MANDIR=$PREFIX/man/man6
|
||||
-CPDIR=$PREFIX/lib/games/childsplay
|
||||
-SHAREDIR=$PREFIX/share/childsplay
|
||||
-BINDIR=$PREFIX/games
|
||||
+SCOREDIR=$DESTDIR/var/games
|
||||
+DOCDIR=$DESTDIR$PREFIX/share/doc/childsplay
|
||||
+MANDIR=$DESTDIR$PREFIX/man/man6
|
||||
+CPDIR=$DESTDIR$PREFIX/lib/childsplay
|
||||
+SHAREDIR=$DESTDIR$PREFIX/share/childsplay
|
||||
+BINDIR=$DESTDIR$PREFIX/bin
|
||||
SHARELIBDATADIR=$SHAREDIR/lib
|
||||
SHAREDATADIR=$SHAREDIR/Data
|
||||
|
||||
##################################################
|
||||
# Package text to be displayed as last step
|
||||
# 0 = no readmes to display, 1 = there are readmes
|
||||
-README=1
|
||||
+README=0
|
||||
# if README=1 then READMES=names of readmes in CWD
|
||||
# like this READMES="README README2 README3"
|
||||
READMES="README"
|
||||
@@ -42,52 +43,11 @@
|
||||
|
||||
CWD=`pwd`
|
||||
|
||||
-USERID=`id | sed -e 's/).*//; s/^.*(//;'`
|
||||
-if [ "$USERID" != "root" ]; then
|
||||
- echo " You must be root to install the plugins"
|
||||
- echo " exit"
|
||||
- exit 1
|
||||
-fi
|
||||
-
|
||||
echo -e "\n>>>>>>>>>>> Install childsplay plugins >>>>>>>>>>>>>>>>>>>>"
|
||||
echo -e "\n This release depends on childsplay version >= $DEPEN"
|
||||
-echo -n " Checking, version = "
|
||||
-#CP=`which childsplay`
|
||||
-CP=$BINDIR/childsplay
|
||||
-VERSION=$($CP --version)
|
||||
-echo $VERSION
|
||||
-
|
||||
-if [ `expr $VERSION \< $DEPEN` -eq 1 ]
|
||||
-then
|
||||
- echo " Childsplay version incorrect, please upgrade to at least";
|
||||
- echo " version $DEPEN";
|
||||
- echo "exit";
|
||||
- exit 1
|
||||
-fi
|
||||
-
|
||||
-if [ ! -f $CP ]
|
||||
-then echo "############# Can\`t find childsplay ###########" && \
|
||||
- echo "Be sure to install childsplay first" && \
|
||||
- exit 1
|
||||
-fi
|
||||
|
||||
set -e
|
||||
|
||||
-echo -e "\n The path to install the plugins in is $CPDIR."
|
||||
-echo " If you have installed childsplay in a other place, you can"
|
||||
-echo " give the full path to childsplay, otherwise just hit enter"
|
||||
-echo " Hit enter to install in $CPDIR, or give the full path"
|
||||
-read path
|
||||
-if [ $path ];then
|
||||
- if [ -e $path/install.py ];then
|
||||
- CPDIR=path
|
||||
- else
|
||||
- echo "*********** WARNING *************"
|
||||
- echo " $path does not exists or is not the childsplay directory"
|
||||
- echo " exit"
|
||||
- exit 1
|
||||
- fi
|
||||
-fi
|
||||
echo " Installing in $CPDIR"
|
||||
|
||||
echo "Compiling modules to bytecode..."
|
||||
@@ -138,5 +98,4 @@
|
||||
echo " in your home directory."
|
||||
echo "***********************************************************************"
|
||||
echo " Enjoy childsplay :-)"
|
||||
-echo ""
|
||||
-
|
||||
+echo ""
|
||||
\ No newline at end of file
|
11
childsplay-0.90.2-install_score.patch
Normal file
11
childsplay-0.90.2-install_score.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- childsplay-0.90.2/childsplay_plugins-0.90/install.sh 2008-09-27 04:31:33.000000000 +0200
|
||||
+++ childsplay-0.90.2/childsplay_plugins-0.90/install.sh-gil 2008-09-27 04:37:00.000000000 +0200
|
||||
@@ -77,8 +77,6 @@
|
||||
done
|
||||
|
||||
echo -e "\n Trying to add $SCORE to the childsplay score sheet"
|
||||
-echo " Start add-score.py"
|
||||
-$PYTHON $CWD/add-score.py $SHAREDATADIR $SCORE
|
||||
|
||||
echo -e "\n Installing MT_users2cvs.py"
|
||||
echo " Look at the file called README.MT_users2csv for info on how"
|
1936
childsplay-0.90.2-it_lang_plugins_lfc.patch
Normal file
1936
childsplay-0.90.2-it_lang_plugins_lfc.patch
Normal file
File diff suppressed because it is too large
Load Diff
98
childsplay-0.90.2-locale_it.patch
Normal file
98
childsplay-0.90.2-locale_it.patch
Normal file
@ -0,0 +1,98 @@
|
||||
--- childsplay-0.90.2/assetml/childsplay/memory-136x136/memory-136x136.assetml 2008-01-17 15:38:57.000000000 +0100
|
||||
+++ childsplay-0.90.2/assetml/childsplay/memory-136x136/memory-136x136.assetml-gil 2008-09-27 04:27:32.000000000 +0200
|
||||
@@ -10,6 +10,7 @@
|
||||
<Description xml:lang="fr">Pomme</Description>
|
||||
<Description xml:lang="he">תפוח</Description>
|
||||
<Description xml:lang="id">Apel</Description>
|
||||
+ <Description xml:lang="it">Mela</Description>
|
||||
<Description xml:lang="nl">Appel</Description>
|
||||
<Description xml:lang="ru">Яблоко</Description>
|
||||
<Description xml:lang="sv">äpple</Description>
|
||||
@@ -27,6 +28,7 @@
|
||||
<Description xml:lang="fr">Ours</Description>
|
||||
<Description xml:lang="he">דוב</Description>
|
||||
<Description xml:lang="id">Beruang</Description>
|
||||
+ <Description xml:lang="it">Orso</Description>
|
||||
<Description xml:lang="nl">Beer</Description>
|
||||
<Description xml:lang="ru">Медведь</Description>
|
||||
<Description xml:lang="sv">Björn</Description>
|
||||
@@ -44,6 +46,7 @@
|
||||
<Description xml:lang="fr">Bateau</Description>
|
||||
<Description xml:lang="he">סירה</Description>
|
||||
<Description xml:lang="id">Perahu</Description>
|
||||
+ <Description xml:lang="it">Nave</Description>
|
||||
<Description xml:lang="nl">Boot</Description>
|
||||
<Description xml:lang="ru">Корабль</Description>
|
||||
<Description xml:lang="sv">Båt</Description>
|
||||
@@ -61,6 +64,7 @@
|
||||
<Description xml:lang="fr">Pain</Description>
|
||||
<Description xml:lang="he">ציפור</Description>
|
||||
<Description xml:lang="id">Roti</Description>
|
||||
+ <Description xml:lang="it">Pane</Description>
|
||||
<Description xml:lang="nl">Brood</Description>
|
||||
<Description xml:lang="ru">Хлеб</Description>
|
||||
<Description xml:lang="sv">Bröd</Description>
|
||||
@@ -78,6 +82,7 @@
|
||||
<Description xml:lang="fr">Voiture</Description>
|
||||
<Description xml:lang="he">מכונית</Description>
|
||||
<Description xml:lang="id">Mobil</Description>
|
||||
+ <Description xml:lang="it">Auto</Description>
|
||||
<Description xml:lang="nl">Auto</Description>
|
||||
<Description xml:lang="ru">Машина</Description>
|
||||
<Description xml:lang="sv">Bil</Description>
|
||||
@@ -96,6 +101,7 @@
|
||||
<Description xml:lang="fr">Chien</Description>
|
||||
<Description xml:lang="he">כלב</Description>
|
||||
<Description xml:lang="id">Anjing</Description>
|
||||
+ <Description xml:lang="it">Cane</Description>
|
||||
<Description xml:lang="nl">Hond</Description>
|
||||
<Description xml:lang="ru">Собака</Description>
|
||||
<Description xml:lang="sv">Hund</Description>
|
||||
@@ -113,6 +119,7 @@
|
||||
<Description xml:lang="fr">Poisson</Description>
|
||||
<Description xml:lang="he">דג</Description>
|
||||
<Description xml:lang="id">Ikan</Description>
|
||||
+ <Description xml:lang="it">Pesce</Description>
|
||||
<Description xml:lang="nl">Vis</Description>
|
||||
<Description xml:lang="ru">Рыба</Description>
|
||||
<Description xml:lang="sv">Fisk</Description>
|
||||
@@ -131,6 +138,7 @@
|
||||
<Description xml:lang="fr">Raisins</Description>
|
||||
<Description xml:lang="he">ענבים</Description>
|
||||
<Description xml:lang="id">Anggur</Description>
|
||||
+ <Description xml:lang="it">Uva</Description>
|
||||
<Description xml:lang="nl">Druiven</Description>
|
||||
<Description xml:lang="ru">Виноград</Description>
|
||||
<Description xml:lang="sv">Vindruvor</Description>
|
||||
@@ -148,6 +156,7 @@
|
||||
<Description xml:lang="fr">Lion</Description>
|
||||
<Description xml:lang="he">אריה</Description>
|
||||
<Description xml:lang="id">Singa</Description>
|
||||
+ <Description xml:lang="it">Leone</Description>
|
||||
<Description xml:lang="nl">Leeuw</Description>
|
||||
<Description xml:lang="ru">Лев</Description>
|
||||
<Description xml:lang="sv">Lejon</Description>
|
||||
@@ -166,6 +175,7 @@
|
||||
<Description xml:lang="fr">Singe</Description>
|
||||
<Description xml:lang="he">קוף</Description>
|
||||
<Description xml:lang="id">Monyet</Description>
|
||||
+ <Description xml:lang="it">Scimmia</Description>
|
||||
<Description xml:lang="nl">Aap</Description>
|
||||
<Description xml:lang="ru">Обезьяна</Description>
|
||||
<Description xml:lang="sv">Apa</Description>
|
||||
@@ -183,6 +193,7 @@
|
||||
<Description xml:lang="fr">Avion</Description>
|
||||
<Description xml:lang="he">מטוס</Description>
|
||||
<Description xml:lang="id">Pesawat</Description>
|
||||
+ <Description xml:lang="it">Aereo</Description>
|
||||
<Description xml:lang="nl">Vliegtuig</Description>
|
||||
<Description xml:lang="ru">Самолёт</Description>
|
||||
<Description xml:lang="sv">Flygplan</Description>
|
||||
@@ -200,6 +211,7 @@
|
||||
<Description xml:lang="fr">Arbre</Description>
|
||||
<Description xml:lang="he">עץ</Description>
|
||||
<Description xml:lang="id">Pohon</Description>
|
||||
+ <Description xml:lang="it">Albero</Description>
|
||||
<Description xml:lang="nl">Boom</Description>
|
||||
<Description xml:lang="ru">Дерево</Description>
|
||||
<Description xml:lang="sv">Träd</Description>
|
19
childsplay-0.90.2-locale_it_font.patch
Normal file
19
childsplay-0.90.2-locale_it_font.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- childsplay-0.90.2/utils.py 2008-01-17 15:38:56.000000000 +0100
|
||||
+++ utils.py 2008-09-30 10:18:24.000000000 +0200
|
||||
@@ -169,6 +169,16 @@
|
||||
else:
|
||||
print "No suitable fonset found for your locale"
|
||||
rtl_ttf = None
|
||||
+ elif loc=='it':
|
||||
+ if os.path.exists('/usr/lib/site-python/pygame/freesansbold.ttf'):
|
||||
+ rtl_ttf = '/usr/lib/site-python/pygame/freesansbold.ttf'
|
||||
+ elif os.path.exists('/usr/lib/site-python/pygame/freesansbold.ttf'):
|
||||
+ rtl_ttf = '/usr/lib/site-python/pygame/freesansbold.ttf'
|
||||
+ elif os.path.exists(os.path.join(DATADIR,'freesansbold.ttf')):
|
||||
+ rtl_ttf = os.path.join(DATADIR,'freesansbold.ttf')
|
||||
+ else:
|
||||
+ print "No suitable fonset found for your locale"
|
||||
+ rtl_ttf = None
|
||||
|
||||
if UT_DEBUG: print "using fontset %s \nfor RTL locale" % rtl_ttf
|
||||
return (rtl,rtl_ttf,rtl_seq)
|
19
childsplay-1.6-python-SQLAlchemy-0.7.patch
Normal file
19
childsplay-1.6-python-SQLAlchemy-0.7.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- a/SPDataManager.py
|
||||
+++ b/SPDataManager.py
|
||||
@@ -38,7 +38,6 @@
|
||||
|
||||
try:
|
||||
import sqlalchemy as sqla
|
||||
- import sqlalchemy.exceptions as sqlae
|
||||
import SQLTables
|
||||
except ImportError:
|
||||
module_logger.exception("No sqlalchemy package found")
|
||||
@@ -82,7 +81,7 @@
|
||||
sqltb = SQLTables.SqlTables(self.metadata)
|
||||
# returns lookup table to get table objects by name and creates tables
|
||||
self.tables = sqltb._create_tables(self.metadata, self.engine)
|
||||
- except (AttributeError, sqlae.SQLAlchemyError), info:
|
||||
+ except (AttributeError, sqla.exceptions.SQLAlchemyError), info:
|
||||
self.logger.exception("Failed to start the DBase, %s" % info)
|
||||
raise MyError, info
|
||||
else:
|
BIN
childsplay-icon.png
Normal file
BIN
childsplay-icon.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 2.7 KiB |
13
childsplay.desktop
Normal file
13
childsplay.desktop
Normal file
@ -0,0 +1,13 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Childsplay
|
||||
GenericName=Educational suite
|
||||
GenericName[it]=Suite di giochi educativi
|
||||
Comment=Educational game starting at 2 years old
|
||||
Comment[it]=Giochi educativi a partire dai due anni
|
||||
Exec=childsplay
|
||||
Icon=/usr/share/pixmaps/childsplay.png
|
||||
Terminal=false
|
||||
StartupNotify=false
|
||||
Type=Application
|
||||
Categories=Application;Education;
|
127
childsplay.spec
Normal file
127
childsplay.spec
Normal file
@ -0,0 +1,127 @@
|
||||
%define plugins_ver 0.90
|
||||
%define asound_ver 0.9.1
|
||||
|
||||
Name: childsplay
|
||||
Version: 1.6
|
||||
Release: 3mamba
|
||||
Summary: A 'suite' of educational games for young children
|
||||
Group: Applications/Educational
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Aleph0 <aleph0@openmamba.org>
|
||||
URL: http://childsplay.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/project/schoolsplay/childsplay_sp/%{version}/childsplay-%{version}.tgz
|
||||
#Source1: http://downloads.sourceforge.net/sourceforge/%{name}/childsplay_plugins-%{plugins_ver}.tgz
|
||||
Source2: %{name}.desktop
|
||||
Source3: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_ca-%{asound_ver}.tgz
|
||||
Source4: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_de-%{asound_ver}.tgz
|
||||
Source5: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_es-%{asound_ver}.tgz
|
||||
Source6: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_fr-%{asound_ver}.tgz
|
||||
Source7: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_it-%{asound_ver}.tgz
|
||||
Source8: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_nl-%{asound_ver}.tgz
|
||||
Source9: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_ru-%{asound_ver}.tgz
|
||||
Source10: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_sv-0.9.2.tgz
|
||||
Source11: http://downloads.sourceforge.net/project/schoolsplay/alphabet_sounds/%{asound_ver}/alphabet_sounds_pt-%{asound_ver}.tgz
|
||||
#Source13: http://downloads.sourceforge.net/sourceforge/%{name}/childsplay_plugins_lfc-%{plugins_ver}.tgz
|
||||
Source14: %{name}-icon.png
|
||||
Patch0: childsplay-0.80.3.1-install.patch
|
||||
Patch1: childsplay-0.90.2-locale_it.patch
|
||||
Patch2: childsplay-0.90.2-install_plugins_lfc.patch
|
||||
Patch3: childsplay-0.90.2-install_plugins.patch
|
||||
Patch4: childsplay-0.90.2-install_score.patch
|
||||
Patch5: childsplay-0.80.3.1-childsplay_sh.patch
|
||||
Patch6: childsplay-0.90.2-it_lang_plugins_lfc.patch
|
||||
Patch7: childsplay-0.90.2-locale_it_font.patch
|
||||
Patch8: childsplay-1.6-python-SQLAlchemy-0.7.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libpython-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libSDL_image-devel
|
||||
BuildRequires: libSDL_ttf-devel
|
||||
BuildRequires: libSDL_mixer-devel
|
||||
BuildRequires: libogg-devel
|
||||
Requires: python-pygame
|
||||
Requires: python-SQLAlchemy
|
||||
Requires: libfribidi
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Childsplay is a 'suite' of educational games for young children, like gcompris, but without the overkill of c/c++ and the gnome environ.
|
||||
Also the use of the SDL libraries makes smooth animation and the playing of sound very easy.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch8 -p1
|
||||
|
||||
%build
|
||||
sed -i "s|/usr/local|%{buildroot}%{_prefix}|" setup.py
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
python setup.py install \
|
||||
--root=%{buildroot} << _EOF
|
||||
|
||||
_EOF
|
||||
|
||||
# create the italian locale from the italian catalog file
|
||||
##install -d locale/it/LC_MESSAGES
|
||||
##/usr/bin/msgfmt doc/po/it/childsplay.po \
|
||||
## -o locale/it/LC_MESSAGES/%{name}.mo
|
||||
|
||||
#LANG=${LANG/\.UTF-8/} ./INSTALL.sh %{buildroot}
|
||||
#ln -sf /var/games/childsplay.score %{buildroot}%{_datadir}/childsplay/Data/childsplay.score
|
||||
|
||||
%{find_lang} %{name}_sp
|
||||
|
||||
#cd childsplay_plugins-%{plugins_ver}
|
||||
#./install.sh %{buildroot}
|
||||
|
||||
install -D -m644 %{SOURCE2} %{buildroot}%{_datadir}/applications/%{name}.desktop
|
||||
install -D -m0644 %{SOURCE14} %{buildroot}%{_datadir}/pixmaps/childsplay.png
|
||||
sed -i "s,%{buildroot},," %{buildroot}%{python_sitearch}/childsplay_sp/SPBasePaths.py
|
||||
rm -f %{buildroot}%{python_sitearch}/childsplay_sp/SPBasePaths.py
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files -f %{name}_sp.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/childsplay
|
||||
%{python_sitearch}/childsplay_sp-*-py*.egg-info
|
||||
%dir %{python_sitearch}/childsplay_sp
|
||||
%{python_sitearch}/childsplay_sp/*
|
||||
%dir %{_datadir}/childsplay_sp
|
||||
%{_datadir}/childsplay_sp/*
|
||||
%{_datadir}/pixmaps/childsplay.png
|
||||
%{_datadir}/applications/childsplay.desktop
|
||||
%dir %{_datadir}/sp_alphabetsounds
|
||||
%{_datadir}/sp_alphabetsounds/*
|
||||
%dir %{_docdir}/childsplay_sp
|
||||
%{_docdir}/childsplay_sp/*
|
||||
|
||||
%changelog
|
||||
* Sun Jun 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6-3mamba
|
||||
- python 2.7 mass rebuild
|
||||
|
||||
* Tue Dec 04 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6-2mamba
|
||||
- added requirement and patch for python-SQLAlchemy 0.7
|
||||
|
||||
* Sat Jul 21 2012 Automatic Build System <autodist@mambasoft.it> 1.6-1mamba
|
||||
- update to 1.6
|
||||
|
||||
* Wed Aug 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.90.2-2mamba
|
||||
- fixed a syntax error in locale_it_font.patch preventing program to start
|
||||
- fixed desktop menu icon
|
||||
|
||||
* Tue Sep 30 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.90.2-1mamba
|
||||
- update to version 0.90.2
|
||||
|
||||
* Fri Nov 11 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.80.3.1-1qilnx
|
||||
- update to version 0.80.3.1 by autospec
|
||||
|
||||
* Wed Jan 19 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.80.1-1qilnx
|
||||
- package created by autospec
|
||||
- added italian localisation
|
Loading…
Reference in New Issue
Block a user