package created using the webbuild interface [release 4.4.0-1mamba;Mon May 06 2024]
This commit is contained in:
parent
499dfa6280
commit
2a84070f45
@ -1,2 +1,4 @@
|
||||
# cgns
|
||||
|
||||
The CFD General Notation System (CGNS) provides a standard for recording and recovering computer data associated with the numerical solution of fluid dynamics equations.
|
||||
|
||||
|
254
cgns-4.4.0-install-dirs.patch
Normal file
254
cgns-4.4.0-install-dirs.patch
Normal file
@ -0,0 +1,254 @@
|
||||
diff -rupN --no-dereference CGNS-4.4.0/CMakeLists.txt CGNS-4.4.0-new/CMakeLists.txt
|
||||
--- CGNS-4.4.0/CMakeLists.txt 2023-06-15 06:00:19.000000000 +0200
|
||||
+++ CGNS-4.4.0-new/CMakeLists.txt 2024-01-30 08:39:26.686498728 +0100
|
||||
@@ -424,7 +424,7 @@ if (CGNS_BUILD_SHARED)
|
||||
set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
|
||||
|
||||
# the RPATH to be used when installing
|
||||
- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
|
||||
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${LIB_INSTALL_DIR}")
|
||||
|
||||
# add the automatically determined parts of the RPATH
|
||||
# which point to directories outside the build tree to the install RPATH
|
||||
diff -rupN --no-dereference CGNS-4.4.0/src/cgnstools/cgnscalc/CMakeLists.txt CGNS-4.4.0-new/src/cgnstools/cgnscalc/CMakeLists.txt
|
||||
--- CGNS-4.4.0/src/cgnstools/cgnscalc/CMakeLists.txt 2023-06-15 06:00:19.000000000 +0200
|
||||
+++ CGNS-4.4.0-new/src/cgnstools/cgnscalc/CMakeLists.txt 2024-01-30 08:39:26.689498725 +0100
|
||||
@@ -59,11 +59,11 @@ endif ()
|
||||
if (WIN32)
|
||||
install(TARGETS
|
||||
calcwish
|
||||
- RUNTIME DESTINATION bin)
|
||||
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(PROGRAMS
|
||||
cgnscalc.bat
|
||||
unitconv.bat
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(FILES
|
||||
cgnscalc.tcl
|
||||
unitconv.tcl
|
||||
@@ -78,21 +78,21 @@ if (WIN32)
|
||||
else ()
|
||||
install(TARGETS
|
||||
calcwish
|
||||
- RUNTIME DESTINATION bin/cgnstools)
|
||||
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR}/cgnstools)
|
||||
install(PROGRAMS
|
||||
cgnscalc.sh
|
||||
- DESTINATION bin
|
||||
+ DESTINATION ${BIN_INSTALL_DIR}
|
||||
RENAME cgnscalc)
|
||||
install(PROGRAMS
|
||||
cgnscalc.desktop
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(PROGRAMS
|
||||
unitconv.sh
|
||||
- DESTINATION bin
|
||||
+ DESTINATION ${BIN_INSTALL_DIR}
|
||||
RENAME unitconv)
|
||||
install(PROGRAMS
|
||||
unitconv.desktop
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(FILES
|
||||
cgnscalc.tcl
|
||||
unitconv.tcl
|
||||
diff -rupN --no-dereference CGNS-4.4.0/src/cgnstools/cgnsplot/CMakeLists.txt CGNS-4.4.0-new/src/cgnstools/cgnsplot/CMakeLists.txt
|
||||
--- CGNS-4.4.0/src/cgnstools/cgnsplot/CMakeLists.txt 2023-06-15 06:00:19.000000000 +0200
|
||||
+++ CGNS-4.4.0-new/src/cgnstools/cgnsplot/CMakeLists.txt 2024-01-30 08:39:26.692498722 +0100
|
||||
@@ -66,10 +66,10 @@ endif ()
|
||||
if (WIN32)
|
||||
install(TARGETS
|
||||
plotwish
|
||||
- RUNTIME DESTINATION bin)
|
||||
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(PROGRAMS
|
||||
cgnsplot.bat
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(FILES
|
||||
cgnsplot.tcl
|
||||
cgnsplot.ico
|
||||
@@ -80,14 +80,14 @@ if (WIN32)
|
||||
else ()
|
||||
install(TARGETS
|
||||
plotwish
|
||||
- RUNTIME DESTINATION bin/cgnstools)
|
||||
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR}/cgnstools)
|
||||
install(PROGRAMS
|
||||
cgnsplot.sh
|
||||
- DESTINATION bin
|
||||
+ DESTINATION ${BIN_INSTALL_DIR}
|
||||
RENAME cgnsplot)
|
||||
install(PROGRAMS
|
||||
cgnsplot.desktop
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(FILES
|
||||
cgnsplot.tcl
|
||||
cgnsplot.ico
|
||||
diff -rupN --no-dereference CGNS-4.4.0/src/cgnstools/cgnsview/CMakeLists.txt CGNS-4.4.0-new/src/cgnstools/cgnsview/CMakeLists.txt
|
||||
--- CGNS-4.4.0/src/cgnstools/cgnsview/CMakeLists.txt 2023-06-15 06:00:19.000000000 +0200
|
||||
+++ CGNS-4.4.0-new/src/cgnstools/cgnsview/CMakeLists.txt 2024-01-30 08:39:26.696498718 +0100
|
||||
@@ -63,11 +63,11 @@ endif ()
|
||||
if (WIN32)
|
||||
install(TARGETS
|
||||
cgiowish
|
||||
- RUNTIME DESTINATION bin)
|
||||
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(PROGRAMS
|
||||
cgnsview.bat
|
||||
cgnsnodes.bat
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(FILES
|
||||
cgnsview.tcl
|
||||
cgns.tcl
|
||||
@@ -79,21 +79,21 @@ if (WIN32)
|
||||
else ()
|
||||
install(TARGETS
|
||||
cgiowish
|
||||
- RUNTIME DESTINATION bin/cgnstools)
|
||||
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR}/cgnstools)
|
||||
install(PROGRAMS
|
||||
cgnsview.sh
|
||||
- DESTINATION bin
|
||||
+ DESTINATION ${BIN_INSTALL_DIR}
|
||||
RENAME cgnsview)
|
||||
install(PROGRAMS
|
||||
cgnsview.desktop
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(PROGRAMS
|
||||
cgnsnodes.sh
|
||||
- DESTINATION bin
|
||||
+ DESTINATION ${BIN_INSTALL_DIR}
|
||||
RENAME cgnsnodes)
|
||||
install(PROGRAMS
|
||||
cgnsnodes.desktop
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(FILES
|
||||
cgnsview.tcl
|
||||
cgns.tcl
|
||||
diff -rupN --no-dereference CGNS-4.4.0/src/cgnstools/CMakeLists.txt CGNS-4.4.0-new/src/cgnstools/CMakeLists.txt
|
||||
--- CGNS-4.4.0/src/cgnstools/CMakeLists.txt 2023-06-15 06:00:19.000000000 +0200
|
||||
+++ CGNS-4.4.0-new/src/cgnstools/CMakeLists.txt 2024-01-30 08:39:26.699498715 +0100
|
||||
@@ -111,7 +111,7 @@ set CG_LIB_DIR=${WIN_INSTALL_DIR}\\share
|
||||
|
||||
install(PROGRAMS
|
||||
${CMAKE_CURRENT_BINARY_DIR}/cgconfig.bat
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
else ()
|
||||
file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/cgconfig
|
||||
"CG_BIN_DIR=${CMAKE_INSTALL_PREFIX}/bin; export CG_BIN_DIR
|
||||
@@ -120,6 +120,6 @@ CG_LIB_DIR=${CMAKE_INSTALL_PREFIX}/share
|
||||
|
||||
install(PROGRAMS
|
||||
${CMAKE_CURRENT_BINARY_DIR}/cgconfig
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
endif ()
|
||||
|
||||
diff -rupN --no-dereference CGNS-4.4.0/src/cgnstools/utilities/CMakeLists.txt CGNS-4.4.0-new/src/cgnstools/utilities/CMakeLists.txt
|
||||
--- CGNS-4.4.0/src/cgnstools/utilities/CMakeLists.txt 2023-06-15 06:00:19.000000000 +0200
|
||||
+++ CGNS-4.4.0-new/src/cgnstools/utilities/CMakeLists.txt 2024-01-30 08:39:26.702498712 +0100
|
||||
@@ -243,7 +243,7 @@ if (WIN32)
|
||||
interpolate_cgns
|
||||
update_ngon
|
||||
cgns_info
|
||||
- RUNTIME DESTINATION bin)
|
||||
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR})
|
||||
install(FILES
|
||||
conserved.cnv
|
||||
convert.tcl
|
||||
@@ -281,7 +281,7 @@ else ()
|
||||
interpolate_cgns
|
||||
update_ngon
|
||||
cgns_info
|
||||
- RUNTIME DESTINATION bin/cgnstools)
|
||||
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR}/cgnstools)
|
||||
install(FILES
|
||||
conserved.cnv
|
||||
convert.tcl
|
||||
diff -rupN --no-dereference CGNS-4.4.0/src/CMakeLists.txt CGNS-4.4.0-new/src/CMakeLists.txt
|
||||
--- CGNS-4.4.0/src/CMakeLists.txt 2023-06-15 06:00:19.000000000 +0200
|
||||
+++ CGNS-4.4.0-new/src/CMakeLists.txt 2024-01-30 08:39:26.706498708 +0100
|
||||
@@ -45,7 +45,7 @@ set(SYSCFLAGS "")
|
||||
set(CFGFLAGS "")
|
||||
set(LIBS "")
|
||||
|
||||
-file(TO_NATIVE_PATH ${CMAKE_INSTALL_PREFIX}/lib LIBDIR)
|
||||
+file(TO_NATIVE_PATH ${CMAKE_INSTALL_PREFIX}/${LIB_INSTALL_DIR} LIBDIR)
|
||||
file(TO_NATIVE_PATH ${CMAKE_INSTALL_PREFIX}/include INCLUDEDIR)
|
||||
file(TO_NATIVE_PATH ${CMAKE_C_COMPILER} CC)
|
||||
if (WIN32)
|
||||
@@ -683,10 +683,10 @@ endif ()
|
||||
# for windows, need to install both cgnsdll.dll and cgnsdll.lib
|
||||
install (TARGETS ${install_targets}
|
||||
EXPORT cgns-targets
|
||||
- LIBRARY DESTINATION lib COMPONENT libraries
|
||||
- ARCHIVE DESTINATION lib COMPONENT libraries
|
||||
- RUNTIME DESTINATION bin COMPONENT libraries
|
||||
- INCLUDES DESTINATION include)
|
||||
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR} COMPONENT libraries
|
||||
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR} COMPONENT libraries
|
||||
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR} COMPONENT libraries
|
||||
+ INCLUDES DESTINATION ${INCLUDE_INSTALL_DIR})
|
||||
|
||||
# Set the install path of the header files
|
||||
set(headers
|
||||
@@ -725,13 +725,13 @@ endif ()
|
||||
|
||||
# Set the install path of the header files
|
||||
install(FILES ${headers}
|
||||
- DESTINATION include)
|
||||
+ DESTINATION ${INCLUDE_INSTALL_DIR})
|
||||
|
||||
#if (NOT CGNS_EXTERNALLY_CONFIGURE)
|
||||
install(EXPORT cgns-targets
|
||||
FILE cgns-targets.cmake
|
||||
NAMESPACE CGNS::
|
||||
- DESTINATION lib/cmake/cgns
|
||||
+ DESTINATION ${LIB_INSTALL_DIR}/cmake/cgns
|
||||
)
|
||||
#endif()
|
||||
|
||||
diff -rupN --no-dereference CGNS-4.4.0/src/tools/CMakeLists.txt CGNS-4.4.0-new/src/tools/CMakeLists.txt
|
||||
--- CGNS-4.4.0/src/tools/CMakeLists.txt 2023-06-15 06:00:19.000000000 +0200
|
||||
+++ CGNS-4.4.0-new/src/tools/CMakeLists.txt 2024-01-30 08:39:26.709498705 +0100
|
||||
@@ -72,27 +72,27 @@ install(TARGETS
|
||||
cgnslist
|
||||
cgnsnames
|
||||
cgnscompress
|
||||
- RUNTIME DESTINATION bin)
|
||||
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR})
|
||||
|
||||
if (WIN32)
|
||||
install(PROGRAMS
|
||||
cgnsupdate.bat
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
if (CGNS_ENABLE_HDF5)
|
||||
install(PROGRAMS
|
||||
adf2hdf.bat
|
||||
hdf2adf.bat
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
endif ()
|
||||
else ()
|
||||
install(PROGRAMS
|
||||
cgnsupdate
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
if (CGNS_ENABLE_HDF5)
|
||||
install(PROGRAMS
|
||||
adf2hdf
|
||||
hdf2adf
|
||||
- DESTINATION bin)
|
||||
+ DESTINATION ${BIN_INSTALL_DIR})
|
||||
endif ()
|
||||
endif ()
|
||||
|
120
cgns.spec
Normal file
120
cgns.spec
Normal file
@ -0,0 +1,120 @@
|
||||
Name: cgns
|
||||
Version: 4.4.0
|
||||
Release: 1mamba
|
||||
Summary: A standard for recording and recovering computer data associated with the numerical solution of fluid dynamics equations
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://cgns.org/
|
||||
Source: https://github.com/CGNS/CGNS.git/v%{version}/CGNS-%{version}.tar.bz2
|
||||
Patch0: cgns-4.4.0-install-dirs.patch
|
||||
License: Zlib
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: gcc-fortran
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXmu-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglu-devel
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libhdf5-devel
|
||||
BuildRequires: libtcl-devel
|
||||
BuildRequires: libtk-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description
|
||||
The CFD General Notation System (CGNS) provides a standard for recording and recovering computer data associated with the numerical solution of fluid dynamics equations.
|
||||
|
||||
%package -n lib%{name}
|
||||
Group: System/Libraries
|
||||
Summary: Shared libraries for %{name}
|
||||
|
||||
%description -n lib%{name}
|
||||
This package contains shared libraries for %{name}.
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n CGNS-%{version}
|
||||
%patch 0 -p1 -b .install-dirs
|
||||
|
||||
%build
|
||||
%cmake \
|
||||
-DBIN_INSTALL_DIR=%{_bindir} \
|
||||
-DLIB_INSTALL_DIR=%{_libdir} \
|
||||
-DINCLUDE_INSTALL_DIR=%{_includedir} \
|
||||
-DCMAKE_SKIP_RPATH=ON \
|
||||
-DCGNS_ENABLE_TESTS=ON \
|
||||
-DCGNS_ENABLE_FORTRAN=ON \
|
||||
-DCGNS_BUILD_CGNSTOOLS=ON \
|
||||
-DCGNS_ENABLE_HDF5=ON
|
||||
|
||||
%cmake_build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%cmake_install
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/adf2hdf
|
||||
%{_bindir}/cgconfig
|
||||
%{_bindir}/cgnscalc
|
||||
%{_bindir}/cgnscalc.desktop
|
||||
%{_bindir}/cgnscheck
|
||||
%{_bindir}/cgnscompress
|
||||
%{_bindir}/cgnsconvert
|
||||
%{_bindir}/cgnsdiff
|
||||
%{_bindir}/cgnslist
|
||||
%{_bindir}/cgnsnames
|
||||
%{_bindir}/cgnsnodes
|
||||
%{_bindir}/cgnsnodes.desktop
|
||||
%{_bindir}/cgnsplot
|
||||
%{_bindir}/cgnsplot.desktop
|
||||
%dir %{_bindir}/cgnstools
|
||||
%{_bindir}/cgnstools/*
|
||||
%{_bindir}/cgnsupdate
|
||||
%{_bindir}/cgnsview
|
||||
%{_bindir}/cgnsview.desktop
|
||||
%{_bindir}/hdf2adf
|
||||
%{_bindir}/unitconv
|
||||
%{_bindir}/unitconv.desktop
|
||||
%dir %{_datadir}/cgnstools
|
||||
%{_datadir}/cgnstools/*
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libcgns.so.*
|
||||
%doc src/LICENSE
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/cgns*
|
||||
%dir %{_libdir}/cmake/cgns
|
||||
%{_libdir}/cmake/cgns/cgns-targets*.cmake
|
||||
%{_libdir}/libcgns.a
|
||||
%{_libdir}/libcgns.so
|
||||
%doc README.md
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon May 06 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.0-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user