automatic version update by autodist [release 1.2.3-1mamba;Mon May 27 2024]
This commit is contained in:
parent
407ca70134
commit
e383af8fa1
@ -1,39 +0,0 @@
|
|||||||
diff -Nru cgit-0.8.3.4.orig/Makefile cgit-0.8.3.4/Makefile
|
|
||||||
--- cgit-0.8.3.4.orig/Makefile 2010-09-27 08:00:47.000000000 +0200
|
|
||||||
+++ cgit-0.8.3.4/Makefile 2013-08-12 15:05:18.796843671 +0200
|
|
||||||
@@ -8,6 +8,7 @@
|
|
||||||
GIT_VER = 1.7.3
|
|
||||||
GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
|
|
||||||
INSTALL = install
|
|
||||||
+LIBDIR := /usr/lib
|
|
||||||
|
|
||||||
# Define NO_STRCASESTR if you don't have strcasestr.
|
|
||||||
#
|
|
||||||
@@ -68,7 +69,7 @@
|
|
||||||
$(QUIET_CC)$(CC) -o $*.o -c $(CFLAGS) $<
|
|
||||||
|
|
||||||
|
|
||||||
-EXTLIBS = git/libgit.a git/xdiff/lib.a -lz -lcrypto -lpthread
|
|
||||||
+EXTLIBS = $(LIBDIR)/libgit.a $(LIBDIR)/libgit_xdiff.a -lz -lcrypto -lpthread
|
|
||||||
OBJECTS =
|
|
||||||
OBJECTS += cache.o
|
|
||||||
OBJECTS += cgit.o
|
|
||||||
@@ -124,17 +125,13 @@
|
|
||||||
CFLAGS += -DNO_STRCASESTR
|
|
||||||
endif
|
|
||||||
|
|
||||||
-cgit: $(OBJECTS) libgit
|
|
||||||
+cgit: $(OBJECTS)
|
|
||||||
$(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o cgit $(OBJECTS) $(EXTLIBS)
|
|
||||||
|
|
||||||
cgit.o: VERSION
|
|
||||||
|
|
||||||
-include $(OBJECTS:.o=.d)
|
|
||||||
|
|
||||||
-libgit:
|
|
||||||
- $(QUIET_SUBDIR0)git $(QUIET_SUBDIR1) NO_CURL=1 libgit.a
|
|
||||||
- $(QUIET_SUBDIR0)git $(QUIET_SUBDIR1) NO_CURL=1 xdiff/lib.a
|
|
||||||
-
|
|
||||||
test: all
|
|
||||||
$(QUIET_SUBDIR0)tests $(QUIET_SUBDIR1) all
|
|
||||||
|
|
1003
cgit-1.2.3-git-2.34.1.patch
Normal file
1003
cgit-1.2.3-git-2.34.1.patch
Normal file
File diff suppressed because it is too large
Load Diff
23
cgit.spec
23
cgit.spec
@ -1,7 +1,7 @@
|
|||||||
%define cgidir %(apxs -q cgidir 2>/dev/null)
|
%define cgidir %(apxs -q cgidir 2>/dev/null)
|
||||||
%define serverdir %(apxs -q htdocsdir 2>/dev/null)
|
%define serverdir %(apxs -q htdocsdir 2>/dev/null)
|
||||||
|
|
||||||
%define gitver 2.0.1
|
%define gitver 2.34.1
|
||||||
# To create a customized installation of cgit:
|
# To create a customized installation of cgit:
|
||||||
# autospec -u cgit -a5 \
|
# autospec -u cgit -a5 \
|
||||||
# -d "installdir=%serverdir/../www.example.com, \
|
# -d "installdir=%serverdir/../www.example.com, \
|
||||||
@ -25,29 +25,28 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: %{?sitename:%sitename-website-}cgit
|
Name: %{?sitename:%sitename-website-}cgit
|
||||||
Version: 0.10.2
|
Version: 1.2.3
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A web frontend for git repositories
|
Summary: A web frontend for git repositories
|
||||||
Group: Applications/Web
|
Group: Applications/Web
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://git.zx2c4.com/cgit/
|
URL: https://git.zx2c4.com/cgit/
|
||||||
Source: http://git.zx2c4.com/cgit/snapshot/cgit-%{version}.tar.xz
|
Source: http://git.zx2c4.com/cgit/snapshot/cgit-%{version}.tar.xz
|
||||||
Source1: cgitrc
|
Source1: cgitrc
|
||||||
# cgit statically depends on a specific git version
|
# cgit statically depends on a specific git version
|
||||||
Source2: http://kernel.org/pub/software/scm/git/git-%{gitver}.tar.xz
|
Source2: http://kernel.org/pub/software/scm/git/git-%{gitver}.tar.xz
|
||||||
Patch0: cgit-0.8.3.4-external-git.patch
|
Patch0: cgit-1.2.3-git-2.34.1.patch
|
||||||
Patch1: cgit-0.8.3.1-cflags.patch
|
Patch1: cgit-0.8.3.1-cflags.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
#user(apache): unidentified build requirement
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libopenssl-devel
|
BuildRequires: libluajit-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: perl-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
Requires: cgit-common = %{version}-%{release}
|
Requires: cgit-common = %{version}-%{release}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
An attempt to create a fast web interface for the git scm, using a builtin cache to decrease server io-pressure.
|
An attempt to create a fast web interface for the git scm, using a builtin cache to decrease server io-pressure.
|
||||||
@ -59,13 +58,14 @@ Group: Applications/Web
|
|||||||
%description common
|
%description common
|
||||||
Common files provided by cgit.
|
Common files provided by cgit.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -a2
|
%setup -q -a2
|
||||||
rmdir git
|
rmdir git
|
||||||
mv git-%{gitver} git
|
mv git-%{gitver} git
|
||||||
|
|
||||||
#% patch0 -p1
|
%patch 0 -p1 -b .git-2.34.1
|
||||||
#% patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%make V=1 \
|
%make V=1 \
|
||||||
@ -150,6 +150,9 @@ EOF
|
|||||||
#README cgitrc.5.txt
|
#README cgitrc.5.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 27 2024 Automatic Build System <autodist@openmamba.org> 1.2.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Thu Oct 09 2014 Automatic Build System <autodist@mambasoft.it> 0.10.2-1mamba
|
* Thu Oct 09 2014 Automatic Build System <autodist@mambasoft.it> 0.10.2-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user