rebuilt with python3 == 3.11 [release 2.9.0-2mamba;Sun Feb 11 2024]
This commit is contained in:
parent
a20a988ecd
commit
49dd656350
77
certbot.spec
77
certbot.spec
@ -1,6 +1,6 @@
|
||||
Name: certbot
|
||||
Version: 2.9.0
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: A fully-featured, extensible client for the Let's Encrypt CA
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -10,33 +10,27 @@ URL: https://letsencrypt.org
|
||||
Source: https://github.com/certbot/certbot.git/v%{version}/certbot-%{version}.tar.bz2
|
||||
Source1: certbot-renew.service
|
||||
Source2: certbot-renew.timer
|
||||
Patch0: python-letsencrypt-0.1.0-use-configargparse.patch
|
||||
Patch1: letsencrypt-0.1.1-acme-0.1.1.patch
|
||||
License: Apache License 2.0
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: (python3.10dist(pyopenssl) < 23.1 or python3.10dist(pyopenssl) > 23.1)
|
||||
BuildRequires: libpython310-devel
|
||||
BuildRequires: python3.10dist(acme)
|
||||
BuildRequires: python3.10dist(configargparse)
|
||||
BuildRequires: python3.10dist(configobj)
|
||||
BuildRequires: python3.10dist(cryptography)
|
||||
BuildRequires: python3.10dist(distro)
|
||||
BuildRequires: python3.10dist(josepy)
|
||||
BuildRequires: python3.10dist(parsedatetime)
|
||||
BuildRequires: python3.10dist(pyopenssl)
|
||||
BuildRequires: python3.10dist(pyparsing)
|
||||
BuildRequires: python3.10dist(pyrfc3339)
|
||||
BuildRequires: python3.10dist(python-augeas)
|
||||
BuildRequires: python3.10dist(pytz)
|
||||
BuildRequires: python3.10dist(setuptools)
|
||||
BuildRequires: (python3.11dist(pyopenssl) < 23.1 or python3.11dist(pyopenssl) > 23.1)
|
||||
BuildRequires: libpython311-devel
|
||||
BuildRequires: python3.11dist(acme)
|
||||
BuildRequires: python3.11dist(configargparse)
|
||||
BuildRequires: python3.11dist(configobj)
|
||||
BuildRequires: python3.11dist(cryptography)
|
||||
BuildRequires: python3.11dist(distro)
|
||||
BuildRequires: python3.11dist(josepy)
|
||||
BuildRequires: python3.11dist(parsedatetime)
|
||||
BuildRequires: python3.11dist(pyopenssl)
|
||||
BuildRequires: python3.11dist(pyparsing)
|
||||
BuildRequires: python3.11dist(pyrfc3339)
|
||||
BuildRequires: python3.11dist(python-augeas)
|
||||
BuildRequires: python3.11dist(pytz)
|
||||
BuildRequires: python3.11dist(setuptools)
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: python-augeas-py310
|
||||
#Requires: python-mock-py3
|
||||
Requires: python-psutil-py310
|
||||
Requires: python-requests-py310
|
||||
Requires: python-six-py310
|
||||
#Requires: python-zope-component-py3
|
||||
#Requires: python-zope-interface-py3
|
||||
Requires: python-psutil-py3
|
||||
Requires: python-requests-py3
|
||||
Requires: python-six-py3
|
||||
Provides: letsencrypt
|
||||
Obsoletes: letsencrypt < 1.31.0
|
||||
|
||||
@ -65,13 +59,11 @@ This package provides the Nginx plugin.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#% patch0 -p1
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
for d in certbot certbot-{apache,nginx}; do
|
||||
cd $d
|
||||
CFLAGS="%{optflags}" %{__python310} -m build --no-isolation --wheel
|
||||
CFLAGS="%{optflags}" %{__python3} -m build --no-isolation --wheel
|
||||
cd ..
|
||||
done
|
||||
|
||||
@ -79,7 +71,7 @@ done
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
for d in certbot certbot-{apache,nginx}; do
|
||||
cd $d
|
||||
%{__python310} -m installer --destdir=%{buildroot} dist/*.whl
|
||||
%{__python3} -m installer --destdir=%{buildroot} dist/*.whl
|
||||
cd ..
|
||||
done
|
||||
|
||||
@ -107,27 +99,30 @@ ln -s %{python310_sitelib}/certbot_apache/_
|
||||
%attr(0700,root,root) %dir %{_localstatedir}/log/letsencrypt
|
||||
%{_unitdir}/certbot-renew.service
|
||||
%{_unitdir}/certbot-renew.timer
|
||||
%dir %{python310_sitelib}/certbot-%{version}.dist-info
|
||||
%{python310_sitelib}/certbot-%{version}.dist-info/*
|
||||
%dir %{python310_sitelib}/certbot
|
||||
%{python310_sitelib}/certbot/*
|
||||
%dir %{python3_sitelib}/certbot-%{version}.dist-info
|
||||
%{python3_sitelib}/certbot-%{version}.dist-info/*
|
||||
%dir %{python3_sitelib}/certbot
|
||||
%{python3_sitelib}/certbot/*
|
||||
%doc LICENSE.txt
|
||||
|
||||
%files apache
|
||||
%defattr(-,root,root)
|
||||
%dir %{python310_sitelib}/certbot_apache-%{version}.dist-info
|
||||
%{python310_sitelib}/certbot_apache-%{version}.dist-info/*
|
||||
%dir %{python310_sitelib}/certbot_apache
|
||||
%{python310_sitelib}/certbot_apache/*
|
||||
%dir %{python3_sitelib}/certbot_apache-%{version}.dist-info
|
||||
%{python3_sitelib}/certbot_apache-%{version}.dist-info/*
|
||||
%dir %{python3_sitelib}/certbot_apache
|
||||
%{python3_sitelib}/certbot_apache/*
|
||||
|
||||
%files nginx
|
||||
%defattr(-,root,root)
|
||||
%dir %{python310_sitelib}/certbot_nginx-%{version}.dist-info
|
||||
%{python310_sitelib}/certbot_nginx-%{version}.dist-info/*
|
||||
%dir %{python310_sitelib}/certbot_nginx
|
||||
%{python310_sitelib}/certbot_nginx/*
|
||||
%dir %{python3_sitelib}/certbot_nginx-%{version}.dist-info
|
||||
%{python3_sitelib}/certbot_nginx-%{version}.dist-info/*
|
||||
%dir %{python3_sitelib}/certbot_nginx
|
||||
%{python3_sitelib}/certbot_nginx/*
|
||||
|
||||
%changelog
|
||||
* Sun Feb 11 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.0-2mamba
|
||||
- rebuilt with python3 == 3.11
|
||||
|
||||
* Fri Feb 09 2024 Automatic Build System <autodist@openmamba.org> 2.9.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
@ -1,22 +0,0 @@
|
||||
From edd20a8b8d97c6b374bb30089d1b3e9103c0876b Mon Sep 17 00:00:00 2001
|
||||
From: Peter Eckersley <pde@eff.org>
|
||||
Date: Fri, 25 Dec 2015 11:11:03 -0800
|
||||
Subject: [PATCH] The actual 0.1.1 release
|
||||
|
||||
Due to bug #1966, the previous v0.1.1 tag was missing a version change to
|
||||
letsencrypt/__init__.py this commit and the v0.1.1-corrected tag are the code
|
||||
that was signed and uploaded to PyPI.
|
||||
---
|
||||
letsencrypt/__init__.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/letsencrypt/__init__.py b/letsencrypt/__init__.py
|
||||
index 1c7815f..e011c3f 100644
|
||||
--- a/letsencrypt/__init__.py
|
||||
+++ b/letsencrypt/__init__.py
|
||||
@@ -1,4 +1,4 @@
|
||||
"""Let's Encrypt client."""
|
||||
|
||||
# version number like 1.2.3a0, must have at least 2 parts, like 1.2
|
||||
-__version__ = '0.2.0.dev0'
|
||||
+__version__ = '0.1.1'
|
@ -1,12 +0,0 @@
|
||||
diff -Nru letsencrypt-0.1.0.orig/letsencrypt/cli.py letsencrypt-0.1.0/letsencrypt/cli.py
|
||||
--- letsencrypt-0.1.0.orig/letsencrypt/cli.py 2015-12-05 12:40:17.000000000 +0100
|
||||
+++ letsencrypt-0.1.0/letsencrypt/cli.py 2015-12-05 14:45:01.689634411 +0100
|
||||
@@ -13,7 +13,7 @@
|
||||
import time
|
||||
import traceback
|
||||
|
||||
-import configargparse
|
||||
+from configargparse import configargparse
|
||||
import OpenSSL
|
||||
import zope.component
|
||||
import zope.interface.exceptions
|
Loading…
Reference in New Issue
Block a user