cereal/cereal.spec

72 lines
2.6 KiB
RPMSpec

Name: cereal
Version: 1.3.2
Release: 1mamba
Summary: A C++11 library for serialization
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://uscilab.github.io/cereal/
Source: https://github.com/USCiLab/cereal.git/v%{version}/cereal-%{version}.tar.bz2
License: BSD
## AUTOBUILDREQ-BEGIN
## AUTOBUILDREQ-END
BuildRequires: cmake
%description
cereal is a header-only C++11 serialization library. cereal takes arbitrary data types and reversibly turns them into different representations, such as compact binary encodings, XML, or JSON. cereal was designed to be fast, light-weight, and easy to extend - it has no external dependencies and can be easily bundled with other code or used standalone.
%package -n lib%{name}-devel
Group: Development/Libraries
Summary: A C++11 header-only library for serialization
%description -n lib%{name}-devel
cereal is a header-only C++11 serialization library. cereal takes arbitrary data types and reversibly turns them into different representations, such as compact binary encodings, XML, or JSON. cereal was designed to be fast, light-weight, and easy to extend - it has no external dependencies and can be easily bundled with other code or used standalone.
This package contains header files for developing applications that use %{name}.
#% debug_package
%prep
%setup -q
%build
%cmake -d build
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -n lib%{name}-devel
%defattr(-,root,root)
%dir %{_includedir}/cereal
%{_includedir}/cereal/*.hpp
%dir %{_includedir}/cereal/archives
%{_includedir}/cereal/archives/*.hpp
%dir %{_includedir}/cereal/details
%{_includedir}/cereal/details/*.hpp
%dir %{_includedir}/cereal/external
%{_includedir}/cereal/external/*
%dir %{_includedir}/cereal/external/rapidjson
%{_includedir}/cereal/external/rapidjson/*
%dir %{_includedir}/cereal/external/rapidxml
%{_includedir}/cereal/external/rapidxml/*
%dir %{_includedir}/cereal/types
%{_includedir}/cereal/types/*
%dir %{_libdir}/cmake/cereal
%{_libdir}/cmake/cereal/cereal*.cmake
%doc LICENSE README.md
%changelog
* Mon Feb 28 2022 Automatic Build System <autodist@mambasoft.it> 1.3.2-1mamba
- automatic version update by autodist
* Sat Jan 22 2022 Automatic Build System <autodist@mambasoft.it> 1.3.1-1mamba
- automatic version update by autodist
* Tue Sep 29 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0-1mamba
- package created using the webbuild interface