automatic update by autodist [release 1.6.1-1mamba;Thu Jul 21 2011]
This commit is contained in:
parent
f5f9e43e7c
commit
fe71aab071
@ -1,2 +1,4 @@
|
||||
# celestia
|
||||
|
||||
The free space simulation that lets you explore our universe in three dimensions.
|
||||
|
||||
|
26
celestia-1.5.0-gcc44.patch
Normal file
26
celestia-1.5.0-gcc44.patch
Normal file
@ -0,0 +1,26 @@
|
||||
Fix build with GCC 4.4
|
||||
|
||||
Lubomir Rintel (Fedora Astronomy) <lkundrak@v3.sk>
|
||||
|
||||
diff -up celestia-1.5.0/src/celengine/overlay.h.gcc44 celestia-1.5.0/src/celengine/overlay.h
|
||||
--- celestia-1.5.0/src/celengine/overlay.h.gcc44 2009-03-01 15:23:44.000000000 +0100
|
||||
+++ celestia-1.5.0/src/celengine/overlay.h 2009-03-01 15:23:50.000000000 +0100
|
||||
@@ -12,6 +12,7 @@
|
||||
|
||||
#include <string>
|
||||
#include <iostream>
|
||||
+#include <cstdio>
|
||||
#include <celtxf/texturefont.h>
|
||||
|
||||
|
||||
diff -up celestia-1.5.0/src/celengine/star.cpp.gcc44 celestia-1.5.0/src/celengine/star.cpp
|
||||
--- celestia-1.5.0/src/celengine/star.cpp.gcc44 2009-03-01 15:26:57.000000000 +0100
|
||||
+++ celestia-1.5.0/src/celengine/star.cpp 2009-03-01 15:27:22.000000000 +0100
|
||||
@@ -9,6 +9,7 @@
|
||||
|
||||
#include <celmath/mathlib.h>
|
||||
#include <cstring>
|
||||
+#include <cstdio>
|
||||
#include <cassert>
|
||||
#include "celestia.h"
|
||||
#include "astro.h"
|
11
celestia-1.5.1-gcc44.patch
Normal file
11
celestia-1.5.1-gcc44.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -Nru celestia-1.5.1.orig/src/celestia/oggtheoracapture.cpp celestia-1.5.1/src/celestia/oggtheoracapture.cpp
|
||||
--- celestia-1.5.1.orig/src/celestia/oggtheoracapture.cpp 2009-05-18 13:09:14.000000000 +0200
|
||||
+++ celestia-1.5.1/src/celestia/oggtheoracapture.cpp 2009-05-18 13:09:33.000000000 +0200
|
||||
@@ -62,6 +62,7 @@
|
||||
#include <cstdlib>
|
||||
#include <cstdio>
|
||||
#include <cmath>
|
||||
+#include <ctime>
|
||||
#include <celutil/debug.h>
|
||||
#include <celutil/util.h>
|
||||
#include "../celengine/gl.h"
|
45
celestia-1.6.0-gcc45.patch
Normal file
45
celestia-1.6.0-gcc45.patch
Normal file
@ -0,0 +1,45 @@
|
||||
--- src/celengine/overlay.h 2010-04-16 17:43:35.000000000 +0200
|
||||
+++ src/celengine/overlay.h 2010-04-16 17:43:55.000000000 +0200
|
||||
@@ -12,6 +12,7 @@
|
||||
|
||||
#include <string>
|
||||
#include <iostream>
|
||||
+#include <cstdio>
|
||||
#include <celtxf/texturefont.h>
|
||||
|
||||
|
||||
--- src/celmath/mathlib.h 2010-04-16 18:16:09.000000000 +0200
|
||||
+++ src/celmath/mathlib.h 2010-04-16 18:16:18.000000000 +0200
|
||||
@@ -44,11 +44,6 @@ template<class T> T radToDeg(T r)
|
||||
return r * 180 / static_cast<T>(PI);
|
||||
}
|
||||
|
||||
-template<class T> T abs(T x)
|
||||
-{
|
||||
- return (x < 0) ? -x : x;
|
||||
-}
|
||||
-
|
||||
template<class T> T square(T x)
|
||||
{
|
||||
return x * x;
|
||||
--- src/celengine/star.cpp 2010-04-16 18:17:42.000000000 +0200
|
||||
+++ src/celengine/star.cpp 2010-04-16 18:17:57.000000000 +0200
|
||||
@@ -10,6 +10,7 @@
|
||||
#include <celmath/mathlib.h>
|
||||
#include <cstring>
|
||||
#include <cassert>
|
||||
+#include <cstdio>
|
||||
#include "celestia.h"
|
||||
#include "astro.h"
|
||||
#include "orbit.h"
|
||||
--- src/celestia/celx_object.cpp 2010-04-16 18:19:52.000000000 +0200
|
||||
+++ src/celestia/celx_object.cpp 2010-04-16 18:22:37.000000000 +0200
|
||||
@@ -773,7 +773,7 @@ static int object_mark(lua_State* l)
|
||||
markAlpha = 1.0f;
|
||||
|
||||
Color markColorAlpha(0.0f, 1.0f, 0.0f, 0.9f);
|
||||
- markColorAlpha = Color::Color(markColor, markAlpha);
|
||||
+ markColorAlpha = Color(markColor, markAlpha);
|
||||
|
||||
const char* markLabel = celx.safeGetString(6, WrongType, "Fifth argument to object:mark must be a string");
|
||||
if (markLabel == NULL)
|
22
celestia-1.6.0-png14.patch
Normal file
22
celestia-1.6.0-png14.patch
Normal file
@ -0,0 +1,22 @@
|
||||
$NetBSD: patch-ap,v 1.1 2010/06/13 22:44:58 wiz Exp $
|
||||
|
||||
--- src/celengine/image.cpp.orig 2005-07-19 20:30:54.000000000 +0000
|
||||
+++ src/celengine/image.cpp
|
||||
@@ -78,7 +78,7 @@ using namespace std;
|
||||
// Define various expansion transformations for old versions of libpng
|
||||
#if PNG_LIBPNG_VER < 10004
|
||||
#define png_set_palette_to_rgb(p) png_set_expand(p)
|
||||
-#define png_set_gray_1_2_4_to_8(p) png_set_expand(p)
|
||||
+#define png_set_expand_gray_1_2_4_to_8(p) png_set_expand(p)
|
||||
#define png_set_tRNS_to_alpha(p) png_set_expand(p)
|
||||
#endif // PNG_LIBPNG_VER < 10004
|
||||
|
||||
@@ -720,7 +720,7 @@ Image* LoadPNGImage(const string& filena
|
||||
|
||||
if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
|
||||
{
|
||||
- png_set_gray_1_2_4_to_8(png_ptr);
|
||||
+ png_set_expand_gray_1_2_4_to_8(png_ptr);
|
||||
}
|
||||
|
||||
if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS))
|
14
celestia-1.6.0-png15.patch
Normal file
14
celestia-1.6.0-png15.patch
Normal file
@ -0,0 +1,14 @@
|
||||
$NetBSD$
|
||||
|
||||
Fix build with png-1.5.
|
||||
|
||||
--- src/celestia/imagecapture.cpp.orig 2004-11-16 07:14:20.000000000 +0000
|
||||
+++ src/celestia/imagecapture.cpp
|
||||
@@ -30,6 +30,7 @@ extern "C" {
|
||||
#else
|
||||
#include "png.h"
|
||||
#endif
|
||||
+#include <zlib.h>
|
||||
|
||||
// Define png_jmpbuf() in case we are using a pre-1.0.6 version of libpng
|
||||
#ifndef png_jmpbuf
|
12
celestia.desktop
Normal file
12
celestia.desktop
Normal file
@ -0,0 +1,12 @@
|
||||
|
||||
[Desktop Entry]
|
||||
Name=Celestia space simulator
|
||||
GenericName=Space simulator
|
||||
Comment=A real-time space simulator
|
||||
Categories=Application;Education;Astronomy;Science;
|
||||
Icon=celestia.png
|
||||
Exec=celestia
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Encoding=UTF-8
|
||||
StartupNotify=true
|
189
celestia.spec
Normal file
189
celestia.spec
Normal file
@ -0,0 +1,189 @@
|
||||
Name: celestia
|
||||
Version: 1.6.1
|
||||
Release: 1mamba
|
||||
Summary: the free space simulation that lets you explore our universe in three dimensions
|
||||
Group: Graphical Desktop/Applications/Educational
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.shatters.net/celestia
|
||||
Source0: http://puzzle.dl.sourceforge.net/sourceforge/celestia/celestia-%{version}.tar.gz
|
||||
Source1: %{name}.desktop
|
||||
Patch2: %{name}-1.5.0-gcc44.patch
|
||||
Patch3: %{name}-1.5.1-gcc44.patch
|
||||
Patch4: %{name}-1.6.0-png14.patch
|
||||
Patch5: %{name}-1.6.0-png15.patch
|
||||
Patch6: %{name}-1.6.0-gcc45.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: kdelibs-devel
|
||||
BuildRequires: libart_lgpl-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libidn-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblcms-devel
|
||||
BuildRequires: liblua-devel
|
||||
BuildRequires: libmng-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libqt-devel
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtheora-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libXcursor-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXft-devel
|
||||
BuildRequires: libXi-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXmu-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The free space simulation that lets you explore our universe in three dimensions.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch2 -p1
|
||||
%patch3 -p1
|
||||
#%patch4 -p0
|
||||
%patch5 -p0
|
||||
#%patch6 -p0
|
||||
|
||||
%build
|
||||
export QTDIR=%{_qt3_prefix} KDEDIR=%{prefix} QTLIB=%{_qt3_libdir}
|
||||
CFLAGS="%{optflags}" \
|
||||
CXXFLAGS="%{optflags}" \
|
||||
%configure \
|
||||
--with-kde \
|
||||
--bindir=%{_bindir} \
|
||||
--sbindir=%{_sbindir} \
|
||||
--libdir=%{_libdir} \
|
||||
--includedir=%{_includedir} \
|
||||
--datadir=%{_datadir} \
|
||||
--infodir=%{_infodir} \
|
||||
--localedir=%{_localedir}/celestia \
|
||||
--mandir=%{_mandir} \
|
||||
--docdir=%{_docdir}/celestia \
|
||||
--with-extra-includes=%{_kdeincludedir} \
|
||||
--with-extra-libs=%{_libdir}/kde3 \
|
||||
--with-extra-libs=%{_libdir}/kde3 \
|
||||
--enable-cairo \
|
||||
--with-x \
|
||||
--with-xinerama
|
||||
%make
|
||||
###### -j1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
install -D %{S:1} \
|
||||
%{buildroot}%{_datadir}/applications/%{name}.desktop
|
||||
##rm -r %{buildroot}/celestia.schemas
|
||||
|
||||
#%find_lang %{name}-f %{name}.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/celestia
|
||||
%{_localedir}/*/LC_MESSAGES/celestia_constellations.mo
|
||||
%{_localedir}/*/LC_MESSAGES/celestia.mo
|
||||
%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/applnk/Edutainment/Science/celestia.desktop
|
||||
%{_datadir}/apps/celestia
|
||||
%{_datadir}/config/celestiarc
|
||||
%{_datadir}/icons/hicolor/*/apps/celestia.png
|
||||
%{_datadir}/mimelnk/application/x-celestia-script.desktop
|
||||
%{_datadir}/services/celestia.protocol
|
||||
%dir %{_datadir}/celestia
|
||||
%{_datadir}/celestia/COPYING
|
||||
%{_datadir}/celestia/COPYING_*
|
||||
%{_datadir}/celestia/bookmarks.xml
|
||||
%{_datadir}/celestia/celestia.cfg
|
||||
%{_datadir}/celestia/celestiaui.rc
|
||||
%{_datadir}/celestia/*.cel
|
||||
%{_datadir}/celestia/*.txt
|
||||
%dir %{_datadir}/celestia/data
|
||||
%{_datadir}/celestia/data/*.ssc
|
||||
%{_datadir}/celestia/data/*.dat
|
||||
#%{_datadir}/celestia/data/*.xyz
|
||||
%{_datadir}/celestia/data/*.dsc
|
||||
%{_datadir}/celestia/data/*.stc
|
||||
%dir %{_datadir}/celestia/extras-standard
|
||||
%{_datadir}/celestia/extras-standard/*
|
||||
%dir %{_datadir}/celestia/extras
|
||||
%{_datadir}/celestia/extras/*.ssc
|
||||
%dir %{_datadir}/celestia/favicons
|
||||
%{_datadir}/celestia/favicons/*.png
|
||||
%dir %{_datadir}/celestia/fonts
|
||||
%{_datadir}/celestia/fonts/*.txf
|
||||
%dir %{_datadir}/celestia/models
|
||||
%{_datadir}/celestia/models/*.png
|
||||
%{_datadir}/celestia/models/*.3ds
|
||||
%{_datadir}/celestia/models/*.cmod
|
||||
%{_datadir}/celestia/models/*.cms
|
||||
%dir %{_datadir}/celestia/scripts
|
||||
%{_datadir}/celestia/scripts/*
|
||||
%dir %{_datadir}/celestia/shaders
|
||||
%{_datadir}/celestia/shaders/*.vp
|
||||
%{_datadir}/celestia/shaders/*.fp
|
||||
%dir %{_datadir}/celestia/splash
|
||||
%{_datadir}/celestia/splash/splash.png
|
||||
%dir %{_datadir}/celestia/textures
|
||||
%{_datadir}/celestia/textures/flare.jpg
|
||||
%{_datadir}/celestia/textures/logo.png
|
||||
%dir %{_datadir}/celestia/textures/hires
|
||||
%{_datadir}/celestia/textures/hires/*.jpg
|
||||
%dir %{_datadir}/celestia/textures/lores
|
||||
%{_datadir}/celestia/textures/lores/*.jpg
|
||||
%{_datadir}/celestia/textures/lores/*.png
|
||||
%dir %{_datadir}/celestia/textures/medres
|
||||
%{_datadir}/celestia/textures/medres/*.jpg
|
||||
%{_datadir}/celestia/textures/medres/*.png
|
||||
%dir %{_docdir}/HTML/en/celestia
|
||||
%doc %{_docdir}/HTML/en/celestia/common
|
||||
%doc %{_docdir}/HTML/en/celestia/*.jpg
|
||||
%doc %{_docdir}/HTML/en/celestia/index.cache.bz2
|
||||
%doc %{_docdir}/HTML/en/celestia/index.docbook
|
||||
%doc AUTHORS ChangeLog INSTALL README
|
||||
|
||||
%changelog
|
||||
* Thu Jul 21 2011 Automatic Build System <autodist@mambasoft.it> 1.6.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Mar 26 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-2mamba
|
||||
- rebuilt with libjpeg 8
|
||||
- added patches for libpng 1.4 and 1.5
|
||||
|
||||
* Tue Jul 14 2009 Automatic Build System <autodist@mambasoft.it> 1.6.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon May 18 2009 Automatic Build System <autodist@mambasoft.it> 1.5.1-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Sun Jun 08 2008 gil <puntogil@libero.it> 1.5.1-1mamba
|
||||
- update to 1.5.1
|
||||
- removed patch
|
||||
|
||||
* Fri Jul 08 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 1.3.2-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user