remove obsolete build requirements [release 1.2.5-2mamba;Mon Jul 08 2024]
This commit is contained in:
parent
e3dd8c554c
commit
104866af95
@ -1,79 +0,0 @@
|
||||
Submitted By: DJ Lucas <dj at linuxfromscratch dot org>
|
||||
Date: 2009-09-28
|
||||
Initial Package Version: 1.2.2
|
||||
Upstream Status: unknown
|
||||
Origin: http://bugs.gentoo.org/270414
|
||||
Description: Fix compilation with recent versions of glibc.
|
||||
|
||||
diff -puNr cdrdao-1.2.2.orig/scsilib/include/schily.h cdrdao-1.2.2/scsilib/include/schily.h
|
||||
--- cdrdao-1.2.2.orig/scsilib/include/schily.h 2004-03-05 01:30:40.000000000 +0100
|
||||
+++ cdrdao-1.2.2/scsilib/include/schily.h 2009-03-11 21:55:15.000000000 +0100
|
||||
@@ -108,7 +108,7 @@ extern int fexecle __PR((const char *, F
|
||||
/* 6th arg not const, fexecv forces av[ac] = NULL */
|
||||
extern int fexecv __PR((const char *, FILE *, FILE *, FILE *, int,
|
||||
char **));
|
||||
-extern int fexecve __PR((const char *, FILE *, FILE *, FILE *,
|
||||
+extern int f_execve __PR((const char *, FILE *, FILE *, FILE *,
|
||||
char * const *, char * const *));
|
||||
extern int fspawnv __PR((FILE *, FILE *, FILE *, int, char * const *));
|
||||
extern int fspawnl __PR((FILE *, FILE *, FILE *,
|
||||
@@ -187,7 +187,7 @@ extern char *fillbytes __PR((void *, int
|
||||
extern char *findbytes __PR((const void *, int, char));
|
||||
extern int findline __PR((const char *, char, const char *,
|
||||
int, char **, int));
|
||||
-extern int getline __PR((char *, int));
|
||||
+extern int get_line __PR((char *, int));
|
||||
extern int getstr __PR((char *, int));
|
||||
extern int breakline __PR((char *, char, char **, int));
|
||||
extern int getallargs __PR((int *, char * const**, const char *, ...));
|
||||
diff -puNr cdrdao-1.2.2.orig/scsilib/libscg/scsitransp.c cdrdao-1.2.2/scsilib/libscg/scsitransp.c
|
||||
--- cdrdao-1.2.2.orig/scsilib/libscg/scsitransp.c 2004-06-17 22:20:27.000000000 +0200
|
||||
+++ cdrdao-1.2.2/scsilib/libscg/scsitransp.c 2009-03-11 21:54:24.000000000 +0100
|
||||
@@ -323,7 +323,7 @@ scg_yes(msg)
|
||||
|
||||
js_printf("%s", msg);
|
||||
flush();
|
||||
- if (getline(okbuf, sizeof (okbuf)) == EOF)
|
||||
+ if (get_line(okbuf, sizeof (okbuf)) == EOF)
|
||||
exit(EX_BAD);
|
||||
if (streql(okbuf, "y") || streql(okbuf, "yes") ||
|
||||
streql(okbuf, "Y") || streql(okbuf, "YES"))
|
||||
diff -puNr cdrdao-1.2.2.orig/scsilib/libschily/fexec.c cdrdao-1.2.2/scsilib/libschily/fexec.c
|
||||
--- cdrdao-1.2.2.orig/scsilib/libschily/fexec.c 2004-06-06 13:50:24.000000000 +0200
|
||||
+++ cdrdao-1.2.2/scsilib/libschily/fexec.c 2009-03-11 21:55:06.000000000 +0100
|
||||
@@ -159,7 +159,7 @@ fexecle(name, in, out, err, va_alist)
|
||||
} while (p != NULL);
|
||||
va_end(args);
|
||||
|
||||
- ret = fexecve(name, in, out, err, av, env);
|
||||
+ ret = f_execve(name, in, out, err, av, env);
|
||||
if (av != xav)
|
||||
free(av);
|
||||
return (ret);
|
||||
@@ -173,11 +173,11 @@ fexecv(name, in, out, err, ac, av)
|
||||
char *av[];
|
||||
{
|
||||
av[ac] = NULL; /* force list to be null terminated */
|
||||
- return (fexecve(name, in, out, err, av, environ));
|
||||
+ return (f_execve(name, in, out, err, av, environ));
|
||||
}
|
||||
|
||||
EXPORT int
|
||||
-fexecve(name, in, out, err, av, env)
|
||||
+f_execve(name, in, out, err, av, env)
|
||||
const char *name;
|
||||
FILE *in, *out, *err;
|
||||
char * const av[], * const env[];
|
||||
diff -puNr cdrdao-1.2.2.orig/scsilib/libschily/stdio/fgetline.c cdrdao-1.2.2/scsilib/libschily/stdio/fgetline.c
|
||||
--- cdrdao-1.2.2.orig/scsilib/libschily/stdio/fgetline.c 2004-08-08 13:02:05.000000000 +0200
|
||||
+++ cdrdao-1.2.2/scsilib/libschily/stdio/fgetline.c 2009-03-11 21:54:04.000000000 +0100
|
||||
@@ -64,7 +64,7 @@ fgetline(f, buf, len)
|
||||
}
|
||||
|
||||
EXPORT int
|
||||
-getline(buf, len)
|
||||
+get_line(buf, len)
|
||||
char *buf;
|
||||
int len;
|
||||
{
|
||||
|
@ -1,28 +0,0 @@
|
||||
diff -Nru cdrdao-1.2.3.orig//dao/sg_err.cc cdrdao-1.2.3/dao/sg_err.cc
|
||||
--- cdrdao-1.2.3.orig//dao/sg_err.cc 2009-09-28 12:12:03.000000000 +0200
|
||||
+++ cdrdao-1.2.3/dao/sg_err.cc 2010-05-30 00:39:42.481766725 +0200
|
||||
@@ -26,7 +26,7 @@
|
||||
static const unsigned char scsi_command_size[8] = { 6, 10, 10, 12,
|
||||
12, 12, 10, 10 };
|
||||
|
||||
-#define COMMAND_SIZE(opcode) scsi_command_size[((opcode) >> 5) & 7]
|
||||
+#define _COMMAND_SIZE(opcode) scsi_command_size[((opcode) >> 5) & 7]
|
||||
|
||||
static const char unknown[] = "UNKNOWN";
|
||||
|
||||
@@ -126,7 +126,7 @@
|
||||
void sg_print_command (const unsigned char * command) {
|
||||
int i,s;
|
||||
print_opcode(command[0]);
|
||||
- for ( i = 1, s = COMMAND_SIZE(command[0]); i < s; ++i)
|
||||
+ for ( i = 1, s = _COMMAND_SIZE(command[0]); i < s; ++i)
|
||||
log_message(0, "%02x ", command[i]);
|
||||
log_message(0, "");
|
||||
}
|
||||
@@ -660,5 +660,5 @@
|
||||
|
||||
int sg_get_command_size(unsigned char opcode)
|
||||
{
|
||||
- return COMMAND_SIZE(opcode);
|
||||
+ return _COMMAND_SIZE(opcode);
|
||||
}
|
27
cdrdao.spec
27
cdrdao.spec
@ -2,7 +2,7 @@
|
||||
|
||||
Name: cdrdao
|
||||
Version: 1.2.5
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: Cdrdao records audio or data CD-Rs in disk-at-once (DAO) mode
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
@ -10,8 +10,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://cdrdao.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/cdrdao/cdrdao-%{version}.tar.bz2
|
||||
Patch0: %{name}-1.2.3-gcc44.patch
|
||||
Patch1: %{name}-1.2.2-glibc210_fixes-1.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -34,26 +32,13 @@ BuildRequires: libpangomm1-devel
|
||||
BuildRequires: libsigc++2-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: setup
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libsigc++2-devel
|
||||
%if %with_gui
|
||||
BuildRequires: libgtkmm-devel
|
||||
BuildRequires: libgnomeuimm-devel
|
||||
BuildRequires: libgnome-devel
|
||||
BuildRequires: libgnomemm-devel
|
||||
BuildRequires: libgnomecanvas-devel
|
||||
BuildRequires: libgnomecanvasmm-devel
|
||||
BuildRequires: gconfmm-devel
|
||||
BuildRequires: libglademm-devel
|
||||
BuildRequires: libglade-devel
|
||||
BuildRequires: libgnomeui-devel
|
||||
BuildRequires: libbonoboui-devel
|
||||
%endif
|
||||
|
||||
%description
|
||||
Cdrdao records audio or data CD-Rs in disk-at-once (DAO) mode based on a textual description of the CD contents.
|
||||
|
||||
%if %with_gui
|
||||
%package gcdmaster
|
||||
Summary: GNOME frontend for cdrdao
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
@ -61,14 +46,11 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description gcdmaster
|
||||
Gnome frontend for cdrdao.
|
||||
%endif
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
export PKG_CONFIG=%{_bindir}/pkg-config
|
||||
@ -118,6 +100,9 @@ export PKG_CONFIG=%{_bindir}/pkg-config
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jul 08 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.5-2mamba
|
||||
- remove obsolete build requirements
|
||||
|
||||
* Wed Feb 08 2023 Automatic Build System <autodist@mambasoft.it> 1.2.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user