automatic rebuild by autodist [release 0.2.1-2mamba;Thu Sep 05 2013]
This commit is contained in:
parent
af911a7273
commit
80e352ffa6
@ -1,2 +1,4 @@
|
|||||||
# ccze
|
# ccze
|
||||||
|
|
||||||
|
CCZE is a robust and modular log coloriser, with plugins for apm, exim, fetchmail, httpd, postfix, procmail, squid, syslog, ulogd, vsftpd, xferlog and more.
|
||||||
|
|
||||||
|
30
ccze-0.2.1-argp.patch
Normal file
30
ccze-0.2.1-argp.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -uprk.orig ccze-0.2.1.orig/src/ccze.c ccze-0.2.1/src/ccze.c
|
||||||
|
--- ccze-0.2.1.orig/src/ccze.c 2003-05-13 22:09:30 +0400
|
||||||
|
+++ ccze-0.2.1/src/ccze.c 2004-05-19 20:21:02 +0400
|
||||||
|
@@ -209,7 +209,7 @@ parse_opt (int key, char *arg, struct ar
|
||||||
|
}
|
||||||
|
break;
|
||||||
|
case 'a':
|
||||||
|
- plugin = strtok (optarg, "=");
|
||||||
|
+ plugin = strtok (arg, "=");
|
||||||
|
value = strtok (NULL, "\n");
|
||||||
|
ccze_plugin_argv_set (plugin, value);
|
||||||
|
break;
|
||||||
|
@@ -249,7 +249,7 @@ parse_opt (int key, char *arg, struct ar
|
||||||
|
ccze_config.remfac = 1;
|
||||||
|
break;
|
||||||
|
case 'm':
|
||||||
|
- subopts = optarg;
|
||||||
|
+ subopts = arg;
|
||||||
|
while (*subopts != '\0')
|
||||||
|
{
|
||||||
|
switch (getsubopt (&subopts, m_subopts, &value))
|
||||||
|
@@ -273,7 +273,7 @@ parse_opt (int key, char *arg, struct ar
|
||||||
|
}
|
||||||
|
break;
|
||||||
|
case 'o':
|
||||||
|
- subopts = optarg;
|
||||||
|
+ subopts = arg;
|
||||||
|
while (*subopts != '\0')
|
||||||
|
{
|
||||||
|
switch (getsubopt (&subopts, o_subopts, &value))
|
11
ccze-0.2.1-configure.patch
Normal file
11
ccze-0.2.1-configure.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- ccze-0.2.1.orig/configure.ac
|
||||||
|
+++ ccze-0.2.1/configure.ac
|
||||||
|
@@ -84,8 +84,6 @@
|
||||||
|
AC_TYPE_SIZE_T
|
||||||
|
AC_TYPE_SIGNAL
|
||||||
|
|
||||||
|
-AC_CHECK_TYPE(error_t, int)
|
||||||
|
-
|
||||||
|
dnl **********************
|
||||||
|
dnl * Library functions
|
||||||
|
dnl **********************
|
11
ccze-0.2.1-gcc4.patch
Normal file
11
ccze-0.2.1-gcc4.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- ccze-0.2.1/src/Makefile.in.orig 2003-05-13 20:09:30.000000000 +0200
|
||||||
|
+++ ccze-0.2.1/src/Makefile.in 2007-07-14 16:59:34.000000000 +0200
|
||||||
|
@@ -22,7 +22,7 @@
|
||||||
|
-Wbad-function-cast -Wsign-compare -Wchar-subscripts \
|
||||||
|
-Wcomment -Wformat -Wformat-nonliteral -Wformat-security \
|
||||||
|
-Wimplicit -Wmain -Wmissing-braces -Wparentheses \
|
||||||
|
- -Wreturn-type -Wswitch -Wmulticharacter \
|
||||||
|
+ -Wreturn-type -Wswitch \
|
||||||
|
-Wmissing-noreturn -Wmissing-declarations @WFLAGS_3X@
|
||||||
|
WFLAGS_ICC = -Wall -wd193,279,810,869,1418,1419
|
||||||
|
WFLAGS_3X = -Wsequence-point -Wdiv-by-zero -W -Wunused \
|
20
ccze-0.2.1-man.patch
Normal file
20
ccze-0.2.1-man.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- ccze-0.2.1.orig/doc/ccze.1.in
|
||||||
|
+++ ccze-0.2.1/doc/ccze.1.in
|
||||||
|
@@ -94,7 +94,7 @@
|
||||||
|
|
||||||
|
If \fIcssfile\fR is set, then CCZE will not inline the Cascading Style
|
||||||
|
Sheet information into the outputted HTML, but include a link to the
|
||||||
|
-external stylesheet given in this paramater.
|
||||||
|
+external stylesheet given in this parameter.
|
||||||
|
.TP
|
||||||
|
.B \-p, \-\-plugin \fIPLUGIN\fR
|
||||||
|
While the default action is to load all plugins (see the \fBPlugins\fR
|
||||||
|
@@ -102,7 +102,7 @@
|
||||||
|
plugins will be loaded. If one knows what kind of log will be piped
|
||||||
|
through \fBccze\fR, using this option may result in a slight speedup.
|
||||||
|
.TP
|
||||||
|
-.B \-r, \-\-remove\-facilty
|
||||||
|
+.B \-r, \-\-remove\-facility
|
||||||
|
Syslog\-ng puts the facility level before log messages. With this
|
||||||
|
switch, these can be cut off.
|
||||||
|
.TP
|
11
ccze-0.2.1-mod_syslog.patch
Normal file
11
ccze-0.2.1-mod_syslog.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- ccze-0.2.1.orig/src/mod_syslog.c
|
||||||
|
+++ ccze-0.2.1/src/mod_syslog.c
|
||||||
|
@@ -104,7 +104,7 @@
|
||||||
|
int errptr;
|
||||||
|
|
||||||
|
reg_syslog = pcre_compile ("^(\\S*\\s{1,2}\\d{1,2}\\s\\d\\d:\\d\\d:\\d\\d)"
|
||||||
|
- "\\s(\\S+)\\s((\\S+:?)\\s(.*))$", 0, &error,
|
||||||
|
+ "\\s(\\S+)\\s+((\\S+:?)\\s(.*))$", 0, &error,
|
||||||
|
&errptr, NULL);
|
||||||
|
hints_syslog = pcre_study (reg_syslog, 0, &error);
|
||||||
|
}
|
18
ccze-0.2.1-wordcolor.patch
Normal file
18
ccze-0.2.1-wordcolor.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
--- ccze-0.2.1.orig/src/ccze-wordcolor.c
|
||||||
|
+++ ccze-0.2.1/src/ccze-wordcolor.c
|
||||||
|
@@ -37,13 +37,13 @@
|
||||||
|
"warn", "restart", "exit", "stop", "end", "shutting", "down", "close",
|
||||||
|
"unreach", "can't", "cannot", "skip", "deny", "disable", "ignored",
|
||||||
|
"miss", "oops", "not", "backdoor", "blocking", "ignoring",
|
||||||
|
- "unable", "readonly", "offline", "terminate", "empty"
|
||||||
|
+ "unable", "readonly", "offline", "terminate", "empty", "virus"
|
||||||
|
};
|
||||||
|
|
||||||
|
static char *words_good[] = {
|
||||||
|
"activ", "start", "ready", "online", "load", "ok", "register", "detected",
|
||||||
|
"configured", "enable", "listen", "open", "complete", "attempt", "done",
|
||||||
|
- "check", "listen", "connect", "finish"
|
||||||
|
+ "check", "listen", "connect", "finish", "clean"
|
||||||
|
};
|
||||||
|
|
||||||
|
static char *words_error[] = {
|
66
ccze.spec
Normal file
66
ccze.spec
Normal file
@ -0,0 +1,66 @@
|
|||||||
|
Name: ccze
|
||||||
|
Version: 0.2.1
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: A robust, modular log coloriser
|
||||||
|
Group: Applications/Text
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
||||||
|
URL: http://packages.debian.org/unstable/utils/ccze.html
|
||||||
|
Source: http://ftp.debian.org/debian/pool/main/c/ccze/ccze_%{version}.orig.tar.gz
|
||||||
|
Patch1: %{name}-0.2.1-argp.patch
|
||||||
|
Patch2: %{name}-0.2.1-configure.patch
|
||||||
|
Patch3: %{name}-0.2.1-mod_syslog.patch
|
||||||
|
Patch4: %{name}-0.2.1-wordcolor.patch
|
||||||
|
Patch5: %{name}-0.2.1-man.patch
|
||||||
|
Patch6: %{name}-0.2.1-gcc4.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRequires: libncurses-devel
|
||||||
|
BuildRequires: libpcre-devel
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
CCZE is a robust and modular log coloriser, with plugins for apm, exim, fetchmail, httpd, postfix, procmail, squid, syslog, ulogd, vsftpd, xferlog and more.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
|
%patch6 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
autoreconf -vif
|
||||||
|
%configure \
|
||||||
|
--with-builtins=all
|
||||||
|
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
install -d %{buildroot}/%{_sysconfdir}
|
||||||
|
src/ccze-dump > %{buildroot}/%{_sysconfdir}/%{name}rc
|
||||||
|
|
||||||
|
rm -fr %{buildroot}%{_includedir}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/%{name}*
|
||||||
|
%{_sysconfdir}/%{name}rc
|
||||||
|
%{_mandir}/man1/*
|
||||||
|
%{_mandir}/man7/*
|
||||||
|
%doc AUTHORS COPYING ChangeLog ChangeLog-0.1 NEWS README THANKS
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Sep 05 2013 Automatic Build System <autodist@mambasoft.it> 0.2.1-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Sat Jul 14 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.2.1-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user