automatic version update by autodist [release 24.02.1-1mamba;Sun Mar 24 2024]
This commit is contained in:
parent
b82981fa86
commit
497e551095
@ -1,11 +0,0 @@
|
||||
--- cantor-20.04.0/src/backends/lua/CMakeLists.txt.orig 2020-04-25 14:50:29.066000000 +0200
|
||||
+++ cantor-20.04.0/src/backends/lua/CMakeLists.txt 2020-04-25 14:49:59.745000000 +0200
|
||||
@@ -18,7 +18,7 @@
|
||||
|
||||
include_directories(${LUAJIT_INCLUDE_DIR})
|
||||
|
||||
-target_link_libraries(cantor_luabackend ${LUAJIT_LIBRARY} KF5::SyntaxHighlighting)
|
||||
+target_link_libraries(cantor_luabackend ${LUAJIT_LIBRARY} KF5::SyntaxHighlighting dl)
|
||||
|
||||
if(BUILD_TESTING)
|
||||
add_executable( testlua testlua.cpp)
|
61
cantor.spec
61
cantor.spec
@ -1,14 +1,13 @@
|
||||
Name: cantor
|
||||
Version: 23.08.5
|
||||
Release: 2mamba
|
||||
Version: 24.02.1
|
||||
Release: 1mamba
|
||||
Summary: KDE Frontend to Mathematical Software
|
||||
Group: Graphical Desktop/Applications/Educational
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://kde.org/
|
||||
Source: http://download.kde.org/stable/release-service/%{version}/src/cantor-%{version}.tar.xz
|
||||
Patch0: cantor-20.04.0-luajit-5.1.patch
|
||||
Source: https://download.kde.org/%{stable_kde6}/release-service/%{version}/src/cantor-%{version}.tar.xz
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: gcc-fortran
|
||||
@ -20,7 +19,6 @@ BuildRequires: libQt5WebEngine-devel
|
||||
BuildRequires: libQt5XmlPatterns-devel
|
||||
BuildRequires: libR-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libanalitza-devel
|
||||
BuildRequires: libattica5-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libkarchive-devel
|
||||
@ -91,17 +89,18 @@ This package contains static libraries and header files needed for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake_kde5 -d build
|
||||
%make
|
||||
%cmake_kf6 \
|
||||
-DBUILD_WITH_QT6=OFF
|
||||
|
||||
%cmake_build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
%cmake_install
|
||||
|
||||
%find_lang %{name}5_qt --with-qt --with-html --all-name || touch %{name}5_qt.lang
|
||||
%find_lang %{name} --with-qt --with-html --all-name || touch %{name}.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -114,49 +113,53 @@ exit 0
|
||||
%posttrans
|
||||
/sbin/ldconfig
|
||||
update-desktop-database -q &>/dev/null
|
||||
gtk-update-icon-cache %{_kde5_icondir}/hicolor &>/dev/null
|
||||
gtk-update-icon-cache %{_kf6_icondir}/hicolor &>/dev/null
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
/sbin/ldconfig
|
||||
if [ $1 -eq 0 ]; then
|
||||
update-desktop-database -q &>/dev/null
|
||||
touch --no-create %{_kde5_icondir}/hicolor &>/dev/null
|
||||
gtk-update-icon-cache %{_kde5_icondir}/hicolor &>/dev/null
|
||||
touch --no-create %{_kf6_icondir}/hicolor &>/dev/null
|
||||
gtk-update-icon-cache %{_kf6_icondir}/hicolor &>/dev/null
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%files -f %{name}5_qt.lang
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/cantor
|
||||
%{_bindir}/cantor_*
|
||||
%{_kde5_datadir}/cantor
|
||||
%{_kde5_icondir}/hicolor/*/apps/*.png
|
||||
%{_kde5_kcfgdir}/*.kcfg
|
||||
%{_kde5_libdir}/libcantor_config.so
|
||||
%{_kde5_libdir}/libcantorlibs.so.*
|
||||
%{_libdir}/cantor_pythonbackend.so
|
||||
%dir %{_libdir}/qt5/plugins/cantor
|
||||
%{_libdir}/qt5/plugins/cantor/*
|
||||
%{_libdir}/qt5/plugins/kf5/parts/cantorpart.so
|
||||
%{_datadir}/config.kcfg/octavebackend.kcfg.in
|
||||
%{_datadir}/applications/org.kde.cantor.desktop
|
||||
%{_datadir}/knsrcfiles/cantor*
|
||||
%dir %{_datadir}/kxmlgui5/cantor
|
||||
%{_datadir}/kxmlgui5/cantor/cantor_*.rc
|
||||
%{_kde5_sharedir}/metainfo/org.kde.cantor.appdata.xml
|
||||
%{_datadir}/metainfo/org.kde.cantor.appdata.xml
|
||||
%{_datadir}/mime/packages/cantor.xml
|
||||
%{_kf6_datadir}/cantor
|
||||
%{_kf6_kcfgdir}/*.kcfg
|
||||
%{_kf6_libdir}/libcantor_config.so
|
||||
%{_kf6_libdir}/libcantorlibs.so.*
|
||||
%{_libdir}/cantor_pythonbackend.so
|
||||
%dir %{_libdir}/qt6/plugins/cantor
|
||||
%{_libdir}/qt6/plugins/cantor/*
|
||||
%{_qt6_plugindir}/kf5/parts/cantorpart.so
|
||||
%{_datadir}/config.kcfg/octavebackend.kcfg.in
|
||||
%{_datadir}/knsrcfiles/cantor*
|
||||
%{_kf6_icondir}/hicolor/*/apps/*.png
|
||||
%doc LICENSES
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/cantor
|
||||
%{_includedir}/cantor/*
|
||||
%{_kde5_libdir}/libcantorlibs.so
|
||||
%{_kf6_libdir}/libcantorlibs.so
|
||||
%dir %{_libdir}/cmake/Cantor
|
||||
%{_libdir}/cmake/Cantor/Cantor*.cmake
|
||||
|
||||
%changelog
|
||||
* Sun Mar 24 2024 Automatic Build System <autodist@openmamba.org> 24.02.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Mar 07 2024 Automatic Build System <autodist@openmamba.org> 24.02.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Feb 25 2024 Automatic Build System <autodist@mambasoft.it> 23.08.5-2mamba
|
||||
- rebuilt by autoport with build requirements: libpoppler-devel>=24.02.0-1mamba
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user