automatic version update by autodist [release 5.12.0-1mamba;Sat Mar 06 2021]
This commit is contained in:
parent
7e64161b3f
commit
5ef91eca7e
11
calibre-5.10.1-slug-build-fix.patch
Normal file
11
calibre-5.10.1-slug-build-fix.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- calibre-5.10.1/setup/translations.py.orig 2021-02-10 10:29:11.518360983 +0100
|
||||
+++ calibre-5.10.1/setup/translations.py 2021-02-10 10:37:37.017022669 +0100
|
||||
@@ -159,7 +159,7 @@
|
||||
f.seek(0), f.truncate(), f.write('\n'.join(lines).encode('utf-8'))
|
||||
break
|
||||
else:
|
||||
- raise SystemExit(f'Failed to add file_filter for {slug=} to config file')
|
||||
+ raise SystemExit(f'Failed to add file_filter for slug= to config file')
|
||||
self.git('add .tx/config')
|
||||
self.upload_pot(resource=slug)
|
||||
self.git(['add', dest])
|
13
calibre-5.12.0-python-3.7.patch
Normal file
13
calibre-5.12.0-python-3.7.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- calibre-5.12.0/src/calibre/utils/formatter.py.orig 2021-03-06 21:06:44.587932763 +0100
|
||||
+++ calibre-5.12.0/src/calibre/utils/formatter.py 2021-03-06 21:07:14.202470086 +0100
|
||||
@@ -656,8 +656,8 @@
|
||||
|
||||
def do_node_first_non_empty(self, prog):
|
||||
for expr in prog.expression_list:
|
||||
- if v := self.expr(expr):
|
||||
- return v
|
||||
+ if self.expr(expr):
|
||||
+ return self.expr(expr)
|
||||
return ''
|
||||
|
||||
def do_node_for(self, prog):
|
67
calibre.spec
67
calibre.spec
@ -1,29 +1,31 @@
|
||||
Name: calibre
|
||||
Version: 4.23.0
|
||||
Version: 5.12.0
|
||||
Release: 1mamba
|
||||
Summary: A free and open source e-book library management application
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||
URL: http://calibre-ebook.com
|
||||
URL: https://calibre-ebook.com
|
||||
Source: https://github.com/kovidgoyal/calibre.git/v%{version}/calibre-%{version}.tar.bz2
|
||||
#Source: http://downloads.sourceforge.net/project/calibre/%{version}/calibre-%{version}.tar.xz
|
||||
#Source: http://calibre-ebook.googlecode.com/files/calibre-%{version}.tar.gz
|
||||
Source1: calibre.desktop
|
||||
Patch0: calibre-0.8.33-libpoppler-0.20.patch
|
||||
Patch1: calibre-0.7.59-libpoppler-0.18.patch
|
||||
Patch2: calibre-0.7.59-libpng-1.5.patch
|
||||
Patch3: calibre-0.7.50-python-lxml.patch
|
||||
Patch4: calibre-5.10.1-slug-build-fix.patch
|
||||
Patch5: calibre-5.12.0-python-3.7.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libchm-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libhunspell-devel
|
||||
BuildRequires: libhyphen-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libmtp-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
@ -33,6 +35,7 @@ BuildRequires: libqt5-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libusb-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: python3
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libpython3-devel
|
||||
BuildRequires: libpodofo-devel >= 0.9.3
|
||||
@ -62,7 +65,10 @@ BuildRequires: python-webencodings-py3
|
||||
BuildRequires: PyQt5-devel
|
||||
BuildRequires: PyQt5-py3
|
||||
BuildRequires: pyqtwebengine-py3
|
||||
Requires: PyQt5-py3 >= 5.13.0
|
||||
BuildRequires: PyQt-builder-py3
|
||||
BuildRequires: python-zeroconf-py3
|
||||
BuildRequires: python-ifaddr-py3
|
||||
Requires: PyQt5-py3 >= 5.15.2
|
||||
Requires: pyqtwebengine-py3 >= 5.13.0
|
||||
Requires: python3 >= %python3_version
|
||||
#Requires: BeautifulSoup
|
||||
@ -78,6 +84,7 @@ Requires: python-dateutil-py3
|
||||
Requires: python-feedparser-py3
|
||||
Requires: python-html5lib-py3
|
||||
Requires: python-html5-parser-py3
|
||||
Requires: python-ifaddr-py3
|
||||
Requires: python-lxml-py3
|
||||
Requires: python-mechanize-py3
|
||||
Requires: python-msgpack-py3
|
||||
@ -86,7 +93,8 @@ Requires: python-regex-py3
|
||||
Requires: python-six-py3
|
||||
Requires: python-soupsieve-py3
|
||||
Requires: python-webencodings-py3
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Requires: python-zeroconf-py3
|
||||
Requires: liberation-fonts-ttf
|
||||
|
||||
%description
|
||||
calibre is a free and open source e-book library management application developed by users of e-books for users of e-books.
|
||||
@ -94,6 +102,14 @@ calibre is a free and open source e-book library management application develope
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch4 -p1
|
||||
%patch5 -p1
|
||||
# Use uppercase naming scheme, don't delete config files under fakeroot.
|
||||
sed -e "/import config_dir/,/os.rmdir(config_dir)/d" \
|
||||
-e "s/'ctc-posml'/'text' not in mt and 'pdf' not in mt and 'xhtml'/" \
|
||||
-e "s/^Name=calibre/Name=Calibre/g" \
|
||||
-i src/calibre/linux.py
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -101,13 +117,19 @@ calibre is a free and open source e-book library management application develope
|
||||
export QTWEBENGINE_DISABLE_SANDBOX=1
|
||||
%endif
|
||||
|
||||
CALIBRE_PY3_PORT=1 CFLAGS="%{optflags}" %{__python3} setup.py bootstrap
|
||||
CALIBRE_PY3_PORT=1 CFLAGS="%{optflags}" %{__python3} setup.py build
|
||||
CALIBRE_PY3_PORT=1 CFLAGS="%{optflags}" %{__python3} setup.py resources
|
||||
CFLAGS="%{optflags}" %{__python3} setup.py bootstrap
|
||||
LANG='en_US.UTF-8' %{__python3} setup.py build
|
||||
LANG='en_US.UTF-8' %{__python3} setup.py gui
|
||||
%{__python3} setup.py liberation_fonts --path-to-liberation_fonts /usr/share/fonts/liberation --system-liberation_fonts
|
||||
LANG='en_US.UTF-8' %{__python3} setup.py resources
|
||||
LANG='en_US.UTF-8' %{__python3} setup.py rapydscript
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
CALIBRE_PY3_PORT=1 %{__python3} setup.py install \
|
||||
# If this directory doesn't exist, zsh completion won't install.
|
||||
install -d %{buildroot}%{_datadir}/zsh/site-functions
|
||||
|
||||
%{__python3} setup.py install \
|
||||
--root=%{buildroot}/usr \
|
||||
--staging-libdir=%{buildroot}%{_libdir} \
|
||||
--libdir=%{_libdir}
|
||||
@ -129,10 +151,10 @@ CALIBRE_PY3_PORT=1 %{__python3} setup.py install \
|
||||
%{_datadir}/mime/packages/calibre-mimetypes.xml
|
||||
%{_datadir}/bash-completion/completions/*
|
||||
%dir %{_libdir}/calibre
|
||||
%dir %{_libdir}/calibre/backports
|
||||
%{_libdir}/calibre/backports/*
|
||||
%dir %{_libdir}/calibre/biplist
|
||||
%{_libdir}/calibre/biplist/*
|
||||
#%dir %{_libdir}/calibre/backports
|
||||
#%{_libdir}/calibre/backports/*
|
||||
#%dir %{_libdir}/calibre/biplist
|
||||
#%{_libdir}/calibre/biplist/*
|
||||
%dir %{_libdir}/calibre/calibre
|
||||
%{_libdir}/calibre/calibre/*.py
|
||||
%dir %{_libdir}/calibre/calibre/db
|
||||
@ -148,16 +170,16 @@ CALIBRE_PY3_PORT=1 %{__python3} setup.py install \
|
||||
%dir %{_libdir}/calibre/calibre/library
|
||||
%{_libdir}/calibre/calibre/library/*
|
||||
%dir %{_libdir}/calibre/calibre/plugins
|
||||
%dir %{_libdir}/calibre/calibre/plugins/3
|
||||
%{_libdir}/calibre/calibre/plugins/3/*
|
||||
#%dir %{_libdir}/calibre/calibre/plugins/3
|
||||
#%{_libdir}/calibre/calibre/plugins/3/*
|
||||
%dir %{_libdir}/calibre/calibre/srv
|
||||
%{_libdir}/calibre/calibre/srv/*.py
|
||||
%dir %{_libdir}/calibre/calibre/srv/tests
|
||||
%{_libdir}/calibre/calibre/srv/tests/*.py
|
||||
%dir %{_libdir}/calibre/calibre_lzma
|
||||
%{_libdir}/calibre/calibre_lzma/*
|
||||
#%dir %{_libdir}/calibre/calibre_lzma
|
||||
#%{_libdir}/calibre/calibre_lzma/*
|
||||
%dir %{_libdir}/calibre/calibre/plugins
|
||||
#%{_libdir}/calibre/calibre/plugins/*.so
|
||||
%{_libdir}/calibre/calibre/plugins/*.so
|
||||
%dir %{_libdir}/calibre/calibre/spell
|
||||
%{_libdir}/calibre/calibre/spell/*.py
|
||||
%dir %{_libdir}/calibre/calibre/translations
|
||||
@ -180,8 +202,10 @@ CALIBRE_PY3_PORT=1 %{__python3} setup.py install \
|
||||
%{_libdir}/calibre/tinycss/*.py
|
||||
%dir %{_libdir}/calibre/tinycss/tests
|
||||
%{_libdir}/calibre/tinycss/tests/*.py
|
||||
%{_libdir}/calibre/sgmllib.py
|
||||
%dir %{_datadir}/calibre
|
||||
%{_datadir}/calibre/*
|
||||
%{_datadir}/zsh/site-functions/_calibre
|
||||
%{_datadir}/icons/hicolor/*/apps/calibre-*.png
|
||||
%{_datadir}/icons/hicolor/*/mimetypes/application-*.png
|
||||
%{_datadir}/icons/hicolor/*/mimetypes/gnome-mime-*.png
|
||||
@ -189,6 +213,9 @@ CALIBRE_PY3_PORT=1 %{__python3} setup.py install \
|
||||
%{python3_sitelib}/init_calibre.py
|
||||
|
||||
%changelog
|
||||
* Sat Mar 06 2021 Automatic Build System <autodist@mambasoft.it> 5.12.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Aug 21 2020 Automatic Build System <autodist@mambasoft.it> 4.23.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user