added patch to use pythonlib 3.3 instead of python binary to run python scripts [release 3.1.11-3mamba;Mon Jan 01 2018]
This commit is contained in:
parent
ef4108d3c5
commit
42c6cd55c2
@ -1,41 +0,0 @@
|
||||
diff -Nru calamares-1.1.2.orig/src/modules/packages/main.py calamares-1.1.2/src/modules/packages/main.py
|
||||
--- calamares-1.1.2.orig/src/modules/packages/main.py 2015-08-10 16:20:20.000000000 +0200
|
||||
+++ calamares-1.1.2/src/modules/packages/main.py 2015-08-13 09:08:59.320685283 +0200
|
||||
@@ -62,6 +62,8 @@
|
||||
check_chroot_call(["emerge", "-v"] + pkgs)
|
||||
elif self.backend == "entropy":
|
||||
check_chroot_call(["equo", "i"] + pkgs)
|
||||
+ elif self.backend == "smart":
|
||||
+ check_chroot_call(["smart", "install", "-y"] + pkgs)
|
||||
|
||||
def remove(self, pkgs):
|
||||
""" Removes packages.
|
||||
@@ -89,6 +91,8 @@
|
||||
check_chroot_call(["emerge", "-C"] + pkgs)
|
||||
elif self.backend == "entropy":
|
||||
check_chroot_call(["equo", "rm"] + pkgs)
|
||||
+ elif self.backend == "smart":
|
||||
+ check_chroot_call(["smart", "remove", "-y"] + pkgs)
|
||||
|
||||
|
||||
def run_operations(pkgman, entry):
|
||||
@@ -114,7 +118,7 @@
|
||||
"""
|
||||
backend = libcalamares.job.configuration.get("backend")
|
||||
|
||||
- if backend not in ("packagekit", "zypp", "yum", "dnf", "urpmi", "apt", "pacman", "portage", "entropy"):
|
||||
+ if backend not in ("packagekit", "zypp", "yum", "dnf", "urpmi", "apt", "pacman", "portage", "entropy", "smart"):
|
||||
return "Bad backend", "backend=\"{}\"".format(backend)
|
||||
|
||||
pkgman = PackageManager(backend)
|
||||
diff -Nru calamares-1.1.2.orig/src/modules/packages/packages.conf calamares-1.1.2/src/modules/packages/packages.conf
|
||||
--- calamares-1.1.2.orig/src/modules/packages/packages.conf 2015-08-10 16:20:20.000000000 +0200
|
||||
+++ calamares-1.1.2/src/modules/packages/packages.conf 2015-08-13 09:09:57.105431680 +0200
|
||||
@@ -10,6 +10,7 @@
|
||||
# - pacman - Pacman
|
||||
# - portage - Gentoo package manager
|
||||
# - entropy - Sabayon package manager
|
||||
+# - smart - Smart package manage
|
||||
#
|
||||
backend: packagekit
|
||||
#
|
@ -1,11 +0,0 @@
|
||||
--- calamares-1.1.2.orig/src/modules/dracut/main.py 2015-08-10 16:20:20.000000000 +0200
|
||||
+++ calamares-1.1.2/src/modules/dracut/main.py 2015-08-13 09:21:59.439535568 +0200
|
||||
@@ -28,7 +28,7 @@
|
||||
|
||||
:return:
|
||||
"""
|
||||
- return chroot_call(['dracut', '-f'])
|
||||
+ return chroot_call(['dracut', '-f', '-H'])
|
||||
|
||||
|
||||
def run():
|
29
calamares-2.3-add_smart_package_manager_support.patch
Normal file
29
calamares-2.3-add_smart_package_manager_support.patch
Normal file
@ -0,0 +1,29 @@
|
||||
--- calamares-2.3/src/modules/packages/main.py.orig 2016-07-14 14:46:30.000000000 +0200
|
||||
+++ calamares-2.3/src/modules/packages/main.py 2016-07-14 14:51:57.738546931 +0200
|
||||
@@ -39,6 +39,8 @@
|
||||
if self.backend == "packagekit":
|
||||
for pkg in pkgs:
|
||||
check_target_env_call(["pkcon", "-py", "install", pkg])
|
||||
+ elif self.backend == "smart":
|
||||
+ check_target_env_call(["smart", "install", "-y"] + pkgs)
|
||||
elif self.backend == "zypp":
|
||||
check_target_env_call(["zypper", "--non-interactive", "--quiet-install", "install",
|
||||
"--auto-agree-with-licenses", "install"] + pkgs)
|
||||
@@ -71,6 +73,8 @@
|
||||
if self.backend == "packagekit":
|
||||
for pkg in pkgs:
|
||||
check_target_env_call(["pkcon", "-py", "remove", pkg])
|
||||
+ elif self.backend == "smart":
|
||||
+ check_target_env_call(["smart", "remove", "-y"] + pkgs)
|
||||
elif self.backend == "zypp":
|
||||
check_target_env_call(["zypper", "--non-interactive", "remove"] + pkgs)
|
||||
elif self.backend == "yum":
|
||||
@@ -114,7 +118,7 @@
|
||||
"""
|
||||
backend = libcalamares.job.configuration.get("backend")
|
||||
|
||||
- if backend not in ("packagekit", "zypp", "yum", "dnf", "urpmi", "apt", "pacman", "portage", "entropy"):
|
||||
+ if backend not in ("packagekit", "zypp", "yum", "dnf", "urpmi", "apt", "pacman", "portage", "entropy", "smart"):
|
||||
return "Bad backend", "backend=\"{}\"".format(backend)
|
||||
|
||||
pkgman = PackageManager(backend)
|
11
calamares-3.1.11-dracut_hostonly.patch
Normal file
11
calamares-3.1.11-dracut_hostonly.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- calamares-3.1.11/src/modules/dracut/main.py.orig 2017-12-24 12:22:26.939346472 +0100
|
||||
+++ calamares-3.1.11/src/modules/dracut/main.py 2017-12-24 12:23:37.212394612 +0100
|
||||
@@ -30,7 +30,7 @@
|
||||
|
||||
:return:
|
||||
"""
|
||||
- return target_env_call(['dracut', '-f'])
|
||||
+ return target_env_call(['dracut', '-f', '-H'])
|
||||
|
||||
|
||||
def run():
|
11
calamares-3.1.11-python-3.3.patch
Normal file
11
calamares-3.1.11-python-3.3.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- calamares-3.1.11/CMakeLists.txt.orig 2018-01-01 02:00:41.654943238 +0100
|
||||
+++ calamares-3.1.11/CMakeLists.txt 2018-01-01 01:59:38.849762152 +0100
|
||||
@@ -133,7 +133,7 @@
|
||||
enable_testing()
|
||||
endif ()
|
||||
|
||||
-find_package( PythonLibs 3.3 )
|
||||
+find_package( PythonLibs 3.3 EXACT REQUIRED )
|
||||
set_package_properties(
|
||||
PythonLibs PROPERTIES
|
||||
DESCRIPTION "C interface libraries for the Python 3 interpreter."
|
@ -1,5 +1,5 @@
|
||||
Name: calamares
|
||||
Version: 1.1.4.2
|
||||
Version: 3.1.11
|
||||
Release: 3mamba
|
||||
Summary: Distribution-independent installer framework
|
||||
Group: Graphical Desktop/Applications/Utilities
|
||||
@ -9,29 +9,44 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/calamares/calamares
|
||||
## GITSOURCE https://github.com/calamares/calamares.git v1.0.1
|
||||
Source: https://github.com/calamares/calamares.git/v%{version}/calamares-%{version}.tar.bz2
|
||||
Source1: https://github.com/calamares/partitionmanager.git/calamares/partitionmanager-%{version}.tar.bz2
|
||||
Patch0: calamares-1.1.2-add_smart_package_manager_support.patch
|
||||
Patch0: calamares-2.3-add_smart_package_manager_support.patch
|
||||
Patch1: calamares-1.0.1-plymouth_path.patch
|
||||
Patch2: calamares-1.1.2-displaymanager_fix_paths_openmamba.patch
|
||||
Patch3: calamares-1.0.1-fix_reboot.patch
|
||||
Patch4: calamares-1.1.2-dracut_hostonly.patch
|
||||
Patch4: calamares-3.1.11-dracut_hostonly.patch
|
||||
Patch5: calamares-1.0.1-locale_use_LANG.patch
|
||||
Patch6: calamares-1.0.1-replace_chroot_call.patch
|
||||
Patch7: calamares-1.1.2-openmamba_autopartitioning.patch
|
||||
Patch8: calamares-3.1.11-python-3.3.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libQt5WebEngine-devel
|
||||
BuildRequires: libatasmart-devel
|
||||
BuildRequires: libblkid-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libkauth-devel
|
||||
BuildRequires: libkcodecs-devel
|
||||
BuildRequires: libkcompletion-devel
|
||||
BuildRequires: libkconfig-devel
|
||||
BuildRequires: libkconfigwidgets-devel
|
||||
BuildRequires: libkcoreaddons-devel
|
||||
BuildRequires: libki18n-devel
|
||||
BuildRequires: libkio-devel
|
||||
BuildRequires: libkjobwidgets-devel
|
||||
BuildRequires: libkpackage-devel
|
||||
BuildRequires: libkparts-devel
|
||||
BuildRequires: libkpmcore-devel
|
||||
BuildRequires: libkservice-devel
|
||||
BuildRequires: libktextwidgets-devel
|
||||
BuildRequires: libkwidgetsaddons-devel
|
||||
BuildRequires: libkxmlgui-devel
|
||||
BuildRequires: libparted-devel
|
||||
BuildRequires: libpython3-devel
|
||||
BuildRequires: libplasma-framework-devel
|
||||
BuildRequires: libpython36-devel
|
||||
BuildRequires: libqt5-devel
|
||||
BuildRequires: libsolid-devel
|
||||
BuildRequires: libsonnet-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libyaml-cpp-devel
|
||||
@ -46,6 +61,7 @@ Requires: grub-efi-x86_64
|
||||
Requires: libqt5-plugins
|
||||
Requires: squashfs
|
||||
Requires: gptfdisk
|
||||
Requires: ckbcomp
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
@ -70,20 +86,9 @@ This package contains libraries and header files for developing applications tha
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -a1
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
#%patch3 -p1
|
||||
%setup -q
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
#%patch6 -p1
|
||||
%patch7 -p1
|
||||
|
||||
rmdir src/modules/partition/partitionmanager
|
||||
mv partitionmanager-%{version} src/modules/partition/partitionmanager
|
||||
%patch8 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build \
|
||||
@ -97,17 +102,20 @@ mv partitionmanager-%{version} src/modules/partition/partitionmanager
|
||||
|
||||
install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps/calamares.png
|
||||
|
||||
%find_lang %{name}5_qt --with-qt --with-man --all-name || touch %{name}5_qt.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%files -f %{name}5_qt.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/calamares
|
||||
%{_datadir}/applications/calamares.desktop
|
||||
%{_datadir}/pixmaps/calamares.png
|
||||
%{_datadir}/icons/hicolor/scalable/apps/calamares.svg
|
||||
%dir %{_datadir}/calamares
|
||||
%dir %{_datadir}/calamares/branding
|
||||
%dir %{_datadir}/calamares/branding/default
|
||||
@ -120,12 +128,13 @@ install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps
|
||||
%{_datadir}/calamares/qml/calamares/slideshow/*
|
||||
%{_datadir}/calamares/settings.conf
|
||||
%{_datadir}/polkit-1/actions/com.github.calamares.calamares.policy
|
||||
%{_mandir}/man8/calamares.8*
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libcalamares.so.*
|
||||
%{_libdir}/libcalamaresui.so.*
|
||||
%{_libdir}/libcalapm.so
|
||||
#%{_libdir}/libcalapm.so
|
||||
%dir %{_libdir}/calamares
|
||||
%{_libdir}/calamares/libcalamares.so
|
||||
%dir %{_libdir}/calamares/modules
|
||||
@ -135,6 +144,12 @@ install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps
|
||||
%{_libdir}/calamares/modules/displaymanager/*
|
||||
%dir %{_libdir}/calamares/modules/dracut
|
||||
%{_libdir}/calamares/modules/dracut/*
|
||||
%dir %{_libdir}/calamares/modules/dracutlukscfg
|
||||
%{_libdir}/calamares/modules/dracutlukscfg/*
|
||||
%dir %{_libdir}/calamares/modules/dummycpp
|
||||
%{_libdir}/calamares/modules/dummycpp/*
|
||||
%dir %{_libdir}/calamares/modules/dummypythonqt
|
||||
%{_libdir}/calamares/modules/dummypythonqt/*
|
||||
%dir %{_libdir}/calamares/modules/dummyprocess
|
||||
%{_libdir}/calamares/modules/dummyprocess/*
|
||||
%dir %{_libdir}/calamares/modules/dummypython
|
||||
@ -153,6 +168,14 @@ install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps
|
||||
%{_libdir}/calamares/modules/initcpiocfg/*
|
||||
%dir %{_libdir}/calamares/modules/initramfs
|
||||
%{_libdir}/calamares/modules/initramfs/*
|
||||
%dir %{_libdir}/calamares/modules/initramfscfg
|
||||
%{_libdir}/calamares/modules/initramfscfg/*
|
||||
%dir %{_libdir}/calamares/modules/interactiveterminal
|
||||
%{_libdir}/calamares/modules/interactiveterminal/*
|
||||
%dir %{_libdir}/calamares/modules/luksbootkeyfile
|
||||
%{_libdir}/calamares/modules/luksbootkeyfile/*
|
||||
%dir %{_libdir}/calamares/modules/luksopenswaphookcfg
|
||||
%{_libdir}/calamares/modules/luksopenswaphookcfg/*
|
||||
%dir %{_libdir}/calamares/modules/keyboard
|
||||
%{_libdir}/calamares/modules/keyboard/*
|
||||
%dir %{_libdir}/calamares/modules/license
|
||||
@ -165,12 +188,18 @@ install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps
|
||||
%{_libdir}/calamares/modules/machineid/*
|
||||
%dir %{_libdir}/calamares/modules/mount
|
||||
%{_libdir}/calamares/modules/mount/*
|
||||
%dir %{_libdir}/calamares/modules/netinstall
|
||||
%{_libdir}/calamares/modules/netinstall/*
|
||||
%dir %{_libdir}/calamares/modules/networkcfg
|
||||
%{_libdir}/calamares/modules/networkcfg/*
|
||||
%dir %{_libdir}/calamares/modules/packages
|
||||
%{_libdir}/calamares/modules/packages/*
|
||||
%dir %{_libdir}/calamares/modules/partition
|
||||
%{_libdir}/calamares/modules/partition/*
|
||||
%dir %{_libdir}/calamares/modules/plasmalnf
|
||||
%{_libdir}/calamares/modules/plasmalnf/*
|
||||
%dir %{_libdir}/calamares/modules/plymouthcfg
|
||||
%{_libdir}/calamares/modules/plymouthcfg/*
|
||||
%dir %{_libdir}/calamares/modules/removeuser
|
||||
%{_libdir}/calamares/modules/removeuser/*
|
||||
%dir %{_libdir}/calamares/modules/services
|
||||
@ -205,6 +234,18 @@ install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 01 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.11-3mamba
|
||||
- added patch to use pythonlib 3.3 instead of python binary to run python scripts
|
||||
|
||||
* Sun Dec 31 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.11-2mamba
|
||||
- require ckbcomp for keyboard module
|
||||
|
||||
* Sun Dec 24 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.11-1mamba
|
||||
- update to 3.1.11
|
||||
|
||||
* Thu Jul 14 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3-1mamba
|
||||
- update to 2.3
|
||||
|
||||
* Sat Jun 18 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.4.2-3mamba
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user