automatic version update by autodist [release 3.3.1-1mamba;Fri Jan 19 2024]

This commit is contained in:
Automatic Build System 2024-01-19 14:23:19 +01:00
parent ab65920d9d
commit 1eb59bc0f3
12 changed files with 9 additions and 298 deletions

View File

@ -1,11 +0,0 @@
--- calamares-1.0.1/src/modules/finished/FinishedPage.cpp.orig 2015-02-20 15:57:02.785426632 +0100
+++ calamares-1.0.1/src/modules/finished/FinishedPage.cpp 2015-02-20 15:57:20.687409146 +0100
@@ -90,7 +90,7 @@
{
if ( ui->restartCheckBox->isVisible() &&
ui->restartCheckBox->isChecked() )
- QProcess::execute( "/bin/sh", { m_restartNowCommand } );
+ QProcess::execute( { m_restartNowCommand } );
} );
}
}

View File

@ -1,38 +0,0 @@
--- calamares-1.0.1/src/modules/locale/LocalePage.cpp.orig 2015-02-20 15:17:31.878095644 +0100
+++ calamares-1.0.1/src/modules/locale/LocalePage.cpp 2015-02-20 15:51:22.166759362 +0100
@@ -303,7 +303,7 @@
QLocale myLocale = QLocale();
if ( m_localeGenLines.isEmpty() )
- return "en_US.UTF-8 UTF-8";
+ return QString::fromUtf8(getenv("LANG")) + " UTF-8";
QString myLanguage = myLocale.name().split( '_' ).first();
QStringList linesForLanguage;
@@ -314,7 +314,7 @@
}
if ( linesForLanguage.length() == 0 )
- return "en_US.UTF-8 UTF-8";
+ return QString::fromUtf8(getenv("LANG")) + " UTF-8";
else if ( linesForLanguage.length() == 1 )
return linesForLanguage.first();
else
@@ -340,7 +340,7 @@
}
if ( linesForLanguageAndCountry.length() == 0 )
- return "en_US.UTF-8 UTF-8";
+ return QString::fromUtf8(getenv("LANG")) + " UTF-8";
else if ( linesForLanguageAndCountry.length() == 1 )
return linesForLanguageAndCountry.first();
else
@@ -356,7 +356,7 @@
return linesForLanguageAndCountryUtf.first();
}
- return "en_US.UTF-8 UTF-8";
+ return QString::fromUtf8(getenv("LANG")) + " UTF-8";
}

View File

@ -1,12 +0,0 @@
diff -Nru calamares-1.0.1.orig/src/modules/grubcfg/main.py calamares-1.0.1/src/modules/grubcfg/main.py
--- calamares-1.0.1.orig/src/modules/grubcfg/main.py 2015-02-03 22:15:35.000000000 +0100
+++ calamares-1.0.1/src/modules/grubcfg/main.py 2015-02-19 14:46:59.134060816 +0100
@@ -25,7 +25,7 @@
default_dir = os.path.join(root_mount_point, "etc/default")
default_grub = os.path.join(default_dir, "grub")
- plymouth_bin = os.path.join(root_mount_point, "usr/bin/plymouth")
+ plymouth_bin = os.path.join(root_mount_point, "bin/plymouth")
use_splash = ""
swap_uuid = ""

View File

@ -1,13 +0,0 @@
--- calamares-1.0.1/src/modules/grub/main.py.orig 2015-03-07 13:37:38.315162881 +0100
+++ calamares-1.0.1/src/modules/grub/main.py 2015-03-07 13:39:03.078129593 +0100
@@ -35,8 +35,8 @@
efi_bootloader_id = distribution.translate(file_name_sanitizer)
check_chroot_call([libcalamares.job.configuration["grubInstall"], "--target=x86_64-efi", "--efi-directory={!s}".format(efi_directory), "--bootloader-id={!s}".format(efi_bootloader_id)])
# Workaround for some UEFI firmwares
- chroot_call(["mkdir", "-p", "{!s}/EFI/boot".format(efi_directory)])
- chroot_call(["cp", "{!s}/EFI/{!s}/grubx64.efi".format(efi_directory,efi_bootloader_id), "{!s}/EFI/boot/bootx64.efi".format(efi_directory)])
+ check_chroot_call(["mkdir", "-p", "{!s}/EFI/boot".format(efi_directory)])
+ check_chroot_call(["cp", "{!s}/EFI/{!s}/grubx64.efi".format(efi_directory,efi_bootloader_id), "{!s}/EFI/boot/bootx64.efi".format(efi_directory)])
else:
install_path = boot_loader["installPath"]
check_chroot_call([libcalamares.job.configuration["grubInstall"], "--target=i386-pc", install_path])

View File

@ -1,30 +0,0 @@
--- calamares-1.1.2.orig/src/modules/displaymanager/main.py 2015-08-10 16:20:20.000000000 +0200
+++ calamares-1.1.2/src/modules/displaymanager/main.py 2015-08-13 09:15:44.573602915 +0200
@@ -30,7 +30,7 @@
desktop_environments = [
DesktopEnvironment('/usr/bin/startkde', 'plasma'), # KDE Plasma 5
- DesktopEnvironment('/usr/bin/startkde', 'kde-plasma'), # KDE Plasma 4
+ DesktopEnvironment('/opt/kde/bin/startkde', 'kde-plasma'), # KDE Plasma 4
DesktopEnvironment('/usr/bin/gnome-session', 'gnome'),
DesktopEnvironment('/usr/bin/startxfce4', 'xfce'),
DesktopEnvironment('/usr/bin/cinnamon-session-cinnamon', 'cinnamon'),
@@ -72,7 +72,8 @@
"""
return os.path.exists(
"{!s}/usr/bin/{!s}".format(root_mount_point, dm_name)) or os.path.exists(
- "{!s}/usr/sbin/{!s}".format(root_mount_point, dm_name))
+ "{!s}/usr/sbin/{!s}".format(root_mount_point, dm_name)) or os.path.exists(
+ "{!s}/opt/kde/bin/{!s}".format(root_mount_point, dm_name))
def set_autologin(username, displaymanagers, default_desktop_environment, root_mount_point):
@@ -156,7 +157,7 @@
if "kdm" in displaymanagers:
# Systems with KDM as Desktop Manager
- kdm_conf_path = os.path.join(root_mount_point, "usr/share/config/kdm/kdmrc")
+ kdm_conf_path = os.path.join(root_mount_point, "opt/kde/share/config/kdm/kdmrc")
text = []
if os.path.exists(kdm_conf_path):

View File

@ -1,90 +0,0 @@
--- calamares-1.1.2.orig/src/modules/partition/gui/EraseDiskPage.cpp 2015-08-10 16:20:20.000000000 +0200
+++ calamares-1.1.2/src/modules/partition/gui/EraseDiskPage.cpp 2015-08-13 10:32:06.442017396 +0200
@@ -181,24 +181,35 @@
m_core->createPartitionTable( dev, PartitionTable::msdos );
}
+ qint64 suggestedRootSizeB =
+ ( Calamares::JobQueue::instance()->
+ globalStorage()->
+ value( "requiredStorageGB" ).toDouble() + 0.1 + 20.0 ) GiB;
+
bool shouldCreateSwap = false;
qint64 availableSpaceB = ( dev->totalSectors() - firstFreeSector ) * dev->logicalSectorSize();
qint64 suggestedSwapSizeB = swapSuggestion( availableSpaceB );
- qint64 requiredSpaceB =
- ( Calamares::JobQueue::instance()->
- globalStorage()->
- value( "requiredStorageGB" ).toDouble() + 0.1 + 2.0 ) GiB +
- suggestedSwapSizeB;
+ qint64 requiredSpaceB = suggestedRootSizeB + suggestedSwapSizeB;
// If there is enough room for ESP + root + swap, create swap, otherwise don't.
shouldCreateSwap = availableSpaceB > requiredSpaceB;
- qint64 lastSectorForRoot = dev->totalSectors() - 1; //last sector of the device
- if ( shouldCreateSwap )
- {
- lastSectorForRoot -= suggestedSwapSizeB / dev->logicalSectorSize() + 1;
+ bool shouldCreateHome = false;
+ if ( shouldCreateSwap ) {
+ availableSpaceB -= requiredSpaceB;
+ qint64 suggestedHomeSizeB = 30 GiB;
+ requiredSpaceB += suggestedHomeSizeB;
+
+ // If there is enough room for ESP + root + swap, create swap, otherwise don't.
+ shouldCreateHome = availableSpaceB > requiredSpaceB;
+ if ( !shouldCreateHome ) {
+ suggestedRootSizeB = availableSpaceB - suggestedSwapSizeB;
+ }
+ } else {
+ suggestedRootSizeB = availableSpaceB;
}
+ qint64 lastSectorForRoot = firstFreeSector + suggestedRootSizeB / dev->logicalSectorSize() - 1;
Partition* rootPartition = PMUtils::createNewPartition(
dev->partitionTable(),
*dev,
@@ -210,21 +221,40 @@
PartitionInfo::setFormat( rootPartition, true );
PartitionInfo::setMountPoint( rootPartition, "/" );
m_core->createPartition( dev, rootPartition );
+ firstFreeSector = firstFreeSector + suggestedRootSizeB / dev->logicalSectorSize();
if ( shouldCreateSwap )
{
+ qint64 lastSectorForSwap = firstFreeSector + suggestedSwapSizeB / dev->logicalSectorSize() - 1;
Partition* swapPartition = PMUtils::createNewPartition(
dev->partitionTable(),
*dev,
PartitionRole( PartitionRole::Primary ),
FileSystem::LinuxSwap,
- lastSectorForRoot + 1,
- dev->totalSectors() - 1
+ firstFreeSector,
+ lastSectorForSwap
);
PartitionInfo::setFormat( swapPartition, true );
m_core->createPartition( dev, swapPartition );
+ firstFreeSector = firstFreeSector + suggestedSwapSizeB / dev->logicalSectorSize();
}
+ if ( shouldCreateHome )
+ {
+ Partition* homePartition = PMUtils::createNewPartition(
+ dev->partitionTable(),
+ *dev,
+ PartitionRole( PartitionRole::Primary ),
+ FileSystem::Ext4,
+ firstFreeSector,
+ dev->totalSectors() - 1
+ );
+ PartitionInfo::setFormat( homePartition, true );
+ m_core->createPartition( dev, homePartition );
+ }
+
+ m_core->setBootLoaderInstallPath( dev->deviceNode() );
+
updatePreviews();
m_core->dumpQueue();

View File

@ -1,29 +0,0 @@
--- calamares-2.3/src/modules/packages/main.py.orig 2016-07-14 14:46:30.000000000 +0200
+++ calamares-2.3/src/modules/packages/main.py 2016-07-14 14:51:57.738546931 +0200
@@ -39,6 +39,8 @@
if self.backend == "packagekit":
for pkg in pkgs:
check_target_env_call(["pkcon", "-py", "install", pkg])
+ elif self.backend == "smart":
+ check_target_env_call(["smart", "install", "-y"] + pkgs)
elif self.backend == "zypp":
check_target_env_call(["zypper", "--non-interactive", "--quiet-install", "install",
"--auto-agree-with-licenses", "install"] + pkgs)
@@ -71,6 +73,8 @@
if self.backend == "packagekit":
for pkg in pkgs:
check_target_env_call(["pkcon", "-py", "remove", pkg])
+ elif self.backend == "smart":
+ check_target_env_call(["smart", "remove", "-y"] + pkgs)
elif self.backend == "zypp":
check_target_env_call(["zypper", "--non-interactive", "remove"] + pkgs)
elif self.backend == "yum":
@@ -114,7 +118,7 @@
"""
backend = libcalamares.job.configuration.get("backend")
- if backend not in ("packagekit", "zypp", "yum", "dnf", "urpmi", "apt", "pacman", "portage", "entropy"):
+ if backend not in ("packagekit", "zypp", "yum", "dnf", "urpmi", "apt", "pacman", "portage", "entropy", "smart"):
return "Bad backend", "backend=\"{}\"".format(backend)
pkgman = PackageManager(backend)

View File

@ -1,24 +0,0 @@
--- calamares-3.2.17.1/src/modules/users/CreateUserJob.cpp.orig 2019-12-21 18:59:25.196000000 +0100
+++ calamares-3.2.17.1/src/modules/users/CreateUserJob.cpp 2019-12-21 18:59:51.859000000 +0100
@@ -130,21 +130,6 @@
}
}
- // If we're looking to reuse the contents of an existing /home
- if ( gs->value( "reuseHome" ).toBool() )
- {
- QString shellFriendlyHome = "/home/" + m_userName;
- QDir existingHome( destDir.absolutePath() + shellFriendlyHome );
- if ( existingHome.exists() )
- {
- QString backupDirName = "dotfiles_backup_" + QDateTime::currentDateTime().toString( "yyyy-MM-dd_HH-mm-ss" );
- existingHome.mkdir( backupDirName );
-
- CalamaresUtils::System::instance()->targetEnvCall(
- { "sh", "-c", "mv -f " + shellFriendlyHome + "/.* " + shellFriendlyHome + "/" + backupDirName } );
- }
- }
-
cDebug() << "[CREATEUSER]: creating user";
QStringList useradd { "useradd", "-m", "-U" };

View File

@ -1,11 +0,0 @@
--- calamares-3.2.2/CMakeLists.txt.orig 2018-09-23 15:08:02.457509790 +0200
+++ calamares-3.2.2/CMakeLists.txt 2018-09-23 15:08:10.307540896 +0200
@@ -248,7 +248,7 @@
enable_testing()
endif ()
-find_package( PythonLibs ${PYTHONLIBS_VERSION} )
+find_package( PythonLibs ${PYTHONLIBS_VERSION} EXACT REQUIRED )
set_package_properties(
PythonLibs PROPERTIES
DESCRIPTION "C interface libraries for the Python 3 interpreter."

View File

@ -1,10 +0,0 @@
--- calamares-3.2.17.1/src/libcalamares/CMakeLists.txt.orig 2019-12-22 17:08:29.322000000 +0100
+++ calamares-3.2.17.1/src/libcalamares/CMakeLists.txt 2019-12-22 17:07:28.115000000 +0100
@@ -125,6 +125,7 @@
Qt5::Core
KF5::CoreAddons
${OPTIONAL_PUBLIC_LIBRARIES}
+ boost_python3
)
install( TARGETS calamares

View File

@ -1,15 +0,0 @@
--- calamares-3.2.32.1/src/modules/partition/core/PartitionLayout.cpp.orig 2020-11-07 18:42:24.546000000 +0100
+++ calamares-3.2.32.1/src/modules/partition/core/PartitionLayout.cpp 2020-11-07 18:54:28.790000000 +0100
@@ -283,6 +283,12 @@
size = availableSize;
}
+ if ( availableSize < 5 * 1024 * 1024) {
+ cWarning() << "Partition" << part.partMountPoint << "available size"
+ << "is insufficient to add partition, skipping...";
+ continue;
+ }
+
end = firstSector + std::max( size - 1, Q_INT64_C( 0 ) );
if ( luksPassphrase.isEmpty() )

View File

@ -1,5 +1,5 @@
Name: calamares
Version: 3.3.0
Version: 3.3.1
Release: 1mamba
Summary: Distribution-independent installer framework
Group: Graphical Desktop/Applications/Utilities
@ -8,18 +8,7 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/calamares/calamares
Source: https://github.com/calamares/calamares.git/v%{version}/calamares-%{version}.tar.bz2
Patch0: calamares-2.3-add_smart_package_manager_support.patch
Patch1: calamares-1.0.1-plymouth_path.patch
Patch2: calamares-1.1.2-displaymanager_fix_paths_openmamba.patch
Patch3: calamares-1.0.1-fix_reboot.patch
Patch4: calamares-3.3.0-dracut_hostonly.patch
Patch5: calamares-1.0.1-locale_use_LANG.patch
Patch6: calamares-1.0.1-replace_chroot_call.patch
Patch7: calamares-1.1.2-openmamba_autopartitioning.patch
Patch8: calamares-3.2.2-python-3.3.patch
Patch9: calamares-3.2.32.1-skip-partition-if-minsize-less-than-available-size.patch
Patch10: calamares-3.2.17.1-dont-backup-dotfiles.patch
Patch11: calamares-3.2.32.1-boost-python36-link-fix.patch
Patch12: calamares-3.2.32.1-lxqt-0.16.0.patch
Patch13: calamares-3.2.61-prefer_vconsole_it_over_it2.patch
Patch14: calamares-3.2.61-fix-plasma-session-x11.patch
@ -28,7 +17,6 @@ License: GPL
BuildRequires: glibc-devel
BuildRequires: libQt5Svg-devel
BuildRequires: libX11-devel
BuildRequires: libappstream-qt-devel
BuildRequires: libgcc
BuildRequires: libicu-devel
BuildRequires: libkauth-devel
@ -110,7 +98,6 @@ This package contains libraries and header files for developing applications tha
#-D -T
#:<< _EOF
%patch 4 -p1
#%patch 11 -p1
%patch 12 -p1
%patch 13 -p1
%patch 14 -p1
@ -301,6 +288,8 @@ install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps
%defattr(-,root,root)
%dir %{_includedir}/libcalamares
%{_includedir}/libcalamares/*.h
%dir %{_includedir}/libcalamares/compat
%{_includedir}/libcalamares/compat/*.h
%dir %{_includedir}/libcalamares/geoip
%{_includedir}/libcalamares/geoip/*.h
%dir %{_includedir}/libcalamares/locale
@ -309,6 +298,8 @@ install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps
%{_includedir}/libcalamares/modulesystem/*.h
%dir %{_includedir}/libcalamares/network
%{_includedir}/libcalamares/network/*.h
%dir %{_includedir}/libcalamares/packages
%{_includedir}/libcalamares/packages/*.h
%dir %{_includedir}/libcalamares/partition
%{_includedir}/libcalamares/partition/*.h
%dir %{_includedir}/libcalamares/utils
@ -323,9 +314,12 @@ install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps
%{_libdir}/cmake/Calamares/FindYAMLCPP.cmake
%{_libdir}/libcalamares.so
%{_libdir}/libcalamaresui.so
#%doc README.md
%doc README.md
%changelog
* Fri Jan 19 2024 Automatic Build System <autodist@openmamba.org> 3.3.1-1mamba
- automatic version update by autodist
* Fri Dec 15 2023 Automatic Build System <autodist@mambasoft.it> 3.3.0-1mamba
- automatic version update by autodist