rebuilt with cmake options and python binding [release 3.07-2mamba;Fri Dec 11 2020]
This commit is contained in:
parent
79fec47096
commit
bcf5e10a87
58
bullet-3.07-upstream-release-fix.patch
Normal file
58
bullet-3.07-upstream-release-fix.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
From e32fc59c88a3908876949c6f2665e8d091d987fa Mon Sep 17 00:00:00 2001
|
||||||
|
From: Erwin Coumans <erwin.coumans@gmail.com>
|
||||||
|
Date: Thu, 26 Nov 2020 14:25:33 -0800
|
||||||
|
Subject: [PATCH] bump up version to 3.07
|
||||||
|
|
||||||
|
---
|
||||||
|
VERSION | 2 +-
|
||||||
|
setup.py | 2 +-
|
||||||
|
src/LinearMath/btScalar.h | 2 +-
|
||||||
|
src/LinearMath/btSerializer.h | 2 +-
|
||||||
|
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/VERSION b/VERSION
|
||||||
|
index e5dba2ed35..e449dd2a3b 100644
|
||||||
|
--- a/VERSION
|
||||||
|
+++ b/VERSION
|
||||||
|
@@ -1 +1 @@
|
||||||
|
-3.05
|
||||||
|
+3.07
|
||||||
|
diff --git a/setup.py b/setup.py
|
||||||
|
index ce9fa5a96c..5f549d3b95 100644
|
||||||
|
--- a/setup.py
|
||||||
|
+++ b/setup.py
|
||||||
|
@@ -501,7 +501,7 @@ def _single_compile(obj):
|
||||||
|
|
||||||
|
setup(
|
||||||
|
name='pybullet',
|
||||||
|
- version='3.0.6',
|
||||||
|
+ version='3.0.7',
|
||||||
|
description=
|
||||||
|
'Official Python Interface for the Bullet Physics SDK specialized for Robotics Simulation and Reinforcement Learning',
|
||||||
|
long_description=
|
||||||
|
diff --git a/src/LinearMath/btScalar.h b/src/LinearMath/btScalar.h
|
||||||
|
index a92caf1817..36b90cc944 100644
|
||||||
|
--- a/src/LinearMath/btScalar.h
|
||||||
|
+++ b/src/LinearMath/btScalar.h
|
||||||
|
@@ -25,7 +25,7 @@ subject to the following restrictions:
|
||||||
|
#include <float.h>
|
||||||
|
|
||||||
|
/* SVN $Revision$ on $Date$ from http://bullet.googlecode.com*/
|
||||||
|
-#define BT_BULLET_VERSION 305
|
||||||
|
+#define BT_BULLET_VERSION 307
|
||||||
|
|
||||||
|
inline int btGetVersion()
|
||||||
|
{
|
||||||
|
diff --git a/src/LinearMath/btSerializer.h b/src/LinearMath/btSerializer.h
|
||||||
|
index 6ea36fbb39..9abcf031d0 100644
|
||||||
|
--- a/src/LinearMath/btSerializer.h
|
||||||
|
+++ b/src/LinearMath/btSerializer.h
|
||||||
|
@@ -481,7 +481,7 @@ class btDefaultSerializer : public btSerializer
|
||||||
|
|
||||||
|
buffer[9] = '3';
|
||||||
|
buffer[10] = '0';
|
||||||
|
- buffer[11] = '5';
|
||||||
|
+ buffer[11] = '7';
|
||||||
|
}
|
||||||
|
|
||||||
|
virtual void startSerialization()
|
59
bullet.spec
59
bullet.spec
@ -1,19 +1,23 @@
|
|||||||
%define pkgver %(echo %version | tr _ -)
|
%define pkgver %(echo %version | tr _ -)
|
||||||
Name: bullet
|
Name: bullet
|
||||||
Version: 3.07
|
Version: 3.07
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A Collision Detection and Rigid Body Dynamics Library
|
Summary: A Collision Detection and Rigid Body Dynamics Library
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://bulletphysics.org
|
URL: http://bulletphysics.org
|
||||||
Source: https://github.com/bulletphysics/bullet3.git/%{version}/bullet3-%{version}.tar.bz2
|
Source: https://github.com/bulletphysics/bullet3.git/%{version}/bullet3-%{version}.tar.bz2
|
||||||
|
Patch0: bullet-3.07-upstream-release-fix.patch
|
||||||
License: zlib
|
License: zlib
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: ldconfig
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libpython3-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: python3
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
@ -39,19 +43,46 @@ Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
%description -n lib%{name}-devel
|
%description -n lib%{name}-devel
|
||||||
This package contains libraries and header files for developing applications that use %{name}.
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
%package -n python-%{name}-py3
|
||||||
|
Group: System/Libraries/Python
|
||||||
|
Summary: Python bindings for %{name}
|
||||||
|
|
||||||
|
%description -n python-%{name}-py3
|
||||||
|
This package contains the Python bindings forr %{name}.
|
||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}3-%{pkgver}
|
%setup -q -n %{name}3-%{pkgver}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake
|
%cmake -d build \
|
||||||
|
-DBUILD_SHARED_LIBS=1 \
|
||||||
|
-DINSTALL_LIBS=1 \
|
||||||
|
-DINSTALL_EXTRA_LIBS=1 \
|
||||||
|
-DBUILD_PYBULLET=ON \
|
||||||
|
-DBUILD_PYBULLET_NUMPY=ON \
|
||||||
|
-DBUILD_OPENGL3_DEMOS=ON \
|
||||||
|
-DBUILD_BULLET2_DEMOS=OFF \
|
||||||
|
-DBUILD_UNIT_TESTS=OFF \
|
||||||
|
-DBUILD_EXTRAS=OFF
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
|
cd ..
|
||||||
|
%{__python3} setup.py build
|
||||||
|
doxygen
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall
|
%makeinstall -C build
|
||||||
|
|
||||||
|
%{__python3} setup.py install \
|
||||||
|
--prefix=%{_prefix} \
|
||||||
|
--root=%{buildroot} \
|
||||||
|
--optimize=1 \
|
||||||
|
--skip-build
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -72,9 +103,27 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%{_libdir}/cmake/bullet/BulletConfig.cmake
|
%{_libdir}/cmake/bullet/BulletConfig.cmake
|
||||||
%{_libdir}/cmake/bullet/UseBullet.cmake
|
%{_libdir}/cmake/bullet/UseBullet.cmake
|
||||||
%{_libdir}/pkgconfig/bullet*.pc
|
%{_libdir}/pkgconfig/bullet*.pc
|
||||||
%{_prefix}/lib/libclsocket.a
|
#%{_prefix}/lib/libclsocket.a
|
||||||
|
|
||||||
|
%files -n python-%{name}-py3
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{python3_sitearch}/eglRenderer.cpython-*.so
|
||||||
|
%dir %{python3_sitearch}/pybullet-*-py*.egg-info
|
||||||
|
%{python3_sitearch}/pybullet-*-py*.egg-info/*
|
||||||
|
%{python3_sitearch}/pybullet.cpython-*.so
|
||||||
|
%dir %{python3_sitearch}/pybullet_data
|
||||||
|
%{python3_sitearch}/pybullet_data/*
|
||||||
|
%dir %{python3_sitearch}/pybullet_envs
|
||||||
|
%{python3_sitearch}/pybullet_envs/*
|
||||||
|
%dir %{python3_sitearch}/pybullet_robots
|
||||||
|
%{python3_sitearch}/pybullet_robots/*
|
||||||
|
%dir %{python3_sitearch}/pybullet_utils
|
||||||
|
%{python3_sitearch}/pybullet_utils/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 11 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 3.07-2mamba
|
||||||
|
- rebuilt with cmake options and python binding
|
||||||
|
|
||||||
* Sat Dec 05 2020 Automatic Build System <autodist@mambasoft.it> 3.07-1mamba
|
* Sat Dec 05 2020 Automatic Build System <autodist@mambasoft.it> 3.07-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user