automatic version update by autodist [release 6.0.2-1mamba;Wed Mar 13 2024]
This commit is contained in:
parent
63eb0475e1
commit
ba1486980e
@ -1,46 +0,0 @@
|
||||
From 386d3b8ed1e0595c9fc6e21643ff748402171429 Mon Sep 17 00:00:00 2001
|
||||
From: Vlad Zagorodniy <vladzzag@gmail.com>
|
||||
Date: Tue, 2 Apr 2019 16:01:19 +0300
|
||||
Subject: [PATCH] Fix build with Qt 4
|
||||
|
||||
Reviewers: #plasma, davidedmundson, fvogt
|
||||
|
||||
Reviewed By: #plasma, davidedmundson, fvogt
|
||||
|
||||
Subscribers: fvogt, plasma-devel
|
||||
|
||||
Tags: #plasma
|
||||
|
||||
Differential Revision: https://phabricator.kde.org/D20201
|
||||
---
|
||||
kstyle/breezewindowmanager.cpp | 11 +++--------
|
||||
1 file changed, 3 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/kstyle/breezewindowmanager.cpp b/kstyle/breezewindowmanager.cpp
|
||||
index aba29eef..5ca3fea5 100644
|
||||
--- a/kstyle/breezewindowmanager.cpp
|
||||
+++ b/kstyle/breezewindowmanager.cpp
|
||||
@@ -895,20 +895,15 @@ namespace Breeze
|
||||
// connection
|
||||
auto connection( Helper::connection() );
|
||||
|
||||
- #if QT_VERSION >= 0x050300
|
||||
- const qreal dpiRatio = window->devicePixelRatio();
|
||||
- #else
|
||||
- const qreal dpiRatio = 1;
|
||||
- #endif
|
||||
-
|
||||
#if BREEZE_USE_KDE4
|
||||
auto net_connection = QX11Info::display();
|
||||
+ const QPoint native = position;
|
||||
#else
|
||||
auto net_connection = connection;
|
||||
- #endif
|
||||
-
|
||||
+ const qreal dpiRatio = window->devicePixelRatio();
|
||||
const QPoint origin = window->screen()->geometry().topLeft();
|
||||
const QPoint native = (position - origin) * dpiRatio + origin;
|
||||
+ #endif
|
||||
|
||||
xcb_ungrab_pointer( connection, XCB_TIME_CURRENT_TIME );
|
||||
NETRootInfo( net_connection, NET::WMMoveResize ).moveResizeRequest(
|
82
breeze.spec
82
breeze.spec
@ -3,43 +3,53 @@
|
||||
|
||||
|
||||
Name: breeze
|
||||
Version: 5.27.10
|
||||
Version: 6.0.2
|
||||
Release: 1mamba
|
||||
Summary: Breeze Dark Desktop Design Language by the KDE VDG
|
||||
Group: Graphical Desktop/Look 'n' feel
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://kde.org/
|
||||
Source: http://download.kde.org/stable/plasma/%{plasmaver}/breeze-%{version}.tar.xz
|
||||
Patch0: breeze-5.15.4-libqt4.patch
|
||||
URL: https://kde.org/it/plasma-desktop/
|
||||
Source: https://download.kde.org/%{stable_kf6}/plasma/%{plasmaver}/breeze-%{version}.tar.xz
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libQt5X11Extras-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libframeworkintegration-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libkauth-devel
|
||||
BuildRequires: libkcmutils-devel
|
||||
BuildRequires: libkcodecs-devel
|
||||
BuildRequires: libkconfig-devel
|
||||
BuildRequires: libkconfigwidgets-devel
|
||||
BuildRequires: libkcoreaddons-devel
|
||||
BuildRequires: libkdecoration-devel
|
||||
BuildRequires: libkf6-frameworkintegration-devel
|
||||
BuildRequires: libkf6-kcmutils-devel
|
||||
BuildRequires: libkf6-kcolorscheme-devel
|
||||
BuildRequires: libkf6-kconfig-devel
|
||||
BuildRequires: libkf6-kconfigwidgets-devel
|
||||
BuildRequires: libkf6-kcoreaddons-devel
|
||||
BuildRequires: libkf6-kguiaddons-devel
|
||||
BuildRequires: libkf6-ki18n-devel
|
||||
BuildRequires: libkf6-kiconthemes-devel
|
||||
BuildRequires: libkf6-kirigami-devel
|
||||
BuildRequires: libkf6-kwidgetsaddons-devel
|
||||
BuildRequires: libkf6-kwindowsystem-devel
|
||||
BuildRequires: libkguiaddons-devel
|
||||
BuildRequires: libki18n-devel
|
||||
BuildRequires: libkiconthemes-devel
|
||||
BuildRequires: libkirigami2-devel
|
||||
BuildRequires: libkservice-devel
|
||||
BuildRequires: libkwidgetsaddons-devel
|
||||
BuildRequires: libkwindowsystem-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
BuildRequires: qt5-qtdeclarative-devel
|
||||
BuildRequires: qt6-qtbase-devel
|
||||
BuildRequires: qt6-qtdeclarative-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
BuildRequires: rpm-macros-kde5
|
||||
BuildRequires: kf6-rpm-macros
|
||||
BuildRequires: extra-cmake-modules
|
||||
Requires: breeze-icons
|
||||
Requires: breeze-default-lookandfeel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
@ -68,33 +78,31 @@ This package contains the libraries provided with %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake_kde5 -d build
|
||||
%make
|
||||
%cmake_kf6
|
||||
%cmake_build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
%cmake_install
|
||||
|
||||
%find_lang %{name}5_qt --with-qt --all-name || touch %{name}5_qt.lang
|
||||
%find_lang %{name} --with-qt --all-name || touch %{name}.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}5_qt.lang
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/breeze-settings5
|
||||
%{_bindir}/breeze-settings6
|
||||
%{_datadir}/applications/breezestyleconfig.desktop
|
||||
%{_datadir}/applications/kcm_breezedecoration.desktop
|
||||
%{_datadir}/kconf_update/*.upd
|
||||
%{_datadir}/kstyle/themes/breeze.themerc
|
||||
%{_datadir}/QtCurve/Breeze.qtcurve
|
||||
%dir %{_datadir}/icons/Breeze_Snow
|
||||
%dir %{_datadir}/icons/Breeze_Snow/cursors
|
||||
%{_datadir}/icons/Breeze_Snow/cursors/*
|
||||
%{_datadir}/icons/Breeze_Snow/index.theme
|
||||
%dir %{_datadir}/icons/Breeze_Light
|
||||
%dir %{_datadir}/icons/Breeze_Light/cursors
|
||||
%{_datadir}/icons/Breeze_Light/cursors/*
|
||||
%{_datadir}/icons/Breeze_Light/index.theme
|
||||
%dir %{_datadir}/icons/breeze_cursors/cursors
|
||||
%{_datadir}/icons/breeze_cursors/cursors/*
|
||||
%{_datadir}/icons/breeze_cursors/index.theme
|
||||
@ -109,23 +117,35 @@ This package contains the libraries provided with %{name}.
|
||||
%{_datadir}/wallpapers/Next/contents/images/*
|
||||
%dir %{_datadir}/wallpapers/Next/contents/images_dark
|
||||
%{_datadir}/wallpapers/Next/contents/images_dark/*
|
||||
%{_datadir}/wallpapers/Next/contents/screenshot.png
|
||||
%{_datadir}/wallpapers/Next/metadata.json
|
||||
|
||||
%files -n lib%{name} -f %{name}5_qt.lang
|
||||
%files -n lib%{name} -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libbreezecommon5.so.*
|
||||
%{_libdir}/kconf_update_bin/*
|
||||
%{_libdir}/kconf_update_bin/breezetobreezelight
|
||||
%{_libdir}/qt5/plugins/plasma/kcms/breeze/kcm_breezedecoration.so
|
||||
%{_libdir}/qt5/plugins/plasma/kcms/systemsettings_qwidgets/breezestyleconfig.so
|
||||
%{_libdir}/qt5/plugins/org.kde.kdecoration2/breezedecoration.so
|
||||
%{_libdir}/qt5/plugins/styles/breeze.so
|
||||
%{_qt6_plugindir}/kstyle_config/breezestyleconfig.so
|
||||
%{_qt6_plugindir}/org.kde.kdecoration2.kcm/kcm_breezedecoration.so
|
||||
%{_qt6_plugindir}/org.kde.kdecoration2/org.kde.breeze.so
|
||||
%{_qt6_plugindir}/styles/breeze5.so
|
||||
%{_qt6_plugindir}/styles/breeze6.so
|
||||
%dir %{_libdir}/cmake/Breeze
|
||||
%{_libdir}/cmake/Breeze/Breeze*.cmake
|
||||
%doc AUTHORS LICENSES
|
||||
#%doc AUTHORS LICENSES
|
||||
|
||||
%changelog
|
||||
* Wed Mar 13 2024 Automatic Build System <autodist@openmamba.org> 6.0.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Mar 07 2024 Automatic Build System <autodist@openmamba.org> 6.0.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Mar 01 2024 Automatic Build System <autodist@openmamba.org> 6.0.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Feb 03 2024 Automatic Build System <autodist@openmamba.org> 5.93.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jan 27 2024 Automatic Build System <autodist@openmamba.org> 5.92.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Dec 06 2023 Automatic Build System <autodist@mambasoft.it> 5.27.10-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user