rebuild with qt (qt6-qtsvg-devel) 6.9.0 [release 6.3.4-2mamba;Thu Apr 10 2025]
This commit is contained in:
parent
a787851797
commit
0603bf08b3
27
breeze-6.3.4-qt-6.9.0-2.patch
Normal file
27
breeze-6.3.4-qt-6.9.0-2.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From e2f16562b64c63b623def44476eadc635a82c7de Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kai Uwe Broulik <kde@privat.broulik.de>
|
||||||
|
Date: Fri, 17 Jan 2025 18:41:26 +0100
|
||||||
|
Subject: [PATCH] kcursorgen: Add QDebug include
|
||||||
|
|
||||||
|
It failed to build for me because of qCritical.
|
||||||
|
|
||||||
|
(cherry picked from commit 663da19b8ba6b9849b81bc57f7f8ff4944f6976a)
|
||||||
|
---
|
||||||
|
cursors/src/kcursorgen/kcursorgen.cpp | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/cursors/src/kcursorgen/kcursorgen.cpp b/cursors/src/kcursorgen/kcursorgen.cpp
|
||||||
|
index 3ae733501..aa4bd9ff2 100644
|
||||||
|
--- a/cursors/src/kcursorgen/kcursorgen.cpp
|
||||||
|
+++ b/cursors/src/kcursorgen/kcursorgen.cpp
|
||||||
|
@@ -7,6 +7,7 @@
|
||||||
|
#include "options.h"
|
||||||
|
|
||||||
|
#include <QCollator>
|
||||||
|
+#include <QDebug>
|
||||||
|
#include <QDir>
|
||||||
|
#include <QImage>
|
||||||
|
#include <QJsonArray>
|
||||||
|
--
|
||||||
|
GitLab
|
||||||
|
|
25
breeze-6.3.4-qt-6.9.0.patch
Normal file
25
breeze-6.3.4-qt-6.9.0.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 098ad3facb3d76fe4476424f1b7bf3c9c2c1b142 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Nicolas Fella <nicolas.fella@gmx.de>
|
||||||
|
Date: Fri, 17 Jan 2025 16:46:19 +0100
|
||||||
|
Subject: [PATCH] Add missing includes
|
||||||
|
|
||||||
|
(cherry picked from commit 9df8a685aa2d7ed1e9e633dda96d141c591f398e)
|
||||||
|
---
|
||||||
|
cursors/src/kcursorgen/main.cpp | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/cursors/src/kcursorgen/main.cpp b/cursors/src/kcursorgen/main.cpp
|
||||||
|
index 96d5e2ecd..b1a284f44 100644
|
||||||
|
--- a/cursors/src/kcursorgen/main.cpp
|
||||||
|
+++ b/cursors/src/kcursorgen/main.cpp
|
||||||
|
@@ -8,6 +8,7 @@
|
||||||
|
|
||||||
|
#include <QCommandLineParser>
|
||||||
|
#include <QCoreApplication>
|
||||||
|
+#include <QDebug>
|
||||||
|
#include <QString>
|
||||||
|
|
||||||
|
int main(int argc, char **argv)
|
||||||
|
--
|
||||||
|
GitLab
|
||||||
|
|
11
breeze.spec
11
breeze.spec
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
Name: breeze
|
Name: breeze
|
||||||
Version: 6.3.4
|
Version: 6.3.4
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Breeze Dark Desktop Design Language by the KDE VDG
|
Summary: Breeze Dark Desktop Design Language by the KDE VDG
|
||||||
Group: Graphical Desktop/Look 'n' feel
|
Group: Graphical Desktop/Look 'n' feel
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -11,6 +11,8 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://kde.org/it/plasma-desktop/
|
URL: https://kde.org/it/plasma-desktop/
|
||||||
Source: https://download.kde.org/%{stable_kf6}/plasma/%{plasmaver}/breeze-%{version}.tar.xz
|
Source: https://download.kde.org/%{stable_kf6}/plasma/%{plasmaver}/breeze-%{version}.tar.xz
|
||||||
|
Patch0: breeze-6.3.4-qt-6.9.0.patch
|
||||||
|
Patch1: breeze-6.3.4-qt-6.9.0-2.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -58,6 +60,7 @@ BuildRequires: qt5-qtdeclarative-devel
|
|||||||
BuildRequires: qt6-qtdeclarative-devel
|
BuildRequires: qt6-qtdeclarative-devel
|
||||||
BuildRequires: qt6-qtsvg-devel
|
BuildRequires: qt6-qtsvg-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: qt6-qtsvg-devel >= 6.9.0
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: kf6-rpm-macros
|
BuildRequires: kf6-rpm-macros
|
||||||
BuildRequires: extra-cmake-modules
|
BuildRequires: extra-cmake-modules
|
||||||
@ -91,9 +94,10 @@ Group: System/Libraries
|
|||||||
Breeze Dark Desktop Design Language by the KDE VDG for KDE Plasma 5.
|
Breeze Dark Desktop Design Language by the KDE VDG for KDE Plasma 5.
|
||||||
This package contains the libraries provided with %{name}.
|
This package contains the libraries provided with %{name}.
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch 0 -p1 -b .qt-6.9.0
|
||||||
|
%patch 1 -p1 -b .qt-6.9.0-2
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake_kf6
|
%cmake_kf6
|
||||||
@ -163,6 +167,9 @@ This package contains the libraries provided with %{name}.
|
|||||||
%{_qt5_plugindir}/styles/breeze5.so
|
%{_qt5_plugindir}/styles/breeze5.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 10 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 6.3.4-2mamba
|
||||||
|
- rebuild with qt (qt6-qtsvg-devel) 6.9.0
|
||||||
|
|
||||||
* Wed Apr 02 2025 Automatic Build System <autodist@openmamba.org> 6.3.4-1mamba
|
* Wed Apr 02 2025 Automatic Build System <autodist@openmamba.org> 6.3.4-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user