automatic version update by autodist [release 1.97-1mamba;Fri Jan 04 2013]
This commit is contained in:
parent
f138e2a7bb
commit
3356333991
@ -1,2 +1,5 @@
|
||||
# bonniePlusPlus
|
||||
# bonnie++
|
||||
|
||||
bonnie++ filesystem and disk benchmark suite aggressively reads & writes in various ways on your filesystem then outputs useful benchmark performance data.
|
||||
bonnie++ is also useful as a hardware, disk, and filesystem stability test, exposing some types of hardware or kernel failures that would otherwise be difficult to detect.
|
||||
|
||||
|
34
bonnie++-1.96-makefile.patch
Normal file
34
bonnie++-1.96-makefile.patch
Normal file
@ -0,0 +1,34 @@
|
||||
--- bonnie++-1.96.orig/Makefile.in 2009-12-09 10:01:09.000000000 -0500
|
||||
+++ bonnie++-1.96/Makefile.in 2009-12-09 10:02:33.000000000 -0500
|
||||
@@ -17,6 +17,8 @@ THREAD_LFLAGS=@thread_ldflags@
|
||||
INSTALL=@INSTALL@
|
||||
INSTALL_PROGRAM=@INSTALL_PROGRAM@
|
||||
|
||||
+DESTDIR=
|
||||
+
|
||||
BONSRC=bonnie++.cpp bon_io.cpp bon_file.cpp bon_time.cpp semaphore.cpp \
|
||||
sync.cpp thread.cpp bon_suid.cpp duration.cpp rand.o util.o
|
||||
BONOBJS=$(BONSRC:.cpp=.o)
|
||||
@@ -52,15 +54,15 @@ generate_randfile: generate_randfile.o
|
||||
$(LINK) generate_randfile.o -o generate_randfile
|
||||
|
||||
install-bin: $(EXE) $(EXES)
|
||||
- mkdir -p $(eprefix)/bin $(eprefix)/sbin
|
||||
- @INSTALL_PROGRAM@ @stripping@ $(EXES) $(eprefix)/sbin
|
||||
- @INSTALL_PROGRAM@ @stripping@ $(EXE) $(eprefix)/bin
|
||||
- @INSTALL_SCRIPT@ $(SCRIPTS) $(eprefix)/bin
|
||||
+ mkdir -p $(DESTDIR)$(eprefix)/bin $(DESTDIR)$(eprefix)/sbin
|
||||
+ @INSTALL_PROGRAM@ @stripping@ $(EXES) $(DESTDIR)$(eprefix)/sbin
|
||||
+ @INSTALL_PROGRAM@ @stripping@ $(EXE) $(DESTDIR)$(eprefix)/bin
|
||||
+ @INSTALL_SCRIPT@ $(SCRIPTS) $(DESTDIR)$(eprefix)/bin
|
||||
|
||||
install: install-bin
|
||||
- mkdir -p @mandir@/man1 @mandir@/man8
|
||||
- @INSTALL_DATA@ $(MAN1) @mandir@/man1
|
||||
- @INSTALL_DATA@ $(MAN8) @mandir@/man8
|
||||
+ mkdir -p $(DESTDIR)@mandir@/man1 $(DESTDIR)@mandir@/man8
|
||||
+ @INSTALL_DATA@ $(MAN1) $(DESTDIR)@mandir@/man1
|
||||
+ @INSTALL_DATA@ $(MAN8) $(DESTDIR)@mandir@/man8
|
||||
|
||||
%.o: %.cpp
|
||||
$(CXX) -c $<
|
58
bonnie++.spec
Normal file
58
bonnie++.spec
Normal file
@ -0,0 +1,58 @@
|
||||
Name: bonnie++
|
||||
Version: 1.97
|
||||
Release: 1mamba
|
||||
Summary: Benchmark suite to perform simple tests of hard drive and file system performance
|
||||
Group: System/Benchmarks
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.coker.com.au/bonnie++
|
||||
Source: http://www.coker.com.au/bonnie++/experimental/bonnie++-%{version}.tgz
|
||||
Patch: %{name}-1.96-makefile.patch
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
bonnie++ filesystem and disk benchmark suite aggressively reads & writes in various ways on your filesystem then outputs useful benchmark performance data.
|
||||
bonnie++ is also useful as a hardware, disk, and filesystem stability test, exposing some types of hardware or kernel failures that would otherwise be difficult to detect.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}.1
|
||||
%patch -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/*
|
||||
%{_sbindir}/*
|
||||
%{_mandir}/man?/*
|
||||
%doc readme.html copyright.txt credits.txt debian/changelog
|
||||
|
||||
%changelog
|
||||
* Fri Jan 04 2013 Automatic Build System <autodist@mambasoft.it> 1.97-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jul 03 2012 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.96-1mamba
|
||||
- update to 1.96
|
||||
- added missing build requirements
|
||||
|
||||
* Tue May 29 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.03a-2mamba
|
||||
- rebuilt
|
||||
|
||||
* Mon Nov 11 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.6-1qilnx
|
||||
- First build
|
Loading…
Reference in New Issue
Block a user