blender/blender-2.46-xvidcore_configure.patch

31 lines
1.7 KiB
Diff

diff -Nru blender-2.46.orig/extern/xvidcore/build/generic/configure blender-2.46/extern/xvidcore/build/generic/configure
--- blender-2.46.orig/extern/xvidcore/build/generic/configure 2008-05-19 16:38:45.000000000 +0200
+++ blender-2.46/extern/xvidcore/build/generic/configure 2008-05-22 13:18:35.000000000 +0200
@@ -4016,9 +4016,9 @@
if test "$ac_nasm" = "yes" ; then
echo "$as_me:$LINENO: checking for nasm patch version" >&5
echo $ECHO_N "checking for nasm patch version... $ECHO_C" >&6
- nasm_patch=`$nasm_prog -r | cut -d '.' -f 3 | cut -d ' ' -f 1`
+ nasm_patch=`($nasm_prog -r || $nasm_prog -v) | cut -d '.' -f 3 | cut -d ' ' -f 1`
if test -z $nasm_patch ; then
- nasm_patch=-1
+ nasm_patch=45
fi
echo "$as_me:$LINENO: result: $nasm_patch" >&5
echo "${ECHO_T}$nasm_patch" >&6
diff -Nru blender-2.46.orig/extern/xvidcore/build/generic/configure.in blender-2.46/extern/xvidcore/build/generic/configure.in
--- blender-2.46.orig/extern/xvidcore/build/generic/configure.in 2008-05-19 16:38:45.000000000 +0200
+++ blender-2.46/extern/xvidcore/build/generic/configure.in 2008-05-22 13:18:28.000000000 +0200
@@ -363,9 +363,9 @@
dnl Checking nasm patch version
dnl
AC_MSG_CHECKING([for nasm patch version])
- nasm_patch=`$nasm_prog -r | cut -d '.' -f 3 | cut -d ' ' -f 1`
+ nasm_patch=`($nasm_prog -r || $nasm_prog -v) | cut -d '.' -f 3 | cut -d ' ' -f 1`
if test -z $nasm_patch ; then
- nasm_patch=-1
+ nasm_patch=45
fi
AC_MSG_RESULT([$nasm_patch])