automatic version update by autodist [release 2.70a-1mamba;Sun Apr 13 2014]
This commit is contained in:
parent
f6280a41d0
commit
cfc7ffe6f1
@ -1,2 +1,5 @@
|
|||||||
# blender
|
# blender
|
||||||
|
|
||||||
|
Blender is the essential software solution you need for 3D, from modeling, animation, rendering and post-production to interactive creation and playback.
|
||||||
|
Professionals and novices can easily and inexpensively publish stand-alone, secure, multi-platform content to the web, CD-ROMs, and other media, whether they are users of Windows, Linux, Irix, Sun Solaris, FreeBSD or OSX.
|
||||||
|
|
||||||
|
30
blender-2.46-xvidcore_configure.patch
Normal file
30
blender-2.46-xvidcore_configure.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -Nru blender-2.46.orig/extern/xvidcore/build/generic/configure blender-2.46/extern/xvidcore/build/generic/configure
|
||||||
|
--- blender-2.46.orig/extern/xvidcore/build/generic/configure 2008-05-19 16:38:45.000000000 +0200
|
||||||
|
+++ blender-2.46/extern/xvidcore/build/generic/configure 2008-05-22 13:18:35.000000000 +0200
|
||||||
|
@@ -4016,9 +4016,9 @@
|
||||||
|
if test "$ac_nasm" = "yes" ; then
|
||||||
|
echo "$as_me:$LINENO: checking for nasm patch version" >&5
|
||||||
|
echo $ECHO_N "checking for nasm patch version... $ECHO_C" >&6
|
||||||
|
- nasm_patch=`$nasm_prog -r | cut -d '.' -f 3 | cut -d ' ' -f 1`
|
||||||
|
+ nasm_patch=`($nasm_prog -r || $nasm_prog -v) | cut -d '.' -f 3 | cut -d ' ' -f 1`
|
||||||
|
if test -z $nasm_patch ; then
|
||||||
|
- nasm_patch=-1
|
||||||
|
+ nasm_patch=45
|
||||||
|
fi
|
||||||
|
echo "$as_me:$LINENO: result: $nasm_patch" >&5
|
||||||
|
echo "${ECHO_T}$nasm_patch" >&6
|
||||||
|
diff -Nru blender-2.46.orig/extern/xvidcore/build/generic/configure.in blender-2.46/extern/xvidcore/build/generic/configure.in
|
||||||
|
--- blender-2.46.orig/extern/xvidcore/build/generic/configure.in 2008-05-19 16:38:45.000000000 +0200
|
||||||
|
+++ blender-2.46/extern/xvidcore/build/generic/configure.in 2008-05-22 13:18:28.000000000 +0200
|
||||||
|
@@ -363,9 +363,9 @@
|
||||||
|
dnl Checking nasm patch version
|
||||||
|
dnl
|
||||||
|
AC_MSG_CHECKING([for nasm patch version])
|
||||||
|
- nasm_patch=`$nasm_prog -r | cut -d '.' -f 3 | cut -d ' ' -f 1`
|
||||||
|
+ nasm_patch=`($nasm_prog -r || $nasm_prog -v) | cut -d '.' -f 3 | cut -d ' ' -f 1`
|
||||||
|
if test -z $nasm_patch ; then
|
||||||
|
- nasm_patch=-1
|
||||||
|
+ nasm_patch=45
|
||||||
|
fi
|
||||||
|
AC_MSG_RESULT([$nasm_patch])
|
||||||
|
|
100
blender-2.48a-ffmpeg-includes.patch
Normal file
100
blender-2.48a-ffmpeg-includes.patch
Normal file
@ -0,0 +1,100 @@
|
|||||||
|
diff -Naur blender-2.46-orig/source/blender/blenkernel/intern/writeffmpeg.c blender-2.46/source/blender/blenkernel/intern/writeffmpeg.c
|
||||||
|
--- blender-2.46-orig/source/blender/blenkernel/intern/writeffmpeg.c 2008-07-28 15:33:17.000000000 +0300
|
||||||
|
+++ blender-2.46/source/blender/blenkernel/intern/writeffmpeg.c 2008-07-28 15:35:25.000000000 +0300
|
||||||
|
@@ -29,11 +29,11 @@
|
||||||
|
|
||||||
|
#include <stdlib.h>
|
||||||
|
|
||||||
|
-#include <ffmpeg/avformat.h>
|
||||||
|
-#include <ffmpeg/avcodec.h>
|
||||||
|
-#include <ffmpeg/rational.h>
|
||||||
|
-#include <ffmpeg/swscale.h>
|
||||||
|
-#include <ffmpeg/opt.h>
|
||||||
|
+#include <libavformat/avformat.h>
|
||||||
|
+#include <libavcodec/avcodec.h>
|
||||||
|
+#include <libavutil/rational.h>
|
||||||
|
+#include <libswscale/swscale.h>
|
||||||
|
+#include <libavcodec/opt.h>
|
||||||
|
|
||||||
|
#if LIBAVFORMAT_VERSION_INT < (49 << 16)
|
||||||
|
#define FFMPEG_OLD_FRAME_RATE 1
|
||||||
|
diff -Naur blender-2.46-orig/source/blender/imbuf/intern/anim.c blender-2.46/source/blender/imbuf/intern/anim.c
|
||||||
|
--- blender-2.46-orig/source/blender/imbuf/intern/anim.c 2008-05-19 17:38:41.000000000 +0300
|
||||||
|
+++ blender-2.46/source/blender/imbuf/intern/anim.c 2008-07-28 16:06:04.000000000 +0300
|
||||||
|
@@ -83,10 +83,10 @@
|
||||||
|
#include "IMB_anim5.h"
|
||||||
|
|
||||||
|
#ifdef WITH_FFMPEG
|
||||||
|
-#include <ffmpeg/avformat.h>
|
||||||
|
-#include <ffmpeg/avcodec.h>
|
||||||
|
-#include <ffmpeg/rational.h>
|
||||||
|
-#include <ffmpeg/swscale.h>
|
||||||
|
+#include <libavformat/avformat.h>
|
||||||
|
+#include <libavcodec/avcodec.h>
|
||||||
|
+#include <libavutil/rational.h>
|
||||||
|
+#include <libswscale/swscale.h>
|
||||||
|
|
||||||
|
#if LIBAVFORMAT_VERSION_INT < (49 << 16)
|
||||||
|
#define FFMPEG_OLD_FRAME_RATE 1
|
||||||
|
diff -Naur blender-2.46-orig/source/blender/imbuf/intern/IMB_anim.h blender-2.46/source/blender/imbuf/intern/IMB_anim.h
|
||||||
|
--- blender-2.46-orig/source/blender/imbuf/intern/IMB_anim.h 2008-05-19 17:38:41.000000000 +0300
|
||||||
|
+++ blender-2.46/source/blender/imbuf/intern/IMB_anim.h 2008-07-28 16:06:04.000000000 +0300
|
||||||
|
@@ -76,9 +76,9 @@
|
||||||
|
#endif /* WITH_QUICKTIME */
|
||||||
|
|
||||||
|
#ifdef WITH_FFMPEG
|
||||||
|
-#include <ffmpeg/avformat.h>
|
||||||
|
-#include <ffmpeg/avcodec.h>
|
||||||
|
-#include <ffmpeg/swscale.h>
|
||||||
|
+#include <libavformat/avformat.h>
|
||||||
|
+#include <libavcodec/avcodec.h>
|
||||||
|
+#include <libswscale/swscale.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#include "IMB_imbuf_types.h"
|
||||||
|
diff -Naur blender-2.46-orig/source/blender/imbuf/intern/util.c blender-2.46/source/blender/imbuf/intern/util.c
|
||||||
|
--- blender-2.46-orig/source/blender/imbuf/intern/util.c 2008-05-19 17:38:41.000000000 +0300
|
||||||
|
+++ blender-2.46/source/blender/imbuf/intern/util.c 2008-07-28 16:06:04.000000000 +0300
|
||||||
|
@@ -62,8 +62,8 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifdef WITH_FFMPEG
|
||||||
|
-#include <ffmpeg/avcodec.h>
|
||||||
|
-#include <ffmpeg/avformat.h>
|
||||||
|
+#include <libavcodec/avcodec.h>
|
||||||
|
+#include <libavformat/avformat.h>
|
||||||
|
|
||||||
|
#if LIBAVFORMAT_VERSION_INT < (49 << 16)
|
||||||
|
#define FFMPEG_OLD_FRAME_RATE 1
|
||||||
|
diff -Naur blender-2.46-orig/source/blender/src/buttons_scene.c blender-2.46/source/blender/src/buttons_scene.c
|
||||||
|
--- blender-2.46-orig/source/blender/src/buttons_scene.c 2008-07-28 16:13:29.000000000 +0300
|
||||||
|
+++ blender-2.46/source/blender/src/buttons_scene.c 2008-07-28 16:20:45.000000000 +0300
|
||||||
|
@@ -108,9 +108,9 @@
|
||||||
|
|
||||||
|
#ifdef WITH_FFMPEG
|
||||||
|
|
||||||
|
-#include <ffmpeg/avcodec.h> /* for PIX_FMT_* and CODEC_ID_* */
|
||||||
|
-#include <ffmpeg/avformat.h>
|
||||||
|
-#include <ffmpeg/opt.h>
|
||||||
|
+#include <libavcodec/avcodec.h> /* for PIX_FMT_* and CODEC_ID_* */
|
||||||
|
+#include <libavformat/avformat.h>
|
||||||
|
+#include <libavcodec/opt.h>
|
||||||
|
|
||||||
|
static int ffmpeg_preset_sel = 0;
|
||||||
|
|
||||||
|
diff -Naur blender-2.46-orig/source/blender/src/hddaudio.c blender-2.46/source/blender/src/hddaudio.c
|
||||||
|
--- blender-2.46-orig/source/blender/src/hddaudio.c 2008-07-28 16:13:29.000000000 +0300
|
||||||
|
+++ blender-2.46/source/blender/src/hddaudio.c 2008-07-28 16:20:45.000000000 +0300
|
||||||
|
@@ -33,9 +33,9 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifdef WITH_FFMPEG
|
||||||
|
-#include <ffmpeg/avformat.h>
|
||||||
|
-#include <ffmpeg/avcodec.h>
|
||||||
|
-#include <ffmpeg/rational.h>
|
||||||
|
+#include <libavformat/avformat.h>
|
||||||
|
+#include <libavcodec/avcodec.h>
|
||||||
|
+#include <libavutil/rational.h>
|
||||||
|
#if LIBAVFORMAT_VERSION_INT < (49 << 16)
|
||||||
|
#define FFMPEG_OLD_FRAME_RATE 1
|
||||||
|
#else
|
21
blender-2.48a-ffmpeg.patch
Normal file
21
blender-2.48a-ffmpeg.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -Nru blender-2.48a.orig/source/blender/src/hddaudio.c blender-2.48a/source/blender/src/hddaudio.c
|
||||||
|
--- blender-2.48a.orig/source/blender/src/hddaudio.c 2008-10-22 18:36:41.000000000 +0200
|
||||||
|
+++ blender-2.48a/source/blender/src/hddaudio.c 2008-11-17 15:13:24.000000000 +0100
|
||||||
|
@@ -311,7 +311,7 @@
|
||||||
|
audio_pkt_size = packet.size;
|
||||||
|
|
||||||
|
while (audio_pkt_size > 0) {
|
||||||
|
- len = avcodec_decode_audio(
|
||||||
|
+ len = avcodec_decode_audio2(
|
||||||
|
hdaudio->pCodecCtx,
|
||||||
|
hdaudio->decode_cache
|
||||||
|
+ decode_pos,
|
||||||
|
@@ -478,7 +478,7 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
while (audio_pkt_size > 0) {
|
||||||
|
- len = avcodec_decode_audio(
|
||||||
|
+ len = avcodec_decode_audio2(
|
||||||
|
hdaudio->pCodecCtx,
|
||||||
|
hdaudio->decode_cache
|
||||||
|
+ decode_pos,
|
16
blender-2.68a-freestyle-build.patch
Normal file
16
blender-2.68a-freestyle-build.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- blender-2.68a/source/blender/freestyle/intern/scene_graph/NodeCamera.cpp 2013-07-26 22:37:28.836673925 +0200
|
||||||
|
+++ blender-2.68a.orig/source/blender/freestyle/intern/scene_graph/NodeCamera.cpp 2013-04-09 02:46:49.000000000 +0200
|
||||||
|
@@ -53,13 +53,11 @@
|
||||||
|
loadIdentity(projection_matrix_);
|
||||||
|
}
|
||||||
|
|
||||||
|
-#if 0 /* UNUSED, gives warning in gcc */
|
||||||
|
NodeCamera::NodeCamera(const NodeCamera& iBrother) : camera_type_(iBrother.camera_type_)
|
||||||
|
{
|
||||||
|
memcpy(modelview_matrix_, iBrother.modelview_matrix_, 16 * sizeof(double));
|
||||||
|
memcpy(projection_matrix_, iBrother.projection_matrix_, 16 * sizeof(double));
|
||||||
|
}
|
||||||
|
-#endif
|
||||||
|
|
||||||
|
void NodeCamera::accept(SceneVisitor& v)
|
||||||
|
{
|
3
blender-wrapper
Normal file
3
blender-wrapper
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
cd /usr/share/blender && ./blender -w
|
86
blender.desktop
Normal file
86
blender.desktop
Normal file
@ -0,0 +1,86 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Encoding=UTF-8
|
||||||
|
Name=Blender
|
||||||
|
Name[ar]=بليندر
|
||||||
|
Name[bn]=ব্লেণ্ডার
|
||||||
|
Name[es]=Indice
|
||||||
|
Name[fa]=بلِندر
|
||||||
|
Name[hi]=ब्लैण्डर
|
||||||
|
Name[is]=Hrærivél
|
||||||
|
Name[km]=កម្មវិធីលាយ
|
||||||
|
Name[ko]=블렌더
|
||||||
|
Name[pa]=ਬਲੈਡਰ
|
||||||
|
Name[rw]=Kuvanga
|
||||||
|
Name[ta]=ப்ளன்டர்
|
||||||
|
Name[tg]=Блендер
|
||||||
|
Name[th]=เบลนเดอร์
|
||||||
|
Name[xx]=xxBlenderxx
|
||||||
|
MimeType=
|
||||||
|
GenericName=3D Modeler/Renderer
|
||||||
|
GenericName[af]=3D Beeld Moduleerder/Renderer
|
||||||
|
GenericName[ar]=أداة نمذجة ثلاثية الأبعاد
|
||||||
|
GenericName[az]=3D Modelləyici/Render Vasitəsi
|
||||||
|
GenericName[bg]=Редактор за триизмерни изображения
|
||||||
|
GenericName[bn]=ত্রিমাত্রিক মডেলার/প্রদর্শক
|
||||||
|
GenericName[ca]=Modelador i renderitzador 3D
|
||||||
|
GenericName[cs]=Modelář 3D scén
|
||||||
|
GenericName[cy]=Modelydd/Trosydd 3D
|
||||||
|
GenericName[da]=3D Modelerer/Fremviser
|
||||||
|
GenericName[de]=3D-Modeler/Renderer
|
||||||
|
GenericName[el]=3D Μοντελοποιητής/Renderer
|
||||||
|
GenericName[en_GB]=3D Modeller/Renderer
|
||||||
|
GenericName[eo]=Desegnilo/bildigilo por tridimensiaj scenoj
|
||||||
|
GenericName[es]=Modelador de escenas 3D
|
||||||
|
GenericName[et]=3D modelleerija/teisendaja
|
||||||
|
GenericName[eu]=3D Modelatzailea/Renderizatzailea
|
||||||
|
GenericName[fa]=پردازشکننده/مدلگر سه بعدی
|
||||||
|
GenericName[fi]=3D-mallintaja/renderöijä
|
||||||
|
GenericName[fr]=Logiciel d'animation et de modélisation 3D
|
||||||
|
GenericName[fy]=3D modelearprogramma
|
||||||
|
GenericName[ga]=Insamhlóir/Rindreálaí 3T
|
||||||
|
GenericName[gl]=Modelador/Renderizador 3D
|
||||||
|
GenericName[he]=ממדל ומרנדר תלת־מימד
|
||||||
|
GenericName[hi]=3डी मॉडलर/रेंडरर
|
||||||
|
GenericName[hr]=Program za modeliranje/renderiranje 3d scena
|
||||||
|
GenericName[hu]=3D-s modellező
|
||||||
|
GenericName[is]=Tól til vinnslu með 3D hluti
|
||||||
|
GenericName[it]=Modellatore e render 3D
|
||||||
|
GenericName[ja]=3Dモデラ/レンダラ
|
||||||
|
GenericName[ko]=3차원 모델링/렌더링 도구
|
||||||
|
GenericName[lv]=3D Scēnu Modelētājs
|
||||||
|
GenericName[mk]=3D Моделирач/Исцртувач
|
||||||
|
GenericName[mn]=3 хэмжээст дүр зураг загварчилагч
|
||||||
|
GenericName[ms]=Pemodel/Pelukis 3D
|
||||||
|
GenericName[nb]=3D-modellering/visning
|
||||||
|
GenericName[nds]=3D-Modellmaak- un -tekenprogramm
|
||||||
|
GenericName[nl]=3D modeleerprogramma
|
||||||
|
GenericName[nn]=3d-modellering/-vising
|
||||||
|
GenericName[pa]=3ਡੀ ਮੋਡੀਲੀਰ/ਪੇਸ਼ਕਾਰ
|
||||||
|
GenericName[pl]=Program do modelowania trójwymiarowego
|
||||||
|
GenericName[pt]=Modelador/Rasterizador 3D
|
||||||
|
GenericName[pt_BR]=Modelador/Renderizador 3D
|
||||||
|
GenericName[ro]=Modelator de scene 3D
|
||||||
|
GenericName[ru]=3D рендерер/моделер
|
||||||
|
GenericName[rw]=Mutunganya/Mutanga Nyamubyimba
|
||||||
|
GenericName[se]=3d-modelleren/-čájeheapmi
|
||||||
|
GenericName[sk]=3D modelovanie/rendrovanie scén
|
||||||
|
GenericName[sl]=3D Modelirnik scen/upodabljalnik
|
||||||
|
GenericName[sr]=3D моделар/рендерер
|
||||||
|
GenericName[sr@Latn]=3D modelar/renderer
|
||||||
|
GenericName[sv]=3D-modellering/uppritning
|
||||||
|
GenericName[ta]=முப்பரிமாண மாதிரி
|
||||||
|
GenericName[tg]=3D Модулгар/Пардозишкунанда
|
||||||
|
GenericName[th]=วาดภาพ/ออกแบบโมเดล 3 มิติ
|
||||||
|
GenericName[tr]=3B Modelleme Programı
|
||||||
|
GenericName[uk]=Модельєр 3D
|
||||||
|
GenericName[vi]=Trình tạo mẫu và hỗ trợ 3D
|
||||||
|
GenericName[xx]=xx3D Modeler/Rendererxx
|
||||||
|
GenericName[zh_CN]=3D 建模/渲染器
|
||||||
|
GenericName[zh_TW]=3D 場景繪製程式
|
||||||
|
Exec=blender -w
|
||||||
|
Icon=blender
|
||||||
|
Path=
|
||||||
|
Type=Application
|
||||||
|
Categories=Graphics;3DGraphics;KDE
|
||||||
|
Terminal=false
|
||||||
|
X-KDE-StartupNotify=false
|
BIN
blender.png
Normal file
BIN
blender.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 4.4 KiB |
324
blender.spec
Normal file
324
blender.spec
Normal file
@ -0,0 +1,324 @@
|
|||||||
|
%define majver %(echo %version | sed "s|[a-z]*$||")
|
||||||
|
Name: blender
|
||||||
|
Version: 2.70a
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: 3D modeling, animation, rendering and post-production
|
||||||
|
Group: Applications/Multimedia
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.blender.org/
|
||||||
|
Source0: http://download.blender.org/source/blender-%{version}.tar.gz
|
||||||
|
Source1: blender.png
|
||||||
|
Source2: blender.desktop
|
||||||
|
Source3: blender-wrapper
|
||||||
|
Patch0: %{name}-2.46-xvidcore_configure.patch
|
||||||
|
Patch1: %{name}-2.48a-ffmpeg.patch
|
||||||
|
Patch2: %{name}-2.48a-ffmpeg-includes.patch
|
||||||
|
Patch3: blender-2.68a-freestyle-build.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libboost-devel
|
||||||
|
BuildRequires: libfftw-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libglew-devel
|
||||||
|
BuildRequires: libGLU-devel
|
||||||
|
BuildRequires: libgomp-devel
|
||||||
|
BuildRequires: libilmbase-devel
|
||||||
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: libopenal-devel
|
||||||
|
BuildRequires: libopenexr-devel
|
||||||
|
BuildRequires: libopenjpeg-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libpython3-devel
|
||||||
|
BuildRequires: libSDL-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libtiff-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXi-devel
|
||||||
|
BuildRequires: libXxf86vm-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: bash
|
||||||
|
BuildRequires: ldconfig
|
||||||
|
#BuildRequires: yafray
|
||||||
|
BuildRequires: nasm
|
||||||
|
BuildRequires: scons
|
||||||
|
BuildRequires: libtool
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: libglut-devel
|
||||||
|
BuildRequires: libopenssl-devel
|
||||||
|
BuildRequires: libesound-devel
|
||||||
|
BuildRequires: libnspr-devel
|
||||||
|
BuildRequires: libsmpeg-devel
|
||||||
|
BuildRequires: libode-devel
|
||||||
|
BuildRequires: gettext-devel
|
||||||
|
BuildRequires: libspnav-devel
|
||||||
|
BuildRequires: python-numpy-py3
|
||||||
|
BuildRequires: libopenexr-devel >= 2.0.1-3mamba
|
||||||
|
BuildRequires: libilmbase-devel >= 2.0.1-2mamba
|
||||||
|
#Requires: yafray
|
||||||
|
%py_requires
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root/
|
||||||
|
|
||||||
|
# FIXME : (build requirements)
|
||||||
|
# fmod: http://www.fmod.org/
|
||||||
|
# quicktime: http://developer.apple.com/quicktime/
|
||||||
|
# FTGL: http://homepages.paradise.net.nz/henryj/code/#FTGL
|
||||||
|
|
||||||
|
%description
|
||||||
|
Blender is the essential software solution you need for 3D, from modeling, animation, rendering and post-production to interactive creation and playback.
|
||||||
|
Professionals and novices can easily and inexpensively publish stand-alone, secure, multi-platform content to the web, CD-ROMs, and other media, whether they are users of Windows, Linux, Irix, Sun Solaris, FreeBSD or OSX.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-v%{version}
|
||||||
|
#-D -T
|
||||||
|
#:<< _EOF
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
#:<< _EOF
|
||||||
|
%cmake -d build \
|
||||||
|
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
||||||
|
-DCMAKE_SKIP_RPATH=ON \
|
||||||
|
-DWITH_INSTALL_PORTABLE=OFF \
|
||||||
|
-DOPENJPEG_INCLUDE_DIR=%{_includedir}/openjpeg-1.5 \
|
||||||
|
-DWITH_CYCLES=0 \
|
||||||
|
-DBOOST_ROOT=1
|
||||||
|
|
||||||
|
export LD_LIBRARY_PATH=`pwd`/lib
|
||||||
|
%make
|
||||||
|
|
||||||
|
#sed -i "s/use_openal =.*/use_openal = 'true'/g" SConstruct
|
||||||
|
##sed -i "s/release_flags = .*/release_flags = \"%{optflags}\"/" SConstruct
|
||||||
|
#
|
||||||
|
#scons clean || :
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != "/" ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall -C build
|
||||||
|
|
||||||
|
install -d %{buildroot}%{_libdir}/blender
|
||||||
|
cp -a build/lib/* %{buildroot}%{_libdir}/blender/
|
||||||
|
|
||||||
|
install -d %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
||||||
|
cat > %{buildroot}%{_sysconfdir}/ld.so.conf.d/blender.conf << _EOF
|
||||||
|
%{_libdir}/blender
|
||||||
|
_EOF
|
||||||
|
|
||||||
|
# BF_PYTHON=%{python3_inc} \
|
||||||
|
#scons install \
|
||||||
|
# BF_BUILDDIR=./rpmbuildir \
|
||||||
|
# BF_PYTHON_INC=%{python3_inc} \
|
||||||
|
# BF_PYTHON_BINARY=%{_bindir}/python3 \
|
||||||
|
# BF_PYTHON_LIB=python%{python3_version} \
|
||||||
|
# WITH_BF_FFMPEG='true' \
|
||||||
|
# BF_FFMPEG='%{_prefix}' \
|
||||||
|
# BF_FFMPEG_INC='%{_includedir}' \
|
||||||
|
# BF_FFMPEG_LIB='avformat avcodec avdevice avutil swscale xvidcore ogg dc1394 raw1394 faac faad x264 mp3lame vorbis theora vorbisenc dts' \
|
||||||
|
# BF_FFMPEG_EXTRA='-D__STDC_CONSTANT_MACROS' \
|
||||||
|
# WITH_BF_GAMEENGINE='true' \
|
||||||
|
# BF_INSTALLDIR=%{buildroot}%{_datadir}/blender/ \
|
||||||
|
# BF_OPENEXR_INC=%{_includedir}/OpenEXR/
|
||||||
|
#
|
||||||
|
#install -D -m0644 %{S:1} %{buildroot}%{_datadir}/pixmaps/blender.png
|
||||||
|
#install -D -m0644 %{S:2} %{buildroot}%{_datadir}/applications/blender.desktop
|
||||||
|
#install -D -m0755 %{S:3} %{buildroot}%{_bindir}/blender
|
||||||
|
#
|
||||||
|
##rmdir %{buildroot}%{_datadir}/blender/%{majver}/python/lib
|
||||||
|
##rmdir %{buildroot}%{_datadir}/blender/%{majver}/python
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != "/" ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post
|
||||||
|
/sbin/ldconfig
|
||||||
|
:
|
||||||
|
|
||||||
|
%postun
|
||||||
|
if [ $? -eq 0 ]; then
|
||||||
|
/sbin/ldconfig
|
||||||
|
fi
|
||||||
|
:
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-, root, root)
|
||||||
|
%{_sysconfdir}/ld.so.conf.d/blender.conf
|
||||||
|
%{_bindir}/blender
|
||||||
|
%{_bindir}/blender-thumbnailer.py
|
||||||
|
%dir %{_libdir}/blender
|
||||||
|
%{_libdir}/blender/*.so
|
||||||
|
%dir %{_datadir}/blender
|
||||||
|
%{_datadir}/blender/*
|
||||||
|
%{_datadir}/applications/blender.desktop
|
||||||
|
%{_datadir}/icons/hicolor/*/apps/blender.png
|
||||||
|
%{_datadir}/icons/hicolor/scalable/apps/blender.svg
|
||||||
|
%dir %{_datadir}/doc/blender
|
||||||
|
%{_datadir}/doc/blender/*
|
||||||
|
%{_mandir}/man1/blender.1.gz
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Apr 13 2014 Automatic Build System <autodist@mambasoft.it> 2.70a-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Mar 31 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.70-2mamba
|
||||||
|
- rebuilt with openexr 2.1.0
|
||||||
|
|
||||||
|
* Thu Mar 20 2014 Automatic Build System <autodist@mambasoft.it> 2.70-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Dec 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.69-2mamba
|
||||||
|
- rebuilt with boost 1.55
|
||||||
|
|
||||||
|
* Thu Oct 31 2013 Automatic Build System <autodist@mambasoft.it> 2.69-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Jul 27 2013 Automatic Build System <autodist@mambasoft.it> 2.68a-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Mar 08 2013 Automatic Build System <autodist@mambasoft.it> 2.66a-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Feb 24 2013 Automatic Build System <autodist@mambasoft.it> 2.66-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Dec 26 2012 Automatic Build System <autodist@mambasoft.it> 2.65a-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Oct 10 2012 Automatic Build System <autodist@mambasoft.it> 2.64a-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Oct 04 2012 Automatic Build System <autodist@mambasoft.it> 2.64-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri May 11 2012 Automatic Build System <autodist@mambasoft.it> 2.63a-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Apr 27 2012 Automatic Build System <autodist@mambasoft.it> 2.63-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Feb 17 2012 Automatic Build System <autodist@mambasoft.it> 2.62-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Dec 14 2011 Automatic Build System <autodist@mambasoft.it> 2.61-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Oct 26 2011 Automatic Build System <autodist@mambasoft.it> 2.60a-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Sep 01 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.59-2mamba
|
||||||
|
- remove empty python dir in blender datadir to fix application startup
|
||||||
|
|
||||||
|
* Mon Aug 29 2011 Automatic Build System <autodist@mambasoft.it> 2.59-1mamba
|
||||||
|
- update to 2.59
|
||||||
|
|
||||||
|
* Wed Jun 30 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.49b-7mamba
|
||||||
|
- rebuilt with ffmpeg 0.6
|
||||||
|
|
||||||
|
* Thu Jun 10 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.49b-6mamba
|
||||||
|
- rebuilt with ffmpeg 0.52
|
||||||
|
|
||||||
|
* Thu Mar 18 2010 Automatic Build System <autodist@mambasoft.it> 2.49b-5mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Dec 07 2009 Automatic Build System <autodist@mambasoft.it> 2.49b-4mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Sat Oct 31 2009 Automatic Build System <autodist@mambasoft.it> 2.49b-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Thu Oct 15 2009 Automatic Build System <autodist@mambasoft.it> 2.49b-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Thu Sep 10 2009 Automatic Build System <autodist@mambasoft.it> 2.49b-1mamba
|
||||||
|
- automatic update to 2.49b by autodist
|
||||||
|
|
||||||
|
* Wed Aug 19 2009 Automatic Build System <autodist@mambasoft.it> 2.49a-5mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Wed Aug 12 2009 Automatic Build System <autodist@mambasoft.it> 2.49a-4mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Tue Jul 14 2009 Automatic Build System <autodist@mambasoft.it> 2.49a-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Fri Jul 10 2009 Automatic Build System <autodist@mambasoft.it> 2.49a-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Jun 29 2009 Automatic Build System <autodist@mambasoft.it> 2.49a-1mamba
|
||||||
|
- automatic update to 2.49a by autodist
|
||||||
|
|
||||||
|
* Sat Apr 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.48a-7mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Wed Jan 07 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.48a-6mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Wed Dec 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.48a-5mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Sun Nov 23 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.48a-4mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Sun Nov 23 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.48a-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Nov 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.48a-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Fri Oct 24 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.48a-1mamba
|
||||||
|
- automatic update to 2.48a by autodist
|
||||||
|
|
||||||
|
* Wed Oct 15 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.48-1mamba
|
||||||
|
- automatic update to 2.48 by autodist
|
||||||
|
|
||||||
|
* Sun Aug 24 2008 gil <puntogil@libero.it> 2.47-1mamba
|
||||||
|
- update to 2.47
|
||||||
|
|
||||||
|
* Mon Jun 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.46-2mamba
|
||||||
|
- rebuilt against recent libdc1394
|
||||||
|
|
||||||
|
* Tue May 20 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.46-1mamba
|
||||||
|
- update to 2.46
|
||||||
|
- game engine build enabled
|
||||||
|
- build against external ffmpeg
|
||||||
|
|
||||||
|
* Fri Dec 28 2007 Aleph0 <aleph0@openmamba.org> 2.45-3mamba
|
||||||
|
- rebuilt against new gettext libraries
|
||||||
|
- use %%python_version to get the current version of python
|
||||||
|
- set BF_BUILDDIR to build blender inside the build directory
|
||||||
|
|
||||||
|
* Thu Oct 11 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.45-2mamba
|
||||||
|
- added requirement for yafray
|
||||||
|
|
||||||
|
* Mon Sep 24 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.45-1mamba
|
||||||
|
- update to 2.45
|
||||||
|
|
||||||
|
* Sat May 19 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.44-2mamba
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Tue May 15 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.44-1mamba
|
||||||
|
- update to 2.44
|
||||||
|
- moved desktop menu icon to %{_datadir}/applications
|
||||||
|
|
||||||
|
* Sat Apr 14 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.42a-2mamba
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Mon Jan 29 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.42a-1qilnx
|
||||||
|
- update to version 2.42a by autospec
|
||||||
|
|
||||||
|
* Thu Jan 26 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.41-1qilnx
|
||||||
|
- update to version 2.41 by autospec
|
||||||
|
- new desktop file
|
||||||
|
|
||||||
|
* Fri Jul 01 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 2.37a-1qilnx
|
||||||
|
- update to version 2.37a by autospec
|
||||||
|
|
||||||
|
* Tue Apr 05 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 2.36-2qilnx
|
||||||
|
- Rebuild and moved from devel-contrib repository to devel repository
|
||||||
|
|
||||||
|
* Wed Mar 16 2005 Matteo Bernasconi <voyagernm@virgilio.it> 2.36-1qilnx
|
||||||
|
- First Build
|
Loading…
Reference in New Issue
Block a user