automatic version update by autodist [release 4.1.0-1mamba;Fri Mar 29 2024]
This commit is contained in:
parent
0606004e36
commit
5daedda979
@ -1,29 +0,0 @@
|
||||
From cf4365e555a759d5b3225bce77858374cb07faad Mon Sep 17 00:00:00 2001
|
||||
From: Ray Molenkamp <github@lazydodo.com>
|
||||
Date: Thu, 1 Feb 2024 09:09:20 -0700
|
||||
Subject: [PATCH] CMake: Disable unity builds on cmake 2.28.2
|
||||
|
||||
CMake 2.28.2 has a regression that breaks the combination of
|
||||
precompiled headers and unity builds [1]. Disable unity builds
|
||||
for this specific cmake version to sidestep the issue.
|
||||
|
||||
[1] https://gitlab.kitware.com/cmake/cmake/-/issues/25650
|
||||
---
|
||||
CMakeLists.txt | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index c12dc749ce3..7460f0282ce 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -245,7 +245,9 @@ mark_as_advanced(CPACK_OVERRIDE_PACKAGENAME)
|
||||
mark_as_advanced(BUILDINFO_OVERRIDE_DATE)
|
||||
mark_as_advanced(BUILDINFO_OVERRIDE_TIME)
|
||||
|
||||
-if(${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.16")
|
||||
+# CMAKE 3.28.2 has issues with the combination of PCH and unity builds, disable for now.
|
||||
+# upstream ticket https://gitlab.kitware.com/cmake/cmake/-/issues/25650
|
||||
+if(${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.16" AND NOT ${CMAKE_VERSION} VERSION_EQUAL "3.28.2")
|
||||
option(WITH_UNITY_BUILD "\
|
||||
Enable unity build for modules that support it to improve compile times.\n\
|
||||
WARNING: this option allows files to be built without all necessary headers!\n
|
28
blender.spec
28
blender.spec
@ -1,7 +1,7 @@
|
||||
%define majver %(echo %version | sed "s|[a-z]*$||")
|
||||
Name: blender
|
||||
Version: 4.0.2
|
||||
Release: 2mamba
|
||||
Version: 4.1.0
|
||||
Release: 1mamba
|
||||
Summary: 3D modeling, animation, rendering and post-production
|
||||
Group: Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
@ -12,10 +12,8 @@ Source0: https+git://projects.blender.org/blender/blender.git/v%{version}/
|
||||
Source1: https://developer.download.nvidia.com/redist/optix/v7.7/OptiX-7.7-Include.zip
|
||||
Patch5: blender-3.6.2-force-draco1.patch
|
||||
Patch6: blender-3.6.2-force-draco2.patch
|
||||
Patch9: blender-4.0.2-cmake-3.28.2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
#libOpenColorIO.so.2.1()(64bit): library not reported by ldconfig and not provided in any installed package
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libX11-devel
|
||||
@ -45,6 +43,7 @@ BuildRequires: libjemalloc-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libminizip1-devel
|
||||
BuildRequires: libopenal-devel
|
||||
BuildRequires: libopencolorio-devel
|
||||
BuildRequires: libopenexr-devel
|
||||
BuildRequires: libopenimageio-devel
|
||||
BuildRequires: libopenjpeg-devel
|
||||
@ -67,7 +66,6 @@ BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
BuildRequires: pugixml-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libopencolorio-devel >= 2.3.2-1mamba
|
||||
BuildRequires: bash
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: ldconfig
|
||||
@ -76,16 +74,17 @@ BuildRequires: nasm
|
||||
BuildRequires: scons
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: libdecor-devel
|
||||
BuildRequires: libembree-devel
|
||||
BuildRequires: libembree-devel >= 4.3.0
|
||||
BuildRequires: libesound-devel
|
||||
BuildRequires: libglut-devel
|
||||
BuildRequires: libode-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libopenimageio-devel >= 2.5.6.0
|
||||
BuildRequires: libnspr-devel
|
||||
BuildRequires: libode-devel
|
||||
BuildRequires: libopencolorio-devel >= 1:2.3.2-1mamba
|
||||
BuildRequires: libopenimageio-devel >= 2.5.6.0
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libsmpeg-devel
|
||||
BuildRequires: libspnav-devel
|
||||
BuildRequires: python-numpy-py310
|
||||
BuildRequires: python-numpy-py3
|
||||
|
||||
%description
|
||||
Blender is the essential software solution you need for 3D, from modeling, animation, rendering and post-production to interactive creation and playback.
|
||||
@ -97,6 +96,11 @@ Professionals and novices can easily and inexpensively publish stand-alone, secu
|
||||
%setup -q -a1
|
||||
#% setup -q -D -T
|
||||
#:<< _EOF
|
||||
|
||||
%ifarch aarch64
|
||||
sed -i "s|make_update.py|make_update.py --architecture arm64|" GNUmakefile
|
||||
%endif
|
||||
|
||||
make update
|
||||
|
||||
%define _default_patch_fuzz 2
|
||||
@ -104,7 +108,6 @@ make update
|
||||
cd scripts/addons
|
||||
%patch 6 -p1 -b .force-draco2
|
||||
cd ../..
|
||||
%patch 9 -p1 -b .cmake-3.28.2
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -174,6 +177,9 @@ install -D -m644 release/freedesktop/org.blender.Blender.metainfo.xml \
|
||||
#%{_mandir}/man1/blender.1.gz
|
||||
|
||||
%changelog
|
||||
* Fri Mar 29 2024 Automatic Build System <autodist@openmamba.org> 4.1.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Feb 05 2024 Automatic Build System <autodist@mambasoft.it> 4.0.2-2mamba
|
||||
- rebuilt by autoport with build requirements: libopencolorio-devel>=2.3.2-1mamba
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user