automatic version update by autodist [release 4.3.2-1mamba;Tue Dec 17 2024]
This commit is contained in:
parent
9e2a471f46
commit
3dbff10f68
@ -1,15 +0,0 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 75f5795db68..d50686adfb0 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -754,10 +754,6 @@ endif()
|
||||
set_and_warn_dependency(WITH_PYTHON WITH_CYCLES OFF)
|
||||
set_and_warn_dependency(WITH_PYTHON WITH_DRACO OFF)
|
||||
|
||||
-if(WITH_DRACO AND NOT WITH_PYTHON_INSTALL)
|
||||
- message(STATUS "WITH_DRACO requires WITH_PYTHON_INSTALL to be ON, disabling WITH_DRACO for now")
|
||||
- set(WITH_DRACO OFF)
|
||||
-endif()
|
||||
|
||||
# enable boost for cycles, audaspace or i18n
|
||||
# otherwise if the user disabled
|
18
blender-4.3.0-force-draco1.patch
Normal file
18
blender-4.3.0-force-draco1.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 97596dbee8d..d1ad6ac5de0 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -1237,13 +1237,6 @@ set_and_warn_dependency(WITH_PYTHON WITH_CYCLES OFF)
|
||||
set_and_warn_dependency(WITH_PYTHON WITH_DRACO OFF)
|
||||
set_and_warn_dependency(WITH_PYTHON WITH_MOD_FLUID OFF)
|
||||
|
||||
-if(NOT WITH_PYTHON_MODULE)
|
||||
- if(WITH_DRACO AND NOT WITH_PYTHON_INSTALL)
|
||||
- message(STATUS "WITH_DRACO requires WITH_PYTHON_INSTALL to be ON, disabling WITH_DRACO for now")
|
||||
- set(WITH_DRACO OFF)
|
||||
- endif()
|
||||
-endif()
|
||||
-
|
||||
# enable boost for cycles, audaspace or i18n
|
||||
# otherwise if the user disabled
|
||||
|
24
blender.spec
24
blender.spec
@ -1,6 +1,6 @@
|
||||
%define majver %(echo %version | sed "s|[a-z]*$||")
|
||||
Name: blender
|
||||
Version: 4.2.3
|
||||
Version: 4.3.2
|
||||
Release: 1mamba
|
||||
Summary: 3D modeling, animation, rendering and post-production
|
||||
Group: Applications/Multimedia
|
||||
@ -10,13 +10,12 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.blender.org
|
||||
Source0: https+git://projects.blender.org/blender/blender.git/v%{version}/blender-%{version}.tar.bz2
|
||||
Source1: https://developer.download.nvidia.com/redist/optix/v7.7/OptiX-7.7-Include.zip
|
||||
Patch0: blender-3.6.2-force-draco1.patch
|
||||
Patch0: blender-4.3.0-force-draco1.patch
|
||||
Patch1: blender-4.2.3-ffmpeg-7.1-1.patch
|
||||
Patch2: blender-4.2.3-ffmpeg-7.1-2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXi-devel
|
||||
@ -58,6 +57,7 @@ BuildRequires: libpulseaudio-devel
|
||||
BuildRequires: libpystring-devel
|
||||
BuildRequires: libpython3-devel
|
||||
BuildRequires: libpython311-devel
|
||||
BuildRequires: libshaderc-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libspnav-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
@ -65,6 +65,7 @@ BuildRequires: libswresample-devel
|
||||
BuildRequires: libswscale-devel
|
||||
BuildRequires: libtbb-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libvulkan-devel
|
||||
BuildRequires: libwebp-devel
|
||||
BuildRequires: libxkbcommon-devel
|
||||
BuildRequires: libyaml-cpp-devel
|
||||
@ -72,6 +73,9 @@ BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
BuildRequires: pugixml-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libopenvdb-devel >= 0:12.0.0-1mamba
|
||||
BuildRequires: libopenshadinglanguage-devel
|
||||
BuildRequires: libdraco-devel
|
||||
BuildRequires: bash
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: git-lfs
|
||||
@ -117,9 +121,11 @@ make update
|
||||
%build
|
||||
#:<< _EOF
|
||||
%cmake -d build \
|
||||
-Wno-dev \
|
||||
-DBUILD_SHARED_LIBS:BOOL=OFF \
|
||||
-DCUDA_HOST_COMPILER=/usr/bin/gcc \
|
||||
-DPYTHON_VERSION=%{python3_version} \
|
||||
-DPYTHON_NUMPY_INCLUDE_DIRS=%{_includedir}/numpy \
|
||||
-DHIP_ROOT_DIR=/opt/rocm \
|
||||
-DOPTIX_ROOT_DIR="${PWD}" \
|
||||
-DWITH_CYCLES_OSL=NO \
|
||||
@ -179,6 +185,18 @@ install -D -m644 release/freedesktop/org.blender.Blender.metainfo.xml \
|
||||
#%{_mandir}/man1/blender.1.gz
|
||||
|
||||
%changelog
|
||||
* Tue Dec 17 2024 Automatic Build System <autodist@openmamba.org> 4.3.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Dec 10 2024 Automatic Build System <autodist@openmamba.org> 4.3.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 23 2024 Automatic Build System <autodist@openmamba.org> 4.3.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Nov 20 2024 Automatic Build System <autodist@mambasoft.it> 4.2.3-2mamba
|
||||
- rebuilt by autoport with build requirements: libopenvdb-devel>=0:12.0.0-1mamba
|
||||
|
||||
* Tue Oct 22 2024 Automatic Build System <autodist@openmamba.org> 4.2.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user