rebuilt by autoport with build requirements: libopencolorio-devel>=2.3.2-1mamba [release 4.0.2-2mamba;Mon Feb 05 2024]
This commit is contained in:
parent
44da0ca149
commit
0606004e36
@ -1,30 +0,0 @@
|
|||||||
diff -Nru blender-2.46.orig/extern/xvidcore/build/generic/configure blender-2.46/extern/xvidcore/build/generic/configure
|
|
||||||
--- blender-2.46.orig/extern/xvidcore/build/generic/configure 2008-05-19 16:38:45.000000000 +0200
|
|
||||||
+++ blender-2.46/extern/xvidcore/build/generic/configure 2008-05-22 13:18:35.000000000 +0200
|
|
||||||
@@ -4016,9 +4016,9 @@
|
|
||||||
if test "$ac_nasm" = "yes" ; then
|
|
||||||
echo "$as_me:$LINENO: checking for nasm patch version" >&5
|
|
||||||
echo $ECHO_N "checking for nasm patch version... $ECHO_C" >&6
|
|
||||||
- nasm_patch=`$nasm_prog -r | cut -d '.' -f 3 | cut -d ' ' -f 1`
|
|
||||||
+ nasm_patch=`($nasm_prog -r || $nasm_prog -v) | cut -d '.' -f 3 | cut -d ' ' -f 1`
|
|
||||||
if test -z $nasm_patch ; then
|
|
||||||
- nasm_patch=-1
|
|
||||||
+ nasm_patch=45
|
|
||||||
fi
|
|
||||||
echo "$as_me:$LINENO: result: $nasm_patch" >&5
|
|
||||||
echo "${ECHO_T}$nasm_patch" >&6
|
|
||||||
diff -Nru blender-2.46.orig/extern/xvidcore/build/generic/configure.in blender-2.46/extern/xvidcore/build/generic/configure.in
|
|
||||||
--- blender-2.46.orig/extern/xvidcore/build/generic/configure.in 2008-05-19 16:38:45.000000000 +0200
|
|
||||||
+++ blender-2.46/extern/xvidcore/build/generic/configure.in 2008-05-22 13:18:28.000000000 +0200
|
|
||||||
@@ -363,9 +363,9 @@
|
|
||||||
dnl Checking nasm patch version
|
|
||||||
dnl
|
|
||||||
AC_MSG_CHECKING([for nasm patch version])
|
|
||||||
- nasm_patch=`$nasm_prog -r | cut -d '.' -f 3 | cut -d ' ' -f 1`
|
|
||||||
+ nasm_patch=`($nasm_prog -r || $nasm_prog -v) | cut -d '.' -f 3 | cut -d ' ' -f 1`
|
|
||||||
if test -z $nasm_patch ; then
|
|
||||||
- nasm_patch=-1
|
|
||||||
+ nasm_patch=45
|
|
||||||
fi
|
|
||||||
AC_MSG_RESULT([$nasm_patch])
|
|
||||||
|
|
@ -1,100 +0,0 @@
|
|||||||
diff -Naur blender-2.46-orig/source/blender/blenkernel/intern/writeffmpeg.c blender-2.46/source/blender/blenkernel/intern/writeffmpeg.c
|
|
||||||
--- blender-2.46-orig/source/blender/blenkernel/intern/writeffmpeg.c 2008-07-28 15:33:17.000000000 +0300
|
|
||||||
+++ blender-2.46/source/blender/blenkernel/intern/writeffmpeg.c 2008-07-28 15:35:25.000000000 +0300
|
|
||||||
@@ -29,11 +29,11 @@
|
|
||||||
|
|
||||||
#include <stdlib.h>
|
|
||||||
|
|
||||||
-#include <ffmpeg/avformat.h>
|
|
||||||
-#include <ffmpeg/avcodec.h>
|
|
||||||
-#include <ffmpeg/rational.h>
|
|
||||||
-#include <ffmpeg/swscale.h>
|
|
||||||
-#include <ffmpeg/opt.h>
|
|
||||||
+#include <libavformat/avformat.h>
|
|
||||||
+#include <libavcodec/avcodec.h>
|
|
||||||
+#include <libavutil/rational.h>
|
|
||||||
+#include <libswscale/swscale.h>
|
|
||||||
+#include <libavcodec/opt.h>
|
|
||||||
|
|
||||||
#if LIBAVFORMAT_VERSION_INT < (49 << 16)
|
|
||||||
#define FFMPEG_OLD_FRAME_RATE 1
|
|
||||||
diff -Naur blender-2.46-orig/source/blender/imbuf/intern/anim.c blender-2.46/source/blender/imbuf/intern/anim.c
|
|
||||||
--- blender-2.46-orig/source/blender/imbuf/intern/anim.c 2008-05-19 17:38:41.000000000 +0300
|
|
||||||
+++ blender-2.46/source/blender/imbuf/intern/anim.c 2008-07-28 16:06:04.000000000 +0300
|
|
||||||
@@ -83,10 +83,10 @@
|
|
||||||
#include "IMB_anim5.h"
|
|
||||||
|
|
||||||
#ifdef WITH_FFMPEG
|
|
||||||
-#include <ffmpeg/avformat.h>
|
|
||||||
-#include <ffmpeg/avcodec.h>
|
|
||||||
-#include <ffmpeg/rational.h>
|
|
||||||
-#include <ffmpeg/swscale.h>
|
|
||||||
+#include <libavformat/avformat.h>
|
|
||||||
+#include <libavcodec/avcodec.h>
|
|
||||||
+#include <libavutil/rational.h>
|
|
||||||
+#include <libswscale/swscale.h>
|
|
||||||
|
|
||||||
#if LIBAVFORMAT_VERSION_INT < (49 << 16)
|
|
||||||
#define FFMPEG_OLD_FRAME_RATE 1
|
|
||||||
diff -Naur blender-2.46-orig/source/blender/imbuf/intern/IMB_anim.h blender-2.46/source/blender/imbuf/intern/IMB_anim.h
|
|
||||||
--- blender-2.46-orig/source/blender/imbuf/intern/IMB_anim.h 2008-05-19 17:38:41.000000000 +0300
|
|
||||||
+++ blender-2.46/source/blender/imbuf/intern/IMB_anim.h 2008-07-28 16:06:04.000000000 +0300
|
|
||||||
@@ -76,9 +76,9 @@
|
|
||||||
#endif /* WITH_QUICKTIME */
|
|
||||||
|
|
||||||
#ifdef WITH_FFMPEG
|
|
||||||
-#include <ffmpeg/avformat.h>
|
|
||||||
-#include <ffmpeg/avcodec.h>
|
|
||||||
-#include <ffmpeg/swscale.h>
|
|
||||||
+#include <libavformat/avformat.h>
|
|
||||||
+#include <libavcodec/avcodec.h>
|
|
||||||
+#include <libswscale/swscale.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#include "IMB_imbuf_types.h"
|
|
||||||
diff -Naur blender-2.46-orig/source/blender/imbuf/intern/util.c blender-2.46/source/blender/imbuf/intern/util.c
|
|
||||||
--- blender-2.46-orig/source/blender/imbuf/intern/util.c 2008-05-19 17:38:41.000000000 +0300
|
|
||||||
+++ blender-2.46/source/blender/imbuf/intern/util.c 2008-07-28 16:06:04.000000000 +0300
|
|
||||||
@@ -62,8 +62,8 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#ifdef WITH_FFMPEG
|
|
||||||
-#include <ffmpeg/avcodec.h>
|
|
||||||
-#include <ffmpeg/avformat.h>
|
|
||||||
+#include <libavcodec/avcodec.h>
|
|
||||||
+#include <libavformat/avformat.h>
|
|
||||||
|
|
||||||
#if LIBAVFORMAT_VERSION_INT < (49 << 16)
|
|
||||||
#define FFMPEG_OLD_FRAME_RATE 1
|
|
||||||
diff -Naur blender-2.46-orig/source/blender/src/buttons_scene.c blender-2.46/source/blender/src/buttons_scene.c
|
|
||||||
--- blender-2.46-orig/source/blender/src/buttons_scene.c 2008-07-28 16:13:29.000000000 +0300
|
|
||||||
+++ blender-2.46/source/blender/src/buttons_scene.c 2008-07-28 16:20:45.000000000 +0300
|
|
||||||
@@ -108,9 +108,9 @@
|
|
||||||
|
|
||||||
#ifdef WITH_FFMPEG
|
|
||||||
|
|
||||||
-#include <ffmpeg/avcodec.h> /* for PIX_FMT_* and CODEC_ID_* */
|
|
||||||
-#include <ffmpeg/avformat.h>
|
|
||||||
-#include <ffmpeg/opt.h>
|
|
||||||
+#include <libavcodec/avcodec.h> /* for PIX_FMT_* and CODEC_ID_* */
|
|
||||||
+#include <libavformat/avformat.h>
|
|
||||||
+#include <libavcodec/opt.h>
|
|
||||||
|
|
||||||
static int ffmpeg_preset_sel = 0;
|
|
||||||
|
|
||||||
diff -Naur blender-2.46-orig/source/blender/src/hddaudio.c blender-2.46/source/blender/src/hddaudio.c
|
|
||||||
--- blender-2.46-orig/source/blender/src/hddaudio.c 2008-07-28 16:13:29.000000000 +0300
|
|
||||||
+++ blender-2.46/source/blender/src/hddaudio.c 2008-07-28 16:20:45.000000000 +0300
|
|
||||||
@@ -33,9 +33,9 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#ifdef WITH_FFMPEG
|
|
||||||
-#include <ffmpeg/avformat.h>
|
|
||||||
-#include <ffmpeg/avcodec.h>
|
|
||||||
-#include <ffmpeg/rational.h>
|
|
||||||
+#include <libavformat/avformat.h>
|
|
||||||
+#include <libavcodec/avcodec.h>
|
|
||||||
+#include <libavutil/rational.h>
|
|
||||||
#if LIBAVFORMAT_VERSION_INT < (49 << 16)
|
|
||||||
#define FFMPEG_OLD_FRAME_RATE 1
|
|
||||||
#else
|
|
@ -1,21 +0,0 @@
|
|||||||
diff -Nru blender-2.48a.orig/source/blender/src/hddaudio.c blender-2.48a/source/blender/src/hddaudio.c
|
|
||||||
--- blender-2.48a.orig/source/blender/src/hddaudio.c 2008-10-22 18:36:41.000000000 +0200
|
|
||||||
+++ blender-2.48a/source/blender/src/hddaudio.c 2008-11-17 15:13:24.000000000 +0100
|
|
||||||
@@ -311,7 +311,7 @@
|
|
||||||
audio_pkt_size = packet.size;
|
|
||||||
|
|
||||||
while (audio_pkt_size > 0) {
|
|
||||||
- len = avcodec_decode_audio(
|
|
||||||
+ len = avcodec_decode_audio2(
|
|
||||||
hdaudio->pCodecCtx,
|
|
||||||
hdaudio->decode_cache
|
|
||||||
+ decode_pos,
|
|
||||||
@@ -478,7 +478,7 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
while (audio_pkt_size > 0) {
|
|
||||||
- len = avcodec_decode_audio(
|
|
||||||
+ len = avcodec_decode_audio2(
|
|
||||||
hdaudio->pCodecCtx,
|
|
||||||
hdaudio->decode_cache
|
|
||||||
+ decode_pos,
|
|
@ -1,16 +0,0 @@
|
|||||||
--- blender-2.68a/source/blender/freestyle/intern/scene_graph/NodeCamera.cpp 2013-07-26 22:37:28.836673925 +0200
|
|
||||||
+++ blender-2.68a.orig/source/blender/freestyle/intern/scene_graph/NodeCamera.cpp 2013-04-09 02:46:49.000000000 +0200
|
|
||||||
@@ -53,13 +53,11 @@
|
|
||||||
loadIdentity(projection_matrix_);
|
|
||||||
}
|
|
||||||
|
|
||||||
-#if 0 /* UNUSED, gives warning in gcc */
|
|
||||||
NodeCamera::NodeCamera(const NodeCamera& iBrother) : camera_type_(iBrother.camera_type_)
|
|
||||||
{
|
|
||||||
memcpy(modelview_matrix_, iBrother.modelview_matrix_, 16 * sizeof(double));
|
|
||||||
memcpy(projection_matrix_, iBrother.projection_matrix_, 16 * sizeof(double));
|
|
||||||
}
|
|
||||||
-#endif
|
|
||||||
|
|
||||||
void NodeCamera::accept(SceneVisitor& v)
|
|
||||||
{
|
|
@ -1,9 +0,0 @@
|
|||||||
--- blender-2.79a/source/blender/blentranslation/msgfmt/CMakeLists.txt.orig 2018-03-11 21:41:59.164492990 +0100
|
|
||||||
+++ blender-2.79a/source/blender/blentranslation/msgfmt/CMakeLists.txt 2018-03-11 21:39:01.994550654 +0100
|
|
||||||
@@ -48,3 +48,6 @@
|
|
||||||
|
|
||||||
target_link_libraries(msgfmt ${ZLIB_LIBRARIES})
|
|
||||||
target_link_libraries(msgfmt ${PLATFORM_LINKLIBS})
|
|
||||||
+target_link_libraries(msgfmt extern_wcwidth)
|
|
||||||
+target_link_libraries(msgfmt bf_intern_eigen)
|
|
||||||
+target_link_libraries(msgfmt "-lfreetype")
|
|
@ -15,7 +15,7 @@ index e7518ac4..c0d78564 100644
|
|||||||
python_version = 'python{v[0]}.{v[1]}'.format(v=sys.version_info)
|
python_version = 'python{v[0]}.{v[1]}'.format(v=sys.version_info)
|
||||||
|
|
||||||
- path = os.environ.get('BLENDER_EXTERN_DRACO_LIBRARY_PATH')
|
- path = os.environ.get('BLENDER_EXTERN_DRACO_LIBRARY_PATH')
|
||||||
+ path = site.getsitepackages()[0]
|
+ path = f"{site.getsitepackages()[0]}/libextern_draco.so"
|
||||||
if path is None:
|
if path is None:
|
||||||
path = {
|
path = {
|
||||||
'win32': blender_root / python_lib / 'site-packages',
|
'win32': blender_root / python_lib / 'site-packages',
|
29
blender-4.0.2-cmake-3.28.2.patch
Normal file
29
blender-4.0.2-cmake-3.28.2.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From cf4365e555a759d5b3225bce77858374cb07faad Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ray Molenkamp <github@lazydodo.com>
|
||||||
|
Date: Thu, 1 Feb 2024 09:09:20 -0700
|
||||||
|
Subject: [PATCH] CMake: Disable unity builds on cmake 2.28.2
|
||||||
|
|
||||||
|
CMake 2.28.2 has a regression that breaks the combination of
|
||||||
|
precompiled headers and unity builds [1]. Disable unity builds
|
||||||
|
for this specific cmake version to sidestep the issue.
|
||||||
|
|
||||||
|
[1] https://gitlab.kitware.com/cmake/cmake/-/issues/25650
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 4 +++-
|
||||||
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index c12dc749ce3..7460f0282ce 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -245,7 +245,9 @@ mark_as_advanced(CPACK_OVERRIDE_PACKAGENAME)
|
||||||
|
mark_as_advanced(BUILDINFO_OVERRIDE_DATE)
|
||||||
|
mark_as_advanced(BUILDINFO_OVERRIDE_TIME)
|
||||||
|
|
||||||
|
-if(${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.16")
|
||||||
|
+# CMAKE 3.28.2 has issues with the combination of PCH and unity builds, disable for now.
|
||||||
|
+# upstream ticket https://gitlab.kitware.com/cmake/cmake/-/issues/25650
|
||||||
|
+if(${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.16" AND NOT ${CMAKE_VERSION} VERSION_EQUAL "3.28.2")
|
||||||
|
option(WITH_UNITY_BUILD "\
|
||||||
|
Enable unity build for modules that support it to improve compile times.\n\
|
||||||
|
WARNING: this option allows files to be built without all necessary headers!\n
|
@ -1,3 +0,0 @@
|
|||||||
#!/bin/bash
|
|
||||||
|
|
||||||
cd /usr/share/blender && ./blender -w
|
|
@ -1,86 +0,0 @@
|
|||||||
[Desktop Entry]
|
|
||||||
Encoding=UTF-8
|
|
||||||
Name=Blender
|
|
||||||
Name[ar]=بليندر
|
|
||||||
Name[bn]=ব্লেণ্ডার
|
|
||||||
Name[es]=Indice
|
|
||||||
Name[fa]=بلِندر
|
|
||||||
Name[hi]=ब्लैण्डर
|
|
||||||
Name[is]=Hrærivél
|
|
||||||
Name[km]=កម្មវិធីលាយ
|
|
||||||
Name[ko]=블렌더
|
|
||||||
Name[pa]=ਬਲੈਡਰ
|
|
||||||
Name[rw]=Kuvanga
|
|
||||||
Name[ta]=ப்ளன்டர்
|
|
||||||
Name[tg]=Блендер
|
|
||||||
Name[th]=เบลนเดอร์
|
|
||||||
Name[xx]=xxBlenderxx
|
|
||||||
MimeType=
|
|
||||||
GenericName=3D Modeler/Renderer
|
|
||||||
GenericName[af]=3D Beeld Moduleerder/Renderer
|
|
||||||
GenericName[ar]=أداة نمذجة ثلاثية الأبعاد
|
|
||||||
GenericName[az]=3D Modelləyici/Render Vasitəsi
|
|
||||||
GenericName[bg]=Редактор за триизмерни изображения
|
|
||||||
GenericName[bn]=ত্রিমাত্রিক মডেলার/প্রদর্শক
|
|
||||||
GenericName[ca]=Modelador i renderitzador 3D
|
|
||||||
GenericName[cs]=Modelář 3D scén
|
|
||||||
GenericName[cy]=Modelydd/Trosydd 3D
|
|
||||||
GenericName[da]=3D Modelerer/Fremviser
|
|
||||||
GenericName[de]=3D-Modeler/Renderer
|
|
||||||
GenericName[el]=3D Μοντελοποιητής/Renderer
|
|
||||||
GenericName[en_GB]=3D Modeller/Renderer
|
|
||||||
GenericName[eo]=Desegnilo/bildigilo por tridimensiaj scenoj
|
|
||||||
GenericName[es]=Modelador de escenas 3D
|
|
||||||
GenericName[et]=3D modelleerija/teisendaja
|
|
||||||
GenericName[eu]=3D Modelatzailea/Renderizatzailea
|
|
||||||
GenericName[fa]=پردازشکننده/مدلگر سه بعدی
|
|
||||||
GenericName[fi]=3D-mallintaja/renderöijä
|
|
||||||
GenericName[fr]=Logiciel d'animation et de modélisation 3D
|
|
||||||
GenericName[fy]=3D modelearprogramma
|
|
||||||
GenericName[ga]=Insamhlóir/Rindreálaí 3T
|
|
||||||
GenericName[gl]=Modelador/Renderizador 3D
|
|
||||||
GenericName[he]=ממדל ומרנדר תלת־מימד
|
|
||||||
GenericName[hi]=3डी मॉडलर/रेंडरर
|
|
||||||
GenericName[hr]=Program za modeliranje/renderiranje 3d scena
|
|
||||||
GenericName[hu]=3D-s modellező
|
|
||||||
GenericName[is]=Tól til vinnslu með 3D hluti
|
|
||||||
GenericName[it]=Modellatore e render 3D
|
|
||||||
GenericName[ja]=3Dモデラ/レンダラ
|
|
||||||
GenericName[ko]=3차원 모델링/렌더링 도구
|
|
||||||
GenericName[lv]=3D Scēnu Modelētājs
|
|
||||||
GenericName[mk]=3D Моделирач/Исцртувач
|
|
||||||
GenericName[mn]=3 хэмжээст дүр зураг загварчилагч
|
|
||||||
GenericName[ms]=Pemodel/Pelukis 3D
|
|
||||||
GenericName[nb]=3D-modellering/visning
|
|
||||||
GenericName[nds]=3D-Modellmaak- un -tekenprogramm
|
|
||||||
GenericName[nl]=3D modeleerprogramma
|
|
||||||
GenericName[nn]=3d-modellering/-vising
|
|
||||||
GenericName[pa]=3ਡੀ ਮੋਡੀਲੀਰ/ਪੇਸ਼ਕਾਰ
|
|
||||||
GenericName[pl]=Program do modelowania trójwymiarowego
|
|
||||||
GenericName[pt]=Modelador/Rasterizador 3D
|
|
||||||
GenericName[pt_BR]=Modelador/Renderizador 3D
|
|
||||||
GenericName[ro]=Modelator de scene 3D
|
|
||||||
GenericName[ru]=3D рендерер/моделер
|
|
||||||
GenericName[rw]=Mutunganya/Mutanga Nyamubyimba
|
|
||||||
GenericName[se]=3d-modelleren/-čájeheapmi
|
|
||||||
GenericName[sk]=3D modelovanie/rendrovanie scén
|
|
||||||
GenericName[sl]=3D Modelirnik scen/upodabljalnik
|
|
||||||
GenericName[sr]=3D моделар/рендерер
|
|
||||||
GenericName[sr@Latn]=3D modelar/renderer
|
|
||||||
GenericName[sv]=3D-modellering/uppritning
|
|
||||||
GenericName[ta]=முப்பரிமாண மாதிரி
|
|
||||||
GenericName[tg]=3D Модулгар/Пардозишкунанда
|
|
||||||
GenericName[th]=วาดภาพ/ออกแบบโมเดล 3 มิติ
|
|
||||||
GenericName[tr]=3B Modelleme Programı
|
|
||||||
GenericName[uk]=Модельєр 3D
|
|
||||||
GenericName[vi]=Trình tạo mẫu và hỗ trợ 3D
|
|
||||||
GenericName[xx]=xx3D Modeler/Rendererxx
|
|
||||||
GenericName[zh_CN]=3D 建模/渲染器
|
|
||||||
GenericName[zh_TW]=3D 場景繪製程式
|
|
||||||
Exec=blender -w
|
|
||||||
Icon=blender
|
|
||||||
Path=
|
|
||||||
Type=Application
|
|
||||||
Categories=Graphics;3DGraphics;KDE
|
|
||||||
Terminal=false
|
|
||||||
X-KDE-StartupNotify=false
|
|
BIN
blender.png
BIN
blender.png
Binary file not shown.
Before Width: | Height: | Size: 4.4 KiB |
149
blender.spec
149
blender.spec
@ -1,26 +1,21 @@
|
|||||||
%define majver %(echo %version | sed "s|[a-z]*$||")
|
%define majver %(echo %version | sed "s|[a-z]*$||")
|
||||||
Name: blender
|
Name: blender
|
||||||
Version: 3.2.2
|
Version: 4.0.2
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: 3D modeling, animation, rendering and post-production
|
Summary: 3D modeling, animation, rendering and post-production
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://www.blender.org/
|
URL: https://www.blender.org
|
||||||
Source0: https://download.blender.org/source/blender-%{version}.tar.xz
|
Source0: https+git://projects.blender.org/blender/blender.git/v%{version}/blender-%{version}.tar.bz2
|
||||||
Source1: blender.png
|
Source1: https://developer.download.nvidia.com/redist/optix/v7.7/OptiX-7.7-Include.zip
|
||||||
Source2: blender.desktop
|
Patch5: blender-3.6.2-force-draco1.patch
|
||||||
Source3: blender-wrapper
|
Patch6: blender-3.6.2-force-draco2.patch
|
||||||
Patch0: %{name}-2.46-xvidcore_configure.patch
|
Patch9: blender-4.0.2-cmake-3.28.2.patch
|
||||||
Patch1: %{name}-2.48a-ffmpeg.patch
|
|
||||||
Patch2: %{name}-2.48a-ffmpeg-includes.patch
|
|
||||||
Patch3: blender-2.68a-freestyle-build.patch
|
|
||||||
Patch4: blender-2.79a-freetype-link.patch
|
|
||||||
Patch5: blender-3.1.2-force-draco1.patch
|
|
||||||
Patch6: blender-3.1.2-force-draco2.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
#libOpenColorIO.so.2.1()(64bit): library not reported by ldconfig and not provided in any installed package
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libSDL2-devel
|
BuildRequires: libSDL2-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
@ -28,17 +23,19 @@ BuildRequires: libXfixes-devel
|
|||||||
BuildRequires: libXi-devel
|
BuildRequires: libXi-devel
|
||||||
BuildRequires: libXrender-devel
|
BuildRequires: libXrender-devel
|
||||||
BuildRequires: libXxf86vm-devel
|
BuildRequires: libXxf86vm-devel
|
||||||
|
BuildRequires: libatomic-devel
|
||||||
BuildRequires: libavcodec-ffmpeg-devel
|
BuildRequires: libavcodec-ffmpeg-devel
|
||||||
BuildRequires: libavdevice-ffmpeg-devel
|
BuildRequires: libavdevice-ffmpeg-devel
|
||||||
BuildRequires: libavfilter-ffmpeg-devel
|
BuildRequires: libavfilter-ffmpeg-devel
|
||||||
BuildRequires: libavformat-ffmpeg-devel
|
BuildRequires: libavformat-ffmpeg-devel
|
||||||
BuildRequires: libavutil-ffmpeg-devel
|
BuildRequires: libavutil-ffmpeg-devel
|
||||||
BuildRequires: libboost-devel
|
BuildRequires: libboost-devel
|
||||||
|
BuildRequires: libembree-devel
|
||||||
|
BuildRequires: libepoxy-devel
|
||||||
BuildRequires: libexpat-devel
|
BuildRequires: libexpat-devel
|
||||||
BuildRequires: libfftw-devel
|
BuildRequires: libfftw-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libglvnd-devel
|
|
||||||
BuildRequires: libgmp-cxx-devel
|
BuildRequires: libgmp-cxx-devel
|
||||||
BuildRequires: libgmp-devel
|
BuildRequires: libgmp-devel
|
||||||
BuildRequires: libgomp-devel
|
BuildRequires: libgomp-devel
|
||||||
@ -46,46 +43,49 @@ BuildRequires: libimath-devel
|
|||||||
BuildRequires: libjack-devel
|
BuildRequires: libjack-devel
|
||||||
BuildRequires: libjemalloc-devel
|
BuildRequires: libjemalloc-devel
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: libminizip1-devel
|
||||||
BuildRequires: libopenal-devel
|
BuildRequires: libopenal-devel
|
||||||
BuildRequires: libopencolorio-devel
|
|
||||||
BuildRequires: libopenexr-devel
|
BuildRequires: libopenexr-devel
|
||||||
BuildRequires: libopenimageio-devel
|
BuildRequires: libopenimageio-devel
|
||||||
BuildRequires: libopenjpeg-devel
|
BuildRequires: libopenjpeg-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libpotrace-devel
|
BuildRequires: libpotrace-devel
|
||||||
BuildRequires: libpulseaudio-devel
|
BuildRequires: libpulseaudio-devel
|
||||||
BuildRequires: libpython310-devel
|
BuildRequires: libpystring-devel
|
||||||
|
BuildRequires: libpython3-devel
|
||||||
|
BuildRequires: libpython311-devel
|
||||||
BuildRequires: libsndfile-devel
|
BuildRequires: libsndfile-devel
|
||||||
BuildRequires: libspnav-devel
|
BuildRequires: libspnav-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libswresample-ffmpeg-devel
|
BuildRequires: libswresample-ffmpeg-devel
|
||||||
BuildRequires: libswscale-ffmpeg-devel
|
BuildRequires: libswscale-ffmpeg-devel
|
||||||
BuildRequires: libtbb-devel
|
BuildRequires: libtbb-devel
|
||||||
BuildRequires: libtiff-devel
|
|
||||||
BuildRequires: libwebp-devel
|
BuildRequires: libwebp-devel
|
||||||
|
BuildRequires: libxkbcommon-devel
|
||||||
BuildRequires: libyaml-cpp-devel
|
BuildRequires: libyaml-cpp-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: libzstd-devel
|
BuildRequires: libzstd-devel
|
||||||
BuildRequires: pugixml-devel
|
BuildRequires: pugixml-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libopencolorio-devel >= 2.3.2-1mamba
|
||||||
BuildRequires: bash
|
BuildRequires: bash
|
||||||
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: ldconfig
|
BuildRequires: ldconfig
|
||||||
#BuildRequires: yafray
|
BuildRequires: libtool
|
||||||
BuildRequires: nasm
|
BuildRequires: nasm
|
||||||
BuildRequires: scons
|
BuildRequires: scons
|
||||||
BuildRequires: libtool
|
BuildRequires: gettext-devel
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: libdecor-devel
|
||||||
BuildRequires: libglut-devel
|
BuildRequires: libembree-devel
|
||||||
BuildRequires: libopenssl-devel
|
|
||||||
BuildRequires: libesound-devel
|
BuildRequires: libesound-devel
|
||||||
|
BuildRequires: libglut-devel
|
||||||
|
BuildRequires: libode-devel
|
||||||
|
BuildRequires: libopenssl-devel
|
||||||
|
BuildRequires: libopenimageio-devel >= 2.5.6.0
|
||||||
BuildRequires: libnspr-devel
|
BuildRequires: libnspr-devel
|
||||||
BuildRequires: libsmpeg-devel
|
BuildRequires: libsmpeg-devel
|
||||||
BuildRequires: libode-devel
|
|
||||||
BuildRequires: gettext-devel
|
|
||||||
BuildRequires: libspnav-devel
|
BuildRequires: libspnav-devel
|
||||||
BuildRequires: python-numpy-py310
|
BuildRequires: python-numpy-py310
|
||||||
BuildRequires: libembree-devel
|
|
||||||
#Requires: yafray
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Blender is the essential software solution you need for 3D, from modeling, animation, rendering and post-production to interactive creation and playback.
|
Blender is the essential software solution you need for 3D, from modeling, animation, rendering and post-production to interactive creation and playback.
|
||||||
@ -94,37 +94,36 @@ Professionals and novices can easily and inexpensively publish stand-alone, secu
|
|||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -a1
|
||||||
#-D -T
|
#% setup -q -D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
#%patch3 -p1
|
make update
|
||||||
%patch4 -p1
|
|
||||||
%patch5 -p1 -b .force-draco1
|
%define _default_patch_fuzz 2
|
||||||
cd release/scripts/addons
|
%patch 5 -p1 -b .force-draco1
|
||||||
%patch6 -p1 -b .force-draco2
|
cd scripts/addons
|
||||||
cd ../../..
|
%patch 6 -p1 -b .force-draco2
|
||||||
|
cd ../..
|
||||||
|
%patch 9 -p1 -b .cmake-3.28.2
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
-DBUILD_SHARED_LIBS:BOOL=OFF \
|
||||||
-DCMAKE_SKIP_RPATH=ON \
|
-DCUDA_HOST_COMPILER=/usr/bin/gcc \
|
||||||
-DWITH_INSTALL_PORTABLE=OFF \
|
-DLLVM_VERSION=16 \
|
||||||
-DBOOST_ROOT=1 \
|
-DPYTHON_VERSION=%{python3_version} \
|
||||||
-DWITH_CYCLES=OFF \
|
-DHIP_ROOT_DIR=/opt/rocm \
|
||||||
-DWITH_CYCLES_PTEX=OFF \
|
-DOPTIX_ROOT_DIR="${PWD}" \
|
||||||
-DFTGL_LIBPATH=%{_libdir} \
|
-DWITH_CYCLES_OSL=NO \
|
||||||
-DWITH_FREESTYLE=ON \
|
-DCMAKE_BUILD_TYPE=Release \
|
||||||
-DWITH_SYSTEM_OPENJPEG=ON \
|
-DWITH_INSTALL_PORTABLE=OFF \
|
||||||
-DWITH_PYTHON_INSTALL=OFF \
|
-DWITH_PYTHON_INSTALL=OFF \
|
||||||
-DPYTHON_VERSION=%{python310_version} \
|
-DOCLOC_INSTALL_DIR=/usr \
|
||||||
-DPYTHON_LIBPATH=%{_libdir} \
|
-DSYCL_CPP_FLAGS=--verbose \
|
||||||
-DPYTHON_LIBRARY=python%{python310_version} \
|
-DSYCL_OFFLINE_COMPILER_PARALLEL_JOBS=8
|
||||||
-DPYTHON_INCLUDE_DIRS=%{python310_inc} \
|
|
||||||
-DWITH_BULLET=OFF
|
|
||||||
|
|
||||||
|
#export LD_LIBRARY_PATH=`pwd`/lib
|
||||||
export LD_LIBRARY_PATH=`pwd`/lib
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -142,37 +141,11 @@ cat > %{buildroot}%{_sysconfdir}/ld.so.conf.d/blender.conf << _EOF
|
|||||||
_EOF
|
_EOF
|
||||||
|
|
||||||
# Manually install draco bindings
|
# Manually install draco bindings
|
||||||
mv %{buildroot}%{_datadir}/blender/3*/python/lib/python%{python310_version} %{buildroot}%{_libdir}/
|
mv %{buildroot}%{_datadir}/blender/4*/python/lib/python%{python3_version} %{buildroot}%{_libdir}/
|
||||||
rm -rf %{buildroot}%{_datadir}/blender/3*/python
|
rm -rf %{buildroot}%{_datadir}/blender/4*/python
|
||||||
|
|
||||||
install -D -m644 release/freedesktop/org.blender.Blender.appdata.xml \
|
install -D -m644 release/freedesktop/org.blender.Blender.metainfo.xml \
|
||||||
%{buildroot}%{_datadir}/metainfo/org.blender.Blender.appdata.xml
|
%{buildroot}%{_datadir}/metainfo/org.blender.Blender.metainfo.xml
|
||||||
|
|
||||||
## Manually install additional scripts
|
|
||||||
#cp -r release/scripts/addons_contrib/* \
|
|
||||||
# %{buildroot}%{_datadir}/blender/3*/scripts/addons_contrib/
|
|
||||||
|
|
||||||
# BF_PYTHON=%{python3_inc} \
|
|
||||||
#scons install \
|
|
||||||
# BF_BUILDDIR=./rpmbuildir \
|
|
||||||
# BF_PYTHON_INC=%{python3_inc} \
|
|
||||||
# BF_PYTHON_BINARY=%{_bindir}/python3 \
|
|
||||||
# BF_PYTHON_LIB=python%{python3_version} \
|
|
||||||
# WITH_BF_FFMPEG='true' \
|
|
||||||
# BF_FFMPEG='%{_prefix}' \
|
|
||||||
# BF_FFMPEG_INC='%{_includedir}' \
|
|
||||||
# BF_FFMPEG_LIB='avformat avcodec avdevice avutil swscale xvidcore ogg dc1394 raw1394 faac faad x264 mp3lame vorbis theora vorbisenc dts' \
|
|
||||||
# BF_FFMPEG_EXTRA='-D__STDC_CONSTANT_MACROS' \
|
|
||||||
# WITH_BF_GAMEENGINE='true' \
|
|
||||||
# BF_INSTALLDIR=%{buildroot}%{_datadir}/blender/ \
|
|
||||||
# BF_OPENEXR_INC=%{_includedir}/OpenEXR/
|
|
||||||
#
|
|
||||||
#install -D -m0644 %{S:1} %{buildroot}%{_datadir}/pixmaps/blender.png
|
|
||||||
#install -D -m0644 %{S:2} %{buildroot}%{_datadir}/applications/blender.desktop
|
|
||||||
#install -D -m0755 %{S:3} %{buildroot}%{_bindir}/blender
|
|
||||||
#
|
|
||||||
##rmdir %{buildroot}%{_datadir}/blender/%{majver}/python/lib
|
|
||||||
##rmdir %{buildroot}%{_datadir}/blender/%{majver}/python
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != "/" ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != "/" ] && rm -rf "%{buildroot}"
|
||||||
@ -188,10 +161,10 @@ install -D -m644 release/freedesktop/org.blender.Blender.appdata.xml \
|
|||||||
%{_bindir}/blender-thumbnailer
|
%{_bindir}/blender-thumbnailer
|
||||||
%dir %{_libdir}/blender
|
%dir %{_libdir}/blender
|
||||||
%{_libdir}/blender/*.so
|
%{_libdir}/blender/*.so
|
||||||
%{_libdir}/blender/libaudaspace*.a
|
%{_libdir}/blender/lib*.a
|
||||||
%{python310_sitearch}/libextern_draco.so
|
%{python3_sitearch}/libextern_draco.so
|
||||||
%{_datadir}/applications/blender.desktop
|
%{_datadir}/applications/blender.desktop
|
||||||
%{_datadir}/metainfo/org.blender.Blender.appdata.xml
|
%{_datadir}/metainfo/org.blender.Blender.metainfo.xml
|
||||||
%dir %{_datadir}/blender
|
%dir %{_datadir}/blender
|
||||||
%{_datadir}/blender/*
|
%{_datadir}/blender/*
|
||||||
%{_datadir}/icons/hicolor/symbolic/apps/*.svg
|
%{_datadir}/icons/hicolor/symbolic/apps/*.svg
|
||||||
@ -201,6 +174,12 @@ install -D -m644 release/freedesktop/org.blender.Blender.appdata.xml \
|
|||||||
#%{_mandir}/man1/blender.1.gz
|
#%{_mandir}/man1/blender.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 05 2024 Automatic Build System <autodist@mambasoft.it> 4.0.2-2mamba
|
||||||
|
- rebuilt by autoport with build requirements: libopencolorio-devel>=2.3.2-1mamba
|
||||||
|
|
||||||
|
* Sun Feb 04 2024 Automatic Build System <autodist@openmamba.org> 4.0.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sat Aug 20 2022 Automatic Build System <autodist@mambasoft.it> 3.2.2-1mamba
|
* Sat Aug 20 2022 Automatic Build System <autodist@mambasoft.it> 3.2.2-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user