automatic version update by autodist [release 27.1-1mamba;Sun Jun 23 2024]
This commit is contained in:
parent
04469d4688
commit
f564b83568
32
bitcoin-27.1-libminiupnpc-2.2.8.patch
Normal file
32
bitcoin-27.1-libminiupnpc-2.2.8.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
From 8acdf66540834b9f9cf28f16d389e8b6a48516d5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Cory Fields <cory-nospam-@coryfields.com>
|
||||||
|
Date: Thu, 13 Jun 2024 13:25:37 +0000
|
||||||
|
Subject: [PATCH] upnp: add compatibility for miniupnpc 2.2.8
|
||||||
|
|
||||||
|
See: https://github.com/miniupnp/miniupnp/commit/c0a50ce33e3b99ce8a96fd43049bb5b53ffac62f
|
||||||
|
|
||||||
|
The return value of 2 now indicates:
|
||||||
|
"A valid connected IGD has been found but its IP address is reserved (non routable)"
|
||||||
|
|
||||||
|
We continue to ignore any return value other than 1.
|
||||||
|
---
|
||||||
|
src/mapport.cpp | 5 ++++-
|
||||||
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/mapport.cpp b/src/mapport.cpp
|
||||||
|
index 80670230c73a8..1920297be6d35 100644
|
||||||
|
--- a/src/mapport.cpp
|
||||||
|
+++ b/src/mapport.cpp
|
||||||
|
@@ -161,8 +161,11 @@ static bool ProcessUpnp()
|
||||||
|
struct UPNPUrls urls;
|
||||||
|
struct IGDdatas data;
|
||||||
|
int r;
|
||||||
|
-
|
||||||
|
+#if MINIUPNPC_API_VERSION <= 17
|
||||||
|
r = UPNP_GetValidIGD(devlist, &urls, &data, lanaddr, sizeof(lanaddr));
|
||||||
|
+#else
|
||||||
|
+ r = UPNP_GetValidIGD(devlist, &urls, &data, lanaddr, sizeof(lanaddr), nullptr, 0);
|
||||||
|
+#endif
|
||||||
|
if (r == 1)
|
||||||
|
{
|
||||||
|
if (fDiscover) {
|
10
bitcoin.spec
10
bitcoin.spec
@ -1,6 +1,6 @@
|
|||||||
%define maj123ver %(echo %version | cut -d. -f1-3)
|
%define maj123ver %(echo %version | cut -d. -f1-3)
|
||||||
Name: bitcoin
|
Name: bitcoin
|
||||||
Version: 27.0
|
Version: 27.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A frontend for the bitcoin cryptocurrency
|
Summary: A frontend for the bitcoin cryptocurrency
|
||||||
Group: Graphical Desktop/Applications/Other
|
Group: Graphical Desktop/Applications/Other
|
||||||
@ -11,6 +11,7 @@ URL: https://bitcoincore.org/en/download/
|
|||||||
Source: https://github.com/bitcoin/bitcoin.git/v%{version}/bitcoin-%{version}.tar.bz2
|
Source: https://github.com/bitcoin/bitcoin.git/v%{version}/bitcoin-%{version}.tar.bz2
|
||||||
Source1: bitcoin-qt.desktop
|
Source1: bitcoin-qt.desktop
|
||||||
Source2: bitcoin-qt.svg
|
Source2: bitcoin-qt.svg
|
||||||
|
Patch0: bitcoin-27.1-libminiupnpc-2.2.8.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -25,7 +26,7 @@ BuildRequires: libstdc++6-devel
|
|||||||
BuildRequires: libzeromq-devel
|
BuildRequires: libzeromq-devel
|
||||||
BuildRequires: qt5-qtbase-devel
|
BuildRequires: qt5-qtbase-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: miniupnpc-devel >= 1.9.20150206-1mamba
|
BuildRequires: libminiupnpc-devel >= 2.2.8
|
||||||
BuildRequires: protobuf-devel >= 1.6.1
|
BuildRequires: protobuf-devel >= 1.6.1
|
||||||
Conflicts: bitcoinclassic
|
Conflicts: bitcoinclassic
|
||||||
Obsoletes: bitcoin-qt < 22.0
|
Obsoletes: bitcoin-qt < 22.0
|
||||||
@ -47,6 +48,8 @@ A frontend for the bitcoin cryptocurrency. Bitcoin is a decentralized P2P electr
|
|||||||
%setup -q
|
%setup -q
|
||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
|
%patch 0 -p1 -b .libminiupnpc-2.2.8
|
||||||
|
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -117,6 +120,9 @@ exit 0
|
|||||||
%{_libdir}/pkgconfig/libbitcoinconsensus.pc
|
%{_libdir}/pkgconfig/libbitcoinconsensus.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jun 23 2024 Automatic Build System <autodist@openmamba.org> 27.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Apr 16 2024 Automatic Build System <autodist@openmamba.org> 27.0-1mamba
|
* Tue Apr 16 2024 Automatic Build System <autodist@openmamba.org> 27.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user