automatic version update by autodist [release 28.0-1mamba;Sun Oct 06 2024]
This commit is contained in:
parent
f564b83568
commit
9a19ed46fd
@ -1,2 +1,4 @@
|
|||||||
# bitcoin
|
# bitcoin
|
||||||
|
|
||||||
|
A frontend for the bitcoin cryptocurrency. Bitcoin is a decentralized P2P electronic cash system without a central server or trusted parties. Users hold the crypto keys to their own money and transact directly with each other, with the help of the network to check for double-spending.
|
||||||
|
|
||||||
|
@ -1,32 +0,0 @@
|
|||||||
From 8acdf66540834b9f9cf28f16d389e8b6a48516d5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Cory Fields <cory-nospam-@coryfields.com>
|
|
||||||
Date: Thu, 13 Jun 2024 13:25:37 +0000
|
|
||||||
Subject: [PATCH] upnp: add compatibility for miniupnpc 2.2.8
|
|
||||||
|
|
||||||
See: https://github.com/miniupnp/miniupnp/commit/c0a50ce33e3b99ce8a96fd43049bb5b53ffac62f
|
|
||||||
|
|
||||||
The return value of 2 now indicates:
|
|
||||||
"A valid connected IGD has been found but its IP address is reserved (non routable)"
|
|
||||||
|
|
||||||
We continue to ignore any return value other than 1.
|
|
||||||
---
|
|
||||||
src/mapport.cpp | 5 ++++-
|
|
||||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/mapport.cpp b/src/mapport.cpp
|
|
||||||
index 80670230c73a8..1920297be6d35 100644
|
|
||||||
--- a/src/mapport.cpp
|
|
||||||
+++ b/src/mapport.cpp
|
|
||||||
@@ -161,8 +161,11 @@ static bool ProcessUpnp()
|
|
||||||
struct UPNPUrls urls;
|
|
||||||
struct IGDdatas data;
|
|
||||||
int r;
|
|
||||||
-
|
|
||||||
+#if MINIUPNPC_API_VERSION <= 17
|
|
||||||
r = UPNP_GetValidIGD(devlist, &urls, &data, lanaddr, sizeof(lanaddr));
|
|
||||||
+#else
|
|
||||||
+ r = UPNP_GetValidIGD(devlist, &urls, &data, lanaddr, sizeof(lanaddr), nullptr, 0);
|
|
||||||
+#endif
|
|
||||||
if (r == 1)
|
|
||||||
{
|
|
||||||
if (fDiscover) {
|
|
24
bitcoin.spec
24
bitcoin.spec
@ -1,6 +1,6 @@
|
|||||||
%define maj123ver %(echo %version | cut -d. -f1-3)
|
%define maj123ver %(echo %version | cut -d. -f1-3)
|
||||||
Name: bitcoin
|
Name: bitcoin
|
||||||
Version: 27.1
|
Version: 28.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A frontend for the bitcoin cryptocurrency
|
Summary: A frontend for the bitcoin cryptocurrency
|
||||||
Group: Graphical Desktop/Applications/Other
|
Group: Graphical Desktop/Applications/Other
|
||||||
@ -11,7 +11,6 @@ URL: https://bitcoincore.org/en/download/
|
|||||||
Source: https://github.com/bitcoin/bitcoin.git/v%{version}/bitcoin-%{version}.tar.bz2
|
Source: https://github.com/bitcoin/bitcoin.git/v%{version}/bitcoin-%{version}.tar.bz2
|
||||||
Source1: bitcoin-qt.desktop
|
Source1: bitcoin-qt.desktop
|
||||||
Source2: bitcoin-qt.svg
|
Source2: bitcoin-qt.svg
|
||||||
Patch0: bitcoin-27.1-libminiupnpc-2.2.8.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -30,14 +29,7 @@ BuildRequires: libminiupnpc-devel >= 2.2.8
|
|||||||
BuildRequires: protobuf-devel >= 1.6.1
|
BuildRequires: protobuf-devel >= 1.6.1
|
||||||
Conflicts: bitcoinclassic
|
Conflicts: bitcoinclassic
|
||||||
Obsoletes: bitcoin-qt < 22.0
|
Obsoletes: bitcoin-qt < 22.0
|
||||||
|
Obsoletes: bitcoin-devel < 28.0
|
||||||
%package devel
|
|
||||||
Group: Development/Libraries
|
|
||||||
Summary: Development files for %{name}
|
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
|
|
||||||
%description devel
|
|
||||||
This package contains libraries and header files for developing applications that use %{name}.
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
A frontend for the bitcoin cryptocurrency. Bitcoin is a decentralized P2P electronic cash system without a central server or trusted parties. Users hold the crypto keys to their own money and transact directly with each other, with the help of the network to check for double-spending.
|
A frontend for the bitcoin cryptocurrency. Bitcoin is a decentralized P2P electronic cash system without a central server or trusted parties. Users hold the crypto keys to their own money and transact directly with each other, with the help of the network to check for double-spending.
|
||||||
@ -48,7 +40,6 @@ A frontend for the bitcoin cryptocurrency. Bitcoin is a decentralized P2P electr
|
|||||||
%setup -q
|
%setup -q
|
||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%patch 0 -p1 -b .libminiupnpc-2.2.8
|
|
||||||
|
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
|
|
||||||
@ -106,20 +97,15 @@ exit 0
|
|||||||
%{_bindir}/bitcoind
|
%{_bindir}/bitcoind
|
||||||
%{_bindir}/bench_bitcoin
|
%{_bindir}/bench_bitcoin
|
||||||
%{_bindir}/test_bitcoin
|
%{_bindir}/test_bitcoin
|
||||||
%{_libdir}/libbitcoinconsensus.so.*
|
|
||||||
%{_datadir}/applications/bitcoin-qt.desktop
|
%{_datadir}/applications/bitcoin-qt.desktop
|
||||||
%{_datadir}/icons/bitcoin-qt.svg
|
%{_datadir}/icons/bitcoin-qt.svg
|
||||||
%{_mandir}/man1/bitcoin-*.1*
|
%{_mandir}/man1/bitcoin-*.1*
|
||||||
%{_mandir}/man1/bitcoind.1*
|
%{_mandir}/man1/bitcoind.1*
|
||||||
|
|
||||||
%files devel
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_includedir}/bitcoinconsensus.h
|
|
||||||
%{_libdir}/libbitcoinconsensus.a
|
|
||||||
%{_libdir}/libbitcoinconsensus.so
|
|
||||||
%{_libdir}/pkgconfig/libbitcoinconsensus.pc
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Oct 06 2024 Automatic Build System <autodist@openmamba.org> 28.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sun Jun 23 2024 Automatic Build System <autodist@openmamba.org> 27.1-1mamba
|
* Sun Jun 23 2024 Automatic Build System <autodist@openmamba.org> 27.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user