automatic version update by autodist [release 0.16.19-1mamba;Wed Sep 05 2012]
This commit is contained in:
parent
57b7a9402c
commit
bc4ab4d4d4
@ -1,2 +1,5 @@
|
|||||||
# bin86
|
# bin86
|
||||||
|
|
||||||
|
This package provides an assembler and linker for real mode 80x86 instructions.
|
||||||
|
Programs that run in real mode, including LILO and the kernel's bootstrapping code, need to have this package installed to be built from the sources.
|
||||||
|
|
||||||
|
11
bin86-0.16.18-replace_strcpy_for_x86_64_build.patch
Normal file
11
bin86-0.16.18-replace_strcpy_for_x86_64_build.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- linux86-0.16.17/copt/copt.c.orig 2003-10-08 04:46:35.000000000 +0900
|
||||||
|
+++ linux86-0.16.17/copt/copt.c 2010-10-12 12:30:25.000000000 +0900
|
||||||
|
@@ -174,7 +174,7 @@ static char *readline(FILE *fp)
|
||||||
|
/* Delete leading white spaces */
|
||||||
|
for (cp = buf; *cp && isspace(*cp); cp++) ;
|
||||||
|
if (cp != buf && *cp)
|
||||||
|
- strcpy(buf, cp);
|
||||||
|
+ memmove(buf, cp, strlen(cp) + 1);
|
||||||
|
|
||||||
|
return(buf);
|
||||||
|
}
|
91
bin86.spec
Normal file
91
bin86.spec
Normal file
@ -0,0 +1,91 @@
|
|||||||
|
Name: bin86
|
||||||
|
Version: 0.16.19
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Real mode x86 compiler and linker
|
||||||
|
Group: Development/Tools
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.debath.co.uk/
|
||||||
|
Source: http://www.debath.co.uk/dev86/Dev86src-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-0.16.18-replace_strcpy_for_x86_64_build.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
This package provides an assembler and linker for real mode 80x86 instructions.
|
||||||
|
Programs that run in real mode, including LILO and the kernel's bootstrapping code, need to have this package installed to be built from the sources.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n dev86-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
#touch libc/.config.lst
|
||||||
|
%make -j1 all PREFIX=%{_prefix} << _USEDEFAULTCFG
|
||||||
|
|
||||||
|
_USEDEFAULTCFG
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
install -d %{buildroot}%{_prefix}/bin
|
||||||
|
install -d %{buildroot}%{_mandir}/man1
|
||||||
|
|
||||||
|
make install DIST=%{buildroot} MANDIR=%{_mandir}
|
||||||
|
#%{_prefix} MANDIR=%{buildroot}%{_mandir}/man1
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/ar86
|
||||||
|
%{_bindir}/as86
|
||||||
|
%{_bindir}/bcc
|
||||||
|
%ifarch %{ix86}
|
||||||
|
%{_bindir}/elksemu
|
||||||
|
%endif
|
||||||
|
%{_bindir}/ld86
|
||||||
|
%{_bindir}/nm86
|
||||||
|
%{_bindir}/objdump86
|
||||||
|
%{_bindir}/size86
|
||||||
|
%dir %{_prefix}/lib/bcc
|
||||||
|
%{_prefix}/lib/bcc/*
|
||||||
|
%{_mandir}/man1/as86.*
|
||||||
|
%{_mandir}/man1/bcc.*
|
||||||
|
%{_mandir}/man1/elks.*
|
||||||
|
%{_mandir}/man1/elksemu.*
|
||||||
|
%{_mandir}/man1/ld86.*
|
||||||
|
%doc Changes Contributors COPYING MAGIC README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Sep 05 2012 Automatic Build System <autodist@mambasoft.it> 0.16.19-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Apr 23 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.16.18-1mamba
|
||||||
|
- update to 0.16.18
|
||||||
|
|
||||||
|
* Sun Jul 11 2010 Davide Madrisan <davide.madrisan@gmail.com> 0.16.17-2mamba
|
||||||
|
- Fixed package URL
|
||||||
|
|
||||||
|
* Mon Jun 04 2007 Aleph0 <aleph0@openmamba.org> 0.16.17-1mamba
|
||||||
|
- update to 0.16.17
|
||||||
|
|
||||||
|
* Tue Jul 27 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.16.16-1qilnx
|
||||||
|
- update to 0.16.16
|
||||||
|
|
||||||
|
* Tue Feb 24 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.16.15-1qilnx
|
||||||
|
- new version rebuild
|
||||||
|
|
||||||
|
* Tue Nov 18 2003 Davide Madrisan <davide.madrisan@qilinux.it> 0.16.14-1qilnx
|
||||||
|
- rebuilt with version 0.16.14; specfile updates
|
||||||
|
|
||||||
|
* Mon Apr 14 2003 Mirko Cortillaro <mirko.cortillaro@qinet.it>
|
||||||
|
- modified file list
|
||||||
|
|
||||||
|
* Mon Apr 07 2003 Mirko Cortillaro <mirko.cortillaro@qinet.it>
|
||||||
|
- first build
|
Loading…
Reference in New Issue
Block a user