automatic version update by autodist [release 1.5.0-1mamba;Sun Dec 18 2016]
This commit is contained in:
parent
ba5b731ad4
commit
acf3ce43f0
24
belle-sip-1.5.0-fix-internal-includes.patch
Normal file
24
belle-sip-1.5.0-fix-internal-includes.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
--- belle-sip-1.5.0/include/belle-sip/list.h.orig 2016-12-18 17:25:25.842547817 +0100
|
||||||
|
+++ belle-sip-1.5.0/include/belle-sip/list.h 2016-12-18 17:25:34.362598812 +0100
|
||||||
|
@@ -35,8 +35,8 @@
|
||||||
|
#define belle_sip_list_size bctbx_list_size
|
||||||
|
#define belle_sip_list_for_each bctbx_list_for_each
|
||||||
|
#define belle_sip_list_for_each2 bctbx_list_for_each2
|
||||||
|
-#define belle_sip_list_remove_link bctbx_list_remove_link
|
||||||
|
-#define belle_sip_list_delete_link bctbx_list_delete_link
|
||||||
|
+#define belle_sip_list_remove_link bctbx_list_unlink
|
||||||
|
+#define belle_sip_list_delete_link bctbx_list_erase_link
|
||||||
|
#define belle_sip_list_find bctbx_list_find
|
||||||
|
#define belle_sip_list_free bctbx_list_free
|
||||||
|
#define belle_sip_list_free_with_data bctbx_list_free_with_data
|
||||||
|
--- belle-sip-1.5.0/src/transports/tls_channel.c.orig 2016-12-18 17:31:41.067884327 +0100
|
||||||
|
+++ belle-sip-1.5.0/src/transports/tls_channel.c 2016-12-18 17:31:45.741914352 +0100
|
||||||
|
@@ -814,7 +814,7 @@
|
||||||
|
bctbx_ssl_config_set_rng(obj->sslcfg, random_generator, NULL);
|
||||||
|
bctbx_ssl_set_io_callbacks(obj->sslctx, obj, tls_callback_write, tls_callback_read);
|
||||||
|
if (crypto_config->root_ca && belle_sip_tls_channel_load_root_ca(obj,crypto_config->root_ca)==0){
|
||||||
|
- bctbx_ssl_config_set_ca_chain(obj->sslcfg, obj->root_ca, super->base.peer_cname ? super->base.peer_cname : super->base.peer_name );
|
||||||
|
+ bctbx_ssl_config_set_ca_chain(obj->sslcfg, obj->root_ca);
|
||||||
|
}
|
||||||
|
bctbx_ssl_config_set_callback_verify(obj->sslcfg, belle_sip_ssl_verify, crypto_config);
|
||||||
|
bctbx_ssl_config_set_callback_cli_cert(obj->sslcfg, belle_sip_client_certificate_request_callback, obj);
|
@ -1,5 +1,5 @@
|
|||||||
Name: belle-sip
|
Name: belle-sip
|
||||||
Version: 1.4.2
|
Version: 1.5.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A SIP (RFC3261) implementation written in C, with an object oriented API.
|
Summary: A SIP (RFC3261) implementation written in C, with an object oriented API.
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -8,12 +8,14 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.linphone.org
|
URL: http://www.linphone.org
|
||||||
Source: http://download.savannah.gnu.org/releases/linphone/belle-sip/%{name}-%{version}.tar.gz
|
Source: http://download.savannah.gnu.org/releases/linphone/belle-sip/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: belle-sip-1.5.0-fix-internal-includes.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libantlr3c-devel
|
BuildRequires: libantlr3c-devel
|
||||||
|
BuildRequires: libbctoolbox-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libpolarssl-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libpolarssl-devel >= 1.3.8-1mamba
|
BuildRequires: libpolarssl-devel >= 1.3.8-1mamba
|
||||||
BuildRequires: antlr3
|
BuildRequires: antlr3
|
||||||
@ -43,10 +45,14 @@ This package contains libraries and header files for developing applications tha
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
sed -i \
|
||||||
|
-e "s#antlr_java_prefixes=.*#antlr_java_prefixes="$srcdir"#" \
|
||||||
|
configure.ac
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
CFLAGS="-Wno-error=pragmas"
|
CFLAGS="-Wno-error"
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
@ -76,6 +82,9 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%doc NEWS README
|
%doc NEWS README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 18 2016 Automatic Build System <autodist@mambasoft.it> 1.5.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Nov 03 2015 Automatic Build System <autodist@mambasoft.it> 1.4.2-1mamba
|
* Tue Nov 03 2015 Automatic Build System <autodist@mambasoft.it> 1.4.2-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user