update to 1.06.95 [release 1.06.95-1mamba;Sat Feb 01 2014]
This commit is contained in:
parent
95a9a29818
commit
cd96051dc0
@ -1,2 +1,10 @@
|
|||||||
# bc
|
# bc
|
||||||
|
|
||||||
|
Bc is an arbitrary precision numeric processing language.
|
||||||
|
Syntax is similar to C, but differs in many substantial areas.
|
||||||
|
It supports interactive execution of statements.
|
||||||
|
Bc is a utility included in the POSIX P1003.2/D11 draft standard.
|
||||||
|
|
||||||
|
This version does not use the historical method of having bc be a calculator for the dc calculator (the POSIX document doesn't specify how bc must be implemented).
|
||||||
|
This version has a single executable that both compiles the language and runs the resulting 'byte code.' The byte code is not the dc language.
|
||||||
|
|
||||||
|
11
bc-1.06-configure_flex.patch
Normal file
11
bc-1.06-configure_flex.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- bc-1.06/configure.orig 2007-12-04 10:29:01.000000000 +0100
|
||||||
|
+++ bc-1.06/configure 2007-12-04 10:29:42.000000000 +0100
|
||||||
|
@@ -2245,7 +2245,7 @@
|
||||||
|
|
||||||
|
|
||||||
|
if test "$LEX" = "flex" ; then
|
||||||
|
- LEX="flex -I8"
|
||||||
|
+ LEX="flex -I -8"
|
||||||
|
else
|
||||||
|
if test "$bcrl" = "y" ; then
|
||||||
|
echo "configure: warning: readline works only with flex." 1>&2
|
13
bc-1.06-info_direntry.patch
Normal file
13
bc-1.06-info_direntry.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
--- bc-1.06/doc/bc.texi.orig 2006-06-20 10:50:26.000000000 +0200
|
||||||
|
+++ bc-1.06/doc/bc.texi 2006-06-20 10:54:47.000000000 +0200
|
||||||
|
@@ -13,6 +13,10 @@
|
||||||
|
@c \overfullrule=0pt
|
||||||
|
@c end tex
|
||||||
|
|
||||||
|
+@direntry
|
||||||
|
+* bc: (bc). Arbritrary precision calculator language.
|
||||||
|
+@end direntry
|
||||||
|
+
|
||||||
|
@titlepage
|
||||||
|
@title @command{bc}
|
||||||
|
@subtitle an arbitrary precision calculator language
|
15
bc-1.06-info_exp_bessel.patch
Normal file
15
bc-1.06-info_exp_bessel.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- bc-1.06/doc/bc.info.info_exp_bessel 2003-08-12 14:57:45.000000000 +0200
|
||||||
|
+++ bc-1.06/doc/bc.info 2003-08-12 14:57:51.000000000 +0200
|
||||||
|
@@ -664,10 +664,10 @@
|
||||||
|
`l (X)'
|
||||||
|
The natural logarithm of X.
|
||||||
|
|
||||||
|
-`E (X)'
|
||||||
|
+`e (X)'
|
||||||
|
The exponential function of raising E to the value X.
|
||||||
|
|
||||||
|
-`J (N,X)'
|
||||||
|
+`j (N,X)'
|
||||||
|
The bessel function of integer order N of X.
|
||||||
|
|
||||||
|
|
10
bc-1.06-readline42.patch
Normal file
10
bc-1.06-readline42.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- bc-1.06/bc/scan.l.sux Fri May 11 14:27:20 2001
|
||||||
|
+++ bc-1.06/bc/scan.l Fri May 11 14:27:32 2001
|
||||||
|
@@ -143,7 +143,6 @@
|
||||||
|
|
||||||
|
/* Definitions for readline access. */
|
||||||
|
extern FILE *rl_instream;
|
||||||
|
-_PROTOTYPE(char *readline, (char *));
|
||||||
|
|
||||||
|
/* rl_input puts upto MAX characters into BUF with the number put in
|
||||||
|
BUF placed in *RESULT. If the yy input file is the same as
|
10
bc-1.06-string.patch
Normal file
10
bc-1.06-string.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- bc-1.06/lib/number.c.string 2007-07-26 15:01:34.000000000 +0200
|
||||||
|
+++ bc-1.06/lib/number.c 2007-07-26 15:01:41.000000000 +0200
|
||||||
|
@@ -34,6 +34,7 @@
|
||||||
|
#include <number.h>
|
||||||
|
#include <assert.h>
|
||||||
|
#include <stdlib.h>
|
||||||
|
+#include <string.h>
|
||||||
|
#include <ctype.h>/* Prototypes needed for external utility routines. */
|
||||||
|
|
||||||
|
#define bc_rt_warn rt_warn
|
97
bc.spec
Normal file
97
bc.spec
Normal file
@ -0,0 +1,97 @@
|
|||||||
|
Name: bc
|
||||||
|
Version: 1.06.95
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: GNU interactive algebraic language
|
||||||
|
Group: Applications/Mathematics
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Aleph0 <aleph0@openmamba.org>
|
||||||
|
URL: http://www.gnu.org/directory/GNU/bc.html
|
||||||
|
Source: http://alpha.gnu.org/gnu/bc/bc-%{version}.tar.bz2
|
||||||
|
Patch0: %{name}-1.06-info_direntry.patch
|
||||||
|
Patch1: %{name}-1.06-configure_flex.patch
|
||||||
|
Patch2: %{name}-1.06-info_exp_bessel.patch
|
||||||
|
Patch3: %{name}-1.06-string.patch
|
||||||
|
Patch4: %{name}-1.06-readline42.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libncurses-devel
|
||||||
|
BuildRequires: libreadline-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: flex
|
||||||
|
BuildRequires: bison
|
||||||
|
BuildRequires: texinfo
|
||||||
|
Requires(post): %{__install_info}
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Bc is an arbitrary precision numeric processing language.
|
||||||
|
Syntax is similar to C, but differs in many substantial areas.
|
||||||
|
It supports interactive execution of statements.
|
||||||
|
Bc is a utility included in the POSIX P1003.2/D11 draft standard.
|
||||||
|
|
||||||
|
This version does not use the historical method of having bc be a calculator for the dc calculator (the POSIX document doesn't specify how bc must be implemented).
|
||||||
|
This version has a single executable that both compiles the language and runs the resulting 'byte code.' The byte code is not the dc language.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
#%patch2 -p1
|
||||||
|
#%patch3 -p1
|
||||||
|
#%patch4 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --with-readline
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeoldinstall
|
||||||
|
|
||||||
|
%post
|
||||||
|
%install_info %{name}.info
|
||||||
|
%install_info dc.info
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%preun
|
||||||
|
%uninstall_info %{name}.info
|
||||||
|
%uninstall_info dc.info
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/%{name}
|
||||||
|
%{_bindir}/dc
|
||||||
|
%{_infodir}/%{name}.*
|
||||||
|
%{_infodir}/dc.*
|
||||||
|
%{_mandir}/man1/%{name}.*
|
||||||
|
%{_mandir}/man1/dc.*
|
||||||
|
%doc AUTHORS COPYING COPYING.LIB
|
||||||
|
# FAQ NEWS README Examples/* Changelog
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Feb 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.06.95-1mamba
|
||||||
|
- update to 1.06.95
|
||||||
|
|
||||||
|
* Sat Mar 23 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.06-5mamba
|
||||||
|
- rebuilt with libreadline 6.2
|
||||||
|
|
||||||
|
* Tue Dec 04 2007 Aleph0 <aleph0@openmamba.org> 1.06-4mamba
|
||||||
|
- new package mantainer
|
||||||
|
- fixed compilation warnings
|
||||||
|
- fixed some documentation bugs about exp and bessel functions
|
||||||
|
- rebuilt with readline support
|
||||||
|
|
||||||
|
* Tue Jun 20 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.06-3qilnx
|
||||||
|
- added info file patch
|
||||||
|
|
||||||
|
* Wed Sep 28 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.06-2qilnx
|
||||||
|
- install/uninstall info files
|
||||||
|
|
||||||
|
* Fri Feb 06 2004 Davide Madrisan <davide.madrisan@qilinux.it>
|
||||||
|
- first build
|
Loading…
Reference in New Issue
Block a user