specfile cleanups [release 1.07.1-3mamba;Fri May 10 2024]
This commit is contained in:
parent
43bbc3e33d
commit
887f8d24d5
@ -5,6 +5,3 @@ Syntax is similar to C, but differs in many substantial areas.
|
|||||||
It supports interactive execution of statements.
|
It supports interactive execution of statements.
|
||||||
Bc is a utility included in the POSIX P1003.2/D11 draft standard.
|
Bc is a utility included in the POSIX P1003.2/D11 draft standard.
|
||||||
|
|
||||||
This version does not use the historical method of having bc be a calculator for the dc calculator (the POSIX document doesn't specify how bc must be implemented).
|
|
||||||
This version has a single executable that both compiles the language and runs the resulting 'byte code.' The byte code is not the dc language.
|
|
||||||
|
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- bc-1.06/configure.orig 2007-12-04 10:29:01.000000000 +0100
|
|
||||||
+++ bc-1.06/configure 2007-12-04 10:29:42.000000000 +0100
|
|
||||||
@@ -2245,7 +2245,7 @@
|
|
||||||
|
|
||||||
|
|
||||||
if test "$LEX" = "flex" ; then
|
|
||||||
- LEX="flex -I8"
|
|
||||||
+ LEX="flex -I -8"
|
|
||||||
else
|
|
||||||
if test "$bcrl" = "y" ; then
|
|
||||||
echo "configure: warning: readline works only with flex." 1>&2
|
|
@ -1,15 +0,0 @@
|
|||||||
--- bc-1.06/doc/bc.info.info_exp_bessel 2003-08-12 14:57:45.000000000 +0200
|
|
||||||
+++ bc-1.06/doc/bc.info 2003-08-12 14:57:51.000000000 +0200
|
|
||||||
@@ -664,10 +664,10 @@
|
|
||||||
`l (X)'
|
|
||||||
The natural logarithm of X.
|
|
||||||
|
|
||||||
-`E (X)'
|
|
||||||
+`e (X)'
|
|
||||||
The exponential function of raising E to the value X.
|
|
||||||
|
|
||||||
-`J (N,X)'
|
|
||||||
+`j (N,X)'
|
|
||||||
The bessel function of integer order N of X.
|
|
||||||
|
|
||||||
|
|
@ -1,10 +0,0 @@
|
|||||||
--- bc-1.06/bc/scan.l.sux Fri May 11 14:27:20 2001
|
|
||||||
+++ bc-1.06/bc/scan.l Fri May 11 14:27:32 2001
|
|
||||||
@@ -143,7 +143,6 @@
|
|
||||||
|
|
||||||
/* Definitions for readline access. */
|
|
||||||
extern FILE *rl_instream;
|
|
||||||
-_PROTOTYPE(char *readline, (char *));
|
|
||||||
|
|
||||||
/* rl_input puts upto MAX characters into BUF with the number put in
|
|
||||||
BUF placed in *RESULT. If the yy input file is the same as
|
|
@ -1,10 +0,0 @@
|
|||||||
--- bc-1.06/lib/number.c.string 2007-07-26 15:01:34.000000000 +0200
|
|
||||||
+++ bc-1.06/lib/number.c 2007-07-26 15:01:41.000000000 +0200
|
|
||||||
@@ -34,6 +34,7 @@
|
|
||||||
#include <number.h>
|
|
||||||
#include <assert.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
+#include <string.h>
|
|
||||||
#include <ctype.h>/* Prototypes needed for external utility routines. */
|
|
||||||
|
|
||||||
#define bc_rt_warn rt_warn
|
|
24
bc.spec
24
bc.spec
@ -1,22 +1,17 @@
|
|||||||
Name: bc
|
Name: bc
|
||||||
Version: 1.07.1
|
Version: 1.07.1
|
||||||
Release: 2mamba
|
Release: 3mamba
|
||||||
Summary: GNU interactive algebraic language
|
Summary: GNU interactive algebraic language
|
||||||
Group: Applications/Mathematics
|
Group: Applications/Mathematics
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Aleph0 <aleph0@openmamba.org>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.gnu.org/directory/GNU/bc.html
|
URL: https://directory.fsf.org/wiki/GNU/bc
|
||||||
Source: https://ftp.gnu.org/gnu/bc/bc-%{version}.tar.gz
|
Source: https://ftp.gnu.org/gnu/bc/bc-%{version}.tar.gz
|
||||||
Patch0: %{name}-1.06-info_direntry.patch
|
Patch0: %{name}-1.06-info_direntry.patch
|
||||||
Patch1: %{name}-1.06-configure_flex.patch
|
|
||||||
Patch2: %{name}-1.06-info_exp_bessel.patch
|
|
||||||
Patch3: %{name}-1.06-string.patch
|
|
||||||
Patch4: %{name}-1.06-readline42.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: ldconfig
|
|
||||||
BuildRequires: libfl-devel
|
BuildRequires: libfl-devel
|
||||||
BuildRequires: libncurses-devel
|
BuildRequires: libncurses-devel
|
||||||
BuildRequires: libreadline-devel
|
BuildRequires: libreadline-devel
|
||||||
@ -26,7 +21,6 @@ BuildRequires: bison
|
|||||||
BuildRequires: texinfo
|
BuildRequires: texinfo
|
||||||
BuildRequires: ed
|
BuildRequires: ed
|
||||||
Requires(post): %{__install_info}
|
Requires(post): %{__install_info}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Bc is an arbitrary precision numeric processing language.
|
Bc is an arbitrary precision numeric processing language.
|
||||||
@ -34,19 +28,12 @@ Syntax is similar to C, but differs in many substantial areas.
|
|||||||
It supports interactive execution of statements.
|
It supports interactive execution of statements.
|
||||||
Bc is a utility included in the POSIX P1003.2/D11 draft standard.
|
Bc is a utility included in the POSIX P1003.2/D11 draft standard.
|
||||||
|
|
||||||
This version does not use the historical method of having bc be a calculator for the dc calculator (the POSIX document doesn't specify how bc must be implemented).
|
|
||||||
This version has a single executable that both compiles the language and runs the resulting 'byte code.' The byte code is not the dc language.
|
|
||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%define _default_patch_fuzz 2
|
%define _default_patch_fuzz 2
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
#%patch1 -p1
|
|
||||||
#%patch2 -p1
|
|
||||||
#%patch3 -p1
|
|
||||||
#%patch4 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-readline
|
%configure --with-readline
|
||||||
@ -56,6 +43,8 @@ This version has a single executable that both compiles the language and runs th
|
|||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeoldinstall
|
%makeoldinstall
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_infodir}/dir
|
||||||
|
|
||||||
%post
|
%post
|
||||||
%install_info %{name}.info
|
%install_info %{name}.info
|
||||||
%install_info dc.info
|
%install_info dc.info
|
||||||
@ -81,6 +70,9 @@ exit 0
|
|||||||
# FAQ NEWS README Examples/* Changelog
|
# FAQ NEWS README Examples/* Changelog
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 10 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.07.1-3mamba
|
||||||
|
- specfile cleanups
|
||||||
|
|
||||||
* Sat Nov 28 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.07.1-2mamba
|
* Sat Nov 28 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.07.1-2mamba
|
||||||
- rebuilt with debug package
|
- rebuilt with debug package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user