459 lines
16 KiB
RPMSpec
459 lines
16 KiB
RPMSpec
# NOTE: no bash doc 4.x available for now
|
|
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: bash
|
|
Version: 5.2.p37
|
|
Release: 1mamba
|
|
Summary: The GNU Bourne Again shell (bash)
|
|
Group: Applications/Shells
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.gnu.org/software/bash/bash.html
|
|
Source0: https://ftp.gnu.org/pub/gnu/bash/bash-%{majver}.tar.gz
|
|
# Official upstream patches from `http://ftp.gnu.org/gnu/bash/bash-4.2-patches'
|
|
# Create bash-patchset for current release using bash-autoupdate script
|
|
Source1: bash-patchset-%{version}.tar.gz
|
|
Source2: dot-bashrc
|
|
Source3: dot-bash_profile
|
|
Source4: dot-bash_logout
|
|
Source5: bash-2.0.5-cross-compile-config.cache
|
|
Source6: bash-autoupdate
|
|
#Source7: http://translationproject.org/PO-files/it/bash-%{majver}.it.po
|
|
Patch0: %{name}-4.1-bash-requires.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libncurses-devel
|
|
BuildRequires: libreadline-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libreadline-devel
|
|
BuildRequires: bison
|
|
%if "%{stage1}" != "1"
|
|
BuildRequires: emacs
|
|
%endif
|
|
BuildRequires: gettext-devel
|
|
# clear is used by $HOME/.bash_logout
|
|
Requires: %{_bindir}/clear
|
|
Requires(pre): glibc
|
|
Requires(post): %{__install_info}
|
|
Requires(post): chkconfig
|
|
Provides: /bin/sh
|
|
Provides: /usr/bin/bash
|
|
Provides: /usr/bin/sh
|
|
|
|
%description
|
|
Bash (Bourne Again shell) is the shell, or command language interpreter, that will appear in the GNU operating system.
|
|
Bash is an sh-compatible shell that incorporates useful features from the Korn shell (ksh) and C shell (csh).
|
|
It is intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools standard.
|
|
It offers functional improvements over sh for both programming and interactive use.
|
|
In addition, most sh scripts can be run by Bash without modification.
|
|
|
|
The improvements offered by BASH include:
|
|
* Command line editing
|
|
* Unlimited size command history
|
|
* Job Control
|
|
* Shell Functions and Aliases
|
|
* Indexed arrays of unlimited size
|
|
* Integer arithmetic in any base from two to sixty-four
|
|
|
|
%package devel
|
|
Summary: Development files for the GNU Bourne Again shell (bash)
|
|
Group: Documentation
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
This package provides development headers for the GNU Bourne Again shell (bash).
|
|
|
|
%package doc
|
|
Summary: Documentation for the GNU Bourne Again shell (bash)
|
|
Group: Documentation
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description doc
|
|
Bash (Bourne Again shell) is the shell, or command language interpreter, that will appear in the GNU operating system.
|
|
Bash is an sh-compatible shell that incorporates useful features from the Korn shell (ksh) and C shell (csh).
|
|
It is intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools standard.
|
|
It offers functional improvements over sh for both programming and interactive use.
|
|
In addition, most sh scripts can be run by Bash without modification.
|
|
|
|
This package includes doc guide examples and manual for bash.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n %{name}-%{majver} -a1
|
|
#%patch0 -p1 -b .bash-requires
|
|
for f in `find bash-patchset-%{version} -mindepth 1|sort`; do
|
|
[ -e $f ] && patch -p0 < $f
|
|
done
|
|
|
|
%if "%{_host}" != "%{_build}"
|
|
# cross-compiling: give configure some anwsers
|
|
case %{_host_cpu} in ppc|powerpc) install %{S:5} config.cache ;; esac
|
|
%endif
|
|
|
|
## add italian localization
|
|
#install -m0644 %{SOURCE7} po/it.po
|
|
#sed -i "s|\(en@quot.*\)|\1 it|" po/LINGUAS
|
|
|
|
%build
|
|
%configure \
|
|
-C \
|
|
--with-bash-malloc=no \
|
|
--bindir=/bin \
|
|
--libdir=%{_prefix}/lib \
|
|
--with-curses \
|
|
--enable-readline \
|
|
--with-installed-readline \
|
|
%if "%{_host}" != "%{_build}"
|
|
bash_cv_job_control_missing=present
|
|
%endif
|
|
|
|
%make
|
|
%make check
|
|
|
|
make -C po it.gmo
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall
|
|
#ln -s bash %{buildroot}/bin/sh
|
|
#ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
|
|
|
|
#install skeletons
|
|
install -D -c -m644 %{S:2} %{buildroot}/etc/skel/.bashrc
|
|
install -D -c -m644 %{S:3} %{buildroot}/etc/skel/.bash_profile
|
|
install -D -c -m644 %{S:4} %{buildroot}/etc/skel/.bash_logout
|
|
|
|
install -c -m 644 doc/builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
|
|
|
|
%find_lang %{name}
|
|
|
|
rm -f %{buildroot}%{_infodir}/dir
|
|
|
|
%post -p /bin/bash
|
|
if [ $1 -ge 1 ]; then
|
|
%install_info %{name}.info
|
|
sh=`readlink /bin/sh`
|
|
[ "$sh" != "/etc/alternatives/sh" -o ! -L /bin/sh ] && ln -sf bash /bin/sh
|
|
/usr/sbin/update-alternatives \
|
|
--install /bin/sh sh /bin/bash 20
|
|
fi
|
|
exit 0
|
|
|
|
%preun
|
|
%uninstall_info %{name}.info
|
|
exit 0
|
|
|
|
%postun
|
|
if [ $1 -eq 0 ]; then
|
|
# remove legacy alternatives /usr/bin/ld
|
|
/usr/sbin/update-alternatives --remove sh /bin/bash 2>/dev/null
|
|
fi
|
|
exit 0
|
|
|
|
%posttrans -p /bin/bash
|
|
[ -e /bin/sh ] || ln -s /etc/alternatives/sh /bin/sh
|
|
exit 0
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f %{name}.lang
|
|
%defattr(-,root,root)
|
|
/bin/bash
|
|
/bin/bashbug
|
|
#/bin/sh
|
|
%{_sysconfdir}/skel/.b*
|
|
%dir %{_prefix}/lib/bash
|
|
%{_prefix}/lib/bash/*
|
|
%{_infodir}/bash.info*
|
|
%{_mandir}/man1/bash.*
|
|
%{_mandir}/man1/bashbug.*
|
|
%{_mandir}/man1/builtins.*
|
|
#%{_mandir}/man1/sh.*
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/bash
|
|
%{_includedir}/bash/*.h
|
|
%dir %{_includedir}/bash/builtins
|
|
%{_includedir}/bash/builtins/*.h
|
|
%dir %{_includedir}/bash/include
|
|
%{_includedir}/bash/include/*.h
|
|
%{_prefix}/lib/pkgconfig/bash.pc
|
|
|
|
%files doc
|
|
%defattr(-,root,root)
|
|
%doc doc/FAQ doc/INTRO doc/README
|
|
%doc doc/bashref.html
|
|
%dir %{_docdir}/bash
|
|
%{_docdir}/bash/*
|
|
|
|
%changelog
|
|
* Tue Sep 24 2024 Automatic Build System <autodist@openmamba.org> 5.2.p37-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 01 2024 Automatic Build System <autodist@openmamba.org> 5.2.p32-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 14 2024 Automatic Build System <autodist@openmamba.org> 5.2.p26-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 11 2023 Automatic Build System <autodist@mambasoft.it> 5.2.p21-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.p15-1mamba
|
|
- update to 5.2.p15
|
|
|
|
* Wed Nov 09 2022 Automatic Build System <autodist@mambasoft.it> 5.2.p9-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 07 2022 Automatic Build System <autodist@mambasoft.it> 5.2.p2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 01 2022 Automatic Build System <autodist@mambasoft.it> 5.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 05 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 5.1.004-2mamba
|
|
- provide /usr/bin/sh to allow filesystem 2.3 upgrade
|
|
|
|
* Wed Dec 23 2020 Automatic Build System <autodist@mambasoft.it> 5.1.004-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Dec 11 2020 Automatic Build System <autodist@mambasoft.it> 5.1.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 10 2020 Automatic Build System <autodist@mambasoft.it> 5.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 20 2020 Automatic Build System <autodist@mambasoft.it> 5.0.018-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 24 2020 Automatic Build System <autodist@mambasoft.it> 5.0.017-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 17 2020 Automatic Build System <autodist@mambasoft.it> 5.0.016-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Sep 30 2019 Automatic Build System <autodist@mambasoft.it> 5.0.011-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 28 2019 Automatic Build System <autodist@mambasoft.it> 5.0.009-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 10 2019 Automatic Build System <autodist@mambasoft.it> 5.0.007-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 14 2019 Automatic Build System <autodist@mambasoft.it> 5.0.003-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 16 2019 Automatic Build System <autodist@mambasoft.it> 5.0.002-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 13 2019 Automatic Build System <autodist@mambasoft.it> 5.0.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 07 2019 Automatic Build System <autodist@mambasoft.it> 5.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 06 2018 Automatic Build System <autodist@mambasoft.it> 4.4.023-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Feb 17 2018 Automatic Build System <autodist@mambasoft.it> 4.4.019-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 31 2018 Automatic Build System <autodist@mambasoft.it> 4.4.18-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 03 2017 Automatic Build System <autodist@mambasoft.it> 4.4.012-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 26 2017 Automatic Build System <autodist@mambasoft.it> 4.4.011-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 21 2016 Automatic Build System <autodist@mambasoft.it> 4.4.005-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 16 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4-1mamba
|
|
- update to 4.4
|
|
|
|
* Tue Jul 05 2016 Automatic Build System <autodist@mambasoft.it> 4.3.046-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 24 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.042-2mamba
|
|
- don't set skel files as config
|
|
|
|
* Thu Sep 10 2015 Automatic Build System <autodist@mambasoft.it> 4.3.042-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 24 2015 Automatic Build System <autodist@mambasoft.it> 4.3.039-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 11 2015 Automatic Build System <autodist@mambasoft.it> 4.3.033-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 06 2014 Automatic Build System <autodist@mambasoft.it> 4.3.030-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 03 2014 Automatic Build System <autodist@mambasoft.it> 4.3.029-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 03 2014 Automatic Build System <autodist@mambasoft.it> 4.3.028-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Sep 29 2014 Automatic Build System <autodist@mambasoft.it> 4.3.027-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 28 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.026-2mamba
|
|
- restore patchset application (also to fix CVE-2014-6271)
|
|
|
|
* Fri Sep 26 2014 Automatic Build System <autodist@mambasoft.it> 4.3.026-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 26 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.025-2mamba
|
|
- bump release to update a previous incorrect 4.3.025-1mamba
|
|
|
|
* Fri Sep 26 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.025-1mamba
|
|
- update to 4.3.025
|
|
|
|
* Sat Aug 23 2014 Automatic Build System <autodist@mambasoft.it> 4.3.024-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 12 2014 Automatic Build System <autodist@mambasoft.it> 4.3.022-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 04 2014 Automatic Build System <autodist@mambasoft.it> 4.3.018-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 24 2014 Automatic Build System <autodist@mambasoft.it> 4.3.011-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 08 2014 Automatic Build System <autodist@mambasoft.it> 4.3.008-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 07 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3-1mamba
|
|
- update to 4.3
|
|
|
|
* Sat Nov 23 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.045-6mamba
|
|
- added chkconfig Requires(post) for alternatives
|
|
|
|
* Tue Oct 15 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.045-5mamba
|
|
- run scripts with /bin/bash to avoid damage due to /bin/sh disappearing
|
|
|
|
* Tue Oct 15 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.045-4mamba
|
|
- added italian localization
|
|
- add alternative for /bin/sh
|
|
|
|
* Mon Sep 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.045-3mamba
|
|
- removed /bin/sh symlink in favour of dash
|
|
|
|
* Tue May 28 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.045-2mamba
|
|
- really update patchset to 4.2.045 (added bash-patchset.sh new script to generate patchset for current version)
|
|
|
|
* Mon Apr 15 2013 Automatic Build System <autodist@mambasoft.it> 4.2.045-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 03 2013 Automatic Build System <autodist@mambasoft.it> 4.2.042-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 4.2.039-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 06 2012 Davide Madrisan <davide.madrisan@gmail.com> 4.2.028-1mamba
|
|
- update to 4.2.028
|
|
|
|
* Tue Dec 20 2011 Davide Madrisan <davide.madrisan@gmail.com> 4.2.020-1mamba
|
|
- update to 4.2.020
|
|
|
|
* Wed May 04 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.000-2mamba
|
|
- rebuilt with debug package
|
|
|
|
* Thu Feb 17 2011 Davide Madrisan <davide.madrisan@gmail.com> 4.2.000-1mamba
|
|
- update to 4.2.000
|
|
- install builtins.1 manpage
|
|
- install the file bashref.html included in the source tarball
|
|
- provide a manpage for sh
|
|
|
|
* Sun Oct 17 2010 Davide Madrisan <davide.madrisan@gmail.com> 4.1.009-1mamba
|
|
- update to 4.1.009
|
|
|
|
* Fri Jul 02 2010 Davide Madrisan <davide.madrisan@gmail.com> 4.1.007-1mamba
|
|
- update to 4.1.007
|
|
|
|
* Sat Apr 17 2010 Davide Madrisan <davide.madrisan@gmail.com> 4.1.005-1mamba
|
|
- update to 4.1.005
|
|
|
|
* Sun Mar 28 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.1.002-1mamba
|
|
- update to 4.1.002 (fixed specfile for automatic updates: Version field cannot be parametric
|
|
- added stage1 code for cross compilation
|
|
|
|
* Sat Mar 20 2010 Davide Madrisan <davide.madrisan@gmail.com> 4.1-2mamba
|
|
- really update to version 4.1
|
|
- removed obsolete patches bash-4.0-nnn.patch
|
|
- update bash-requires patch
|
|
- provide bashref.html for bash 4.0 instead of outdate documentation files
|
|
|
|
* Fri Jan 01 2010 Automatic Build System <autodist@mambasoft.it> 4.1-1mamba
|
|
- automatic update to 4.1 by autodist
|
|
|
|
* Mon Oct 26 2009 Davide Madrisan <davide.madrisan@gmail.com> 4.0.035-1mamba
|
|
- update to 4.0p35
|
|
|
|
* Thu Jun 11 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0-4mamba
|
|
- rebuilt with option "--with-curses" to re-enable support for multiline prompt
|
|
|
|
* Tue Mar 24 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0-3mamba
|
|
- rebuilt against libreadline 6
|
|
|
|
* Sun Mar 22 2009 Davide Madrisan <davide.madrisan@gmail.com> 4.0-2mamba
|
|
- update to 4.0p10
|
|
|
|
* Sun Mar 01 2009 Davide Madrisan <davide.madrisan@gmail.com> 4.0-1mamba
|
|
- update to 4.0
|
|
|
|
* Tue Aug 26 2008 Aleph0 <aleph0@openmamba.org> 3.2p39-1mamba
|
|
- update to 3.2p39
|
|
|
|
* Fri Jun 13 2008 Aleph0 <aleph0@openmamba.org> 3.2p37-1mamba
|
|
- update to 3.2p37
|
|
- source file `dot-bash_profile' updated
|
|
|
|
* Mon Jun 04 2007 Aleph0 <aleph0@openmamba.org> 3.2p17-1mamba
|
|
- update to 3.2p17
|
|
|
|
* Sun Feb 25 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2p9-2qilnx
|
|
- add glibc prereq
|
|
|
|
* Wed Jan 17 2007 Davide Madrisan <davide.madrisan@qilinux.it> 3.2p9-1qilnx
|
|
- update to patch level 9
|
|
|
|
* Fri Oct 13 2006 Davide Madrisan <davide.madrisan@qilinux.it> 3.2-2qilnx
|
|
- rebuilt against libreadline 5.2
|
|
|
|
* Thu Oct 12 2006 Davide Madrisan <davide.madrisan@qilinux.it> 3.2-1qilnx
|
|
- update to version 3.2 by autospec
|
|
|
|
* Mon May 15 2006 Davide Madrisan <davide.madrisan@qilinux.it> 3.1-2qilnx
|
|
- added a patch from ALT Linux that enable the command '--rpm-requires'
|
|
- added all the available official patches (p#1 to 9)
|
|
|
|
* Tue Dec 13 2005 Davide Madrisan <davide.madrisan@qilinux.it> 3.1-1qilnx
|
|
- update to version 3.1 by autospec
|
|
|
|
* Thu Sep 08 2005 Davide Madrisan <davide.madrisan@qilinux.it> 3.0-1qilnx
|
|
- update to version 3.0 by autospec
|
|
|
|
* Sun Sep 04 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.05b-6qilnx
|
|
- rebuilt with gcc4
|
|
- added cross-platform build support
|
|
|
|
* Wed Jul 28 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.05b-5qilnx
|
|
- added patches from ufficial site
|
|
- specfile updated
|
|
|
|
* Tue Apr 22 2003 Silvan Calarco <silvan.calarco@qinet.it> 2.05b-4qilnx
|
|
- removed Prefix variable definition
|
|
- corrected infodir and mandir locations
|