automatic rebuild by autodist [release 0.7.5-3mamba;Wed Aug 28 2013]
This commit is contained in:
parent
c93490f9cc
commit
e8cfa7d7ea
@ -1,2 +1,9 @@
|
||||
# awka
|
||||
|
||||
Awka is an open-source implementation of the AWK programming language and is actually two products:
|
||||
|
||||
- the AWK to C translator
|
||||
- a library against which the C code is linked
|
||||
|
||||
Awka is not an interpreter like Gawk, Mawk or Nawk, but instead it converts the program to ANSI-C, then compiles this using gcc or a native C compiler to create a binary executable. This means you must have an ANSI C compiler present on your system for Awka to work.
|
||||
|
||||
|
126
awka-0.7.5-DESTDIR.patch
Normal file
126
awka-0.7.5-DESTDIR.patch
Normal file
@ -0,0 +1,126 @@
|
||||
--- ./awka/Makefile.in.orig Thu Jun 14 15:35:31 2001
|
||||
+++ ./awka/Makefile.in Thu Jun 14 15:38:47 2001
|
||||
@@ -14,17 +14,15 @@
|
||||
|
||||
YACC = @YACC@
|
||||
AWK = @AWK@
|
||||
+LDFLAGS = @LDFLAGS@
|
||||
|
||||
# where to put awka
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
|
||||
-BINDIR = @bindir@
|
||||
-LIBDIR = @libdir@
|
||||
-INCDIR = @includedir@
|
||||
-# where to put the man pages
|
||||
-MANDIR = @mandir@
|
||||
-MANEXT = @MANEXT@
|
||||
+bindir = @bindir@
|
||||
+libdir = @libdir@
|
||||
+includedir = @includedir@
|
||||
#######################################
|
||||
|
||||
MAKEFILEIN = Makefile.in
|
||||
@@ -40,7 +38,7 @@
|
||||
cd ..; /bin/sh ./config.status
|
||||
|
||||
awka : $(OBJS)
|
||||
- $(CC) $(CFLAGS) $(OBJS) -o awka
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -o awka
|
||||
|
||||
parse.c : parse.y
|
||||
@echo expect 6 shift/reduce conflicts
|
||||
@@ -51,8 +49,8 @@
|
||||
else mv y.tab.h parse.h ; fi
|
||||
|
||||
install : awka
|
||||
- cp awka$(EXE) $(BINDIR)
|
||||
- chmod a+rx $(BINDIR)/awka$(EXE)
|
||||
+ cp awka$(EXE) $(DESTDIR)$(bindir)
|
||||
+ chmod a+rx $(DESTDIR)$(bindir)/awka$(EXE)
|
||||
|
||||
clean :
|
||||
rm -f *.o core awka awka$(EXE)
|
||||
--- ./lib/Makefile.in.orig Thu Jun 14 15:42:03 2001
|
||||
+++ ./lib/Makefile.in Thu Jun 14 15:44:48 2001
|
||||
@@ -18,12 +18,10 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
|
||||
-BINDIR = @bindir@
|
||||
-LIBDIR = @libdir@
|
||||
-INCDIR = @includedir@
|
||||
+bindir = @bindir@
|
||||
+libdir = @libdir@
|
||||
+includedir = @includedir@
|
||||
# where to put the man pages
|
||||
-MANDIR = @mandir@
|
||||
-MANEXT = @MANEXT@
|
||||
SHAREDLIB = @SHARED_LIB@
|
||||
VERSION = @VERSION@
|
||||
BUILDLIB = libawka.a $(SHAREDLIB)
|
||||
@@ -55,11 +53,11 @@
|
||||
$(AWK) -f ../examples/fixhdr.awk libawka.h.in >libawka.h
|
||||
|
||||
install : libawka.a $(SHAREDLIB)
|
||||
- cp libawka.a $(LIBDIR)
|
||||
- if [ -f libawka.so ]; then cp libawka.so $(LIBDIR); fi
|
||||
- cp libawka.h $(INCDIR)
|
||||
- chmod a+r $(LIBDIR)/libawka.*
|
||||
- chmod a+r $(INCDIR)/libawka.h
|
||||
+ cp libawka.a $(DESTDIR)$(libdir)
|
||||
+ if [ -f libawka.so ]; then cp libawka.so $(DESTDIR)$(libdir); fi
|
||||
+ cp libawka.h $(DESTDIR)$(includedir)
|
||||
+ chmod a+r $(DESTDIR)$(libdir)/libawka.*
|
||||
+ chmod a+r $(DESTDIR)$(includedir)/libawka.h
|
||||
|
||||
clean :
|
||||
rm -f *.o ../regexp/*.o ../regexp/.done core libawka.a libawka.so libawka.h
|
||||
--- ./Makefile.in.orig Thu Jun 14 15:25:17 2001
|
||||
+++ ./Makefile.in Thu Jun 14 15:35:12 2001
|
||||
@@ -20,13 +20,11 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
|
||||
-BINDIR = @bindir@
|
||||
-LIBDIR = @libdir@
|
||||
-INCDIR = @includedir@
|
||||
+bindir = @bindir@
|
||||
+libdir = @libdir@
|
||||
+includedir = @includedir@
|
||||
# where to put the man pages
|
||||
-MANEXT = @MANEXT@
|
||||
-MANSRCDIR = @mandir@
|
||||
-MANDIR = $(MANSRCDIR)/man$(MANEXT)
|
||||
+mandir = @mandir@
|
||||
SHARED_LIB = @SHARED_LIB@
|
||||
BUILDLIB = libawka.a $(SHARED_LIB)
|
||||
#######################################
|
||||
@@ -44,20 +44,17 @@
|
||||
awka_exe:
|
||||
cd awka; $(MAKE)
|
||||
|
||||
-AWKAMAN = $(MANDIR)/awka.$(MANEXT)
|
||||
install: awka_exe libawka
|
||||
- if [ ! -d $(LIBDIR) ]; then mkdir -p $(LIBDIR); fi
|
||||
- if [ ! -d $(INCDIR) ]; then mkdir -p $(INCDIR); fi
|
||||
- if [ ! -d $(BINDIR) ]; then mkdir -p $(BINDIR); fi
|
||||
- if [ ! -d $(MANDIR) ]; then mkdir -p $(MANDIR); fi
|
||||
- if [ ! -d $(MANSRCDIR)/man5 ]; then mkdir -p $(MANSRCDIR)/man5; fi
|
||||
+ mkdir -p $(DESTDIR)$(libdir)
|
||||
+ mkdir -p $(DESTDIR)$(includedir)
|
||||
+ mkdir -p $(DESTDIR)$(bindir)
|
||||
+ mkdir -p $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(mandir)/man5
|
||||
cd awka; $(MAKE) install
|
||||
cd lib; $(MAKE) install
|
||||
- cp doc/awka.1 $(AWKAMAN)
|
||||
- cp doc/awka-elm.5 $(MANSRCDIR)/man5
|
||||
- cp doc/awka-elmref.5 $(MANSRCDIR)/man5
|
||||
- chmod 0644 $(AWKAMAN)
|
||||
+ cp doc/awka.1 $(DESTDIR)$(mandir)/man1
|
||||
+ cp doc/awka-elm.5 $(DESTDIR)$(mandir)/man5
|
||||
+ cp doc/awka-elmref.5 $(DESTDIR)$(mandir)/man5
|
||||
|
||||
clean:
|
||||
cd awka; $(MAKE) clean
|
70
awka.spec
Normal file
70
awka.spec
Normal file
@ -0,0 +1,70 @@
|
||||
Name: awka
|
||||
Version: 0.7.5
|
||||
Release: 3mamba
|
||||
Summary: Translator of the AWK programming language to ANSI-C
|
||||
Group: Applications/Text
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Stefano Cotta Ramusino <stefano.cotta@qilinux.it>
|
||||
URL: http://awka.sourceforge.net/
|
||||
Source: http://awka.sourceforge.net/%{name}-%{version}.tar.gz
|
||||
Patch: awka-%{version}-DESTDIR.patch
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Awka is an open-source implementation of the AWK programming language and is actually two products:
|
||||
|
||||
- the AWK to C translator
|
||||
- a library against which the C code is linked
|
||||
|
||||
Awka is not an interpreter like Gawk, Mawk or Nawk, but instead it converts the program to ANSI-C, then compiles this using gcc or a native C compiler to create a binary executable. This means you must have an ANSI C compiler present on your system for Awka to work.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}
|
||||
|
||||
%description devel
|
||||
This package contains static libraries need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/awka
|
||||
%{_libdir}/libawka.so*
|
||||
%{_includedir}/libawka.h
|
||||
%{_mandir}/man[15]/*
|
||||
%doc ACKNOWLEDGEMENTS CHANGELOG.txt PROBLEMS.txt README.txt TODO.txt
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libawka.a
|
||||
|
||||
%changelog
|
||||
* Wed Aug 28 2013 Automatic Build System <autodist@mambasoft.it> 0.7.5-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Tue Oct 28 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.7.5-2mamba
|
||||
- rebuild
|
||||
- update Group in devel package
|
||||
|
||||
* Wed Nov 16 2005 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 0.7.5-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user