pass --localstatedir=/ to configure to use /run everywhere
add "mdns_minimal [NOTFOUND=return]" in nsswitch.conf on installation [release 0.6.31-7mamba;Wed Apr 30 2014]
This commit is contained in:
parent
f665221b79
commit
bf5c7050ab
@ -1,2 +1,4 @@
|
||||
# avahi
|
||||
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
|
95
avahi-0.6.31-gtk-3.12.patch
Normal file
95
avahi-0.6.31-gtk-3.12.patch
Normal file
@ -0,0 +1,95 @@
|
||||
--- avahi-0.6.31/avahi-ui/avahi-ui.c.orig 2011-02-18 19:04:10.251546734 +0100
|
||||
+++ avahi-0.6.31/avahi-ui/avahi-ui.c 2013-11-22 23:15:26.702181607 +0100
|
||||
@@ -991,7 +991,11 @@
|
||||
gtk_dialog_set_has_separator(GTK_DIALOG(p->domain_dialog), FALSE);
|
||||
#endif
|
||||
|
||||
+#if GTK_CHECK_VERSION(3,0,0)
|
||||
+ vbox = gtk_box_new(GTK_ORIENTATION_VERTICAL, 8);
|
||||
+#else
|
||||
vbox = gtk_vbox_new(FALSE, 8);
|
||||
+#endif
|
||||
gtk_container_set_border_width(GTK_CONTAINER(vbox), 8);
|
||||
gtk_box_pack_start(GTK_BOX(gtk_dialog_get_content_area(GTK_DIALOG(p->domain_dialog))), vbox, TRUE, TRUE, 0);
|
||||
|
||||
@@ -1002,7 +1006,11 @@
|
||||
g_signal_connect(p->domain_entry, "changed", G_CALLBACK(domain_entry_changed_callback), d);
|
||||
gtk_box_pack_start(GTK_BOX(vbox), p->domain_entry, FALSE, FALSE, 0);
|
||||
|
||||
+#if GTK_CHECK_VERSION(3,0,0)
|
||||
+ vbox2 = gtk_box_new(GTK_ORIENTATION_VERTICAL, 8);
|
||||
+#else
|
||||
vbox2 = gtk_vbox_new(FALSE, 8);
|
||||
+#endif
|
||||
gtk_box_pack_start(GTK_BOX(vbox), vbox2, TRUE, TRUE, 0);
|
||||
|
||||
scrolled_window = gtk_scrolled_window_new(NULL, NULL);
|
||||
@@ -1032,8 +1040,8 @@
|
||||
gtk_progress_bar_set_pulse_step(GTK_PROGRESS_BAR(p->domain_progress_bar), 0.1);
|
||||
gtk_box_pack_end(GTK_BOX(vbox2), p->domain_progress_bar, FALSE, FALSE, 0);
|
||||
|
||||
- gtk_dialog_add_button(GTK_DIALOG(p->domain_dialog), GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL);
|
||||
- p->domain_ok_button = GTK_WIDGET(gtk_dialog_add_button(GTK_DIALOG(p->domain_dialog), GTK_STOCK_OK, GTK_RESPONSE_ACCEPT));
|
||||
+ gtk_dialog_add_button(GTK_DIALOG(p->domain_dialog), _("_Cancel"), GTK_RESPONSE_CANCEL);
|
||||
+ p->domain_ok_button = GTK_WIDGET(gtk_dialog_add_button(GTK_DIALOG(p->domain_dialog), _("_OK"), GTK_RESPONSE_ACCEPT));
|
||||
gtk_dialog_set_default_response(GTK_DIALOG(p->domain_dialog), GTK_RESPONSE_ACCEPT);
|
||||
gtk_widget_set_sensitive(p->domain_ok_button, is_valid_domain_suffix(gtk_entry_get_text(GTK_ENTRY(p->domain_entry))));
|
||||
|
||||
@@ -1113,7 +1121,11 @@
|
||||
|
||||
gtk_container_set_border_width(GTK_CONTAINER(d), 5);
|
||||
|
||||
+#if GTK_CHECK_VERSION(3,0,0)
|
||||
+ vbox = gtk_box_new(GTK_ORIENTATION_VERTICAL, 8);
|
||||
+#else
|
||||
vbox = gtk_vbox_new(FALSE, 8);
|
||||
+#endif
|
||||
gtk_container_set_border_width(GTK_CONTAINER(vbox), 8);
|
||||
gtk_box_pack_start(GTK_BOX(gtk_dialog_get_content_area(GTK_DIALOG(d))), vbox, TRUE, TRUE, 0);
|
||||
|
||||
@@ -1123,7 +1135,11 @@
|
||||
gtk_box_pack_start(GTK_BOX(vbox), p->domain_label, FALSE, FALSE, 0);
|
||||
|
||||
|
||||
+#if GTK_CHECK_VERSION(3,0,0)
|
||||
+ vbox2 = gtk_box_new(GTK_ORIENTATION_VERTICAL, 8);
|
||||
+#else
|
||||
vbox2 = gtk_vbox_new(FALSE, 8);
|
||||
+#endif
|
||||
gtk_box_pack_start(GTK_BOX(vbox), vbox2, TRUE, TRUE, 0);
|
||||
|
||||
scrolled_window = gtk_scrolled_window_new(NULL, NULL);
|
||||
@@ -1164,7 +1180,7 @@
|
||||
gtk_box_pack_end(GTK_BOX(vbox2), p->service_progress_bar, FALSE, FALSE, 0);
|
||||
|
||||
p->domain_button = gtk_button_new_with_mnemonic(_("_Domain..."));
|
||||
- gtk_button_set_image(GTK_BUTTON(p->domain_button), gtk_image_new_from_stock(GTK_STOCK_NETWORK, GTK_ICON_SIZE_BUTTON));
|
||||
+ gtk_button_set_image(GTK_BUTTON(p->domain_button), gtk_image_new_from_icon_name("network-workgroup", GTK_ICON_SIZE_BUTTON));
|
||||
g_signal_connect(p->domain_button, "clicked", G_CALLBACK(domain_button_clicked), d);
|
||||
gtk_box_pack_start(GTK_BOX(gtk_dialog_get_action_area(GTK_DIALOG(d))), p->domain_button, FALSE, TRUE, 0);
|
||||
gtk_button_box_set_child_secondary(GTK_BUTTON_BOX(gtk_dialog_get_action_area(GTK_DIALOG(d))), p->domain_button, TRUE);
|
||||
--- avahi-0.6.31/avahi-ui/bssh.c.orig 2010-08-26 02:51:39.023153001 +0200
|
||||
+++ avahi-0.6.31/avahi-ui/bssh.c 2013-11-22 23:17:41.635509278 +0100
|
||||
@@ -146,19 +146,19 @@
|
||||
break;
|
||||
|
||||
case COMMAND_SHELL:
|
||||
- d = aui_service_dialog_new(_("Choose Shell Server"), NULL, GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL, GTK_STOCK_CONNECT, GTK_RESPONSE_ACCEPT, NULL);
|
||||
+ d = aui_service_dialog_new(_("Choose Shell Server"), NULL, _("_Cancel"), GTK_RESPONSE_CANCEL, gtk_image_new_from_icon_name("network-workgroup", GTK_ICON_SIZE_BUTTON), GTK_RESPONSE_ACCEPT, NULL);
|
||||
aui_service_dialog_set_browse_service_types(AUI_SERVICE_DIALOG(d), "_rfb._tcp", "_ssh._tcp", NULL);
|
||||
aui_service_dialog_set_service_type_name(AUI_SERVICE_DIALOG(d), "_rfb._tcp", _("Desktop"));
|
||||
aui_service_dialog_set_service_type_name(AUI_SERVICE_DIALOG(d), "_ssh._tcp", _("Terminal"));
|
||||
break;
|
||||
|
||||
case COMMAND_VNC:
|
||||
- d = aui_service_dialog_new(_("Choose VNC server"), NULL, GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL, GTK_STOCK_CONNECT, GTK_RESPONSE_ACCEPT, NULL);
|
||||
+ d = aui_service_dialog_new(_("Choose VNC server"), NULL, _("_Cancel"), GTK_RESPONSE_CANCEL, gtk_image_new_from_icon_name("network-workgroup", GTK_ICON_SIZE_BUTTON), GTK_RESPONSE_ACCEPT, NULL);
|
||||
aui_service_dialog_set_browse_service_types(AUI_SERVICE_DIALOG(d), "_rfb._tcp", NULL);
|
||||
break;
|
||||
|
||||
case COMMAND_SSH:
|
||||
- d = aui_service_dialog_new(_("Choose SSH server"), NULL, GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL, GTK_STOCK_CONNECT, GTK_RESPONSE_ACCEPT, NULL);
|
||||
+ d = aui_service_dialog_new(_("Choose SSH server"), NULL, _("_Cancel"), GTK_RESPONSE_CANCEL, gtk_image_new_from_icon_name("network-workgroup", GTK_ICON_SIZE_BUTTON), GTK_RESPONSE_ACCEPT, NULL);
|
||||
aui_service_dialog_set_browse_service_types(AUI_SERVICE_DIALOG(d), "_ssh._tcp", NULL);
|
||||
break;
|
||||
}
|
595
avahi.spec
Normal file
595
avahi.spec
Normal file
@ -0,0 +1,595 @@
|
||||
%define avahigroupid 65429
|
||||
%define avahiuserid 65429
|
||||
%define avahiautoipdgroupid 65053
|
||||
%define avahiautoipduserid 65053
|
||||
|
||||
Name: avahi
|
||||
Version: 0.6.31
|
||||
Release: 6mamba
|
||||
Summary: A system which facilitates service discovery on a local network
|
||||
Group: Applications/Networking
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://avahi.org
|
||||
Source: http://avahi.org/download/avahi-%{version}.tar.gz
|
||||
Patch0: avahi-0.6.31-gtk-3.12.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: gtk-sharp-devel
|
||||
%endif
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libcap-devel
|
||||
BuildRequires: libdaemon-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgdbm-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblcms-devel
|
||||
BuildRequires: libmng-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng15-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpthread-stubs-devel
|
||||
BuildRequires: libpython-devel
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: libqt3-devel
|
||||
%endif
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libssp-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libXcursor-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXft-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXmu-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: mono-core
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: pygtk-devel
|
||||
BuildRequires: python-dbus-devel
|
||||
BuildRequires: systemd-devel
|
||||
Requires: libnss_mdns
|
||||
Requires: libavahi = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
%package -n libavahi
|
||||
Summary: A system which facilitates service discovery on a local network
|
||||
Group: System/Libraries
|
||||
|
||||
%description -n libavahi
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
%package -n libavahi-devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: libavahi = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-devel
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package -n libavahi-glib
|
||||
Summary: Glib binding library for avahi
|
||||
Group: System/Libraries
|
||||
Requires: libavahi = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-glib
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
This package contains the Glib binding library.
|
||||
|
||||
%package -n libavahi-glib-devel
|
||||
Summary: Devel package for %{name} Glib binding library
|
||||
Group: Development/Libraries
|
||||
Requires: libavahi-glib = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: libavahi-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-glib-devel
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
This package contains static libraries and header files need for development of the avahi-glib library.
|
||||
|
||||
%package -n libavahi-gtk3
|
||||
Summary: Gtk3 binding library for avahi
|
||||
Group: System/Libraries
|
||||
Requires: libavahi = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-gtk3
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
This package contains the Glib binding library.
|
||||
|
||||
%package -n libavahi-gtk3-devel
|
||||
Summary: Devel package for %{name} Gtk3 binding library
|
||||
Group: Development/Libraries
|
||||
Requires: libavahi-gtk3 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: libavahi-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-gtk3-devel
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
This package contains static libraries and header files need for development of the avahi-gtk3 library.
|
||||
|
||||
%package -n libavahi-qt3
|
||||
Summary: QT3 binding library for avahi
|
||||
Group: System/Libraries
|
||||
Requires: libavahi = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-qt3
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
This package contains the QT3 binding library.
|
||||
|
||||
%package -n libavahi-qt3-devel
|
||||
Summary: Devel package for %{name} QT3 binding library
|
||||
Group: Development/Libraries
|
||||
Requires: libavahi-qt3 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: libavahi-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-qt3-devel
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
This package contains static libraries and header files need for development of the avahi-qt3 library.
|
||||
|
||||
%package -n libavahi-qt4
|
||||
Summary: QT4 binding library for avahi
|
||||
Group: System/Libraries
|
||||
Requires: libavahi = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-qt4
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
This package contains the QT4 binding library.
|
||||
|
||||
%package -n libavahi-qt4-devel
|
||||
Summary: Devel package for %{name} QT4 binding library
|
||||
Group: Development/Libraries
|
||||
Requires: libavahi-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-qt4-devel
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
This package contains static libraries and header files need for development of the avahi-qt4 library.
|
||||
|
||||
%package mono
|
||||
Summary: A system which facilitates service discovery on a local network
|
||||
Group: System/Libraries
|
||||
Requires: avahi = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description mono
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
This package contains the bindings for the mono language.
|
||||
|
||||
%package python
|
||||
Summary: A system which facilitates service discovery on a local network
|
||||
Group: System/Libraries
|
||||
Requires: avahi = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description python
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
This package contains the bindings for the python language.
|
||||
|
||||
%package compat-howl
|
||||
Summary: Libraries for howl compatibility.
|
||||
Group: Development/Libraries
|
||||
|
||||
%description compat-howl
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
Libraries that are compatible with those provided by the howl package.
|
||||
|
||||
%package compat-howl-devel
|
||||
Summary: Header files for development with the howl compatibility libraries.
|
||||
Group: Development/Libraries
|
||||
Requires: avahi-compat-howl = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description compat-howl-devel
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
Header files for development with the howl compatibility libraries.
|
||||
|
||||
%package compat-libdns_sd
|
||||
Summary: Libraries for Apple Bonjour mDNSResponder compatibility.
|
||||
Group: Development/Libraries
|
||||
Provides: libzeroconf
|
||||
Obsoletes: libzeroconf
|
||||
Provides: zeroconf
|
||||
Obsoletes: zeroconf
|
||||
|
||||
%description compat-libdns_sd
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
Libraries for Apple Bonjour mDNSResponder compatibility.
|
||||
|
||||
%package compat-libdns_sd-devel
|
||||
Summary: Header files for development with the Apple Bonjour mDNSResponder compatibility libraries.
|
||||
Group: Development/Libraries
|
||||
Requires: avahi-compat-libdns_sd = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: libavahi-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: libzeroconf-devel
|
||||
Obsoletes: libzeroconf-devel
|
||||
|
||||
%description compat-libdns_sd-devel
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
Header files for development with the Apple Bonjour mDNSResponder compatibility libraries.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--with-distro=fedora \
|
||||
--enable-compat-howl \
|
||||
--enable-compat-libdns_sd \
|
||||
--enable-tests \
|
||||
--enable-core-docs \
|
||||
--with-avahi-priv-access-group=filesharing \
|
||||
%if "%{stage1}" == "1"
|
||||
--disable-gtk3 \
|
||||
--disable-qt3 \
|
||||
--disable-mono \
|
||||
--disable-monodoc \
|
||||
%endif
|
||||
--localstatedir=/
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
# fix bug 197414 - add missing symlinks for avahi-compat-howl and avahi-compat-dns-sd
|
||||
ln -s avahi-compat-howl.pc %{buildroot}%{_libdir}/pkgconfig/howl.pc
|
||||
ln -s avahi-compat-libdns_sd.pc %{buildroot}%{_libdir}/pkgconfig/libdns_sd.pc
|
||||
|
||||
ln -s avahi-daemon.service %{buildroot}/lib/systemd/system/dbus-org.freedesktop.Avahi.service
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%pre
|
||||
if [ $1 -ge 1 ]; then
|
||||
/usr/sbin/groupadd avahi -g %{avahigroupid} 2>/dev/null
|
||||
/usr/sbin/useradd -u %{avahiuserid} -c 'Avahi user' -d /dev/null -g avahi \
|
||||
-s /bin/false avahi 2>/dev/null
|
||||
/usr/sbin/groupadd avahi-autoipd -g %{avahiautoipdgroupid} 2>/dev/null
|
||||
/usr/sbin/useradd -u %{avahiautoipduserid} -c 'Avahi autoipd user' -d /dev/null -g avahi-autoipd \
|
||||
-s /bin/false avahi-autoipd 2>/dev/null
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%post
|
||||
if [ $1 -ge 1 ]; then
|
||||
chkconfig --add avahi-daemon
|
||||
chkconfig --add avahi-dnsconfd
|
||||
service avahi-daemon start
|
||||
service avahi-dnsconfd start
|
||||
grep "^hosts:.*mdns_minimal" %{_sysconfdir}/nsswitch.conf &>/dev/null || \
|
||||
sed -i "s|\(^hosts:.*files\) \(.*\)|\1 mdns_minimal [NOTFOUND=return] \2|" %{_sysconfdir}/nsswitch.conf
|
||||
fi
|
||||
:
|
||||
|
||||
%preun
|
||||
if [ $1 -eq 0 ]; then
|
||||
/usr/sbin/groupdel avahi-autoipd 2>/dev/null
|
||||
/usr/sbin/userdel avahi-autoipd 2>/dev/null
|
||||
/usr/sbin/groupdel avahi 2>/dev/null
|
||||
/usr/sbin/userdel avahi 2>/dev/null
|
||||
chkconfig --del avahi-daemon
|
||||
chkconfig --del avahi-dnsconfd
|
||||
service avahi-daemon stop
|
||||
service avahi-dnsconfd stop
|
||||
grep "^hosts:.*mdns_minimal" %{_sysconfdir}/nsswitch.conf &>/dev/null && \
|
||||
sed -i "s| mdns_minimal [NOTFOUND=return]||" %{_sysconfdir}/nsswitch.conf
|
||||
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_initrddir}/avahi-daemon
|
||||
%{_initrddir}/avahi-dnsconfd
|
||||
%{_sysconfdir}/avahi/avahi-autoipd.action
|
||||
%{_sysconfdir}/avahi/avahi-daemon.conf
|
||||
%{_sysconfdir}/avahi/avahi-dnsconfd.action
|
||||
%{_sysconfdir}/avahi/hosts
|
||||
%{_sysconfdir}/avahi/services/sftp-ssh.service
|
||||
%{_sysconfdir}/avahi/services/ssh.service
|
||||
%{_sysconfdir}/dbus-1/system.d/avahi-dbus.conf
|
||||
%{_bindir}/avahi-bookmarks
|
||||
%{_bindir}/avahi-browse
|
||||
%{_bindir}/avahi-browse-domains
|
||||
%{_bindir}/avahi-discover
|
||||
%{_bindir}/avahi-discover-standalone
|
||||
%{_bindir}/avahi-publish
|
||||
%{_bindir}/avahi-publish-address
|
||||
%{_bindir}/avahi-publish-service
|
||||
%{_bindir}/avahi-resolve
|
||||
%{_bindir}/avahi-resolve-address
|
||||
%{_bindir}/avahi-resolve-host-name
|
||||
%{_bindir}/avahi-set-host-name
|
||||
%{_bindir}/bshell
|
||||
%{_bindir}/bssh
|
||||
%{_bindir}/bvnc
|
||||
%{_sbindir}/avahi-autoipd
|
||||
%{_sbindir}/avahi-daemon
|
||||
%{_sbindir}/avahi-dnsconfd
|
||||
/lib/systemd/system/avahi-daemon.service
|
||||
/lib/systemd/system/avahi-daemon.socket
|
||||
/lib/systemd/system/avahi-dnsconfd.service
|
||||
/lib/systemd/system/dbus-org.freedesktop.Avahi.service
|
||||
%{_libdir}/avahi/service-types.db
|
||||
%{_datadir}/applications/avahi-discover.desktop
|
||||
%{_datadir}/applications/bssh.desktop
|
||||
%{_datadir}/applications/bvnc.desktop
|
||||
%{_datadir}/avahi/avahi-service.dtd
|
||||
%{_datadir}/avahi/interfaces/avahi-discover.ui
|
||||
#%{_datadir}/avahi/introspection/*.introspect
|
||||
%{_datadir}/avahi/service-types
|
||||
%{_datadir}/dbus-1/interfaces/org.freedesktop.Avahi.*.xml
|
||||
%{_datadir}/dbus-1/system-services/org.freedesktop.Avahi.service
|
||||
%{_mandir}/man1/avahi-bookmarks.1.gz
|
||||
%{_mandir}/man1/avahi-browse-domains.1.gz
|
||||
%{_mandir}/man1/avahi-browse.1.gz
|
||||
%{_mandir}/man1/avahi-discover.1.gz
|
||||
%{_mandir}/man1/avahi-publish-address.1.gz
|
||||
%{_mandir}/man1/avahi-publish-service.1.gz
|
||||
%{_mandir}/man1/avahi-publish.1.gz
|
||||
%{_mandir}/man1/avahi-resolve-address.1.gz
|
||||
%{_mandir}/man1/avahi-resolve-host-name.1.gz
|
||||
%{_mandir}/man1/avahi-resolve.1.gz
|
||||
%{_mandir}/man1/avahi-set-host-name.1.gz
|
||||
%{_mandir}/man1/bssh.1.gz
|
||||
%{_mandir}/man1/bvnc.1.gz
|
||||
%{_mandir}/man8/avahi-autoipd.8.gz
|
||||
%{_mandir}/man8/avahi-autoipd.action.8.gz
|
||||
%{_mandir}/man5/avahi-daemon.conf.5.gz
|
||||
%{_mandir}/man5/avahi.hosts.5.gz
|
||||
%{_mandir}/man5/avahi.service.5.gz
|
||||
%{_mandir}/man8/avahi-daemon.8.gz
|
||||
%{_mandir}/man8/avahi-dnsconfd.8.gz
|
||||
%{_mandir}/man8/avahi-dnsconfd.action.8.gz
|
||||
%doc ChangeLog LICENSE docs/*
|
||||
|
||||
%files -n libavahi
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libavahi-client.so.*
|
||||
%{_libdir}/libavahi-common.so.*
|
||||
%{_libdir}/libavahi-core.so.*
|
||||
%{_libdir}/libavahi-ui.so.*
|
||||
|
||||
%files -n libavahi-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/avahi-client
|
||||
%{_includedir}/avahi-client/*.h
|
||||
%dir %{_includedir}/avahi-common
|
||||
%{_includedir}/avahi-common/*.h
|
||||
%dir %{_includedir}/avahi-core
|
||||
%{_includedir}/avahi-core/*.h
|
||||
%dir %{_includedir}/avahi-ui
|
||||
%{_includedir}/avahi-ui/*.h
|
||||
%{_libdir}/libavahi-client.a
|
||||
%{_libdir}/libavahi-client.la
|
||||
%{_libdir}/libavahi-client.so
|
||||
%{_libdir}/libavahi-common.a
|
||||
%{_libdir}/libavahi-common.la
|
||||
%{_libdir}/libavahi-common.so
|
||||
%{_libdir}/libavahi-core.a
|
||||
%{_libdir}/libavahi-core.la
|
||||
%{_libdir}/libavahi-core.so
|
||||
%{_libdir}/libavahi-ui.a
|
||||
%{_libdir}/libavahi-ui.la
|
||||
%{_libdir}/libavahi-ui.so
|
||||
%{_libdir}/pkgconfig/avahi-ui.pc
|
||||
%{_libdir}/pkgconfig/avahi-client.pc
|
||||
%{_libdir}/pkgconfig/avahi-core.pc
|
||||
|
||||
%files -n libavahi-glib
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libavahi-glib.so.*
|
||||
%{_libdir}/libavahi-gobject.so.*
|
||||
|
||||
%files -n libavahi-glib-devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libavahi-glib.a
|
||||
%{_libdir}/libavahi-glib.la
|
||||
%{_libdir}/libavahi-glib.so
|
||||
%{_libdir}/libavahi-gobject.a
|
||||
%{_libdir}/libavahi-gobject.la
|
||||
%{_libdir}/libavahi-gobject.so
|
||||
%{_includedir}/avahi-glib/*.h
|
||||
%dir %{_includedir}/avahi-glib
|
||||
%{_includedir}/avahi-gobject/*.h
|
||||
%dir %{_includedir}/avahi-gobject
|
||||
%{_libdir}/pkgconfig/avahi-glib.pc
|
||||
%{_libdir}/pkgconfig/avahi-gobject.pc
|
||||
%{_libdir}/girepository-1.0/Avahi*.typelib
|
||||
%{_datadir}/gir-1.0/Avahi*.gir
|
||||
|
||||
%if "%{stage1}" != "1"
|
||||
%files -n libavahi-gtk3
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libavahi-ui-gtk3.so.*
|
||||
|
||||
%files -n libavahi-gtk3-devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libavahi-ui-gtk3.a
|
||||
%{_libdir}/libavahi-ui-gtk3.la
|
||||
%{_libdir}/libavahi-ui-gtk3.so
|
||||
%{_libdir}/pkgconfig/avahi-ui-gtk3.pc
|
||||
|
||||
%files -n libavahi-qt3
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libavahi-qt3.so.*
|
||||
|
||||
%files -n libavahi-qt3-devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libavahi-qt3.a
|
||||
%{_libdir}/libavahi-qt3.la
|
||||
%{_libdir}/libavahi-qt3.so
|
||||
%dir %{_includedir}/avahi-qt3
|
||||
%{_includedir}/avahi-qt3/*.h
|
||||
%{_libdir}/pkgconfig/avahi-qt3.pc
|
||||
%endif
|
||||
|
||||
%files -n libavahi-qt4
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libavahi-qt4.so.*
|
||||
|
||||
%files -n libavahi-qt4-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/avahi-qt4
|
||||
%{_includedir}/avahi-qt4/*.h
|
||||
%{_libdir}/libavahi-qt4.a
|
||||
%{_libdir}/libavahi-qt4.la
|
||||
%{_libdir}/libavahi-qt4.so
|
||||
%{_libdir}/pkgconfig/avahi-qt4.pc
|
||||
|
||||
%files python
|
||||
%defattr(-,root,root)
|
||||
%{python_sitelib}/avahi/ServiceTypeDatabase.py
|
||||
%{python_sitelib}/avahi/__init__.py
|
||||
%{python_sitelib}/avahi/__init__.pyc
|
||||
%{python_sitelib}/avahi/__init__.pyo
|
||||
%{python_sitelib}/avahi_discover/__init__.py
|
||||
%{python_sitelib}/avahi_discover/__init__.pyc
|
||||
%{python_sitelib}/avahi_discover/__init__.pyo
|
||||
|
||||
%if "%{stage1}" != "1"
|
||||
%files mono
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/mono/avahi-sharp/avahi-sharp.dll
|
||||
%{_libdir}/mono/avahi-ui-sharp/avahi-ui-sharp.dll
|
||||
%{_libdir}/mono/gac/avahi-sharp/1.0.0.0__4d116c78973743f5/avahi-sharp.dll
|
||||
%{_libdir}/mono/gac/avahi-sharp/1.0.0.0__4d116c78973743f5/avahi-sharp.dll.config
|
||||
%{_libdir}/mono/gac/avahi-sharp/1.0.0.0__4d116c78973743f5/avahi-sharp.dll.mdb
|
||||
%{_libdir}/mono/gac/avahi-ui-sharp/0.0.0.0__4d116c78973743f5/avahi-ui-sharp.dll
|
||||
%{_libdir}/mono/gac/avahi-ui-sharp/0.0.0.0__4d116c78973743f5/avahi-ui-sharp.dll.config
|
||||
%{_libdir}/mono/gac/avahi-ui-sharp/0.0.0.0__4d116c78973743f5/avahi-ui-sharp.dll.mdb
|
||||
%{_prefix}/lib/monodoc/sources/avahi-sharp-docs.source
|
||||
%{_prefix}/lib/monodoc/sources/avahi-sharp-docs.tree
|
||||
%{_prefix}/lib/monodoc/sources/avahi-sharp-docs.zip
|
||||
%{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.source
|
||||
%{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.tree
|
||||
%{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.zip
|
||||
%{_libdir}/pkgconfig/avahi-sharp.pc
|
||||
%{_libdir}/pkgconfig/avahi-ui-sharp.pc
|
||||
%endif
|
||||
|
||||
%files compat-howl
|
||||
%defattr(-, root, root)
|
||||
%{_libdir}/libhowl.so.*
|
||||
|
||||
%files compat-howl-devel
|
||||
%defattr(-, root, root)
|
||||
%dir %{_includedir}/avahi-compat-howl
|
||||
%{_includedir}/avahi-compat-howl/howl.h
|
||||
%dir %{_includedir}/avahi-compat-howl/corby
|
||||
%{_includedir}/avahi-compat-howl/corby/*.h
|
||||
%dir %{_includedir}/avahi-compat-howl/discovery
|
||||
%{_includedir}/avahi-compat-howl/discovery/*.h
|
||||
%dir %{_includedir}/avahi-compat-howl/rendezvous
|
||||
%{_includedir}/avahi-compat-howl/rendezvous/*.h
|
||||
%dir %{_includedir}/avahi-compat-howl/salt
|
||||
%{_includedir}/avahi-compat-howl/salt/*.h
|
||||
%{_libdir}/libhowl.a
|
||||
%{_libdir}/libhowl.la
|
||||
%{_libdir}/libhowl.so
|
||||
%{_libdir}/pkgconfig/howl.pc
|
||||
%{_libdir}/pkgconfig/avahi-compat-howl.pc
|
||||
|
||||
%files compat-libdns_sd
|
||||
%defattr(-, root, root)
|
||||
%{_libdir}/libdns_sd.so.1.0.0
|
||||
%{_libdir}/libdns_sd.so.1
|
||||
|
||||
%files compat-libdns_sd-devel
|
||||
%defattr(-, root, root)
|
||||
%dir %{_includedir}/avahi-compat-libdns_sd
|
||||
%{_includedir}/avahi-compat-libdns_sd/dns_sd.h
|
||||
%{_libdir}/libdns_sd.a
|
||||
%{_libdir}/libdns_sd.la
|
||||
%{_libdir}/libdns_sd.so
|
||||
%{_libdir}/pkgconfig/avahi-compat-libdns_sd.pc
|
||||
%{_libdir}/pkgconfig/libdns_sd.pc
|
||||
|
||||
%changelog
|
||||
* Wed Apr 30 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.31-7mamba
|
||||
- pass --localstatedir=/ to configure to use /run everywhere
|
||||
- add "mdns_minimal [NOTFOUND=return]" in nsswitch.conf on installation
|
||||
|
||||
* Mon Sep 16 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.31-5mamba
|
||||
- build with avahi_runtime_dir (pid) set to /run
|
||||
|
||||
* Fri Jul 19 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.31-4mamba
|
||||
- add missing symlink dbus-org.freedesktop.Avahi.service required for dbus activation
|
||||
|
||||
* Thu May 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.31-3mamba
|
||||
- rebuilt with systemd support
|
||||
|
||||
* Sat Jul 07 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.31-2mamba
|
||||
- create avahi and avahi-autoipd user and group
|
||||
- avahi: require libnss_mdns
|
||||
- set --with-avahi-priv-access-group=filesharing
|
||||
- set --with-distro=fedora and enable service
|
||||
|
||||
* Wed Apr 25 2012 Automatic Build System <autodist@mambasoft.it> 0.6.31-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jun 19 2011 Automatic Build System <autodist@mambasoft.it> 0.6.30-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Mar 06 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.28-1mamba
|
||||
- update to 0.6.28
|
||||
|
||||
* Thu Oct 28 2010 Automatic Build System <autodist@mambasoft.it> 0.6.25-4mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Thu Sep 10 2009 Automatic Build System <autodist@mambasoft.it> 0.6.25-3mamba
|
||||
- avahi-compat-libdns_sd-devel: added requirement for libavahi-devel
|
||||
|
||||
* Sat May 09 2009 Automatic Build System <autodist@mambasoft.it> 0.6.25-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Thu Apr 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.25-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Mar 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.24-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Sep 15 2008 gil <puntogil@libero.it> 0.6.23-1mamba
|
||||
- update to 0.6.23
|
||||
- addded packages: compat-howl; compat-libdns_sd
|
||||
- changed configure options (see spec)
|
||||
- FIXME excludes:libdns_sd.so.1; libdns_sd.so (conflicts with file from package libzeroconf-107.6-1mamba.i586)
|
||||
|
||||
* Thu Jun 12 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.22-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user