update to 0.8+20240909git.363aaf4 [release 0.8+20240909git.363aaf4-1mamba;Thu Sep 19 2024]
This commit is contained in:
parent
1604cf8506
commit
27f3f3a6a5
@ -1,30 +0,0 @@
|
||||
https://bugs.gentoo.org/484212
|
||||
|
||||
Description: SO_REUSEPORT may not exist in running kernel
|
||||
When userspace defines SO_REUSEPORT we will attempt to enable socket
|
||||
port number reuse. However if the running kernel does not support
|
||||
this call it will fail preventing daemon startup. If this call is
|
||||
present but fails ENOPROTOOPT then we know that actually the kernel
|
||||
does not support it and we should continue as if we did not have the
|
||||
call at all. (LP: #1228204)
|
||||
.
|
||||
This patch could be removed from the debian package after jessie release.
|
||||
Author: Andy Whitcroft <apw@canonical.com>
|
||||
Bug-Ubuntu: https://bugs.launchpad.net/bugs/1228204
|
||||
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=732009
|
||||
Last-Update: 2013-09-20
|
||||
|
||||
Index: avahi-0.6.31/avahi-core/socket.c
|
||||
===================================================================
|
||||
--- avahi-0.6.31.orig/avahi-core/socket.c 2013-09-20 16:36:50.000000000 +0100
|
||||
+++ avahi-0.6.31/avahi-core/socket.c 2013-09-20 16:38:23.781863644 +0100
|
||||
@@ -177,7 +177,8 @@
|
||||
yes = 1;
|
||||
if (setsockopt(fd, SOL_SOCKET, SO_REUSEPORT, &yes, sizeof(yes)) < 0) {
|
||||
avahi_log_warn("SO_REUSEPORT failed: %s", strerror(errno));
|
||||
- return -1;
|
||||
+ if (errno != ENOPROTOOPT)
|
||||
+ return -1;
|
||||
}
|
||||
#endif
|
||||
|
@ -1,95 +0,0 @@
|
||||
--- avahi-0.6.31/avahi-ui/avahi-ui.c.orig 2011-02-18 19:04:10.251546734 +0100
|
||||
+++ avahi-0.6.31/avahi-ui/avahi-ui.c 2013-11-22 23:15:26.702181607 +0100
|
||||
@@ -991,7 +991,11 @@
|
||||
gtk_dialog_set_has_separator(GTK_DIALOG(p->domain_dialog), FALSE);
|
||||
#endif
|
||||
|
||||
+#if GTK_CHECK_VERSION(3,0,0)
|
||||
+ vbox = gtk_box_new(GTK_ORIENTATION_VERTICAL, 8);
|
||||
+#else
|
||||
vbox = gtk_vbox_new(FALSE, 8);
|
||||
+#endif
|
||||
gtk_container_set_border_width(GTK_CONTAINER(vbox), 8);
|
||||
gtk_box_pack_start(GTK_BOX(gtk_dialog_get_content_area(GTK_DIALOG(p->domain_dialog))), vbox, TRUE, TRUE, 0);
|
||||
|
||||
@@ -1002,7 +1006,11 @@
|
||||
g_signal_connect(p->domain_entry, "changed", G_CALLBACK(domain_entry_changed_callback), d);
|
||||
gtk_box_pack_start(GTK_BOX(vbox), p->domain_entry, FALSE, FALSE, 0);
|
||||
|
||||
+#if GTK_CHECK_VERSION(3,0,0)
|
||||
+ vbox2 = gtk_box_new(GTK_ORIENTATION_VERTICAL, 8);
|
||||
+#else
|
||||
vbox2 = gtk_vbox_new(FALSE, 8);
|
||||
+#endif
|
||||
gtk_box_pack_start(GTK_BOX(vbox), vbox2, TRUE, TRUE, 0);
|
||||
|
||||
scrolled_window = gtk_scrolled_window_new(NULL, NULL);
|
||||
@@ -1032,8 +1040,8 @@
|
||||
gtk_progress_bar_set_pulse_step(GTK_PROGRESS_BAR(p->domain_progress_bar), 0.1);
|
||||
gtk_box_pack_end(GTK_BOX(vbox2), p->domain_progress_bar, FALSE, FALSE, 0);
|
||||
|
||||
- gtk_dialog_add_button(GTK_DIALOG(p->domain_dialog), GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL);
|
||||
- p->domain_ok_button = GTK_WIDGET(gtk_dialog_add_button(GTK_DIALOG(p->domain_dialog), GTK_STOCK_OK, GTK_RESPONSE_ACCEPT));
|
||||
+ gtk_dialog_add_button(GTK_DIALOG(p->domain_dialog), _("_Cancel"), GTK_RESPONSE_CANCEL);
|
||||
+ p->domain_ok_button = GTK_WIDGET(gtk_dialog_add_button(GTK_DIALOG(p->domain_dialog), _("_OK"), GTK_RESPONSE_ACCEPT));
|
||||
gtk_dialog_set_default_response(GTK_DIALOG(p->domain_dialog), GTK_RESPONSE_ACCEPT);
|
||||
gtk_widget_set_sensitive(p->domain_ok_button, is_valid_domain_suffix(gtk_entry_get_text(GTK_ENTRY(p->domain_entry))));
|
||||
|
||||
@@ -1113,7 +1121,11 @@
|
||||
|
||||
gtk_container_set_border_width(GTK_CONTAINER(d), 5);
|
||||
|
||||
+#if GTK_CHECK_VERSION(3,0,0)
|
||||
+ vbox = gtk_box_new(GTK_ORIENTATION_VERTICAL, 8);
|
||||
+#else
|
||||
vbox = gtk_vbox_new(FALSE, 8);
|
||||
+#endif
|
||||
gtk_container_set_border_width(GTK_CONTAINER(vbox), 8);
|
||||
gtk_box_pack_start(GTK_BOX(gtk_dialog_get_content_area(GTK_DIALOG(d))), vbox, TRUE, TRUE, 0);
|
||||
|
||||
@@ -1123,7 +1135,11 @@
|
||||
gtk_box_pack_start(GTK_BOX(vbox), p->domain_label, FALSE, FALSE, 0);
|
||||
|
||||
|
||||
+#if GTK_CHECK_VERSION(3,0,0)
|
||||
+ vbox2 = gtk_box_new(GTK_ORIENTATION_VERTICAL, 8);
|
||||
+#else
|
||||
vbox2 = gtk_vbox_new(FALSE, 8);
|
||||
+#endif
|
||||
gtk_box_pack_start(GTK_BOX(vbox), vbox2, TRUE, TRUE, 0);
|
||||
|
||||
scrolled_window = gtk_scrolled_window_new(NULL, NULL);
|
||||
@@ -1164,7 +1180,7 @@
|
||||
gtk_box_pack_end(GTK_BOX(vbox2), p->service_progress_bar, FALSE, FALSE, 0);
|
||||
|
||||
p->domain_button = gtk_button_new_with_mnemonic(_("_Domain..."));
|
||||
- gtk_button_set_image(GTK_BUTTON(p->domain_button), gtk_image_new_from_stock(GTK_STOCK_NETWORK, GTK_ICON_SIZE_BUTTON));
|
||||
+ gtk_button_set_image(GTK_BUTTON(p->domain_button), gtk_image_new_from_icon_name("network-workgroup", GTK_ICON_SIZE_BUTTON));
|
||||
g_signal_connect(p->domain_button, "clicked", G_CALLBACK(domain_button_clicked), d);
|
||||
gtk_box_pack_start(GTK_BOX(gtk_dialog_get_action_area(GTK_DIALOG(d))), p->domain_button, FALSE, TRUE, 0);
|
||||
gtk_button_box_set_child_secondary(GTK_BUTTON_BOX(gtk_dialog_get_action_area(GTK_DIALOG(d))), p->domain_button, TRUE);
|
||||
--- avahi-0.6.31/avahi-ui/bssh.c.orig 2010-08-26 02:51:39.023153001 +0200
|
||||
+++ avahi-0.6.31/avahi-ui/bssh.c 2013-11-22 23:17:41.635509278 +0100
|
||||
@@ -146,19 +146,19 @@
|
||||
break;
|
||||
|
||||
case COMMAND_SHELL:
|
||||
- d = aui_service_dialog_new(_("Choose Shell Server"), NULL, GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL, GTK_STOCK_CONNECT, GTK_RESPONSE_ACCEPT, NULL);
|
||||
+ d = aui_service_dialog_new(_("Choose Shell Server"), NULL, _("_Cancel"), GTK_RESPONSE_CANCEL, gtk_image_new_from_icon_name("network-workgroup", GTK_ICON_SIZE_BUTTON), GTK_RESPONSE_ACCEPT, NULL);
|
||||
aui_service_dialog_set_browse_service_types(AUI_SERVICE_DIALOG(d), "_rfb._tcp", "_ssh._tcp", NULL);
|
||||
aui_service_dialog_set_service_type_name(AUI_SERVICE_DIALOG(d), "_rfb._tcp", _("Desktop"));
|
||||
aui_service_dialog_set_service_type_name(AUI_SERVICE_DIALOG(d), "_ssh._tcp", _("Terminal"));
|
||||
break;
|
||||
|
||||
case COMMAND_VNC:
|
||||
- d = aui_service_dialog_new(_("Choose VNC server"), NULL, GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL, GTK_STOCK_CONNECT, GTK_RESPONSE_ACCEPT, NULL);
|
||||
+ d = aui_service_dialog_new(_("Choose VNC server"), NULL, _("_Cancel"), GTK_RESPONSE_CANCEL, gtk_image_new_from_icon_name("network-workgroup", GTK_ICON_SIZE_BUTTON), GTK_RESPONSE_ACCEPT, NULL);
|
||||
aui_service_dialog_set_browse_service_types(AUI_SERVICE_DIALOG(d), "_rfb._tcp", NULL);
|
||||
break;
|
||||
|
||||
case COMMAND_SSH:
|
||||
- d = aui_service_dialog_new(_("Choose SSH server"), NULL, GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL, GTK_STOCK_CONNECT, GTK_RESPONSE_ACCEPT, NULL);
|
||||
+ d = aui_service_dialog_new(_("Choose SSH server"), NULL, _("_Cancel"), GTK_RESPONSE_CANCEL, gtk_image_new_from_icon_name("network-workgroup", GTK_ICON_SIZE_BUTTON), GTK_RESPONSE_ACCEPT, NULL);
|
||||
aui_service_dialog_set_browse_service_types(AUI_SERVICE_DIALOG(d), "_ssh._tcp", NULL);
|
||||
break;
|
||||
}
|
@ -1,10 +0,0 @@
|
||||
--- avahi-0.8/avahi-libevent.pc.in.orig 2022-07-09 17:35:32.002142320 +0200
|
||||
+++ avahi-0.8/avahi-libevent.pc.in 2022-07-09 17:35:43.164083632 +0200
|
||||
@@ -6,6 +6,6 @@
|
||||
Name: avahi-libevent
|
||||
Description: Avahi Multicast DNS Responder (libevent Support)
|
||||
Version: @PACKAGE_VERSION@
|
||||
-Requires: libevent-2.1.5
|
||||
+Requires: libevent >= 2.1.5
|
||||
Libs: -L${libdir} -lavahi-libevent
|
||||
Cflags: -D_REENTRANT -I${includedir}
|
58
avahi.spec
58
avahi.spec
@ -2,20 +2,18 @@
|
||||
%define avahiuserid 65429
|
||||
%define avahiautoipdgroupid 65053
|
||||
%define avahiautoipduserid 65053
|
||||
%define gitcommit %(echo %version | cut -d+ -f2 | cut -d. -f2)
|
||||
|
||||
Name: avahi
|
||||
Version: 0.8
|
||||
Release: 6mamba
|
||||
Version: 0.8+20240909git.363aaf4
|
||||
Release: 1mamba
|
||||
Summary: A system which facilitates service discovery on a local network
|
||||
Group: Applications/Networking
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://avahi.org
|
||||
Source: https://github.com/lathiat/avahi.git/v%{version}/avahi-%{version}.tar.bz2
|
||||
Patch0: avahi-0.6.31-gtk-3.12.patch
|
||||
Patch1: avahi-0.6.31-SO_REUSEPORT_may_not_exist_in_running_kernel.patch
|
||||
Patch2: avahi-0.8-libevent-2.1.12.patch
|
||||
Source: https://github.com/lathiat/avahi.git/master@%{gitcommit}/avahi-%{version}.tar.bz2
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -37,6 +35,8 @@ BuildRequires: libpango-devel
|
||||
BuildRequires: libpython311-devel
|
||||
BuildRequires: libssp-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: mono-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
## AUTOBUILDREQ-END
|
||||
@ -75,8 +75,7 @@ Requires: libavahi = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-devel
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%package -n libavahi-glib
|
||||
Summary: Glib binding library for avahi
|
||||
@ -95,8 +94,7 @@ Requires: libavahi-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-glib-devel
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
This package contains static libraries and header files need for development of the avahi-glib library.
|
||||
This package contains static libraries and header files needed for development of the avahi-glib library.
|
||||
|
||||
%package -n libavahi-gtk3
|
||||
Summary: Gtk3 binding library for avahi
|
||||
@ -115,8 +113,7 @@ Requires: libavahi-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libavahi-gtk3-devel
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
This package contains static libraries and header files need for development of the avahi-gtk3 library.
|
||||
This package contains static libraries and header files needed for development of the avahi-gtk3 library.
|
||||
|
||||
%package -n libavahi-qt5
|
||||
Summary: QT5 binding library for avahi
|
||||
@ -138,8 +135,7 @@ Obsoletes: libavahi-qt4-devel < 0.8-3mamba
|
||||
|
||||
%description -n libavahi-qt5-devel
|
||||
Avahi is a system which facilitates service discovery on a local network. This means that you can plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared. This kind of technology is already found in Apple MacOS X (branded Rendezvous, Bonjour and sometimes Zeroconf) and is very convenient.
|
||||
|
||||
This package contains static libraries and header files need for development of the avahi-qt5 library.
|
||||
This package contains static libraries and header files needed for development of the avahi-qt5 library.
|
||||
|
||||
%package mono
|
||||
Summary: A system which facilitates service discovery on a local network
|
||||
@ -208,9 +204,6 @@ Header files for development with the Apple Bonjour mDNSResponder compatibility
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch 2 -p1
|
||||
|
||||
./autogen.sh --with-distro=fedora
|
||||
|
||||
@ -300,12 +293,6 @@ fi
|
||||
%systemd_postun avahi-dnsconfd
|
||||
:
|
||||
|
||||
%post -n libavahi -p /sbin/ldconfig
|
||||
%postun -n libavahi -p /sbin/ldconfig
|
||||
|
||||
%post -n libavahi-qt5 -p /sbin/ldconfig
|
||||
%postun -n libavahi-qt5 -p /sbin/ldconfig
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%dir %{_sysconfdir}/avahi
|
||||
@ -316,7 +303,6 @@ fi
|
||||
%dir %{_sysconfdir}/avahi/services
|
||||
%{_sysconfdir}/avahi/services/sftp-ssh.service
|
||||
%{_sysconfdir}/avahi/services/ssh.service
|
||||
%{_sysconfdir}/dbus-1/system.d/avahi-dbus.conf
|
||||
%{_bindir}/avahi-bookmarks
|
||||
%{_bindir}/avahi-browse
|
||||
%{_bindir}/avahi-browse-domains
|
||||
@ -340,14 +326,13 @@ fi
|
||||
%{_libdir}/avahi/service-types.db
|
||||
%{_datadir}/avahi/avahi-service.dtd
|
||||
%{_datadir}/avahi/interfaces/avahi-discover.ui
|
||||
#%{_datadir}/avahi/introspection/*.introspect
|
||||
#%{_datadir}/avahi/service-types
|
||||
%{_datadir}/dbus-1/interfaces/org.freedesktop.Avahi.*.xml
|
||||
%{_datadir}/dbus-1/system-services/org.freedesktop.Avahi.service
|
||||
%{_datadir}/dbus-1/system.d/avahi-dbus.conf
|
||||
%{_mandir}/man1/avahi-bookmarks.1*
|
||||
%{_mandir}/man1/avahi-browse-domains.1*
|
||||
%{_mandir}/man1/avahi-browse.1*
|
||||
#%{_mandir}/man1/avahi-discover.1*
|
||||
%{_mandir}/man1/avahi-discover.1*
|
||||
%{_mandir}/man1/avahi-publish-address.1*
|
||||
%{_mandir}/man1/avahi-publish-service.1*
|
||||
%{_mandir}/man1/avahi-publish.1*
|
||||
@ -355,8 +340,6 @@ fi
|
||||
%{_mandir}/man1/avahi-resolve-host-name.1*
|
||||
%{_mandir}/man1/avahi-resolve.1*
|
||||
%{_mandir}/man1/avahi-set-host-name.1*
|
||||
#%{_mandir}/man1/bssh.1*
|
||||
#%{_mandir}/man1/bvnc.1*
|
||||
%{_mandir}/man8/avahi-autoipd.8*
|
||||
%{_mandir}/man8/avahi-autoipd.action.8*
|
||||
%{_mandir}/man5/avahi-daemon.conf.5*
|
||||
@ -375,6 +358,9 @@ fi
|
||||
%{_datadir}/applications/avahi-discover.desktop
|
||||
%{_datadir}/applications/bssh.desktop
|
||||
%{_datadir}/applications/bvnc.desktop
|
||||
%{_mandir}/man1/bshell.1*
|
||||
%{_mandir}/man1/bssh.1*
|
||||
%{_mandir}/man1/bvnc.1*
|
||||
|
||||
%files -n libavahi
|
||||
%defattr(-,root,root)
|
||||
@ -382,7 +368,6 @@ fi
|
||||
%{_libdir}/libavahi-common.so.*
|
||||
%{_libdir}/libavahi-core.so.*
|
||||
%{_libdir}/libavahi-libevent.so.*
|
||||
#%{_libdir}/libavahi-ui.so.*
|
||||
|
||||
%files -n libavahi-devel
|
||||
%defattr(-,root,root)
|
||||
@ -404,9 +389,6 @@ fi
|
||||
%{_libdir}/libavahi-core.so
|
||||
%{_libdir}/libavahi-libevent.a
|
||||
%{_libdir}/libavahi-libevent.so
|
||||
#%{_libdir}/libavahi-ui.a
|
||||
#%{_libdir}/libavahi-ui.so
|
||||
#%{_libdir}/pkgconfig/avahi-ui.pc
|
||||
%{_libdir}/pkgconfig/avahi-client.pc
|
||||
%{_libdir}/pkgconfig/avahi-core.pc
|
||||
%{_libdir}/pkgconfig/avahi-libevent.pc
|
||||
@ -465,19 +447,12 @@ fi
|
||||
%files mono
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/mono/avahi-sharp/avahi-sharp.dll
|
||||
#%{_libdir}/mono/avahi-ui-sharp/avahi-ui-sharp.dll
|
||||
%{_libdir}/mono/gac/avahi-sharp/1.0.0.0__4d116c78973743f5/avahi-sharp.dll
|
||||
%{_libdir}/mono/gac/avahi-sharp/1.0.0.0__4d116c78973743f5/avahi-sharp.dll.config
|
||||
%{_libdir}/mono/gac/avahi-sharp/1.0.0.0__4d116c78973743f5/avahi-sharp.dll.mdb
|
||||
#%{_libdir}/mono/gac/avahi-ui-sharp/0.0.0.0__4d116c78973743f5/avahi-ui-sharp.dll
|
||||
#%{_libdir}/mono/gac/avahi-ui-sharp/0.0.0.0__4d116c78973743f5/avahi-ui-sharp.dll.config
|
||||
#%{_libdir}/mono/gac/avahi-ui-sharp/0.0.0.0__4d116c78973743f5/avahi-ui-sharp.dll.mdb
|
||||
%{_prefix}/lib/monodoc/sources/avahi-sharp-docs.source
|
||||
%{_prefix}/lib/monodoc/sources/avahi-sharp-docs.tree
|
||||
%{_prefix}/lib/monodoc/sources/avahi-sharp-docs.zip
|
||||
#%{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.source
|
||||
#%{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.tree
|
||||
#%{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.zip
|
||||
%{_libdir}/pkgconfig/avahi-sharp.pc
|
||||
%{_libdir}/pkgconfig/avahi-ui-sharp.pc
|
||||
%endif
|
||||
@ -517,6 +492,9 @@ fi
|
||||
%{_libdir}/pkgconfig/libdns_sd.pc
|
||||
|
||||
%changelog
|
||||
* Thu Sep 19 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8+20240909git.363aaf4-1mamba
|
||||
- update to 0.8+20240909git.363aaf4
|
||||
|
||||
* Thu Oct 12 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8-6mamba
|
||||
- rebuilt with python3 == 3.11
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user