rebuilt with libMagick 6.8.6.9 [release 0.31.1-13mamba;Tue Aug 27 2013]

This commit is contained in:
Silvan Calarco 2024-01-05 20:42:36 +01:00
parent 3a537d2fe8
commit 5b43b318ac
6 changed files with 481 additions and 0 deletions

View File

@ -1,2 +1,6 @@
# autotrace
AutoTrace is a program for converting bitmaps to vector graphics.
The aim of the AutoTrace project is the development of a freely-available application similar to CorelTrace or Adobe Streamline. In some aspects it is already better.
Originally being created as a plugin for the GIMP, AutoTrace is now a standalone program and can be compiled on any UNIX platform using GCC.

View File

@ -0,0 +1,10 @@
--- autotrace-0.31.1/output-swf.c.orig 2006-07-23 03:46:23.000000000 +0900
+++ autotrace-0.31.1/output-swf.c 2006-07-23 03:52:40.000000000 +0900
@@ -90,6 +90,7 @@
int width = urx - llx;
int height = ury - lly;
SWFMovie m;
+ SWFByteOutputMethod fileOutputMethod;
#ifdef _WINDOWS
if(file == stdout)

View File

@ -0,0 +1,64 @@
http://sourceforge.net/mailarchive/forum.php?thread_name=01e601cbc22e%24f45d7200%24dd185600%24%40acm.org&forum_name=png-mng-implement
$NetBSD$
Fix build with png-1.5.
--- input-png.c.orig 2002-10-10 20:44:14.000000000 +0000
+++ input-png.c
@@ -42,17 +42,17 @@ static png_bytep * read_png(png_structp
static void handle_warning(png_structp png, const at_string message) {
LOG1("PNG warning: %s", message);
- at_exception_warning((at_exception_type *)png->error_ptr,
+ at_exception_warning((at_exception_type *)png_get_error_ptr(png),
message);
- /* at_exception_fatal((at_exception_type *)at_png->error_ptr,
+ /* at_exception_fatal((at_exception_type *)png_get_error_ptr(at_png),
"PNG warning"); */
}
static void handle_error(png_structp png, const at_string message) {
LOG1("PNG error: %s", message);
- at_exception_fatal((at_exception_type *)png->error_ptr,
+ at_exception_fatal((at_exception_type *)png_get_error_ptr(png),
message);
- /* at_exception_fatal((at_exception_type *)at_png->error_ptr,
+ /* at_exception_fatal((at_exception_type *)png_get_error_ptr(at_png),
"PNG error"); */
}
@@ -157,8 +157,8 @@ read_png(png_structp png_ptr, png_infop
png_set_strip_16(png_ptr);
png_set_packing(png_ptr);
- if ((png_ptr->bit_depth < 8) ||
- (png_ptr->color_type == PNG_COLOR_TYPE_PALETTE) ||
+ if ((png_get_bit_depth(png_ptr, info_ptr) < 8) ||
+ (png_get_color_type(png_ptr, info_ptr) == PNG_COLOR_TYPE_PALETTE) ||
(png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)))
png_set_expand(png_ptr);
@@ -181,20 +181,10 @@ read_png(png_structp png_ptr, png_infop
PNG_BACKGROUND_GAMMA_FILE, 1, 1.0);
} else
png_set_strip_alpha(png_ptr);
+ png_set_interlace_handling(png_ptr);
png_read_update_info(png_ptr, info_ptr);
-
- info_ptr->row_pointers = (png_bytepp)png_malloc(png_ptr,
- info_ptr->height * sizeof(png_bytep));
-#ifdef PNG_FREE_ME_SUPPORTED
- info_ptr->free_me |= PNG_FREE_ROWS;
-#endif
- for (row = 0; row < (int)info_ptr->height; row++)
- info_ptr->row_pointers[row] = (png_bytep)png_malloc(png_ptr,
- png_get_rowbytes(png_ptr, info_ptr));
-
- png_read_image(png_ptr, info_ptr->row_pointers);
- info_ptr->valid |= PNG_INFO_IDAT;
+ png_read_png(png_ptr, info_ptr, PNG_TRANSFORM_IDENTITY, NULL);
png_read_end(png_ptr, info_ptr);
return png_get_rows(png_ptr, info_ptr);
}

View File

@ -0,0 +1,12 @@
diff -Nru autotrace-0.31.1.orig//autotrace.m4 autotrace-0.31.1/autotrace.m4
--- autotrace-0.31.1.orig//autotrace.m4 2002-10-10 22:44:12.000000000 +0200
+++ autotrace-0.31.1/autotrace.m4 2011-07-26 04:05:49.648813021 +0200
@@ -4,7 +4,7 @@
dnl AM_PATH_AUTOTRACE([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
dnl Test to see if libautotrace is installed, and define AUTOTRACE_CFLAGS, LIBS
dnl
-AC_DEFUN(AM_PATH_AUTOTRACE,
+AC_DEFUN([AM_PATH_AUTOTRACE],
[dnl
dnl Get the cflags and libraries from the autotrace-config script
dnl

View File

@ -0,0 +1,219 @@
diff -urN -F'^f' autotrace-0.31.1.orig/pstoedit-config autotrace-0.31.1/pstoedit-config
--- autotrace-0.31.1.orig/pstoedit-config 1970-01-01 01:00:00.000000000 +0100
+++ autotrace-0.31.1/pstoedit-config 2006-11-13 15:23:06.000000000 +0100
@@ -0,0 +1,215 @@
+#!/bin/sh
+
+af_libs=
+af_cflags=
+prefix=/usr
+exec_prefix=/usr
+
+
+##
+## Define usage()
+##
+usage()
+{
+ cat <<EOF
+Usage: pstoedit-config [OPTIONS] [LIBRARIES]
+Options:
+ --cflags print pre-processor and compiler flags
+ --libs print library linking information
+ --libs-dirs only print the -L/-R part of --libs
+ --libs-names only print the -l part of --libs
+ --help display this help and exit
+ --prefix[=DIR]
+ --exec_prefix[=DIR]
+ --version output pstoedit version information
+Libraries:
+ pstoedit
+EOF
+ exit $1
+}
+
+##
+## Process options
+##
+parse()
+{
+# we must be called with at least one argument
+if test $# -eq 0; then
+ usage 1 1>&2
+fi
+
+# at least one option should be selected
+case "$1" in
+ --*)
+ ;;
+ *)
+ usage 1 1>&2
+ ;;
+esac
+
+# grab all -- arguments
+while test $# -gt 0; do
+ case "$1" in
+ -*=*) af_optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
+ *) af_optarg= ;;
+ esac
+
+ case $1 in
+ --help)
+ usage 0 0>&2
+ ;;
+ --cflags)
+ af_echo_cflags=yes
+ ;;
+ --libs)
+ af_echo_libs_L=yes
+ af_echo_libs_l=yes
+ ;;
+ --libs-dirs)
+ af_echo_libs_L=yes
+ ;;
+ --libs-names)
+ af_echo_libs_l=yes
+ ;;
+ --prefix=*)
+ prefix=$af_optarg
+ af_prefix_set=yes
+ ;;
+ --prefix)
+ af_echo_prefix=yes
+ ;;
+ --exec_prefix=*)
+ exec_prefix=$af_optarg
+ af_exec_prefix_set=yes
+ ;;
+ --exec_prefix)
+ af_echo_exec_prefix=yes
+ ;;
+ --version)
+ af_echo_version=yes
+ ;;
+ --*)
+ usage 1 1>&2
+ ;;
+ *)
+ break
+ ;;
+ esac
+ shift
+done
+
+# if we have a default library use it
+if test $# -eq 0; then
+if test "X$af_lib_default" != "X"; then
+ af_lib__AF_LIB_DEFAULT=yes
+ return
+fi
+fi
+
+while test $# -gt 0; do
+ case $1 in
+ pstoedit)
+ af_lib_pstoedit=yes
+ ;;
+ *)
+ usage 1 1>&2
+ ;;
+ esac
+ shift
+done
+}
+
+print_result()
+{
+if test "X$af_echo_cflags" = "Xyes"; then
+ af_all_flags="$af_cflags"
+fi
+
+if test "X$af_echo_libs_L" = "Xyes" || test "X$af_echo_libs_l" = "Xyes"; then
+ af_all_flags="$af_all_flags $af_libs"
+fi
+
+if test -z "$af_all_flags" || test "X$af_all_flags" = "X "; then
+ exit 1
+fi
+
+# Straight out any possible duplicates, but be careful to
+# get `-lfoo -lbar -lbaz' for `-lfoo -lbaz -lbar -lbaz'
+af_other_flags=
+af_lib_L_flags=
+af_rev_libs=
+for i in $af_all_flags; do
+ case "$i" in
+ # a library, save it for later, in reverse order
+ -l*) af_rev_libs="$i $af_rev_libs" ;;
+ -L*|-R*)
+ if test "X$af_echo_libs_L" = "Xyes"; then
+ case " $af_lib_L_flags " in
+ *\ $i\ *) ;; # already there
+ *) af_lib_L_flags="$af_lib_L_flags $i" ;; # add it to output
+ esac
+ fi;;
+ *)
+ case " $af_other_flags " in
+ *\ $i\ *) ;; # already there
+ *) af_other_flags="$af_other_flags $i" ;; # add it to output
+ esac ;;
+ esac
+done
+
+af_ord_libs=
+if test "X$af_echo_libs_l" = "Xyes"; then
+ for i in $af_rev_libs; do
+ case " $af_ord_libs " in
+ *\ $i\ *) ;; # already there
+ *) af_ord_libs="$i $af_ord_libs" ;; # add it to output in reverse order
+ esac
+ done
+fi
+
+echo $af_other_flags $af_lib_L_flags $af_ord_libs
+}
+
+##
+## Main Body
+##
+
+parse $*
+
+
+##
+## Initialize names
+##
+
+
+##
+## Available options
+##
+if test "X$af_echo_prefix" = "Xyes"; then
+ echo $prefix
+fi
+
+if test "X$af_echo_exec_prefix" = "Xyes"; then
+ echo $exec_prefix
+fi
+
+if test "X$af_echo_version" = "Xyes"; then
+ echo 3.42.0
+ exit 0
+fi
+
+
+##
+## Libraries
+##
+#dummy because this should always be selected
+
+af_cflags="$af_cflags -I/usr/include"
+af_libs="-L/usr/lib -lpstoedit -lplotter -lEMF -lm -lpng -lz -lstdc++ -ldl $af_libs"
+
+
+
+print_result
+
+exit 0
+

172
autotrace.spec Normal file
View File

@ -0,0 +1,172 @@
Name: autotrace
Version: 0.31.1
Release: 13mamba
Summary: Utility for converting bitmaps to vector graphics
Group: Applications/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://autotrace.sf.net/
Source: http://dl.sf.net/autotrace/autotrace-%{version}.tar.gz
Patch0: %{name}-0.31.1-gcc4.patch
Patch1: %{name}-0.31.1-pstoedit.patch
Patch2: %{name}-0.31.1-m4_fix.patch
Patch3: autotrace-0.31.1-libpng-1.5.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: ImageMagick-devel
BuildRequires: libbzip2-devel
BuildRequires: libEMF-devel
BuildRequires: libexpat-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgd-devel
BuildRequires: libICE-devel
BuildRequires: libjpeg-devel
BuildRequires: libming-devel
BuildRequires: libplot-devel
BuildRequires: libpng-devel
BuildRequires: libpstoedit-devel
BuildRequires: libpthread-stubs-devel
BuildRequires: libSM-devel
BuildRequires: libstdc++6-devel
BuildRequires: libgif-devel
BuildRequires: libuuid-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libXaw-devel
BuildRequires: libxcb-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXext-devel
BuildRequires: libXmu-devel
BuildRequires: libXpm-devel
BuildRequires: libXt-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: libMagick-devel >= 6.8.6
Requires: libautotrace = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
AutoTrace is a program for converting bitmaps to vector graphics.
The aim of the AutoTrace project is the development of a freely-available application similar to CorelTrace or Adobe Streamline. In some aspects it is already better.
Originally being created as a plugin for the GIMP, AutoTrace is now a standalone program and can be compiled on any UNIX platform using GCC.
%package -n libautotrace
Summary: Library for converting bitmaps to vector graphics
Group: System/Libraries
%description -n libautotrace
AutoTrace is a program for converting bitmaps to vector graphics.
The aim of the AutoTrace project is the development of a freely-available application similar to CorelTrace or Adobe Streamline. In some aspects it is already better.
Originally being created as a plugin for the GIMP, AutoTrace is now a standalone program and can be compiled on any UNIX platform using GCC.
This package contains static libraries and header files need for development.
%package -n libautotrace-devel
Summary: Devel package for lib%{name}
Group: Development/Libraries
Requires: libautotrace = %{?epoch:%epoch:}%{version}-%{release}
%description -n libautotrace-devel
AutoTrace is a program for converting bitmaps to vector graphics.
The aim of the AutoTrace project is the development of a freely-available application similar to CorelTrace or Adobe Streamline. In some aspects it is already better.
Originally being created as a plugin for the GIMP, AutoTrace is now a standalone program and can be compiled on any UNIX platform using GCC.
This package contains static libraries and header files need for development.
%prep
%setup -q
%patch0 -p1
#%patch1 -p1
%patch2 -p1
%patch3 -p0
cat > pstoedit-config << _EOF
ARGS=\`echo \$@ | sed "s|--version|--modversion|"\`
pkg-config pstoedit \$ARGS
_EOF
chmod +x pstoedit-config
%build
autoreconf -i
%configure \
PSTOEDIT_CONFIG=$(pwd)/pstoedit-config
%make
%install
[ %{buildroot} != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ %{buildroot} != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-, root, root)
%{_bindir}/autotrace
%{_mandir}/man1/autotrace.1.gz
%files -n libautotrace
%defattr(-, root, root)
%{_libdir}/libautotrace.so.*
%doc AUTHORS COPYING*
%files -n libautotrace-devel
%defattr(-, root, root)
%{_bindir}/autotrace-config
%{_libdir}/lib%{name}.a
%{_libdir}/lib%{name}.la
%{_libdir}/lib%{name}.so
%{_libdir}/pkgconfig/*.pc
%dir %{_includedir}/%{name}
%{_includedir}/%{name}/*
%{_datadir}/aclocal/*.m4
%doc FAQ NEWS README* TODO
%doc ChangeLog
%changelog
* Tue Aug 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.31.1-13mamba
- rebuilt with libMagick 6.8.6.9
* Tue Dec 11 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.31.1-12mamba
- rebuilt with ImageMagick 6.8
* Tue Jul 26 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.31.1-11mamba
- fixed autotrace.m4 file
* Fri Jul 09 2010 Automatic Build System <autodist@mambasoft.it> 0.31.1-10mamba
- automatic rebuild by autodist
* Tue Jan 19 2010 Automatic Build System <autodist@mambasoft.it> 0.31.1-9mamba
- automatic rebuild by autodist
* Sat May 09 2009 Automatic Build System <autodist@mambasoft.it> 0.31.1-8mamba
- automatic rebuild by autodist
* Tue Feb 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.31.1-7mamba
- automatic rebuild by autodist
* Tue Nov 18 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.31.1-6mamba
- automatic rebuild by autodist
* Tue Jun 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.31.1-5mamba
- rebuilt against ImageMagick 6.4
* Fri Nov 03 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 0.31.1-4qilnx
- rebuild with libming
- added gcc4 patch
* Mon Jan 02 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.31.1-3qilnx
- rebuilt
- specfile fixed
* Tue Apr 12 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.31.1-2qilnx
- rebuild and moved from devel-contrib repository to devel repository
* Fri Sep 17 2004 Matteo Bernasconi <voyagernm@virgilio.it> 0.31.1-1qilnx
- first build