apply patches to sync with current git [release 1.16.4-2mamba;Tue May 27 2014]

This commit is contained in:
Silvan Calarco 2024-01-05 20:42:22 +01:00
parent 3ede427557
commit 2415d19a4a
5 changed files with 394 additions and 1 deletions

View File

@ -0,0 +1,153 @@
From a7db8b7c72ec107790724df1f04cc717e1c8dd2e Mon Sep 17 00:00:00 2001
From: Silvan Calarco <silvan.calarco@mambasoft.it>
Date: Mon, 9 Dec 2013 10:49:41 +0100
Subject: [PATCH 1/3] templates/ghc: new template for ghc modules
---
conf/02-specfile-rpm-macros-ghc.conf | 5 +++
plugins/spec-create.in | 6 +++
templates/Makefile | 2 +-
templates/ghc | 82 ++++++++++++++++++++++++++++++++++++
4 files changed, 94 insertions(+), 1 deletion(-)
create mode 100644 conf/02-specfile-rpm-macros-ghc.conf
create mode 100644 templates/ghc
diff --git a/conf/02-specfile-rpm-macros-ghc.conf b/conf/02-specfile-rpm-macros-ghc.conf
new file mode 100644
index 0000000..94ca18a
--- /dev/null
+++ b/conf/02-specfile-rpm-macros-ghc.conf
@@ -0,0 +1,5 @@
+## Macros for ghc packages --------------------------------------------------
+
+# Force a name structure for ghc packages
+# Set to "" if you don't want to fix a structure
+ocaml_module_name_structure="^ghc-"
diff --git a/plugins/spec-create.in b/plugins/spec-create.in
index ebf7c35..818cfe7 100644
--- a/plugins/spec-create.in
+++ b/plugins/spec-create.in
@@ -103,6 +103,7 @@ function usage() {
-v, --pck-version "$"Version of the package (default: taken from <source-archive> name)""
-t, --type "$"Typology of the specfile to be created""
standard : "$"standard specfile (default)""
+ ghc : "$"specfile for ghc packages""
gnome : "$"specfile for gnome packages""
kde3 : "$"specfile for kde3 packages""
kde4 : "$"specfile for kde4 packages""
@@ -605,6 +606,11 @@ ${proxy:+--proxy $proxy} ${proxy_user:+--proxy-user $proxy_user} \
* "$"mode"": ${NOTE}$spec_type${NORM}"
case "$spec_type" in
+ ghc)
+ [[ "$pck_name" =~ $ghc_module_name_structure ]] || notify.error $"\
+ghc modules must have this name structure (use \`-n'):"" \
+\`$ghc_module_name_structure'"
+ ;;
library)
[[ "$pck_name" =~ $library_name_structure ]] || notify.error $"\
libraries must have this name structure (use \`-n'):"" \
diff --git a/templates/Makefile b/templates/Makefile
index 4c9ede6..d134aee 100644
--- a/templates/Makefile
+++ b/templates/Makefile
@@ -18,7 +18,7 @@ srcdir = ..
include $(srcdir)/Makefile.env
-pck_templates := gnome kde3 kde4 library ocaml-libs perl python standard standard-daemon web
+pck_templates := ghc gnome kde3 kde4 library ocaml-libs perl python standard standard-daemon web
all:
diff --git a/templates/ghc b/templates/ghc
new file mode 100644
index 0000000..90b74fd
--- /dev/null
+++ b/templates/ghc
@@ -0,0 +1,82 @@
+%define ghc_ver %(ghc --version | sed "s|.*version ||")
+%define pkgname %(echo %name | sed "s|^ghc-||")
+Name: @pck_name@
+Version: @pck_version@
+Release: @spec_first_release@@DISTRO_rpm@
+Summary: ...
+Group: Development/Libraries
+Vendor: @VENDOR@
+Distribution: @DISTRO@
+Packager: @packager_fullname@ <@packager_email@>
+URL: http://hackage.haskell.org/package/%{pkgname}
+Source: ...
+License: BSD
+## AUTOBUILDREQ-BEGIN
+## AUTOBUILDREQ-END
+@if:buildrequires_buildtool
+BuildRequires: @build_tool@
+@fi:buildrequires_buildtool
+@if:infopages
+Requires(post): %{__install_info}
+Requires(preun): %{__install_info}
+@fi:infopages
+BuildRequires: ghc
+BuildRequires: hscolour
+Requires: ghc = %{ghc_ver}
+BuildRoot: @rpm_default_buildroot@
+
+%description
+...
+
+## Remove the following block if there is no binary tool provided
+#%package -n %{pkgname}
+#Group: Applications/Development
+#Summary: ...
+#
+#%description -n %{pkgname}
+#...
+
+%prep
+%setup -q -n %{pkgname}-%{version}
+
+%build
+runghc Setup.hs configure \\
+ --prefix=%{_prefix} --libdir=%{_libdir}
+
+runghc Setup.hs build
+runghc Setup.hs haddock --html-location=URL --hyperlink-source
+
+%install
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+runghc Setup.hs copy --destdir=%{buildroot}
+runghc Setup.hs register \\
+ --gen-pkg-config="%{buildroot}%{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}/%{pkgname}-%{version}.conf"
+
+%clean
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+
+%post
+ghc-pkg register %{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}/%{pkgname}-%{version}.conf &>/dev/null || true
+:
+
+%preun
+ghc-pkg unregister %{pkgname}-%{version} &>/dev/null || true
+:
+
+%files
+%defattr(-,root,root)
+%dir %{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}
+%{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}/*
+%dir %{_docdir}/%{pkgname}-%{version}
+%{_docdir}/doc/%{pkgname}-%{version}/LICENSE
+%dir %{_docdir}/%{pkgname}-%{version}/html
+%{_docdir}/%{pkgname}-%{version}/html/*
+
+## Remove the following block if there is no binary tool provided
+#%files -n %{pkgname}
+#%defattr(-,root,root)
+#%{_bindir}/%{pkgname}
+
+%changelog
+* @spec_changelog_date@ @packager_fullname@ <@packager_email@> @pck_version@-@spec_first_release@@DISTRO_rpm@
+- @spec_changelog_comment@
--
1.9.3

View File

@ -0,0 +1,25 @@
From a23800a2b62026f6d7df6507b719099be145206e Mon Sep 17 00:00:00 2001
From: Silvan Calarco <silvan.calarco@mambasoft.it>
Date: Sat, 14 Dec 2013 14:15:17 +0100
Subject: [PATCH 2/3] templates/python: remove unexisting option
--single-version-externally-managed
---
templates/python | 1 -
1 file changed, 1 deletion(-)
diff --git a/templates/python b/templates/python
index 7da6709..71a1624 100644
--- a/templates/python
+++ b/templates/python
@@ -32,7 +32,6 @@ CFLAGS="%{optflags}" %{__python} setup.py build
\ --root="%{buildroot}" \\
\ --install-headers=%{_includedir}/python \\
\ --install-lib=%{python_sitearch} \\
-\ --single-version-externally-managed \\
\ --record=%{name}.filelist
sed -i "\\,\\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
--
1.9.3

View File

@ -0,0 +1,26 @@
From c4e2f98d93f21049bc7c17f18bd860282382dae2 Mon Sep 17 00:00:00 2001
From: Silvan Calarco <silvan.calarco@mambasoft.it>
Date: Sat, 22 Feb 2014 22:36:10 +0100
Subject: [PATCH 3/3] pck-update: specify target_cpu when installing build
requirements for x86_64 multiarch support
---
plugins/pck-update.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/plugins/pck-update.in b/plugins/pck-update.in
index c20f7f2..48cfd6f 100644
--- a/plugins/pck-update.in
+++ b/plugins/pck-update.in
@@ -1990,7 +1990,7 @@ build requirement found"": \`${NOTE}$f${NORM}' ""\
# remove duplicates
buildreqs_to_install=(
-$(for f in ${buildreqs_to_install[@]}; do echo $f; done | sort -u))
+$(for f in ${buildreqs_to_install[@]}; do echo $f@$target_cpu; done | sort -u))
# install missing build requirements
if [[ "${buildreqs_to_install[@]}" ]]; then
--
1.9.3

View File

@ -0,0 +1,178 @@
From e94617662e2f863c5fc5a7b6ce0defc2c8511ee6 Mon Sep 17 00:00:00 2001
From: Silvan Calarco <silvan.calarco@mambasoft.it>
Date: Tue, 27 May 2014 13:40:45 +0200
Subject: [PATCH 4/4] autospec.po: add missing italian translation strings for
ghc File has also been reordered by tool called by Makefile
---
po/it/autospec.po | 70 ++++++++++++++++++++++++-------------------------------
1 file changed, 31 insertions(+), 39 deletions(-)
diff --git a/po/it/autospec.po b/po/it/autospec.po
index 12990fe..8914005 100644
--- a/po/it/autospec.po
+++ b/po/it/autospec.po
@@ -19,6 +19,9 @@ msgstr "Project-Id-Version: autospec 1.16.4\n"
msgid "this script requires bash version 2 or better"
msgstr "questo script richiede bash versione 2 o superiore"
+msgid "library not found"
+msgstr "libreria non trovata"
+
msgid "This program is free software; you can redistribute it and/or modify "
"it under\n"
"the terms of the GNU General Public License version 2 as published "
@@ -86,15 +89,6 @@ msgstr "Usa '-u -h', '-s -h', '-x -h', '--eval -h' per avere le opzioni a "
msgid "Report bugs to <davide.madrisan@gmail.com>."
msgstr "Segnalare eventuali bug a <davide.madrisan@gmail.com>."
-msgid "library not found"
-msgstr "libreria non trovata"
-
-msgid "deprecated option"
-msgstr "opzione deprecata"
-
-msgid "use \\`--colors' instead"
-msgstr "utilizzare \\`--colors'"
-
msgid "version"
msgstr "versione"
@@ -144,6 +138,9 @@ msgstr "(bug)"
msgid "unknown variable type"
msgstr "tipo di variabile sconosciuto"
+msgid "loading"
+msgstr "caricamento di"
+
msgid "Find for updates scanning the web."
msgstr "Ricerca aggiornamenti cercando nel web."
@@ -195,9 +192,6 @@ msgstr "source0 in formato non parametrico: impossibile aggiornare"
msgid "found version:"
msgstr "versione trovata:"
-msgid "assertion failed:"
-msgstr "asserzione fallita:"
-
msgid "last version of \\`${NOTE}$specname${NORM}' found:"
msgstr "ultima versione di \\`${NOTE}$specname${NORM}' trovata:"
@@ -224,9 +218,6 @@ msgstr "l'utente \\`$(id -nu)' non appartiene al gruppo \\`$packager_group'"
msgid "missing variable in the configuration file"
msgstr "variabile non inizializzata nel file di configurazione"
-msgid "loading"
-msgstr "caricamento di"
-
msgid "no message"
msgstr "nessun messaggio"
@@ -330,6 +321,18 @@ msgstr "\\`%end' utilizzata; forse si intendeva \\`%endif'"
msgid "cannot evaluate:"
msgstr "impossibile valutare:"
+msgid "assertion failed:"
+msgstr "asserzione fallita:"
+
+msgid "the specfile has some syntax errors"
+msgstr "lo specfile ha degli errori di sintassi"
+
+msgid "rpm output"
+msgstr "output rpm"
+
+msgid "the error should be here!"
+msgstr "l'errore dovrebbe essere qui!"
+
msgid "Get informations from a given specfile."
msgstr "Ricava informazioni da un specfile dato."
@@ -508,6 +511,12 @@ msgstr "Forza un valore per l'architettura"
msgid "Set change information for the package"
msgstr "Scrive il messaggio indicato nel changelog del pacchetto"
+msgid "Override packager full name"
+msgstr "Sostituisce il nome completo del packager"
+
+msgid "Override packager email"
+msgstr "Ridefinisce l'indirizzo mail del packager"
+
msgid "action"
msgstr "azione"
@@ -571,15 +580,6 @@ msgstr "specfile con fine linea CR"
msgid "specfile with an unsupported format"
msgstr "specfile in formato non supportato"
-msgid "the specfile has some syntax errors"
-msgstr "lo specfile ha degli errori di sintassi"
-
-msgid "rpm output"
-msgstr "output rpm"
-
-msgid "the error should be here!"
-msgstr "l'errore dovrebbe essere qui!"
-
msgid "release number: unsupported format"
msgstr "numero di release: formato non supportato"
@@ -823,6 +823,9 @@ msgstr "Categoria dello specfile da generare"
msgid "standard specfile (default)"
msgstr "specfile standard (default)"
+msgid "specfile for ghc packages"
+msgstr "specfile per pacchetti ghc"
+
msgid "specfile for gnome packages"
msgstr "specfile per pacchetti gnome"
@@ -853,12 +856,6 @@ msgstr "specfile per applicazioni web"
msgid "Redirect the output to the file <outfile>"
msgstr "Redirige lo standard output sul file <outfile>"
-msgid "Override packager full name"
-msgstr "Sostituisce il nome completo del packager"
-
-msgid "Override packager email"
-msgstr "Ridefinisce l'indirizzo mail del packager"
-
msgid "Specify a git branch"
msgstr "Specifica un branch git"
@@ -910,6 +907,9 @@ msgstr "sorgente"
msgid "mode"
msgstr "modo"
+msgid "ghc modules must have this name structure (use \\`-n'):"
+msgstr "i moduli ghc devono avere questa struttura (usare \\`-n'):"
+
msgid "libraries must have this name structure (use \\`-n'):"
msgstr "i nomi delle librerie devono avere questa struttura (usare \\`-n'):"
@@ -953,15 +953,10 @@ msgstr "manca almeno una direttiva \\`%defattr'"
msgid "use rpm macros if possible:"
msgstr "utilizzare le macro rpm quando possibile:"
+
msgid "localization files must be packaged via \\`%find_lang'"
msgstr "trovati file di localizzazione non gestiti da \\`%find_lang'"
-msgid "info pages"
-msgstr "pagine info"
-
-msgid "info pages are not installed/uninstalled in the correct way"
-msgstr "le pagine info non vengono installate/disinstallate correttamente"
-
msgid "package Groups"
msgstr "campi Group dei pacchetti"
@@ -1085,6 +1080,3 @@ msgid "${NOTE}Security checks: ${#rpmpkg_name[@]} package(s) checked: "
"${NORM}${WARN}$total_issues${NORM}${NOTE} warning(s).${NORM}"
msgstr "${NOTE}Controlli di sicurezza: pacchetti rpm: ${#rpmpkg_name[@]}; "
"problemi riscontrati: ${NORM}${WARN}$total_issues${NORM}"
-
-#~ msgid "not an internet address"
-#~ msgstr "non è un indirizzo internet"
--
1.9.3

View File

@ -4,7 +4,7 @@
Name: autospec Name: autospec
Version: 1.16.4 Version: 1.16.4
Release: 1mamba Release: 2mamba
Summary: Create specfiles and automatically update/check/fix rpm packages Summary: Create specfiles and automatically update/check/fix rpm packages
Summary(it): Crea specfile ed aggiorna/controlla/corregge in modo automatico pacchetti rpm Summary(it): Crea specfile ed aggiorna/controlla/corregge in modo automatico pacchetti rpm
Group: Development/Tools Group: Development/Tools
@ -15,6 +15,10 @@ URL: https://sites.google.com/site/davidemadrisan/opensource#TOC-autos
# http://git.openmamba.org/?p=autospec.git;a=summary # http://git.openmamba.org/?p=autospec.git;a=summary
#Source: autospec-%{version}.tar.bz2 #Source: autospec-%{version}.tar.bz2
Source: git://git.openmamba.org/autospec.git/v%{version}/autospec-%{version}.tar.bz2 Source: git://git.openmamba.org/autospec.git/v%{version}/autospec-%{version}.tar.bz2
Patch0: 0001-templates-ghc-new-template-for-ghc-modules.patch
Patch1: 0002-templates-python-remove-unexisting-option-single-ver.patch
Patch2: 0003-pck-update-specify-target_cpu-when-installing-build-.patch
Patch3: 0004-autospec.po-add-missing-italian-translation-strings-.patch
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
Requires(pre): bash Requires(pre): bash
@ -125,6 +129,10 @@ Questo pacchetto contiene alcuni script extra.
%prep %prep
%setup -q %setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%build %build
make prefix=%{_prefix} make prefix=%{_prefix}
@ -175,6 +183,9 @@ make install DESTDIR=%{buildroot} prefix=%{_prefix}
%{_bindir}/autoupdate-* %{_bindir}/autoupdate-*
%changelog %changelog
* Tue May 27 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.16.4-2mamba
- apply patches to sync with current git
* Mon Nov 25 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.16.4-1mamba * Mon Nov 25 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.16.4-1mamba
- update to 1.16.4 - update to 1.16.4