use two other patches to try to fix blocking problem [release 0.9.88-5mamba;Fri Mar 18 2016]
This commit is contained in:
parent
5776a1570f
commit
5594b6901b
15
automoc4-0.9.88-check_cmake_QProcess_start.patch
Normal file
15
automoc4-0.9.88-check_cmake_QProcess_start.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- kde4automoc.cpp~ 2009-01-22 20:50:09.000000000 +0200
|
||||
+++ kde4automoc.cpp 2011-06-21 20:20:56.000000000 +0200
|
||||
@@ -71,7 +71,11 @@
|
||||
QStringList args(cmakeEchoColorArgs);
|
||||
args << msg;
|
||||
cmakeEcho.start(cmakeExecutable, args, QIODevice::NotOpen);
|
||||
- cmakeEcho.waitForFinished(-1);
|
||||
+ if (cmakeEcho.waitForStarted())
|
||||
+ cmakeEcho.waitForFinished(-1);
|
||||
+ else
|
||||
+ cerr << "automoc4: cmake failed to start: "
|
||||
+ << cmakeEcho.errorString() << endl;
|
||||
}
|
||||
|
||||
QString builddir;
|
13
automoc4-0.9.88-pthread-workaround-for-blocking.patch
Normal file
13
automoc4-0.9.88-pthread-workaround-for-blocking.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- CMakeLists.txt.orig Sun Dec 25 15:35:23 2011
|
||||
+++ CMakeLists.txt Sun Dec 25 15:35:40 2011
|
||||
@@ -21,7 +21,9 @@
|
||||
set_target_properties(automoc4 PROPERTIES SKIP_BUILD_RPATH FALSE
|
||||
INSTALL_RPATH_USE_LINK_PATH TRUE )
|
||||
|
||||
-target_link_libraries(automoc4 ${QT_QTCORE_LIBRARY})
|
||||
+find_package(Threads)
|
||||
+target_link_libraries(automoc4 ${QT_QTCORE_LIBRARY} ${CMAKE_THREAD_LIBS_INIT})
|
||||
+
|
||||
|
||||
install(TARGETS automoc4 DESTINATION bin)
|
||||
install(FILES Automoc4Config.cmake Automoc4Version.cmake automoc4.files.in DESTINATION lib${LIB_SUFFIX}/automoc4)
|
@ -1,6 +1,6 @@
|
||||
Name: automoc4
|
||||
Version: 0.9.88
|
||||
Release: 4mamba
|
||||
Release: 5mamba
|
||||
Summary: Automatic moc for Qt 4 packages
|
||||
Group: Development/Tools
|
||||
Vendor: openmamba
|
||||
@ -10,6 +10,8 @@ URL: http://www.kde.org
|
||||
Source: http://download.kde.org/stable/automoc4/%{version}/automoc4-%{version}.tar.bz2
|
||||
Patch0: automoc4-0.9.88-boost-definitions.patch
|
||||
Patch1: automoc4-0.9.88-fix-blocking.patch
|
||||
Patch2: automoc4-0.9.88-check_cmake_QProcess_start.patch
|
||||
Patch3: automoc4-0.9.88-pthread-workaround-for-blocking.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -27,7 +29,9 @@ This package is part of the KDE4, as a component of the kdesupport module.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0
|
||||
%patch1 -p0
|
||||
#%patch1 -p0
|
||||
%patch2 -p0
|
||||
%patch3 -p0
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
@ -46,6 +50,9 @@ This package is part of the KDE4, as a component of the kdesupport module.
|
||||
%{_libdir}/automoc4/
|
||||
|
||||
%changelog
|
||||
* Fri Mar 18 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.88-5mamba
|
||||
- use two other patches to try to fix blocking problem
|
||||
|
||||
* Thu Mar 03 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.88-4mamba
|
||||
- add a patch to fix blocking (https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=163513)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user