automatic version update by autodist [release 1.5.0-1mamba;Wed Dec 07 2016]
This commit is contained in:
parent
37922d6d6f
commit
43e5fbe9b7
@ -1,11 +0,0 @@
|
|||||||
--- augeas-1.2.0/src/augtool.c.orig 2014-07-22 15:53:13.272830984 +0200
|
|
||||||
+++ augeas-1.2.0/src/augtool.c 2014-07-22 15:53:21.541845065 +0200
|
|
||||||
@@ -190,7 +190,7 @@
|
|
||||||
|
|
||||||
#ifndef HAVE_RL_COMPLETION_MATCHES
|
|
||||||
typedef char *rl_compentry_func_t(const char *, int);
|
|
||||||
-static char **rl_completion_matches(ATTRIBUTE_UNUSED const char *text,
|
|
||||||
+char **rl_completion_matches(ATTRIBUTE_UNUSED const char *text,
|
|
||||||
ATTRIBUTE_UNUSED rl_compentry_func_t *func) {
|
|
||||||
return NULL;
|
|
||||||
}
|
|
28
augeas-1.5.0-gcc-6.2.0.patch
Normal file
28
augeas-1.5.0-gcc-6.2.0.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
--- augeas-1.5.0/src/augtool.c.orig 2016-05-04 01:02:57.000000000 +0200
|
||||||
|
+++ augeas-1.5.0/src/augtool.c 2016-12-07 19:26:25.447710899 +0100
|
||||||
|
@@ -197,14 +197,14 @@
|
||||||
|
|
||||||
|
#ifndef HAVE_RL_COMPLETION_MATCHES
|
||||||
|
typedef char *rl_compentry_func_t(const char *, int);
|
||||||
|
-static char **rl_completion_matches(ATTRIBUTE_UNUSED const char *text,
|
||||||
|
+char **rl_completion_matches(ATTRIBUTE_UNUSED const char *text,
|
||||||
|
ATTRIBUTE_UNUSED rl_compentry_func_t *func) {
|
||||||
|
return NULL;
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef HAVE_RL_CRLF
|
||||||
|
-static int rl_crlf(void) {
|
||||||
|
+int rl_crlf(void) {
|
||||||
|
if (rl_outstream != NULL)
|
||||||
|
putc('\n', rl_outstream);
|
||||||
|
return 0;
|
||||||
|
@@ -212,7 +212,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef HAVE_RL_REPLACE_LINE
|
||||||
|
-static void rl_replace_line(ATTRIBUTE_UNUSED const char *text,
|
||||||
|
+void rl_replace_line(ATTRIBUTE_UNUSED const char *text,
|
||||||
|
ATTRIBUTE_UNUSED int clear_undo) {
|
||||||
|
return;
|
||||||
|
}
|
16
augeas.spec
16
augeas.spec
@ -1,5 +1,5 @@
|
|||||||
Name: augeas
|
Name: augeas
|
||||||
Version: 1.4.0
|
Version: 1.5.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A command line tool that focuses on the most basic problem in handling Linux configurations programmatically
|
Summary: A command line tool that focuses on the most basic problem in handling Linux configurations programmatically
|
||||||
Group: System/Management
|
Group: System/Management
|
||||||
@ -8,10 +8,16 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://augeas.net/
|
URL: http://augeas.net/
|
||||||
Source: http://download.augeas.net/augeas-%{version}.tar.gz
|
Source: http://download.augeas.net/augeas-%{version}.tar.gz
|
||||||
Patch0: augeas-1.2.0-readline.patch
|
Patch0: augeas-1.5.0-gcc-6.2.0.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
## note: run 'autospec -u -a6 augeas' to get the list of build requirements.
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: liblzma-devel
|
||||||
|
BuildRequires: libreadline-devel
|
||||||
|
BuildRequires: libselinux-devel
|
||||||
|
BuildRequires: libtermcap-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -92,8 +98,10 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%{_libdir}/pkgconfig/augeas.pc
|
%{_libdir}/pkgconfig/augeas.pc
|
||||||
%doc ChangeLog NEWS README
|
%doc ChangeLog NEWS README
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 07 2016 Automatic Build System <autodist@mambasoft.it> 1.5.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Mon Jun 22 2015 Automatic Build System <autodist@mambasoft.it> 1.4.0-1mamba
|
* Mon Jun 22 2015 Automatic Build System <autodist@mambasoft.it> 1.4.0-1mamba
|
||||||
- automatic update by autodist
|
- automatic update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user