automatic version update by autodist [release 3.0.1-1mamba;Sun Feb 14 2021]
This commit is contained in:
parent
b280eab443
commit
3314d0c77c
@ -1,59 +0,0 @@
|
|||||||
diff -ru audit-2.8.5.orig/init.d/auditd.conf audit-2.8.5/init.d/auditd.conf
|
|
||||||
--- audit-2.8.5.orig/init.d/auditd.conf 2019-03-01 21:19:13.000000000 +0100
|
|
||||||
+++ audit-2.8.5/init.d/auditd.conf 2019-05-27 10:02:17.350769165 +0200
|
|
||||||
@@ -13,7 +13,7 @@
|
|
||||||
num_logs = 5
|
|
||||||
priority_boost = 4
|
|
||||||
disp_qos = lossy
|
|
||||||
-dispatcher = /sbin/audispd
|
|
||||||
+dispatcher = /usr/sbin/audispd
|
|
||||||
name_format = NONE
|
|
||||||
##name = mydomain
|
|
||||||
max_log_file_action = ROTATE
|
|
||||||
diff -ru audit-2.8.5.orig/init.d/auditd.cron audit-2.8.5/init.d/auditd.cron
|
|
||||||
--- audit-2.8.5.orig/init.d/auditd.cron 2019-02-04 15:26:52.000000000 +0100
|
|
||||||
+++ audit-2.8.5/init.d/auditd.cron 2019-05-27 10:02:17.350769165 +0200
|
|
||||||
@@ -5,7 +5,7 @@
|
|
||||||
# based on a cron job.
|
|
||||||
##########
|
|
||||||
|
|
||||||
-/sbin/service auditd rotate
|
|
||||||
+/usr/sbin/service auditd rotate
|
|
||||||
EXITVALUE=$?
|
|
||||||
if [ $EXITVALUE != 0 ]; then
|
|
||||||
/usr/bin/logger -t auditd "ALERT exited abnormally with [$EXITVALUE]"
|
|
||||||
diff -ru audit-2.8.5.orig/init.d/auditd.service audit-2.8.5/init.d/auditd.service
|
|
||||||
--- audit-2.8.5.orig/init.d/auditd.service 2019-03-01 21:19:13.000000000 +0100
|
|
||||||
+++ audit-2.8.5/init.d/auditd.service 2019-05-27 10:02:56.066935836 +0200
|
|
||||||
@@ -18,15 +18,15 @@
|
|
||||||
[Service]
|
|
||||||
Type=forking
|
|
||||||
PIDFile=/run/auditd.pid
|
|
||||||
-ExecStart=/sbin/auditd
|
|
||||||
+ExecStart=/usr/sbin/auditd
|
|
||||||
## To not use augenrules, copy this file to /etc/systemd/system/auditd.service
|
|
||||||
## and comment/delete the next line and uncomment the auditctl line.
|
|
||||||
## NOTE: augenrules expect any rules to be added to /etc/audit/rules.d/
|
|
||||||
-ExecStartPost=-/sbin/augenrules --load
|
|
||||||
-#ExecStartPost=-/sbin/auditctl -R /etc/audit/audit.rules
|
|
||||||
+ExecStartPost=-/usr/sbin/augenrules --load
|
|
||||||
+#ExecStartPost=-/usr/sbin/auditctl -R /etc/audit/audit.rules
|
|
||||||
# By default we don't clear the rules on exit. To enable this, uncomment
|
|
||||||
# the next line after copying the file to /etc/systemd/system/auditd.service
|
|
||||||
-#ExecStopPost=/sbin/auditctl -R /etc/audit/audit-stop.rules
|
|
||||||
+#ExecStopPost=/usr/sbin/auditctl -R /etc/audit/audit-stop.rules
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
WantedBy=multi-user.target
|
|
||||||
diff -ru audit-2.8.5.orig/init.d/augenrules audit-2.8.5/init.d/augenrules
|
|
||||||
--- audit-2.8.5.orig/init.d/augenrules 2019-02-04 15:26:52.000000000 +0100
|
|
||||||
+++ audit-2.8.5/init.d/augenrules 2019-05-27 10:02:17.354769182 +0200
|
|
||||||
@@ -39,7 +39,7 @@
|
|
||||||
|
|
||||||
try_load() {
|
|
||||||
if [ $LoadRules -eq 1 ] ; then
|
|
||||||
- /sbin/auditctl -R ${DestinationFile}
|
|
||||||
+ /usr/sbin/auditctl -R ${DestinationFile}
|
|
||||||
RETVAL=$?
|
|
||||||
fi
|
|
||||||
}
|
|
83
audit-3.0-usrsbin.patch
Normal file
83
audit-3.0-usrsbin.patch
Normal file
@ -0,0 +1,83 @@
|
|||||||
|
diff -ru audit-3.0.orig/init.d/auditd.cron audit-3.0/init.d/auditd.cron
|
||||||
|
--- audit-3.0.orig/init.d/auditd.cron 2020-12-16 21:44:34.000000000 +0100
|
||||||
|
+++ audit-3.0/init.d/auditd.cron 2021-02-13 20:44:43.484919856 +0100
|
||||||
|
@@ -5,7 +5,7 @@
|
||||||
|
# based on a cron job.
|
||||||
|
##########
|
||||||
|
|
||||||
|
-/sbin/service auditd rotate
|
||||||
|
+/usr/sbin/service auditd rotate
|
||||||
|
EXITVALUE=$?
|
||||||
|
if [ $EXITVALUE != 0 ]; then
|
||||||
|
/usr/bin/logger -t auditd "ALERT exited abnormally with [$EXITVALUE]"
|
||||||
|
diff -ru audit-3.0.orig/init.d/auditd.service audit-3.0/init.d/auditd.service
|
||||||
|
--- audit-3.0.orig/init.d/auditd.service 2020-12-16 21:44:34.000000000 +0100
|
||||||
|
+++ audit-3.0/init.d/auditd.service 2021-02-13 20:44:43.484919856 +0100
|
||||||
|
@@ -18,15 +18,15 @@
|
||||||
|
[Service]
|
||||||
|
Type=forking
|
||||||
|
PIDFile=/run/auditd.pid
|
||||||
|
-ExecStart=/sbin/auditd
|
||||||
|
+ExecStart=/usr/sbin/auditd
|
||||||
|
## To not use augenrules, copy this file to /etc/systemd/system/auditd.service
|
||||||
|
## and comment/delete the next line and uncomment the auditctl line.
|
||||||
|
## NOTE: augenrules expect any rules to be added to /etc/audit/rules.d/
|
||||||
|
-ExecStartPost=-/sbin/augenrules --load
|
||||||
|
-#ExecStartPost=-/sbin/auditctl -R /etc/audit/audit.rules
|
||||||
|
+ExecStartPost=-/usr/sbin/augenrules --load
|
||||||
|
+#ExecStartPost=-/usr/sbin/auditctl -R /etc/audit/audit.rules
|
||||||
|
# By default we don't clear the rules on exit. To enable this, uncomment
|
||||||
|
# the next line after copying the file to /etc/systemd/system/auditd.service
|
||||||
|
-#ExecStopPost=/sbin/auditctl -R /etc/audit/audit-stop.rules
|
||||||
|
+#ExecStopPost=/usr/sbin/auditctl -R /etc/audit/audit-stop.rules
|
||||||
|
|
||||||
|
### Security Settings ###
|
||||||
|
MemoryDenyWriteExecute=true
|
||||||
|
diff -ru audit-3.0.orig/init.d/augenrules audit-3.0/init.d/augenrules
|
||||||
|
--- audit-3.0.orig/init.d/augenrules 2020-12-16 21:44:34.000000000 +0100
|
||||||
|
+++ audit-3.0/init.d/augenrules 2021-02-13 20:44:43.485919874 +0100
|
||||||
|
@@ -39,7 +39,7 @@
|
||||||
|
|
||||||
|
try_load() {
|
||||||
|
if [ $LoadRules -eq 1 ] ; then
|
||||||
|
- /sbin/auditctl -R ${DestinationFile}
|
||||||
|
+ /usr/sbin/auditctl -R ${DestinationFile}
|
||||||
|
RETVAL=$?
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
diff -ru audit-3.0.orig/audisp/plugins/remote/au-remote.conf audit-3.0/audisp/plugins/remote/au-remote.conf
|
||||||
|
--- audit-3.0.orig/audisp/plugins/remote/au-remote.conf 2020-12-16 21:44:34.000000000 +0100
|
||||||
|
+++ audit-3.0/audisp/plugins/remote/au-remote.conf 2021-02-13 21:27:18.038655845 +0100
|
||||||
|
@@ -5,7 +5,7 @@
|
||||||
|
|
||||||
|
active = no
|
||||||
|
direction = out
|
||||||
|
-path = /sbin/audisp-remote
|
||||||
|
+path = /usr/sbin/audisp-remote
|
||||||
|
type = always
|
||||||
|
#args =
|
||||||
|
format = string
|
||||||
|
diff -ru audit-3.0.orig/audisp/plugins/syslog/syslog.conf audit-3.0/audisp/plugins/syslog/syslog.conf
|
||||||
|
--- audit-3.0.orig/audisp/plugins/syslog/syslog.conf 2020-12-16 21:44:34.000000000 +0100
|
||||||
|
+++ audit-3.0/audisp/plugins/syslog/syslog.conf 2021-02-13 21:27:06.886482221 +0100
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
|
||||||
|
active = no
|
||||||
|
direction = out
|
||||||
|
-path = /sbin/audisp-syslog
|
||||||
|
+path = /usr/sbin/audisp-syslog
|
||||||
|
type = always
|
||||||
|
args = LOG_INFO
|
||||||
|
format = string
|
||||||
|
diff -ru audit-3.0.orig/audisp/plugins/zos-remote/audispd-zos-remote.conf audit-3.0/audisp/plugins/zos-remote/audispd-zos-remote.conf
|
||||||
|
--- audit-3.0.orig/audisp/plugins/zos-remote/audispd-zos-remote.conf 2020-12-16 21:44:34.000000000 +0100
|
||||||
|
+++ audit-3.0/audisp/plugins/zos-remote/audispd-zos-remote.conf 2021-02-13 21:26:36.495010422 +0100
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
|
||||||
|
active = no
|
||||||
|
direction = out
|
||||||
|
-path = /sbin/audispd-zos-remote
|
||||||
|
+path = /usr/sbin/audispd-zos-remote
|
||||||
|
type = always
|
||||||
|
args = /etc/audisp/zos-remote.conf
|
||||||
|
format = string
|
16
audit.spec
16
audit.spec
@ -1,5 +1,5 @@
|
|||||||
Name: audit
|
Name: audit
|
||||||
Version: 3.0
|
Version: 3.0.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: User space tools for kernel auditing
|
Summary: User space tools for kernel auditing
|
||||||
Group: System/Tools
|
Group: System/Tools
|
||||||
@ -8,7 +8,7 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://people.redhat.com/sgrubb/audit
|
URL: https://people.redhat.com/sgrubb/audit
|
||||||
Source: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
Source: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
||||||
Patch0: audit-2.8.5-usrsbin.patch
|
Patch0: audit-3.0-usrsbin.patch
|
||||||
Patch1: audit-2.8.4-rundir.patch
|
Patch1: audit-2.8.4-rundir.patch
|
||||||
License: GPL, LGPL
|
License: GPL, LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
@ -97,7 +97,7 @@ The libaudit-devel package contains the header files needed for developing appli
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
%patch0 -p1
|
||||||
#%patch1 -p1
|
#%patch1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -142,6 +142,10 @@ make check
|
|||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%post
|
%post
|
||||||
|
if [ $1 -gt 1 ]; then
|
||||||
|
# fix /sbin -> /usr/sbin paths on upgrade
|
||||||
|
sed -i "s|path = /sbin/|path = /usr/sbin/|" %{_sysconfdir}/audit/plugins.d/*.conf
|
||||||
|
fi
|
||||||
%systemd_post auditd
|
%systemd_post auditd
|
||||||
if [ $1 -eq 1 -o -e /etc/rc5.d/S11auditd ]; then
|
if [ $1 -eq 1 -o -e /etc/rc5.d/S11auditd ]; then
|
||||||
systemctl -q daemon-reload
|
systemctl -q daemon-reload
|
||||||
@ -266,6 +270,12 @@ find /etc/rc[0-6].d/ -type l -xtype l -exec rm -f {} \;
|
|||||||
%{python3_sitearch}/auparse.*
|
%{python3_sitearch}/auparse.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Feb 14 2021 Automatic Build System <autodist@mambasoft.it> 3.0.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Feb 13 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0-2mamba
|
||||||
|
- reapply /usr/sbin patch
|
||||||
|
|
||||||
* Tue Feb 09 2021 Automatic Build System <autodist@mambasoft.it> 3.0-1mamba
|
* Tue Feb 09 2021 Automatic Build System <autodist@mambasoft.it> 3.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user