rebuilt by autoport with build requirements: libwx_gtk3u-devel>=0:3.2.0-1mamba [release 3.1.3-4mamba;Mon Aug 22 2022]

This commit is contained in:
Silvan Calarco 2024-01-05 20:38:46 +01:00
parent 6f1ae1ec82
commit d929b5b5e3
4 changed files with 92 additions and 3 deletions

View File

@ -0,0 +1,11 @@
--- audacity-3.1.3/cmake-proxies/CMakeLists.txt.orig 2022-08-22 16:14:05.428328941 +0200
+++ audacity-3.1.3/cmake-proxies/CMakeLists.txt 2022-08-22 16:14:09.587310197 +0200
@@ -103,7 +103,7 @@
libmad
libmad/0.15.2b@audacity/stable
OPTION_NAME libmad
- PKG_CONFIG "mad >= 0.15.0b" # Ubuntu has broken PC file
+ PKG_CONFIG "libmad >= 0.15.0b" # Ubuntu has broken PC file
)
add_conan_lib(

View File

@ -0,0 +1,28 @@
From 342c4b588f2f069a2df2157ac166237a54277b3a Mon Sep 17 00:00:00 2001
From: Ian McInerney <ian.s.mcinerney@ieee.org>
Date: Fri, 8 Apr 2022 01:27:52 +0100
Subject: [PATCH] Call the proper wxBitmap constructor for XPM data
wxBitmap back to at least 3.0.0 did not have a constructor for an XPM
image that took a size parameter, it would only take the XPM data
itself.
I don't know how this compiled until now, but it doesn't anymore when
the size is included and built against wx 3.1.6 in Fedora.
---
src/MixerBoard.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/MixerBoard.cpp b/src/MixerBoard.cpp
index 54b5f146cc7..7fe81615474 100644
--- a/src/MixerBoard.cpp
+++ b/src/MixerBoard.cpp
@@ -1307,7 +1307,7 @@ void MixerBoard::LoadMusicalInstruments()
wxMemoryDC dc;
for (const auto &data : table) {
- auto bmp = std::make_unique<wxBitmap>(data.bitmap,24);
+ auto bmp = std::make_unique<wxBitmap>(data.bitmap);
dc.SelectObject(*bmp);
AColor::Bevel(dc, false, bev);
mMusicalInstruments.push_back(std::make_unique<MusicalInstrument>(

View File

@ -0,0 +1,41 @@
From efc11c4ac50ac51cd71d4dcfa84e63b11000c3f5 Mon Sep 17 00:00:00 2001
From: Ian McInerney <ian.s.mcinerney@ieee.org>
Date: Fri, 8 Apr 2022 01:08:12 +0100
Subject: [PATCH] Remove custom languages in wx 3.1.6 and above
Basque was added as a language with identifier "eu" into wx 3.1.6, so
there is no more need to provide custom languages. Additionally, this
struct changed formatting in 3.1.6, meaning it threw a compile error
when included (so it would have to be fixed if still needed).
---
src/AudacityApp.cpp | 8 +++-----
1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/src/AudacityApp.cpp b/src/AudacityApp.cpp
index d6e2576bf48..e3979249ceb 100644
--- a/src/AudacityApp.cpp
+++ b/src/AudacityApp.cpp
@@ -992,12 +992,10 @@ void AudacityApp::OnTimer(wxTimerEvent& WXUNUSED(event))
#define WL(lang,sublang)
#endif
-#if wxCHECK_VERSION(3, 0, 1)
+#if wxCHECK_VERSION(3, 0, 1) && !wxCHECK_VERSION(3, 1, 6)
wxLanguageInfo userLangs[] =
{
- // Bosnian is defined in wxWidgets already
-// { wxLANGUAGE_USER_DEFINED, wxT("bs"), WL(0, SUBLANG_DEFAULT) wxT("Bosnian"), wxLayout_LeftToRight },
-
+ // Included upstream in version 3.1.6
{ wxLANGUAGE_USER_DEFINED, wxT("eu"), WL(0, SUBLANG_DEFAULT) wxT("Basque"), wxLayout_LeftToRight },
};
#endif
@@ -1332,7 +1330,7 @@ bool AudacityApp::OnInit()
//
// TODO: The whole Language initialization really need to be reworked.
// It's all over the place.
-#if wxCHECK_VERSION(3, 0, 1)
+#if wxCHECK_VERSION(3, 0, 1) && !wxCHECK_VERSION(3, 1, 6)
for (size_t i = 0, cnt = WXSIZEOF(userLangs); i < cnt; i++)
{
wxLocale::AddLanguage(userLangs[i]);

View File

@ -1,6 +1,6 @@
Name: audacity
Version: 3.1.3
Release: 3mamba
Release: 4mamba
Epoch: 1
Summary: A free multitrack audio editor
Group: Graphical Desktop/Applications/Multimedia
@ -21,6 +21,9 @@ Patch4: audacity-2.1.2-ffmpeg-3.0.patch
Patch5: audacity-2.1.2-gcc-6.1.0.patch
Patch6: audacity-2.4.2-x86-sse-build-fix.patch
Patch7: audacity-3.0.2-gcc-11.1.0.patch
Patch8: audacity-3.1.3-libmad-1.6.2.patch
Patch9: audacity-3.1.3-wxWidgets-3.2.0.patch
Patch10: audacity-3.1.3-wxWidgets-3.2.0-2.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -61,9 +64,9 @@ BuildRequires: libwx_baseu-devel
BuildRequires: libwx_gtk3u-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: libwx_gtk3u-devel >= 0:3.2.0-1mamba
BuildRequires: libsoundtouch-devel >= 1.9.2-1mamba
BuildRequires: libwx_baseu-devel >= 3.1.5
BuildRequires: libwx_gtk3u-devel >= 3.1.5
BuildRequires: liblrdf-devel
BuildRequires: libraptor-devel
BuildRequires: librdf-devel
@ -94,6 +97,9 @@ Built-in effects include Bass Boost, Wahwah, and Noise Removal, and it also supp
#%patch6 -p1
#%endif
%patch7 -p1
%patch8 -p1
%patch9 -p1 -b .wxWidgets-3.2.0
%patch10 -p1 -b .wxWidgets-3.2.0-2
## Disable check for wxWidget audacity fork
#sed -i "s|NOT ours|0|" cmake-proxies/wxWidgets/CMakeLists.txt
@ -210,8 +216,11 @@ done
%{_mandir}/man1/*
%changelog
* Mon Aug 22 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.3-4mamba
- rebuilt by autoport with build requirements: libwx_gtk3u-devel>=0:3.2.0-1mamba
* Sat Jun 18 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.3-3mamba
- use pathelf to fix library seatch path of audacity binaries and libraries (see https://github.com/audacity/audacity/issues/2165)
- use pathelf to fix library search path of audacity binaries and libraries (see https://github.com/audacity/audacity/issues/2165)
- don't provide internal libraries
* Tue Jun 14 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.3-2mamba