automatic version update by autodist [release 3.4.0-1mamba;Fri Nov 03 2023]
This commit is contained in:
parent
cf1b31159b
commit
6c0e027695
26
audacity-3.4.0-upstream-fix-aarch64-build.patch
Normal file
26
audacity-3.4.0-upstream-fix-aarch64-build.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 4f165d7afcbb7cb2bb9769b02b460d8a2994afc9 Mon Sep 17 00:00:00 2001
|
||||
From: Dmitry Vedenko <dmitry@crsib.me>
|
||||
Date: Mon, 6 Nov 2023 13:14:20 +0300
|
||||
Subject: [PATCH] Fixes the GCC build when targeting ARM CPUs with NEON support
|
||||
|
||||
---
|
||||
libraries/lib-time-and-pitch/StaffPad/SimdTypes_neon.h | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libraries/lib-time-and-pitch/StaffPad/SimdTypes_neon.h b/libraries/lib-time-and-pitch/StaffPad/SimdTypes_neon.h
|
||||
index 7bc3c3d49533..7bf36aceda57 100644
|
||||
--- a/libraries/lib-time-and-pitch/StaffPad/SimdTypes_neon.h
|
||||
+++ b/libraries/lib-time-and-pitch/StaffPad/SimdTypes_neon.h
|
||||
@@ -44,8 +44,11 @@ struct float_x4
|
||||
s.n128_f32[1] = v1;
|
||||
s.n128_f32[2] = v2;
|
||||
s.n128_f32[3] = v3;
|
||||
-#else
|
||||
+#elif __clang__
|
||||
s = {v0, v1, v2, v3};
|
||||
+#else
|
||||
+ float f[4] = {v0, v1, v2, v3};
|
||||
+ s = vld1q_f32(f);
|
||||
#endif
|
||||
}
|
||||
|
@ -1,5 +1,5 @@
|
||||
Name: audacity
|
||||
Version: 3.3.3
|
||||
Version: 3.4.0
|
||||
Release: 1mamba
|
||||
Epoch: 1
|
||||
Summary: A free multitrack audio editor
|
||||
@ -24,6 +24,7 @@ Patch7: audacity-3.0.2-gcc-11.1.0.patch
|
||||
Patch8: audacity-3.1.3-libmad-1.6.2.patch
|
||||
Patch9: audacity-3.1.3-wxWidgets-3.2.0.patch
|
||||
Patch10: audacity-3.1.3-wxWidgets-3.2.0-2.patch
|
||||
Patch11: audacity-3.4.0-upstream-fix-aarch64-build.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -97,13 +98,8 @@ Built-in effects include Bass Boost, Wahwah, and Noise Removal, and it also supp
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
|
||||
#%ifarch %{ix86}
|
||||
#%patch6 -p1
|
||||
#%endif
|
||||
%patch 7 -p1
|
||||
#%patch8 -p1
|
||||
#%patch9 -p1 -b .wxWidgets-3.2.0
|
||||
#%patch10 -p1 -b .wxWidgets-3.2.0-2
|
||||
%patch 11 -p1 -b .upstream-fix-aarch64-build
|
||||
|
||||
## Disable check for wxWidget audacity fork
|
||||
#sed -i "s|NOT ours|0|" cmake-proxies/wxWidgets/CMakeLists.txt
|
||||
@ -221,6 +217,9 @@ done
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Fri Nov 03 2023 Automatic Build System <autodist@mambasoft.it> 3.4.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Jun 09 2023 Automatic Build System <autodist@mambasoft.it> 3.3.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user