rebuilt with official wxWidgets 3.1.5 [release 3.0.2-2mamba;Sat Jul 10 2021]

This commit is contained in:
Silvan Calarco 2024-01-05 20:38:46 +01:00
parent 06e7d782c9
commit 5fb1cb792d
2 changed files with 41 additions and 38 deletions

View File

@ -0,0 +1,10 @@
--- audacity-3.0.2/include/audacity/Types.h.orig 2021-07-10 17:02:26.434549605 +0200
+++ audacity-3.0.2/include/audacity/Types.h 2021-07-10 17:02:44.820883759 +0200
@@ -46,6 +46,7 @@
#include <functional>
#include <type_traits>
#include <vector>
+#include <limits>
#include <wx/debug.h> // for wxASSERT
#include <wx/string.h> // type used in inline function and member variable

View File

@ -1,13 +1,13 @@
Name: audacity Name: audacity
Version: 3.0.2 Version: 3.0.2
Release: 1mamba Release: 2mamba
Epoch: 1 Epoch: 1
Summary: A free audio editor Summary: A free audio editor
Group: Graphical Desktop/Applications/Multimedia Group: Graphical Desktop/Applications/Multimedia
Vendor: openmamba Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://audacity.sourceforge.net URL: https://www.audacityteam.org/
Source: https://github.com/audacity/audacity.git/Audacity-%{version}/audacity-%{version}.tar.bz2 Source: https://github.com/audacity/audacity.git/Audacity-%{version}/audacity-%{version}.tar.bz2
#Source: http://www.fosshub.com/Audacity.html/audacity-minsrc-%{version}.tar.xz #Source: http://www.fosshub.com/Audacity.html/audacity-minsrc-%{version}.tar.xz
#Source: http://sourceforge.net/projects/audacity/files/audacity-minsrc-%{version}.tar.xz #Source: http://sourceforge.net/projects/audacity/files/audacity-minsrc-%{version}.tar.xz
@ -20,6 +20,7 @@ Patch3: audacity-1.3.12-playback_underrun.patch
Patch4: audacity-2.1.2-ffmpeg-3.0.patch Patch4: audacity-2.1.2-ffmpeg-3.0.patch
Patch5: audacity-2.1.2-gcc-6.1.0.patch Patch5: audacity-2.1.2-gcc-6.1.0.patch
Patch6: audacity-2.4.2-x86-sse-build-fix.patch Patch6: audacity-2.4.2-x86-sse-build-fix.patch
Patch7: audacity-3.0.2-gcc-11.1.0.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
@ -44,7 +45,6 @@ BuildRequires: libsndfile-devel
BuildRequires: libsord-devel BuildRequires: libsord-devel
BuildRequires: libsoundtouch-devel BuildRequires: libsoundtouch-devel
BuildRequires: libsoxr-devel BuildRequires: libsoxr-devel
BuildRequires: libsqlite-devel
BuildRequires: libsratom-devel BuildRequires: libsratom-devel
BuildRequires: libstdc++6-devel BuildRequires: libstdc++6-devel
BuildRequires: libsuil-devel BuildRequires: libsuil-devel
@ -56,8 +56,8 @@ BuildRequires: libwx_gtk3u-devel
BuildRequires: libz-devel BuildRequires: libz-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: libsoundtouch-devel >= 1.9.2-1mamba BuildRequires: libsoundtouch-devel >= 1.9.2-1mamba
BuildRequires: libwx_baseu-devel >= 3.1.3 BuildRequires: libwx_baseu-devel >= 3.1.5
BuildRequires: libwx_gtk3u-devel >= 3.1.3 BuildRequires: libwx_gtk3u-devel >= 3.1.5
BuildRequires: liblrdf-devel BuildRequires: liblrdf-devel
BuildRequires: libraptor-devel BuildRequires: libraptor-devel
BuildRequires: librdf-devel BuildRequires: librdf-devel
@ -77,47 +77,37 @@ Built-in effects include Bass Boost, Wahwah, and Noise Removal, and it also supp
%setup -q %setup -q
#-D -T #-D -T
#:<< _EOF #:<< _EOF
%global __provides_exclude_from ^%{_libdir}/audacity/.*$
#%ifarch %{ix86} #%ifarch %{ix86}
#%patch6 -p1 #%patch6 -p1
#%endif #%endif
%global __provides_exclude_from ^%{_libdir}/audacity/.*$ %patch7 -p1
#cd lib-src/portmixer # Disable check for wxWidget audacity fork
#autoreconf sed -i "s|NOT ours|0|" cmake-proxies/wxWidgets/CMakeLists.txt
#cd ../..
%build %build
#:<< _EOF #:<< _EOF
%cmake -d build \ %cmake -d build \
-DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-unicode-3 -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-unicode-3 \
-Daudacity_use_sqlite=local \
##export WX_CONFIG=/usr/bin/wx-config-unicode -Daudacity_use_sndfile=system \
# -Daudacity_use_soxr=system \
#WX_CONFIG=wx-config-unicode-3 ./configure \ -Daudacity_use_lame=system \
# --with-wx-version=3.1 \ -Daudacity_use_twolame=system \
# --prefix=%{_prefix} \ -Daudacity_use_flac=system \
# --mandir=%{_mandir} \ -Daudacity_use_ladspa=on \
# --with-libsndfile="system" \ -Daudacity_use_vorbis=system \
# --with-ffmpeg="system" \ -Daudacity_use_id3tag=system \
# --with-expat="system" \ -Daudacity_use_expat=system \
# --with-lame="system" \ -Daudacity_use_soundtouch=system \
# --with-libsoxr="system" \ -Daudacity_use_vamp=system \
# --with-portaudio \ -Daudacity_use_lv2=system \
# --with-portmidi \ -Daudacity_use_portaudio=local \
# --with-libflac \ -Daudacity_use_midi=system \
# --with-libid3tag \ -Daudacity_use_ogg=system \
# --with-libsamplerate \ -Daudacity_use_ffmpeg=loaded
# --with-sbsms \
# --with-soundtouch \
# --with-libtwolame \
# --with-libvorbis \
# --with-lv2 \
#%ifnarch %{ix86} x86_64
# --disable-sse \
#%endif
#%ifarch arm
# LDFLAGS="-latomic -lavutil"
#%endif
%make %make
@ -155,6 +145,9 @@ rm -rf %{buildroot}%{_libdir}/audacity*
%{_mandir}/man1/* %{_mandir}/man1/*
%changelog %changelog
* Sat Jul 10 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.2-2mamba
- rebuilt with official wxWidgets 3.1.5
* Tue Apr 20 2021 Automatic Build System <autodist@mambasoft.it> 3.0.2-1mamba * Tue Apr 20 2021 Automatic Build System <autodist@mambasoft.it> 3.0.2-1mamba
- automatic version update by autodist - automatic version update by autodist