automatic version update by autodist [release 2.4.2-1mamba;Sun Jun 28 2020]
This commit is contained in:
parent
fa96b4c517
commit
56076e9853
11
audacity-2.4.2-x86-sse-build-fix.patch
Normal file
11
audacity-2.4.2-x86-sse-build-fix.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- audacity-2.4.2/cmake-proxies/sbsms/CMakeLists.txt.orig 2020-06-30 12:05:59.536705198 +0200
|
||||
+++ audacity-2.4.2/cmake-proxies/sbsms/CMakeLists.txt 2020-06-30 12:06:50.161622716 +0200
|
||||
@@ -28,7 +28,7 @@
|
||||
list( APPEND OPTIONS
|
||||
PRIVATE
|
||||
$<$<C_COMPILER_ID:AppleClang,Clang,GNU>:-Wno-enum-compare>
|
||||
- ${MMX_FLAG}
|
||||
+ ${MMX_FLAG} ${SSE_FLAG}
|
||||
|
||||
# Bug 2488 - Do not define this for SBSMS
|
||||
# ${SSE_FLAG}
|
@ -1,5 +1,5 @@
|
||||
Name: audacity
|
||||
Version: 2.4.1
|
||||
Version: 2.4.2
|
||||
Release: 1mamba
|
||||
Epoch: 1
|
||||
Summary: A free audio editor
|
||||
@ -19,21 +19,20 @@ Patch2: audacity-1.3.12-portmixer.patch
|
||||
Patch3: audacity-1.3.12-playback_underrun.patch
|
||||
Patch4: audacity-2.1.2-ffmpeg-3.0.patch
|
||||
Patch5: audacity-2.1.2-gcc-6.1.0.patch
|
||||
Patch6: audacity-2.4.2-x86-sse-build-fix.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libatomic-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libflac-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libid3tag-devel
|
||||
@ -42,8 +41,6 @@ BuildRequires: liblilv-devel
|
||||
BuildRequires: libmad-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libserd-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libsord-devel
|
||||
@ -53,7 +50,6 @@ BuildRequires: libsratom-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libsuil-devel
|
||||
BuildRequires: libtwolame-devel
|
||||
BuildRequires: libudev-devel
|
||||
BuildRequires: libvamp-plugin-sdk-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libwx_baseu-devel
|
||||
@ -80,57 +76,52 @@ Built-in effects include Bass Boost, Wahwah, and Noise Removal, and it also supp
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n audacity-%{version}
|
||||
%setup -q
|
||||
%ifarch %{ix86}
|
||||
%patch6 -p1
|
||||
%endif
|
||||
|
||||
#cd lib-src/portmixer
|
||||
#autoreconf
|
||||
#cd ../..
|
||||
|
||||
%build
|
||||
#export WX_CONFIG=/usr/bin/wx-config-unicode
|
||||
WX_CONFIG=wx-config-unicode-3 ./configure \
|
||||
--with-wx-version=3.1 \
|
||||
--prefix=%{_prefix} \
|
||||
--mandir=%{_mandir} \
|
||||
--with-libsndfile="system" \
|
||||
--with-ffmpeg="system" \
|
||||
--with-expat="system" \
|
||||
--with-lame="system" \
|
||||
--with-libsoxr="system" \
|
||||
--with-portaudio \
|
||||
--with-portmidi \
|
||||
--with-libflac \
|
||||
--with-libid3tag \
|
||||
--with-libsamplerate \
|
||||
--with-sbsms \
|
||||
--with-soundtouch \
|
||||
--with-libtwolame \
|
||||
--with-libvorbis \
|
||||
--with-lv2 \
|
||||
%ifnarch %{ix86} x86_64
|
||||
--disable-sse \
|
||||
%endif
|
||||
%ifarch arm
|
||||
LDFLAGS="-latomic -lavutil"
|
||||
%endif
|
||||
%cmake -d build \
|
||||
-DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-unicode-3
|
||||
|
||||
# --with-lib-preference="system local" \
|
||||
# --with-ladspa \
|
||||
# --with-portmixer \
|
||||
# --with-portaudio=local \
|
||||
# --with-libsamplerate \
|
||||
# --enable-unicode \
|
||||
|
||||
# --without-ffmpeg \
|
||||
# --without-portmixer \
|
||||
##export WX_CONFIG=/usr/bin/wx-config-unicode
|
||||
#
|
||||
#WX_CONFIG=wx-config-unicode-3 ./configure \
|
||||
# --with-wx-version=3.1 \
|
||||
# --prefix=%{_prefix} \
|
||||
# --mandir=%{_mandir} \
|
||||
# --with-libsndfile="system" \
|
||||
# --with-ffmpeg="system" \
|
||||
# --with-expat="system" \
|
||||
# --with-lame="system" \
|
||||
# --with-libsoxr="system" \
|
||||
# --with-portaudio \
|
||||
# --with-portmidi \
|
||||
# --with-libflac \
|
||||
# --with-libid3tag \
|
||||
# --with-libsamplerate \
|
||||
# --with-sbsms \
|
||||
# --with-soundtouch \
|
||||
# --with-libtwolame \
|
||||
# --with-libvorbis \
|
||||
# --with-lv2 \
|
||||
#%ifnarch %{ix86} x86_64
|
||||
# --disable-sse \
|
||||
#%endif
|
||||
#%ifarch arm
|
||||
# LDFLAGS="-latomic -lavutil"
|
||||
#%endif
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall \
|
||||
INSTALL_PATH=%{buildroot} \
|
||||
PACKAGE=audacity
|
||||
%makeinstall -C build
|
||||
|
||||
#install -D -m 0755 %{SOURCE1} %{buildroot}%{_datadir}/applications/audacity.desktop
|
||||
|
||||
@ -144,13 +135,14 @@ WX_CONFIG=wx-config-unicode-3 ./configure \
|
||||
%{_bindir}/audacity
|
||||
%{_datadir}/appdata/audacity.appdata.xml
|
||||
%{_datadir}/applications/audacity.desktop
|
||||
%dir %{_datadir}/audacity/include
|
||||
%dir %{_datadir}/audacity/include/audacity
|
||||
%{_datadir}/audacity/include/audacity/*.h
|
||||
%{_datadir}/mime/packages/audacity.xml
|
||||
%dir %{_datadir}/audacity/modules
|
||||
%{_datadir}/audacity/modules/mod-*.so
|
||||
%dir %{_datadir}/audacity/plug-ins
|
||||
%{_datadir}/audacity/plug-ins/*.ny
|
||||
%{_datadir}/audacity/nyquist/*
|
||||
%{_datadir}/audacity/EQDefaultCurves.xml
|
||||
%{_datadir}/mime/packages/audacity.xml
|
||||
%{_datadir}/icons/hicolor/*/apps/audacity.png
|
||||
%{_datadir}/icons/hicolor/*/audacity.png
|
||||
%{_datadir}/icons/hicolor/scalable/apps/audacity.svg
|
||||
%{_datadir}/pixmaps/audacity*.xpm
|
||||
%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
|
||||
@ -158,6 +150,9 @@ WX_CONFIG=wx-config-unicode-3 ./configure \
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Sun Jun 28 2020 Automatic Build System <autodist@mambasoft.it> 2.4.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu May 21 2020 Automatic Build System <autodist@mambasoft.it> 2.4.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user