automatic update by autodist [release 11.6.0-1mamba;Sat Dec 14 2013]
This commit is contained in:
parent
8ebe0f7c17
commit
2c67c2085f
@ -1,2 +1,7 @@
|
||||
# asterisk
|
||||
|
||||
Asterisk is an Open Source PBX and telephony development platform that can both replace a conventional PBX and act as a platform for developing custom telephony applications for delivering dynamic content over a telephone similarly to how one can deliver dynamic content through a web browser using CGI and a web server.
|
||||
|
||||
Asterisk talks to a variety of telephony hardware including BRI, PRI, POTS, and IP telephony clients using the Inter-Asterisk eXchange protocol (e.g. gnophone or miniphone).
|
||||
For more information and a current list of supported hardware, see www.asteriskpbx.com.
|
||||
|
||||
|
12
asterisk-1.6.1.1-BOOL_typedef.patch
Normal file
12
asterisk-1.6.1.1-BOOL_typedef.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru asterisk-1.6.1.1.orig/channels/h323/ast_h323.h asterisk-1.6.1.1/channels/h323/ast_h323.h
|
||||
--- asterisk-1.6.1.1.orig/channels/h323/ast_h323.h 2009-03-17 21:52:54.000000000 +0100
|
||||
+++ asterisk-1.6.1.1/channels/h323/ast_h323.h 2009-07-16 16:23:21.000000000 +0200
|
||||
@@ -33,6 +33,8 @@
|
||||
|
||||
#define VERSION(a,b,c) ((a)*10000+(b)*100+(c))
|
||||
|
||||
+typedef PBoolean BOOL;
|
||||
+
|
||||
class MyH323EndPoint : public H323EndPoint
|
||||
{
|
||||
PCLASSINFO(MyH323EndPoint, H323EndPoint);
|
16
asterisk-1.6.1.6-lua.patch
Normal file
16
asterisk-1.6.1.6-lua.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -Nru asterisk-1.6.1.6.orig/pbx/pbx_lua.c asterisk-1.6.1.6/pbx/pbx_lua.c
|
||||
--- asterisk-1.6.1.6.orig/pbx/pbx_lua.c 2008-11-03 00:56:13.000000000 +0100
|
||||
+++ asterisk-1.6.1.6/pbx/pbx_lua.c 2009-10-13 11:18:52.000000000 +0200
|
||||
@@ -42,9 +42,9 @@
|
||||
#include "asterisk/paths.h"
|
||||
#include "asterisk/hashtab.h"
|
||||
|
||||
-#include <lua5.1/lua.h>
|
||||
-#include <lua5.1/lauxlib.h>
|
||||
-#include <lua5.1/lualib.h>
|
||||
+#include <lua.h>
|
||||
+#include <lauxlib.h>
|
||||
+#include <lualib.h>
|
||||
|
||||
static char *config = "extensions.lua";
|
||||
static char *registrar = "pbx_lua";
|
12
asterisk-1.8.0-fix_build.patch
Normal file
12
asterisk-1.8.0-fix_build.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru asterisk-1.8.0.orig//include/asterisk/localtime.h asterisk-1.8.0/include/asterisk/localtime.h
|
||||
--- asterisk-1.8.0.orig//include/asterisk/localtime.h 2010-09-30 19:50:52.000000000 +0200
|
||||
+++ asterisk-1.8.0/include/asterisk/localtime.h 2010-10-29 12:36:50.846052474 +0200
|
||||
@@ -29,7 +29,7 @@
|
||||
#elif defined(HAVE_LOCALE_T_IN_XLOCALE_H)
|
||||
#include <xlocale.h>
|
||||
#else
|
||||
-typedef void * locale_t;
|
||||
+//typedef void * locale_t;
|
||||
#endif
|
||||
|
||||
struct ast_tm {
|
13
asterisk-11.2.1-libpt-2.10.9-1.patch
Normal file
13
asterisk-11.2.1-libpt-2.10.9-1.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: autoconf/ast_check_pwlib.m4
|
||||
===================================================================
|
||||
--- autoconf/ast_check_pwlib.m4 (revision 380027)
|
||||
+++ autoconf/ast_check_pwlib.m4 (working copy)
|
||||
@@ -198,7 +198,7 @@
|
||||
fi
|
||||
|
||||
if test "${HAS_$2:-unset}" != "unset"; then
|
||||
- $2_VERSION=`grep "$VNAME" ${$2_INCDIR}/$3 | sed -e 's/[[[:space:]]]\{1,\}/ /g' | cut -f3 -d ' ' | sed -e 's/"//g'`
|
||||
+ $2_VERSION=`grep "$VNAME \"" ${$2_INCDIR}/$3 | sed -e 's/[[[:space:]]]\{1,\}/ /g' | cut -f3 -d ' ' | sed -e 's/"//g'`
|
||||
$2_MAJOR_VERSION=`echo ${$2_VERSION} | cut -f1 -d.`
|
||||
$2_MINOR_VERSION=`echo ${$2_VERSION} | cut -f2 -d.`
|
||||
$2_BUILD_NUMBER=`echo ${$2_VERSION} | cut -f3 -d.`
|
13
asterisk-11.2.1-libpt-2.10.9.patch
Normal file
13
asterisk-11.2.1-libpt-2.10.9.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: configure
|
||||
===================================================================
|
||||
--- configure (revision 380027)
|
||||
+++ configure (working copy)
|
||||
@@ -25883,7 +25883,7 @@
|
||||
fi
|
||||
|
||||
if test "${HAS_PWLIB:-unset}" != "unset"; then
|
||||
- PWLIB_VERSION=`grep "$VNAME" ${PWLIB_INCDIR}/ptbuildopts.h | sed -e 's/[[:space:]]\{1,\}/ /g' | cut -f3 -d ' ' | sed -e 's/"//g'`
|
||||
+ PWLIB_VERSION=`grep "$VNAME \"" ${PWLIB_INCDIR}/ptbuildopts.h | sed -e 's/[[:space:]]\{1,\}/ /g' | cut -f3 -d ' ' | sed -e 's/"//g'`
|
||||
PWLIB_MAJOR_VERSION=`echo ${PWLIB_VERSION} | cut -f1 -d.`
|
||||
PWLIB_MINOR_VERSION=`echo ${PWLIB_VERSION} | cut -f2 -d.`
|
||||
PWLIB_BUILD_NUMBER=`echo ${PWLIB_VERSION} | cut -f3 -d.`
|
273
asterisk.spec
Normal file
273
asterisk.spec
Normal file
@ -0,0 +1,273 @@
|
||||
Name: asterisk
|
||||
Version: 11.6.0
|
||||
Release: 1mamba
|
||||
Summary: Asterisk PBX
|
||||
Group: System/Telephony
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.asterisk.org
|
||||
Source: http://downloads.digium.com/pub/asterisk/releases/asterisk-%{version}.tar.gz
|
||||
Patch0: %{name}-1.6.1.1-BOOL_typedef.patch
|
||||
Patch1: %{name}-1.6.1.6-lua.patch
|
||||
Patch2: %{name}-1.8.0-fix_build.patch
|
||||
Patch3: asterisk-11.2.1-libpt-2.10.9.patch
|
||||
Patch4: asterisk-11.2.1-libpt-2.10.9-1.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libcap-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libnetsnmp-devel
|
||||
BuildRequires: libnewt-devel
|
||||
BuildRequires: libodbc-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpopt-devel
|
||||
BuildRequires: libportaudio-devel
|
||||
BuildRequires: libpostgresql-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libSDL_image-devel
|
||||
BuildRequires: libspeex-devel
|
||||
BuildRequires: libsqlite2-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtermcap-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: rpm-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libncurses-devel >= 5.4
|
||||
BuildRequires: libopenh323-devel >= 1.17.3
|
||||
BuildRequires: libpt-devel
|
||||
BuildRequires: libmISDN-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
# FIXME: need mpg123 to enable MusicOnHold
|
||||
|
||||
%description
|
||||
Asterisk is an Open Source PBX and telephony development platform that can both replace a conventional PBX and act as a platform for developing custom telephony applications for delivering dynamic content over a telephone similarly to how one can deliver dynamic content through a web browser using CGI and a web server.
|
||||
|
||||
Asterisk talks to a variety of telephony hardware including BRI, PRI, POTS, and IP telephony clients using the Inter-Asterisk eXchange protocol (e.g. gnophone or miniphone).
|
||||
For more information and a current list of supported hardware, see www.asteriskpbx.com.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for the Asterisk software PBX
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}
|
||||
|
||||
%description devel
|
||||
Asterisk is an Open Source PBX and telephony development platform that can both replace a conventional PBX and act as a platform for developing custom telephony applications for delivering dynamic content over a telephone similarly to how one can deliver dynamic content through a web browser using CGI and a web server.
|
||||
|
||||
Asterisk talks to a variety of telephony hardware including BRI, PRI, POTS, and IP telephony clients using the Inter-Asterisk eXchange protocol (e.g. gnophone or miniphone).
|
||||
For more information and a current list of supported hardware, see www.asteriskpbx.com.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
#%patch3 -p0
|
||||
#%patch4 -p0
|
||||
#./bootstrap.sh
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--with-misdn
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
%makeinstall samples
|
||||
##make install INSTALL_PREFIX=%{buildroot}
|
||||
#make samples INSTALL_PREFIX=%{buildroot}
|
||||
# make progdocs INSTALL_PREFIX=%{buildroot}
|
||||
|
||||
install -D -m 755 contrib/init.d/rc.redhat.asterisk %{buildroot}%{_initrddir}/asterisk
|
||||
|
||||
ln -sf /var/spool/asterisk/vm %{buildroot}/var/lib/asterisk/sounds/vm
|
||||
ln -sf /var/spool/asterisk/voicemail %{buildroot}/var/lib/asterisk/sounds/voicemail
|
||||
ln -sf /var/spool/asterisk/voicemail/default %{buildroot}/var/spool/asterisk/vm
|
||||
|
||||
ln -sf libasteriskssl.so.1 %{buildroot}%{_libdir}/libasteriskssl.so
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%postun
|
||||
if [ $1 -eq 1 ]; then
|
||||
#upgrade
|
||||
[ -e /var/lock/subsys/asterisk ] && service asterisk restart
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%preun
|
||||
if [ $1 -eq 0 ]; then
|
||||
#erase
|
||||
service asterisk stop
|
||||
/sbin/chkconfig --del asterisk
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_initrddir}/asterisk
|
||||
%dir %{_sysconfdir}/asterisk
|
||||
%config(noreplace) %{_sysconfdir}/asterisk/*
|
||||
%{_sbindir}/*
|
||||
%{_libdir}/libasteriskssl.so.*
|
||||
%dir %{_libdir}/asterisk/
|
||||
%{_libdir}/asterisk/*
|
||||
%dir %{_localstatedir}/lib/asterisk
|
||||
%{_localstatedir}/lib/asterisk/*
|
||||
%dir %{_localstatedir}/log/asterisk
|
||||
%{_localstatedir}/log/asterisk/*
|
||||
%dir %{_localstatedir}/spool/asterisk
|
||||
%{_localstatedir}/spool/asterisk/*
|
||||
%{_mandir}/man8/asterisk.*
|
||||
%{_mandir}/man8/astgenkey.8.gz
|
||||
%{_mandir}/man8/autosupport.8.gz
|
||||
%{_mandir}/man8/safe_asterisk.8.gz
|
||||
%doc CREDITS LICENSE
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libasteriskssl.so
|
||||
%{_includedir}/asterisk.h
|
||||
%dir %{_includedir}/asterisk
|
||||
%{_includedir}/asterisk/*
|
||||
%doc BUGS ChangeLog README
|
||||
|
||||
%changelog
|
||||
* Sat Dec 14 2013 Automatic Build System <autodist@mambasoft.it> 11.6.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Aug 29 2013 Automatic Build System <autodist@mambasoft.it> 11.5.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jul 22 2013 Automatic Build System <autodist@mambasoft.it> 11.5.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun May 19 2013 Automatic Build System <autodist@mambasoft.it> 11.4.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Apr 01 2013 Automatic Build System <autodist@mambasoft.it> 11.3.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Mar 01 2013 Automatic Build System <autodist@mambasoft.it> 11.2.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Oct 11 2012 Automatic Build System <autodist@mambasoft.it> 10.9.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Aug 11 2012 Automatic Build System <autodist@mambasoft.it> 10.7.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Apr 26 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.11.1-1mamba
|
||||
- update to 1.8.11.1
|
||||
|
||||
* Sun Oct 02 2011 Automatic Build System <autodist@mambasoft.it> 1.8.7.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jul 25 2011 Automatic Build System <autodist@mambasoft.it> 1.8.5.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Jun 24 2011 Automatic Build System <autodist@mambasoft.it> 1.8.4.3-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Jun 19 2011 Automatic Build System <autodist@mambasoft.it> 1.8.4.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri May 20 2011 Automatic Build System <autodist@mambasoft.it> 1.8.4-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Mar 14 2011 Automatic Build System <autodist@mambasoft.it> 1.8.3-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Feb 24 2011 Automatic Build System <autodist@mambasoft.it> 1.8.2.4-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Feb 01 2011 Automatic Build System <autodist@mambasoft.it> 1.8.2.3-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Dec 19 2010 Automatic Build System <autodist@mambasoft.it> 1.8.1.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Dec 15 2010 Automatic Build System <autodist@mambasoft.it> 1.8.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Oct 29 2010 Automatic Build System <autodist@mambasoft.it> 1.8.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Oct 22 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.2.10-2mamba
|
||||
- rebuilt with net-snmp 5.6
|
||||
|
||||
* Sun Aug 08 2010 Automatic Build System <autodist@mambasoft.it> 1.6.2.10-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jun 28 2010 Automatic Build System <autodist@mambasoft.it> 1.6.2.9-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Jun 03 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.2.8-1mamba
|
||||
- update to 1.6.2.8
|
||||
|
||||
* Tue Oct 13 2009 Automatic Build System <autodist@mambasoft.it> 1.6.1.6-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Aug 28 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.1.4-2mamba
|
||||
- rebuilt with mISDN support
|
||||
|
||||
* Tue Aug 11 2009 Automatic Build System <autodist@mambasoft.it> 1.6.1.4-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Aug 04 2009 Automatic Build System <autodist@mambasoft.it> 1.6.1.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Jul 16 2009 Automatic Build System <autodist@mambasoft.it> 1.6.1.1-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Thu Jul 16 2009 Automatic Build System <autodist@mambasoft.it> 1.6.1.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat May 16 2009 Automatic Build System <autodist@mambasoft.it> 1.6.0.8-1mamba
|
||||
- automatic update to 1.6.0.8 by autodist
|
||||
|
||||
* Mon Nov 24 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-1mamba
|
||||
- update to 1.6.0
|
||||
|
||||
* Fri Oct 31 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.22-1mamba
|
||||
- update to 1.4.22
|
||||
|
||||
* Sun May 20 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.4-1mamba
|
||||
- update to 1.4.4
|
||||
|
||||
* Wed Aug 31 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.9-1qilnx
|
||||
- update to version 1.0.9 by autospec
|
||||
- also fix CAN-2005-2081 (fixed in version 1.0.8)
|
||||
|
||||
* Tue Apr 26 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.7-1qilnx
|
||||
- update to version 1.0.7 by autospec
|
||||
|
||||
* Tue Mar 09 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.7.2-1qilnx
|
||||
- new version rebuild
|
||||
|
||||
* Tue Dec 30 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.0-1qilnx
|
||||
- new version rebuild
|
||||
|
||||
* Wed May 07 2003 Silvan Calarco <silvan.calarco@qinet.it> 0.4.0-3qilnx
|
||||
- added fixing code for /etc/asterisk.conf which is installed with
|
||||
$RPM_BUILD_ROOT content
|
||||
|
||||
* Wed May 07 2003 Silvan Calarco <silvan.calarco@qinet.it> 0.4.0-2qilnx
|
||||
- added make samples
|
||||
|
||||
* Mon May 05 2003 Silvan Calarco <silvan.calarco@qinet.it> 0.4.0-1qilnx
|
||||
- creation of asterisk package
|
Loading…
Reference in New Issue
Block a user