package created using the webbuild interface [release 0.9.3-1mamba;Mon Jan 08 2024]
This commit is contained in:
parent
52de7c2c83
commit
9361b6dbb0
24
ascmhl-0.9.3-python-click-8.patch
Normal file
24
ascmhl-0.9.3-python-click-8.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -Nru ascmhl-0.9.3.orig/ascmhl/cli/ascmhl.py ascmhl-0.9.3/ascmhl/cli/ascmhl.py
|
||||
--- ascmhl-0.9.3.orig/ascmhl/cli/ascmhl.py 2022-09-06 12:51:59.000000000 +0200
|
||||
+++ ascmhl-0.9.3/ascmhl/cli/ascmhl.py 2024-01-08 10:28:38.362325370 +0100
|
||||
@@ -27,7 +27,7 @@
|
||||
pass
|
||||
|
||||
|
||||
-@mhltool_cli.resultcallback()
|
||||
+@mhltool_cli.result_callback()
|
||||
def update(*args, **kwargs):
|
||||
updater.join(timeout=1)
|
||||
if updater.needs_update:
|
||||
diff -Nru ascmhl-0.9.3.orig/ascmhl/cli/ascmhl_debug.py ascmhl-0.9.3/ascmhl/cli/ascmhl_debug.py
|
||||
--- ascmhl-0.9.3.orig/ascmhl/cli/ascmhl_debug.py 2022-09-06 12:51:59.000000000 +0200
|
||||
+++ ascmhl-0.9.3/ascmhl/cli/ascmhl_debug.py 2024-01-08 10:28:55.275355859 +0100
|
||||
@@ -27,7 +27,7 @@
|
||||
pass
|
||||
|
||||
|
||||
-@mhldebugtool_cli.resultcallback()
|
||||
+@mhldebugtool_cli.result_callback()
|
||||
def update(*args, **kwargs):
|
||||
updater.join(timeout=1)
|
||||
if updater.needs_update:
|
65
ascmhl.spec
Normal file
65
ascmhl.spec
Normal file
@ -0,0 +1,65 @@
|
||||
%define pkgname %(echo %name | cut -d- -f2- | tr - _)
|
||||
Name: ascmhl
|
||||
Version: 0.9.3
|
||||
Release: 1mamba
|
||||
Summary: ASC Media Hash List (ASC MHL)
|
||||
Group: Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/ascmitc/mhl
|
||||
Source: https://pypi.debian.net/ascmhl/ascmhl-%{version}.tar.gz
|
||||
Patch0: ascmhl-0.9.3-python-click-8.patch
|
||||
License: MIT
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libpython311-devel
|
||||
BuildRequires: python3.11dist(click)
|
||||
BuildRequires: python3.11dist(lxml)
|
||||
BuildRequires: python3.11dist(packaging)
|
||||
BuildRequires: python3.11dist(pathspec)
|
||||
BuildRequires: python3.11dist(python-dateutil)
|
||||
BuildRequires: python3.11dist(requests)
|
||||
BuildRequires: python3.11dist(xxhash)
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: python-pytest-runner-py3
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%if 0%{?with_pyver}
|
||||
%pyver_package
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch 0 -p1
|
||||
sed -i "s|Click.*7|Click>=7|" setup.py requirements.txt ascmhl.egg-info/requires.txt
|
||||
|
||||
%build
|
||||
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
|
||||
|
||||
#%if "%{?with_pyver}" != "3"
|
||||
## Rename any conflicting file outside of python site packages tree
|
||||
#for f in %{_bindir}/pdm; do
|
||||
# mv %{buildroot}${f}{,-%{?pyappend}}
|
||||
#done
|
||||
#%endif
|
||||
|
||||
rm -rf %{buildroot}%{python_sitelib}/tests
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/ascmhl
|
||||
%{_bindir}/ascmhl-debug
|
||||
%dir %{python_sitelib}/%{pkgname}-%{version}.dist-info
|
||||
%{python_sitelib}/%{pkgname}-%{version}.dist-info/*
|
||||
%dir %{python_sitelib}/%{pkgname}
|
||||
%{python_sitelib}/%{pkgname}/*
|
||||
|
||||
%changelog
|
||||
* Mon Jan 08 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.3-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user