added patch to build with current gcc
call libtoolize --install to recreate a config.sub which is x86_64 compatible [release 3.10.22-3mamba;Wed Aug 22 2012]
This commit is contained in:
parent
ee06a77915
commit
05fc15a838
@ -1,2 +1,4 @@
|
||||
# arj
|
||||
|
||||
The arj program is an open source clone of the ARJ archiver for DOS and Windows. It can be used to create and extract archives and uses the save format as the proprietary version.
|
||||
|
||||
|
11
arj-3.10.22-postproc.patch
Normal file
11
arj-3.10.22-postproc.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- arj-3.10.22/postproc.c 2003-06-22 13:12:28.000000000 +0200
|
||||
+++ arj-3.10.22/postproc.c 2006-01-27 16:57:14.000000000 +0100
|
||||
@@ -71,7 +71,7 @@
|
||||
if((bytes_read=fread(buf, 1, PROC_BLOCK_SIZE, stream))==0)
|
||||
{
|
||||
printf("Patch not found\n");
|
||||
- return(POSTPROC_ERL_BAD_EXE);
|
||||
+ break; /* return(POSTPROC_ERL_BAD_EXE); */
|
||||
}
|
||||
bytes_read-=rp_len;
|
||||
pb_ptr=buf;
|
20
arj-3.10.22-strnlen.patch
Normal file
20
arj-3.10.22-strnlen.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- arj-3.10.22/fardata.c.org 2009-08-20 10:28:36.000000000 +0000
|
||||
+++ arj-3.10.22/fardata.c 2009-08-20 10:28:53.000000000 +0000
|
||||
@@ -190,7 +190,7 @@
|
||||
|
||||
/* Length-limited strlen() */
|
||||
|
||||
-static int strnlen(const char FAR *s, int count)
|
||||
+static int strnlen_arj(const char FAR *s, int count)
|
||||
{
|
||||
const char FAR *sc;
|
||||
|
||||
@@ -569,7 +569,7 @@
|
||||
if(!s)
|
||||
s="(null)";
|
||||
#endif
|
||||
- len=strnlen(s, precision);
|
||||
+ len=strnlen_arj(s, precision);
|
||||
if(!(flags&LEFT))
|
||||
{
|
||||
while(len<field_width--)
|
60
arj.spec
Normal file
60
arj.spec
Normal file
@ -0,0 +1,60 @@
|
||||
Name: arj
|
||||
Version: 3.10.22
|
||||
Release: 3mamba
|
||||
Summary: An open source and portable version of the ARJ archiver
|
||||
Group: Applications/Archiving
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://arj.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/sourceforge/%{name}/%{name}-%{version}.tar.gz
|
||||
Patch: %{name}-3.10.22-postproc.patch
|
||||
Patch1: %{name}-3.10.22-strnlen.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The arj program is an open source clone of the ARJ archiver for DOS and Windows. It can be used to create and extract archives and uses the save format as the proprietary version.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
pushd gnu
|
||||
libtoolize --force --install
|
||||
autoconf
|
||||
%configure
|
||||
popd
|
||||
|
||||
%make -j1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/*
|
||||
%{_libdir}/%{name}/arjcrypt.so
|
||||
%{_mandir}/man1/*
|
||||
%doc doc/COPYING
|
||||
#% doc ChangeLog doc
|
||||
|
||||
%changelog
|
||||
* Wed Aug 22 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.10.22-3mamba
|
||||
- added patch to build with current gcc
|
||||
- call libtoolize --install to recreate a config.sub which is x86_64 compatible
|
||||
|
||||
* Wed Mar 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.10.22-2mamba
|
||||
- specfile updates
|
||||
|
||||
* Fri Jan 27 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 3.10.22-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user