legacy package [release 0.16.4-2mamba;Sun Dec 24 2023]

This commit is contained in:
Silvan Calarco 2024-01-05 20:31:01 +01:00
parent 2544ac6a99
commit 0fbdc84bee
3 changed files with 290 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# appstream0
Tools and libraries to work with AppStream metadata.

View File

@ -0,0 +1,63 @@
From 306eb287a36a2779c304fe47b5473e468c7bd0f6 Mon Sep 17 00:00:00 2001
From: Matthias Klumpp <matthias@tenstral.net>
Date: Fri, 5 Feb 2021 02:51:08 +0100
Subject: [PATCH] Do not automatically clean up errors that will be propagated
---
compose/asc-image.c | 2 +-
src/as-metadata.c | 8 ++++----
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/compose/asc-image.c b/compose/asc-image.c
index 1db354b1..a886c06f 100644
--- a/compose/asc-image.c
+++ b/compose/asc-image.c
@@ -207,7 +207,7 @@ asc_optimize_png (const gchar *fname, GError **error)
g_autofree gchar *opng_stdout = NULL;
g_autofree gchar *opng_stderr = NULL;
g_autofree const gchar **argv = NULL;
- g_autoptr(GError) tmp_error = NULL;
+ GError *tmp_error = NULL;
if (!asc_globals_get_use_optipng ())
return TRUE;
diff --git a/src/as-metadata.c b/src/as-metadata.c
index 9e8848d9..b6c28d26 100644
--- a/src/as-metadata.c
+++ b/src/as-metadata.c
@@ -646,7 +646,7 @@ as_metadata_parse_file (AsMetadata *metad, GFile *file, AsFormatKind format, GEr
g_autoptr(GInputStream) stream_data = NULL;
g_autoptr(GConverter) conv = NULL;
g_autoptr(GString) asdata = NULL;
- g_autoptr(GError) tmp_error = NULL;
+ GError *tmp_error = NULL;
gssize len;
const gsize buffer_size = 1024 * 32;
g_autofree gchar *buffer = NULL;
@@ -701,7 +701,7 @@ as_metadata_parse_file (AsMetadata *metad, GFile *file, AsFormatKind format, GEr
asdata = g_string_new ("");
buffer = g_malloc (buffer_size);
- while ((len = g_input_stream_read (stream_data, buffer, buffer_size, NULL, error)) > 0) {
+ while ((len = g_input_stream_read (stream_data, buffer, buffer_size, NULL, &tmp_error)) > 0) {
g_string_append_len (asdata, buffer, len);
}
/* check if there was an error */
@@ -834,7 +834,7 @@ gboolean
as_metadata_save_metainfo (AsMetadata *metad, const gchar *fname, AsFormatKind format, GError **error)
{
g_autofree gchar *xml_data = NULL;
- g_autoptr(GError) tmp_error = NULL;
+ GError *tmp_error = NULL;
xml_data = as_metadata_component_to_metainfo (metad, format, &tmp_error);
if (tmp_error != NULL) {
@@ -859,7 +859,7 @@ gboolean
as_metadata_save_collection (AsMetadata *metad, const gchar *fname, AsFormatKind format, GError **error)
{
g_autofree gchar *data = NULL;
- g_autoptr(GError) tmp_error = NULL;
+ GError *tmp_error = NULL;
data = as_metadata_components_to_collection (metad, format, &tmp_error);
if (tmp_error != NULL) {

225
appstream0.spec Normal file
View File

@ -0,0 +1,225 @@
Name: appstream0
Version: 0.16.4
Release: 2mamba
Summary: Tools and libraries to work with AppStream metadata
Group: System/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://www.freedesktop.org/wiki/Distributions/AppStream/
Source: https://www.freedesktop.org/software/appstream/releases/AppStream-%{version}.tar.xz
Patch0: appstream-0.14.0-upstream-Do_not_automatically_clean_up_errors_that_will_be_propagated.patch
License: GPL, LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libcurl-devel
BuildRequires: libgcc
BuildRequires: libglib-devel
BuildRequires: libstdc++6-devel
BuildRequires: libstemmer-devel
BuildRequires: libsystemd-devel
BuildRequires: libxml2-devel
BuildRequires: libxmlb-devel
BuildRequires: libyaml-devel
BuildRequires: qt5-qtbase-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description
Tools and libraries to work with AppStream metadata.
%package -n lib%{name}
Group: System/Libraries
Summary: Shared libraries for %{name}
Requires: appstream
%description -n lib%{name}
This package contains shared libraries for %{name}.
%package -n lib%{name}-devel
Group: Development/Libraries
Summary: Development files for %{name}
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: pkg-config
%description -n lib%{name}-devel
This package contains libraries and header files for developing applications that use %{name}.
%package -n lib%{name}-qt
Group: System/Libraries
Summary: Qt shared libraries for %{name}
%description -n lib%{name}-qt
This package contains shared libraries for %{name}.
%package -n lib%{name}-qt-devel
Group: Development/Libraries
Summary: Development files for %{name}
Requires: lib%{name}-qt = %{?epoch:%epoch:}%{version}-%{release}
Requires: pkg-config
%description -n lib%{name}-qt-devel
This package contains libraries and header files for developing applications that use %{name}.
%debug_package
%prep
%setup -q -n AppStream-%{version}
%build
%meson \
-Dcompose=false \
-Dqt=true \
-Dgir=false \
-Dvapi=false
%meson_build
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
export DESTDIR=%{buildroot}
%meson_install
# Conflicting/provided by appstream >= 1.0
rm -rf %{buildroot}{%{_bindir},%{_libexecdir},%{_datadir}/metainfo,%{_mandir},%{_datadir},%{_sysconfdir},/var}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/libappstream.so.*
%doc AUTHORS
%files -n lib%{name}-devel
%defattr(-,root,root)
%dir %{_includedir}/appstream
%{_includedir}/appstream/*
%{_libdir}/libappstream.so
%{_libdir}/pkgconfig/appstream.pc
%doc NEWS README.md
%files -n lib%{name}-qt
%defattr(-,root,root)
%{_libdir}/libAppStreamQt.so.*
%files -n lib%{name}-qt-devel
%defattr(-,root,root)
%dir %{_includedir}/AppStreamQt
%{_includedir}/AppStreamQt/*.h
%dir %{_libdir}/cmake/AppStreamQt
%{_libdir}/cmake/AppStreamQt/AppStreamQt*.cmake
%{_libdir}/libAppStreamQt.so
%changelog
* Sun Dec 24 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.16.4-2mamba
- legacy package
* Sat Nov 11 2023 Automatic Build System <autodist@mambasoft.it> 0.16.4-1mamba
- automatic version update by autodist
* Wed Aug 23 2023 Automatic Build System <autodist@mambasoft.it> 0.16.3-1mamba
- automatic version update by autodist
* Thu Apr 27 2023 Automatic Build System <autodist@mambasoft.it> 0.16.2-1mamba
- automatic version update by autodist
* Sat Feb 11 2023 Automatic Build System <autodist@mambasoft.it> 0.16.1-1mamba
- automatic version update by autodist
* Fri Jan 27 2023 Automatic Build System <autodist@mambasoft.it> 0.16.0-1mamba
- automatic version update by autodist
* Fri Dec 23 2022 Automatic Build System <autodist@mambasoft.it> 0.15.6-1mamba
- automatic version update by autodist
* Tue Aug 23 2022 Automatic Build System <autodist@mambasoft.it> 0.15.5-1mamba
- automatic version update by autodist
* Mon May 23 2022 Automatic Build System <autodist@mambasoft.it> 0.15.4-1mamba
- automatic version update by autodist
* Mon Apr 11 2022 Automatic Build System <autodist@mambasoft.it> 0.15.3-1mamba
- automatic version update by autodist
* Sat Feb 26 2022 Automatic Build System <autodist@mambasoft.it> 0.15.2-1mamba
- automatic version update by autodist
* Wed Dec 22 2021 Automatic Build System <autodist@mambasoft.it> 0.15.1-1mamba
- automatic version update by autodist
* Fri Dec 03 2021 Automatic Build System <autodist@mambasoft.it> 0.15.0-1mamba
- automatic version update by autodist
* Wed Oct 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.14.6-2mamba
- enable appstream-compose build
* Sun Oct 10 2021 Automatic Build System <autodist@mambasoft.it> 0.14.6-1mamba
- automatic version update by autodist
* Tue Aug 31 2021 Automatic Build System <autodist@mambasoft.it> 0.14.5-1mamba
- automatic version update by autodist
* Wed Jun 23 2021 Automatic Build System <autodist@mambasoft.it> 0.14.4-1mamba
- automatic version update by autodist
* Mon Mar 08 2021 Automatic Build System <autodist@mambasoft.it> 0.14.3-1mamba
- automatic version update by autodist
* Sun Mar 07 2021 Automatic Build System <autodist@mambasoft.it> 0.14.2-1mamba
- automatic version update by autodist
* Thu Feb 18 2021 Automatic Build System <autodist@mambasoft.it> 0.14.1-1mamba
- automatic version update by autodist
* Wed Feb 10 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.14.0-2mamba
- added upstream patch to fix crash on applications that use this library (e.g. discover)
* Tue Feb 02 2021 Automatic Build System <autodist@mambasoft.it> 0.14.0-1mamba
- automatic version update by autodist
* Tue Dec 01 2020 Automatic Build System <autodist@mambasoft.it> 0.13.1-1mamba
- automatic version update by autodist
* Tue May 12 2020 Automatic Build System <autodist@mambasoft.it> 0.12.11-1mamba
- automatic version update by autodist
* Sun Jan 19 2020 Automatic Build System <autodist@mambasoft.it> 0.12.10-1mamba
- automatic version update by autodist
* Wed Sep 25 2019 Automatic Build System <autodist@mambasoft.it> 0.12.9-1mamba
- automatic version update by autodist
* Wed Aug 28 2019 Automatic Build System <autodist@mambasoft.it> 0.12.8-1mamba
- automatic version update by autodist
* Mon Jul 08 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.12.7-1mamba
- update to 0.12.7
* Sat Mar 02 2019 Automatic Build System <autodist@mambasoft.it> 0.12.6-1mamba
- automatic version update by autodist
* Mon Jan 28 2019 Automatic Build System <autodist@mambasoft.it> 0.12.5-1mamba
- automatic version update by autodist
* Mon Dec 24 2018 Automatic Build System <autodist@mambasoft.it> 0.12.4-1mamba
- automatic version update by autodist
* Mon Oct 22 2018 Automatic Build System <autodist@mambasoft.it> 0.12.3-1mamba
- automatic version update by autodist
* Thu Aug 23 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 0.12.2-2mamba
- rebuilt with qt support
* Sat Aug 18 2018 Automatic Build System <autodist@mambasoft.it> 0.12.2-1mamba
- automatic version update by autodist
* Sun Aug 12 2018 Automatic Build System <autodist@mambasoft.it> 0.12.1-1mamba
- automatic version update by autodist
* Mon Aug 14 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 0.11.3-1mamba
- package created using the webbuild interface