250 lines
8.2 KiB
RPMSpec
250 lines
8.2 KiB
RPMSpec
Name: appstream
|
|
Version: 0.16.0
|
|
Release: 1mamba
|
|
Summary: Tools and libraries to work with AppStream metadata
|
|
Group: System/Tools
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.freedesktop.org/wiki/Distributions/AppStream/
|
|
Source: https://www.freedesktop.org/software/appstream/releases/AppStream-%{version}.tar.xz
|
|
Patch0: appstream-0.14.0-upstream-Do_not_automatically_clean_up_errors_that_will_be_propagated.patch
|
|
License: GPL, LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libcairo-devel
|
|
BuildRequires: libcurl-devel
|
|
BuildRequires: libfontconfig-devel
|
|
BuildRequires: libfreetype-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libgdk-pixbuf-devel
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libpango-devel
|
|
BuildRequires: librsvg-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libstemmer-devel
|
|
BuildRequires: libsystemd-devel
|
|
BuildRequires: libxml2-devel
|
|
BuildRequires: libxmlb-devel
|
|
BuildRequires: libyaml-devel
|
|
BuildRequires: qt5-qtbase-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description
|
|
Tools and libraries to work with AppStream metadata.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Shared libraries for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n lib%{name}
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: pkg-config
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%package -n lib%{name}-qt
|
|
Group: System/Libraries
|
|
Summary: Qt shared libraries for %{name}
|
|
|
|
%description -n lib%{name}-qt
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-qt-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name}-qt = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: pkg-config
|
|
|
|
%description -n lib%{name}-qt-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n AppStream-%{version}
|
|
|
|
%build
|
|
%meson \
|
|
-Dqt=true \
|
|
-Dstemming=true \
|
|
-Dcompose=true
|
|
|
|
%meson_build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
export DESTDIR=%{buildroot}
|
|
%meson_install
|
|
|
|
%find_lang %{name} || touch %{name}.lang
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name} -p /sbin/ldconfig
|
|
%postun -n lib%{name} -p /sbin/ldconfig
|
|
|
|
%posttrans
|
|
%{_bindir}/appstreamcli refresh --force >& /dev/null ||:
|
|
|
|
%transfiletriggerin -- %{_datadir}/app-info/xmls
|
|
%{_bindir}/appstreamcli refresh --force >& /dev/null ||:
|
|
|
|
%transfiletriggerpostun -- %{_datadir}/app-info/xmls
|
|
%{_bindir}/appstreamcli refresh >& /dev/null ||:
|
|
|
|
%files -f %{name}.lang
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/appstream.conf
|
|
%{_bindir}/appstreamcli
|
|
%{_datadir}/gettext/its/metainfo.its
|
|
%{_datadir}/gettext/its/metainfo.loc
|
|
%{_datadir}/installed-tests/appstream/metainfo-validate.test
|
|
%{_datadir}/metainfo/org.freedesktop.appstream.cli.metainfo.xml
|
|
%{_datadir}/metainfo/org.freedesktop.appstream.compose.metainfo.xml
|
|
%{_mandir}/man1/appstreamcli.1*
|
|
%{_mandir}/man1/appstreamcli-compose.1*
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libappstream.so.*
|
|
%{_libdir}/libappstream-compose.so.*
|
|
%{_libexecdir}/appstreamcli-compose
|
|
%{_libdir}/girepository-1.0/AppStream-1.0.typelib
|
|
%{_libdir}/girepository-1.0/AppStreamCompose-1.0.typelib
|
|
%doc AUTHORS
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/appstream
|
|
%{_includedir}/appstream/*
|
|
%dir %{_includedir}/appstream-compose
|
|
%{_includedir}/appstream-compose/*
|
|
%{_libdir}/libappstream.so
|
|
%{_libdir}/libappstream-compose.so
|
|
%{_datadir}/gir-1.0/AppStreamCompose-1.0.gir
|
|
%{_datadir}/gir-1.0/AppStream-1.0.gir
|
|
%{_libdir}/pkgconfig/appstream.pc
|
|
%{_libdir}/pkgconfig/appstream-compose.pc
|
|
%{_datadir}/gtk-doc/html/appstream
|
|
%{_datadir}/gtk-doc/html/appstream-compose
|
|
%dir %{_datadir}/doc/appstream
|
|
%{_datadir}/doc/appstream/*
|
|
%doc NEWS README.md
|
|
|
|
%files -n lib%{name}-qt
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libAppStreamQt.so.*
|
|
|
|
%files -n lib%{name}-qt-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/AppStreamQt
|
|
%{_includedir}/AppStreamQt/*.h
|
|
%dir %{_libdir}/cmake/AppStreamQt
|
|
%{_libdir}/cmake/AppStreamQt/AppStreamQt*.cmake
|
|
%{_libdir}/libAppStreamQt.so
|
|
|
|
%changelog
|
|
* Fri Jan 27 2023 Automatic Build System <autodist@mambasoft.it> 0.16.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Dec 23 2022 Automatic Build System <autodist@mambasoft.it> 0.15.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 23 2022 Automatic Build System <autodist@mambasoft.it> 0.15.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon May 23 2022 Automatic Build System <autodist@mambasoft.it> 0.15.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Apr 11 2022 Automatic Build System <autodist@mambasoft.it> 0.15.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Feb 26 2022 Automatic Build System <autodist@mambasoft.it> 0.15.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Dec 22 2021 Automatic Build System <autodist@mambasoft.it> 0.15.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Dec 03 2021 Automatic Build System <autodist@mambasoft.it> 0.15.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Oct 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.14.6-2mamba
|
|
- enable appstream-compose build
|
|
|
|
* Sun Oct 10 2021 Automatic Build System <autodist@mambasoft.it> 0.14.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 31 2021 Automatic Build System <autodist@mambasoft.it> 0.14.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 23 2021 Automatic Build System <autodist@mambasoft.it> 0.14.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Mar 08 2021 Automatic Build System <autodist@mambasoft.it> 0.14.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 07 2021 Automatic Build System <autodist@mambasoft.it> 0.14.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Feb 18 2021 Automatic Build System <autodist@mambasoft.it> 0.14.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Feb 10 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.14.0-2mamba
|
|
- added upstream patch to fix crash on applications that use this library (e.g. discover)
|
|
|
|
* Tue Feb 02 2021 Automatic Build System <autodist@mambasoft.it> 0.14.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Dec 01 2020 Automatic Build System <autodist@mambasoft.it> 0.13.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 12 2020 Automatic Build System <autodist@mambasoft.it> 0.12.11-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 19 2020 Automatic Build System <autodist@mambasoft.it> 0.12.10-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Sep 25 2019 Automatic Build System <autodist@mambasoft.it> 0.12.9-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 28 2019 Automatic Build System <autodist@mambasoft.it> 0.12.8-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jul 08 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.12.7-1mamba
|
|
- update to 0.12.7
|
|
|
|
* Sat Mar 02 2019 Automatic Build System <autodist@mambasoft.it> 0.12.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 28 2019 Automatic Build System <autodist@mambasoft.it> 0.12.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 24 2018 Automatic Build System <autodist@mambasoft.it> 0.12.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 22 2018 Automatic Build System <autodist@mambasoft.it> 0.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 23 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 0.12.2-2mamba
|
|
- rebuilt with qt support
|
|
|
|
* Sat Aug 18 2018 Automatic Build System <autodist@mambasoft.it> 0.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 12 2018 Automatic Build System <autodist@mambasoft.it> 0.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Aug 14 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 0.11.3-1mamba
|
|
- package created using the webbuild interface
|