155 lines
4.3 KiB
RPMSpec
155 lines
4.3 KiB
RPMSpec
Name: appstream
|
|
Version: 0.12.6
|
|
Release: 1mamba
|
|
Summary: Tools and libraries to work with AppStream metadata
|
|
Group: System/Tools
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.freedesktop.org/wiki/Distributions/AppStream/
|
|
Source: https://www.freedesktop.org/software/appstream/releases/AppStream-%{version}.tar.xz
|
|
License: GPL, LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libqt5-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libstemmer-devel
|
|
BuildRequires: libxml2-devel
|
|
BuildRequires: libyaml-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
Tools and libraries to work with AppStream metadata.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Shared libraries for %{name}
|
|
|
|
%description -n lib%{name}
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: pkg-config
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%package -n lib%{name}-qt
|
|
Group: System/Libraries
|
|
Summary: Qt shared libraries for %{name}
|
|
|
|
%description -n lib%{name}-qt
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-qt-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name}-qt = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: pkg-config
|
|
|
|
%description -n lib%{name}-qt-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n AppStream-%{version}
|
|
|
|
%build
|
|
%meson \
|
|
-Dqt=true
|
|
|
|
#mkdir build
|
|
|
|
#cd build
|
|
#meson --prefix=%{_prefix} --libdir=%{_libdir} ..
|
|
|
|
#ninja
|
|
|
|
%meson_build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
export DESTDIR=%{buildroot}
|
|
%meson_install
|
|
|
|
%find_lang %{name} || touch %{name}.lang
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name} -p /sbin/ldconfig
|
|
%postun -n lib%{name} -p /sbin/ldconfig
|
|
|
|
%files -f %{name}.lang
|
|
%defattr(-,root,root)
|
|
%{_bindir}/appstreamcli
|
|
%{_mandir}/man1/appstreamcli.1*
|
|
%doc AUTHORS
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libappstream.so.*
|
|
%{_libdir}/girepository-1.0/AppStream-1.0.typelib
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/appstream.conf
|
|
%dir %{_includedir}/appstream
|
|
%{_includedir}/appstream/*
|
|
%{_libdir}/libappstream.so
|
|
%{_libdir}/pkgconfig/appstream.pc
|
|
%{_datadir}/gettext/its/metainfo.its
|
|
%{_datadir}/gettext/its/metainfo.loc
|
|
%{_datadir}/gir-1.0/AppStream-1.0.gir
|
|
%{_datadir}/gtk-doc/html/appstream
|
|
%{_datadir}/metainfo/org.freedesktop.appstream.cli.metainfo.xml
|
|
%dir %{_datadir}/doc/appstream
|
|
%{_datadir}/doc/appstream/*
|
|
%doc NEWS README.md
|
|
|
|
%files -n lib%{name}-qt
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libAppStreamQt.so.*
|
|
|
|
%files -n lib%{name}-qt-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/AppStreamQt
|
|
%{_includedir}/AppStreamQt/*.h
|
|
%dir %{_libdir}/cmake/AppStreamQt
|
|
%{_libdir}/cmake/AppStreamQt/AppStreamQt*.cmake
|
|
%{_libdir}/libAppStreamQt.so
|
|
|
|
%changelog
|
|
* Sat Mar 02 2019 Automatic Build System <autodist@mambasoft.it> 0.12.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 28 2019 Automatic Build System <autodist@mambasoft.it> 0.12.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 24 2018 Automatic Build System <autodist@mambasoft.it> 0.12.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 22 2018 Automatic Build System <autodist@mambasoft.it> 0.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 23 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 0.12.2-2mamba
|
|
- rebuilt with qt support
|
|
|
|
* Sat Aug 18 2018 Automatic Build System <autodist@mambasoft.it> 0.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 12 2018 Automatic Build System <autodist@mambasoft.it> 0.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Aug 14 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 0.11.3-1mamba
|
|
- package created using the webbuild interface
|