46 lines
1.5 KiB
Diff
46 lines
1.5 KiB
Diff
diff --git a/src/asgen/backends/rpmmd/rpmpkgindex.d b/src/asgen/backends/rpmmd/rpmpkgindex.d
|
|
index f336919..733e8f1 100644
|
|
--- a/src/asgen/backends/rpmmd/rpmpkgindex.d
|
|
+++ b/src/asgen/backends/rpmmd/rpmpkgindex.d
|
|
@@ -25,7 +25,7 @@ import std.array : appender, empty;
|
|
import std.string : format;
|
|
import std.algorithm : canFind, endsWith;
|
|
import std.conv : to;
|
|
-import std.xml;
|
|
+import undead.xml;
|
|
static import std.file;
|
|
|
|
import asgen.logging;
|
|
diff --git a/src/asgen/meson.build b/src/asgen/meson.build
|
|
index be49dba..d8a5b46 100644
|
|
--- a/src/asgen/meson.build
|
|
+++ b/src/asgen/meson.build
|
|
@@ -64,6 +64,7 @@ backend_sources = [
|
|
'backends/ubuntu/ubupkg.d',
|
|
'backends/ubuntu/ubupkgindex.d',
|
|
|
|
+ '../../undeaD-1.1.8/src/undead/xml.d',
|
|
'backends/rpmmd/package.d',
|
|
'backends/rpmmd/rpmpkg.d',
|
|
'backends/rpmmd/rpmpkgindex.d',
|
|
@@ -76,7 +77,8 @@ asgen_exe = executable('appstream-generator',
|
|
[asgen_sources,
|
|
backend_sources],
|
|
include_directories: [src_dir,
|
|
- gir_bind_dir],
|
|
+ gir_bind_dir,
|
|
+ '../../undeaD-1.1.8/src'],
|
|
dependencies: [glibd_dep,
|
|
appstream_dep,
|
|
ascompose_dep,
|
|
@@ -92,7 +94,8 @@ asgen_test_exe = executable('asgen_test',
|
|
[asgen_sources,
|
|
backend_sources],
|
|
include_directories: [src_dir,
|
|
- gir_bind_dir],
|
|
+ gir_bind_dir,
|
|
+ '../../undeaD-1.1.8/src'],
|
|
dependencies: [glibd_dep,
|
|
appstream_dep,
|
|
ascompose_dep,
|